3 # enable GUI using: --with gui
4 %define with_gui
0%{?_with_gui:1}
6 # enable opensync 0.2x using: --with opensync
7 %define with_opensync
0%{?_with_opensync:1}
9 # enable opensync 0.4x using: --with opensync4x
10 %define with_opensync4x
0%{?_with_opensync4x:1}
12 # enable desktop using: --with desktop
13 %define with_desktop
0%{?_with_desktop:1}
15 # slight change in udev, fedora 12 and later
16 %if 0%{?fc12} || 0%{?fc13} || 0%{?fc14} || 0%{?fc15}
17 %define use_69_rules
1
19 %define use_69_rules
0
23 Summary: BlackBerry
(tm
) Desktop
for Linux
27 Group: Applications
/Productivity
29 Source: %{name}-%{version}.tar.bz2
30 URL: http
://www.netdirect.ca
/software
/packages
/barry
31 Vendor: Net Direct Inc.
32 BuildRoot: %{_tmppath}/%{name}-%{release}-%{version}-root
34 BuildRequires
: libusb
-devel
, gcc
-c
++, pkgconfig
, boost
-devel
, fuse
-devel
, zlib
-devel
37 BuildRequires
: desktop
-file
-utils
42 BuildRequires
: wxGTK
-devel
45 %define barryroot
%{_builddir}/%{name}-%{version}
48 Barry is a desktop toolset
for managing your BlackBerry
(tm
) device.
(BlackBerry
49 is a registered trademark of Research
in Motion Limited.
)
53 Summary: BlackBerry
(tm
) Desktop
for Linux
- libbarry libraries
54 Group: Development
/Libraries
55 Requires: libusb boost
57 %description -n libbarry0
58 Barry is a desktop toolset
for managing your BlackBerry
(tm
) device.
(BlackBerry
59 is a registered trademark of Research
in Motion Limited.
)
61 This package contains the library files
, license agreement
, README file
,
62 and most other assorted documentation common to all sub
-packages. You most
63 likely want to also
install barry
-util and barry
-gui.
66 %package -n libbarry
-devel
67 Summary: BlackBerry
(tm
) Desktop
for Linux
- libbarry libraries
68 Group: Development
/Libraries
69 Requires: libbarry0 boost
-devel
71 %description -n libbarry
-devel
72 Barry is a desktop toolset
for managing your BlackBerry
(tm
) device.
(BlackBerry
73 is a registered trademark of Research
in Motion Limited.
)
75 This package contains the development library files
for Barry
, libbarry.
79 Summary: BlackBerry
(tm
) Desktop
for Linux
- bcharge
, btool
, breset
, bio and others
80 Group: Applications
/Productivity
81 Requires: libbarry0 fuse
82 Conflicts: barry
-bcharge
85 Barry is a desktop toolset
for managing your BlackBerry
(tm
) device.
(BlackBerry
86 is a registered trademark of Research
in Motion Limited.
)
88 This package contains the commandline tools bcharge
, btool
, breset
, bio and
89 others which will
enable you to charge your device with a proper
500mA
90 and be able to access the data on the device
in many ways.
95 Summary: BlackBerry
(tm
) Desktop
for Linux
- bcharge
, btool
, breset and others
96 Group: Applications
/Productivity
97 Requires: libbarry0 gtkmm24 libglademm24 libtar
98 BuildRequires
: gtkmm24
-devel libglademm24
-devel libtar
-devel
101 Barry is a desktop toolset
for managing your BlackBerry
(tm
) device.
(BlackBerry
102 is a registered trademark of Research
in Motion Limited.
)
104 This package contains the GUI applications built on top of libbarry.
110 Summary: BlackBerry
(tm
) Desktop
for Linux
- opensync plugin
111 Group: Applications
/Productivity
112 Requires: libbarry0
, libopensync
>= 0.22
113 BuildRequires
: libopensync
-devel
115 %description opensync
116 Barry is a desktop toolset
for managing your BlackBerry
(tm
) device.
(BlackBerry
117 is a registered trademark of Research
in Motion Limited.
)
119 This package contains the opensync plugin.
123 %if %{with_opensync4x}
125 Summary: BlackBerry
(tm
) Desktop
for Linux
- opensync
0.4x plugin
126 Group: Applications
/Productivity
127 Requires: libbarry0
, libopensync
>= 0.39
128 BuildRequires
: libopensync
-devel
130 %description opensync4x
131 Barry is a desktop toolset
for managing your BlackBerry
(tm
) device.
(BlackBerry
132 is a registered trademark of Research
in Motion Limited.
)
134 This package contains the opensync
0.4x plugin.
140 Summary: BlackBerry
(tm
) Desktop Panel GUI
for Linux
141 Group: Applications
/Productivity
142 Requires: libbarry0
, libopensync
143 BuildRequires
: wxGTK
-devel
146 Barry is a desktop toolset
for managing your BlackBerry
(tm
) device.
(BlackBerry
147 is a registered trademark of Research
in Motion Limited.
)
149 This package contains the desktop panel GUI.
156 # some systems have an rpath checker, and need their own versions of
157 # configure built on the same system in order to pass... in particular,
158 # Fedora 14's 64bit version needs its own configure, for some reason,
159 # in order to recognize that /usr/lib64 is a system path and therefore
160 # there is no reason to use an rpath... unfortunately, configure's
161 # --disable-rpath option seems to have no effect whatsoever. :-(
163 .
/buildgen.sh cleanall
167 # Generate configure if it does not exist already (for binary-meta)
168 if [ ! -f .
/configure
] ; then
172 # setup the environment if there are additions (for binary-meta)
173 if [ -n "$ADD_TO_PKG_CONFIG_PATH"
] ; then
174 export PKG_CONFIG_PATH
="$ADD_TO_PKG_CONFIG_PATH
:$PKG_CONFIG_PATH"
179 %{configure} --enable-boost
--enable-nls
--with
-zlib
--with
-libusb
--enable-rpathhack
180 %{__make} %{?_smp_mflags}
185 %{configure} PKG_CONFIG_PATH
="..
:$PKG_CONFIG_PATH" CXXFLAGS
="
-I..
/.." LDFLAGS
="
-L..
/..
/src"
--enable-nls
--enable-rpathhack
186 %{__make} %{?_smp_mflags}
193 %{configure} PKG_CONFIG_PATH
="..
:$PKG_CONFIG_PATH" CXXFLAGS
="
-I..
/.." LDFLAGS
="
-L..
/..
/src"
--enable-nls
--enable-rpathhack
194 %{__make} %{?_smp_mflags}
199 %if %{with_opensync4x}
200 cd opensync
-plugin
-0.4x
/
201 %{configure} PKG_CONFIG_PATH
="..
:$PKG_CONFIG_PATH" CXXFLAGS
="
-I..
/.." LDFLAGS
="
-L..
/..
/src"
--enable-nls
--enable-rpathhack
202 %{__make} %{?_smp_mflags}
209 %{configure} PKG_CONFIG_PATH
="..
:$PKG_CONFIG_PATH" CXXFLAGS
="
-I..
/.." LDFLAGS
="
-L..
/..
/src"
--enable-nls
--enable-rpathhack
210 %{__make} %{?_smp_mflags}
216 %{__make} DESTDIR=%{buildroot} install
217 # delete some test-only programs
218 %{__rm} -f %{buildroot}%{_bindir}/bdptest
219 %{__rm} -f %{buildroot}%{_bindir}/bjvmdebug
220 # delete the .la files
221 %{__rm} -f %{buildroot}%{_libdir}/*.la
222 # proceed as usual...
223 %{__mkdir_p} %{buildroot}%{_sysconfdir}/udev
/rules.d
224 %{__cp} udev/10-blackberry.rules %{buildroot}%{_sysconfdir}/udev
/rules.d
/
226 %{__cp} udev/69-blackberry.rules %{buildroot}%{_sysconfdir}/udev
/rules.d
/
228 %{__cp} udev/99-blackberry-perms.rules %{buildroot}%{_sysconfdir}/udev
/rules.d
/
230 %{__mkdir_p} %{buildroot}%{_sysconfdir}/modprobe.d
231 %{__cp} modprobe/blacklist-berry_charge.conf %{buildroot}%{_sysconfdir}/modprobe.d
/
232 %{__mkdir_p} %{buildroot}%{_sysconfdir}/ppp
/peers
233 %{__cp} ppp/barry-rogers %{buildroot}%{_sysconfdir}/ppp
/peers
/
234 %{__cp} ppp/barry-minimal %{buildroot}%{_sysconfdir}/ppp
/peers
/
235 %{__cp} ppp/barry-verizon %{buildroot}%{_sysconfdir}/ppp
/peers
/
236 %{__cp} ppp/barry-sprint %{buildroot}%{_sysconfdir}/ppp
/peers
/
237 %{__cp} ppp/barry-telus %{buildroot}%{_sysconfdir}/ppp
/peers
/
238 %{__cp} ppp/barry-o2ireland %{buildroot}%{_sysconfdir}/ppp
/peers
/
239 %{__cp} ppp/barry-tmobileus %{buildroot}%{_sysconfdir}/ppp
/peers
/
240 %{__cp} ppp/barry-att_cingular %{buildroot}%{_sysconfdir}/ppp
/peers
/
241 %{__cp} ppp/barry-chinamobile %{buildroot}%{_sysconfdir}/ppp
/peers
/
242 %{__cp} ppp/barry-kpn %{buildroot}%{_sysconfdir}/ppp
/peers
/
243 %{__cp} ppp/barry-orange-spain %{buildroot}%{_sysconfdir}/ppp
/peers
/
244 %{__cp} ppp/barry-optus-au %{buildroot}%{_sysconfdir}/ppp
/peers
/
245 %{__cp} ppp/barry-vodafone-au %{buildroot}%{_sysconfdir}/ppp
/peers
/
246 %{__mkdir_p} %{buildroot}%{_sysconfdir}/chatscripts
247 %{__cp} ppp/barry-rogers.chat %{buildroot}%{_sysconfdir}/chatscripts
/
248 %{__cp} ppp/barry-minimal.chat %{buildroot}%{_sysconfdir}/chatscripts
/
249 %{__cp} ppp/barry-verizon.chat %{buildroot}%{_sysconfdir}/chatscripts
/
250 %{__cp} ppp/barry-sprint.chat %{buildroot}%{_sysconfdir}/chatscripts
/
251 %{__cp} ppp/barry-telus.chat %{buildroot}%{_sysconfdir}/chatscripts
/
252 %{__cp} ppp/barry-o2ireland.chat %{buildroot}%{_sysconfdir}/chatscripts
/
253 %{__cp} ppp/barry-tmobileus.chat %{buildroot}%{_sysconfdir}/chatscripts
/
254 %{__cp} ppp/barry-att_cingular.chat %{buildroot}%{_sysconfdir}/chatscripts
/
255 %{__cp} ppp/barry-chinamobile.chat %{buildroot}%{_sysconfdir}/chatscripts
/
256 %{__cp} ppp/barry-kpn.chat %{buildroot}%{_sysconfdir}/chatscripts
/
257 %{__cp} ppp/barry-orange-spain.chat %{buildroot}%{_sysconfdir}/chatscripts
/
258 %{__cp} ppp/barry-optus-au.chat %{buildroot}%{_sysconfdir}/chatscripts
/
259 %{__cp} ppp/barry-vodafone-au.chat %{buildroot}%{_sysconfdir}/chatscripts
/
260 # Install hal fdi config
261 %{__mkdir_p} %{buildroot}%{_datadir}/hal
/fdi
/information
/10freedesktop
262 %{__mkdir_p} %{buildroot}%{_datadir}/hal
/fdi
/policy
/10osvendor
263 %{__cp} hal/fdi/information/10freedesktop/10-blackberry.fdi %{buildroot}%{_datadir}/hal
/fdi
/information
/10freedesktop
264 %{__cp} hal/fdi/policy/10osvendor/19-blackberry-acl.fdi %{buildroot}%{_datadir}/hal
/fdi
/policy
/10osvendor
265 # Install hal support script
266 %{__mkdir_p} %{buildroot}%{_bindir}
267 %{__cp} hal/hal-blackberry %{buildroot}%{_bindir}
268 # Install bash completion scripts
269 %{__mkdir_p} %{buildroot}%{_sysconfdir}/bash_completion.d
270 %{__cp} bash/bjavaloader %{buildroot}%{_sysconfdir}/bash_completion.d
271 %{__cp} bash/btool %{buildroot}%{_sysconfdir}/bash_completion.d
276 %{__make} DESTDIR=%{buildroot} install
277 # Install barry logo icon
279 %{__mkdir_p} %{buildroot}%{_datadir}/pixmaps
280 %{__cp} logo/barry_logo_icon.png %{buildroot}%{_datadir}/pixmaps
281 desktop
-file
-install --vendor netdirect \
282 --dir
%{buildroot}%{_datadir}/applications \
283 menu
/barrybackup.desktop
289 %{__make} DESTDIR=%{buildroot} install
291 %{__rm} -f %{buildroot}%{_libdir}/opensync
/plugins
/*.la
296 %if %{with_opensync4x}
297 cd opensync
-plugin
-0.4x
/
298 %{__make} DESTDIR=%{buildroot} install
300 %{__rm} -f %{buildroot}%{_libdir}/libopensync1
/plugins
/*.la
307 %{__make} DESTDIR=%{buildroot} install
309 %{__rm} -f %{buildroot}%{_libdir}/*.la
311 %{__cp} logo/barry_logo_icon.png %{buildroot}%{_datadir}/pixmaps
/barry_desktop_icon.png
312 desktop
-file
-install --vendor netdirect \
313 --dir
%{buildroot}%{_datadir}/applications \
314 menu
/barrydesktop.desktop
318 %defattr(-,root
,root
)
319 %attr(-,root
,root
) %{_libdir}/libbarry.so.
*
320 %attr(-,root
,root
) %{_libdir}/libbarrydp.so.
*
321 %attr(-,root
,root
) %{_libdir}/libbarryjdwp.so.
*
322 %attr(-,root
,root
) %{_libdir}/libbarrysync.so.
*
323 %attr(-,root
,root
) %{_libdir}/libbarrybackup.so.
*
324 %attr(-,root
,root
) %{_libdir}/libbarryalx.so.
*
325 %doc AUTHORS ChangeLog COPYING NEWS README
327 %files -n libbarry
-devel
328 %defattr(-,root
,root
)
329 %attr(0644,root
,root
) %{_includedir}/barry
*/barry
/*
330 %attr(0644,root
,root
) %{_libdir}/libbarry.a
331 %attr(0644,root
,root
) %{_libdir}/libbarry.so
332 %attr(0644,root
,root
) %{_libdir}/libbarrydp.a
333 %attr(0644,root
,root
) %{_libdir}/libbarrydp.so
334 %attr(0644,root
,root
) %{_libdir}/libbarryjdwp.a
335 %attr(0644,root
,root
) %{_libdir}/libbarryjdwp.so
336 %attr(0644,root
,root
) %{_libdir}/libbarrysync.a
337 %attr(0644,root
,root
) %{_libdir}/libbarrysync.so
338 %attr(0644,root
,root
) %{_libdir}/libbarrybackup.a
339 %attr(0644,root
,root
) %{_libdir}/libbarrybackup.so
340 %attr(0644,root
,root
) %{_libdir}/libbarryalx.a
341 %attr(0644,root
,root
) %{_libdir}/libbarryalx.so
342 %attr(0644,root
,root
) %{_libdir}/pkgconfig
/*.pc
343 %doc COPYING TODO doc
/* examples
/*.cc
346 %defattr(-,root
,root
)
347 %attr(0755,root
,root
) %{_sbindir}/bcharge
348 %attr(0755,root
,root
) %{_sbindir}/breset
349 %attr(0755,root
,root
) %{_sbindir}/pppob
350 %attr(0755,root
,root
) %{_bindir}/btool
351 %attr(0755,root
,root
) %{_bindir}/bio
352 %attr(0755,root
,root
) %{_bindir}/btardump
353 %attr(0755,root
,root
) %{_bindir}/bfuse
354 %attr(0755,root
,root
) %{_bindir}/bjavaloader
355 %attr(0755,root
,root
) %{_bindir}/balxparse
356 %attr(0755,root
,root
) %{_bindir}/bjdwp
357 %attr(0755,root
,root
) %{_bindir}/brawchannel
358 %attr(0755,root
,root
) %{_bindir}/bs11nread
359 %attr(0755,root
,root
) %{_bindir}/bidentify
360 %attr(0755,root
,root
) %{_bindir}/brecsum
361 %attr(0755,root
,root
) %{_bindir}/upldif
362 %attr(0755,root
,root
) %{_bindir}/bktrans
363 %attr(0755,root
,root
) %{_bindir}/btranslate
364 %attr(0755,root
,root
) %{_bindir}/brimtrans
365 %attr(0755,root
,root
) %{_bindir}/hal
-blackberry
366 %attr(0644,root
,root
) %{_mandir}/man1
/btool
*
367 %attr(0644,root
,root
) %{_mandir}/man1
/bio
*
368 %attr(0644,root
,root
) %{_mandir}/man1
/btardump
*
369 %attr(0644,root
,root
) %{_mandir}/man1
/bfuse
*
370 %attr(0644,root
,root
) %{_mandir}/man1
/bjavaloader
*
371 %attr(0644,root
,root
) %{_mandir}/man1
/balxparse
*
372 %attr(0644,root
,root
) %{_mandir}/man1
/bjdwp
*
373 %attr(0644,root
,root
) %{_mandir}/man1
/brawchannel
*
374 %attr(0644,root
,root
) %{_mandir}/man1
/bs11nread
*
375 %attr(0644,root
,root
) %{_mandir}/man1
/bidentify
*
376 %attr(0644,root
,root
) %{_mandir}/man1
/bcharge
*
377 %attr(0644,root
,root
) %{_mandir}/man1
/pppob
*
378 %attr(0644,root
,root
) %{_mandir}/man1
/brecsum
*
379 %attr(0644,root
,root
) %{_mandir}/man1
/breset
*
380 %attr(0644,root
,root
) %{_mandir}/man1
/upldif
*
381 %attr(0644,root
,root
) %{_datadir}/locale
/*
382 %attr(0644,root
,root
) %{_datadir}/hal
/fdi
/information
/10freedesktop
/10-blackberry.fdi
383 %attr(0644,root
,root
) %{_datadir}/hal
/fdi
/policy
/10osvendor
/19-blackberry
-acl.fdi
384 %attr(0644,root
,root
) %config %{_sysconfdir}/udev
/rules.d
/*
385 %attr(0644,root
,root
) %config %{_sysconfdir}/modprobe.d
/blacklist
-berry_charge.conf
386 %attr(0644,root
,root
) %config %{_sysconfdir}/ppp
/peers
/barry
-rogers
387 %attr(0644,root
,root
) %config %{_sysconfdir}/ppp
/peers
/barry
-minimal
388 %attr(0644,root
,root
) %config %{_sysconfdir}/ppp
/peers
/barry
-verizon
389 %attr(0644,root
,root
) %config %{_sysconfdir}/ppp
/peers
/barry
-sprint
390 %attr(0644,root
,root
) %config %{_sysconfdir}/ppp
/peers
/barry
-telus
391 %attr(0644,root
,root
) %config %{_sysconfdir}/ppp
/peers
/barry
-o2ireland
392 %attr(0644,root
,root
) %config %{_sysconfdir}/ppp
/peers
/barry
-tmobileus
393 %attr(0644,root
,root
) %config %{_sysconfdir}/ppp
/peers
/barry
-att_cingular
394 %attr(0644,root
,root
) %config %{_sysconfdir}/ppp
/peers
/barry
-chinamobile
395 %attr(0644,root
,root
) %config %{_sysconfdir}/ppp
/peers
/barry
-kpn
396 %attr(0644,root
,root
) %config %{_sysconfdir}/ppp
/peers
/barry
-orange
-spain
397 %attr(0644,root
,root
) %config %{_sysconfdir}/ppp
/peers
/barry
-optus
-au
398 %attr(0644,root
,root
) %config %{_sysconfdir}/ppp
/peers
/barry
-vodafone
-au
399 %attr(0640,root
,root
) %config %{_sysconfdir}/chatscripts
/barry
-rogers.chat
400 %attr(0640,root
,root
) %config %{_sysconfdir}/chatscripts
/barry
-minimal.chat
401 %attr(0640,root
,root
) %config %{_sysconfdir}/chatscripts
/barry
-verizon.chat
402 %attr(0640,root
,root
) %config %{_sysconfdir}/chatscripts
/barry
-sprint.chat
403 %attr(0640,root
,root
) %config %{_sysconfdir}/chatscripts
/barry
-telus.chat
404 %attr(0640,root
,root
) %config %{_sysconfdir}/chatscripts
/barry
-o2ireland.chat
405 %attr(0640,root
,root
) %config %{_sysconfdir}/chatscripts
/barry
-tmobileus.chat
406 %attr(0640,root
,root
) %config %{_sysconfdir}/chatscripts
/barry
-att_cingular.chat
407 %attr(0640,root
,root
) %config %{_sysconfdir}/chatscripts
/barry
-chinamobile.chat
408 %attr(0640,root
,root
) %config %{_sysconfdir}/chatscripts
/barry
-kpn.chat
409 %attr(0640,root
,root
) %config %{_sysconfdir}/chatscripts
/barry
-orange
-spain.chat
410 %attr(0640,root
,root
) %config %{_sysconfdir}/chatscripts
/barry
-optus
-au.chat
411 %attr(0640,root
,root
) %config %{_sysconfdir}/chatscripts
/barry
-vodafone
-au.chat
412 %attr(0640,root
,root
) %config %{_sysconfdir}/bash_completion.d
/bjavaloader
413 %attr(0640,root
,root
) %config %{_sysconfdir}/bash_completion.d
/btool
420 %defattr(-,root
,root
)
421 %attr(0755,root
,root
) %{_bindir}/barrybackup
422 %attr(0644,root
,root
) %{_datadir}/barry
/glade
/*.glade
423 %attr(0644,root
,root
) %{_datadir}/pixmaps
/barry_logo_icon.png
424 %attr(0644,root
,root
) %{_datadir}/applications
/*barrybackup.desktop
425 %attr(0644,root
,root
) %{_mandir}/man1
/barrybackup
*
431 %defattr(-,root
,root
)
432 %attr(0755,root
,root
) %{_libdir}/opensync
/plugins
/barry_sync.so
433 %attr(0644,root
,root
) %{_datadir}/opensync
/defaults
/barry
-sync
437 %if %{with_opensync4x}
439 %defattr(-,root
,root
)
440 %attr(0755,root
,root
) %{_libdir}/libopensync1
/plugins
/barry_sync.so
441 %attr(0644,root
,root
) %{_datadir}/libopensync1
/defaults
/barry
-sync
448 %defattr(-,root
,root
)
449 %attr(0755,root
,root
) %{_bindir}/barrydesktop
450 %attr(0755,root
,root
) %{_bindir}/bsyncjail
451 %attr(0755,root
,root
) %{_bindir}/bsynccl
452 %attr(0644,root
,root
) %{_datadir}/barry
/desktop
/0.22/*
453 %attr(0644,root
,root
) %{_datadir}/barry
/desktop
/0.40/*
454 %attr(0644,root
,root
) %{_datadir}/barry
/desktop
/images
/*.png
455 %attr(0644,root
,root
) %{_datadir}/pixmaps
/barry_desktop_icon.png
456 %attr(0644,root
,root
) %{_datadir}/applications
/*barrydesktop.desktop
457 %attr(0644,root
,root
) %{_mandir}/man1
/barrydesktop
*
458 %attr(-,root
,root
) %{_libdir}/libosyncwrap.so.
*
459 %attr(-,root
,root
) %{_libdir}/libosyncwrap.a
460 %attr(-,root
,root
) %{_libdir}/libosyncwrap.so
461 %attr(0644,root
,root
) %{_includedir}/barry
*/osyncwrap
/*
466 [ "
%{buildroot}" != "/" ] && %{__rm} -rf %{buildroot}
467 [ "
%{barryroot}" != "/" ] && %{__rm} -rf %{barryroot}
476 * Thu Feb
10 2011 Chris Frey
<cdfrey@foursquare.net
> 0.18.0-0
478 - removed dependency of libbarry
-devel on libusb
(-devel
)
479 - added osyncwrap headers
480 - removed opensuse special cases
481 - back to optional
--with behaviour
482 - added opensync
0.4x package support
484 - split up dev libraries a little better
(-devel should have the dev libs
)
485 - put desktop library
in desktop package
487 * Fri May
28 2010 Chris Frey
<cdfrey@foursquare.net
> 0.17.0-0
490 - cleaned up conditionals
491 - added Fedora
13 support
492 - added new ppp chat scripts
for Orange Spain
, Optus and Vodafone AU
493 - added copy of barry
-sprint as barry
-telus
494 - added brawchannel
, btardump
, bio
, and balxparse
495 - added desktop support
496 - cleaned up desktop variables
498 * Sat Sep
29 2009 Chris Frey
<cdfrey@foursquare.net
> 0.16-0
500 - added new ppp chat script
for KPN Nederland
501 - using new udev rules
set
502 - added bjdwp and manpage
, and removed some
test-only programs
503 - added bash and zsh completion scripts
504 - added .desktop file and icon
for barrybackup
506 * Fri Apr
10 2009 Chris Frey
<cdfrey@foursquare.net
> 0.15-0
508 - added HAL FDI scripts
509 - added bjavaloader and bfuse
510 - updated
for udev directory reorganization
in Barry
source tree
511 - added zlib
-devel to BuildRequires list
514 * Wed Sep
24 2008 Chris Frey
<cdfrey@foursquare.net
> 0.14-0
516 - added new ppp chat script
for T
-Mobile US
517 - renamed libbarry to libbarry0
519 * Thu May
29 2008 Chris Frey
<cdfrey@foursquare.net
> 0.13-1
522 - added ppp options and chat scripts
523 - added manpages
for pppob
, brecsum
, breset
, upldif
, barrybackup
524 - spec file now assumes gui and opensync
, with conditional checks depending on host
526 * Fri Dec
07 2007 Chris Frey
<cdfrey@foursquare.net
> 0.12-1
529 * Fri Nov
30 2007 Chris Frey
<cdfrey@foursquare.net
> 0.11-1
532 * Fri Nov
30 2007 Chris Frey
<cdfrey@foursquare.net
> 0.10-1
534 - removed ktrans and translate from rpm package
537 * Thu Aug
09 2007 Chris Frey
<cdfrey@foursquare.net
> 0.9-1
540 * Fri Aug
03 2007 Chris Frey
<cdfrey@foursquare.net
> 0.8-1
542 - changed tarball to bz2
544 * Tue May
01 2007 Chris Frey
<cdfrey@foursquare.net
> 0.7-2
545 - added pppob to utils
547 * Thu Mar
08 2007 Chris Frey
<cdfrey@foursquare.net
> 0.7-1
548 - removed barry base package that only contained docs
, and put docs
in libbarry
*
549 - changed barrybackup reference to barry
-gui
550 - removed the patch step
, as version
0.7 shouldn't need it
551 - added license file to each package
553 * Sun Mar
04 2007 Troy Engel
<tengel@users.sourceforge.net
> 0.6-1
555 - adding udev and console perms patch
for raw
0.6