lib: changed asserts to exceptions, to guarantee these are never used
[barry.git] / rpm / barry.spec
blob5c201f4a38edecf8afd443af5ab8b5ee738ce5b8
1 %dump
4 # Note: This spec file is intended to be as cross-platform as possible.
5 # As such, it skips listing the BuildRequires lines, expecting to
6 # be built on a system with rpmbuild -ba only, and dependencies
7 # pre-installed. See the ../maintainer/depscripts/ directory
8 # in the Barry source package for scripts to automate installation
9 # of dependencies.
12 # enable GUI using: --with gui
13 %define with_gui 0%{?_with_gui:1}
15 # enable opensync 0.2x using: --with opensync
16 %define with_opensync 0%{?_with_opensync:1}
18 # enable opensync 0.4x using: --with opensync4x
19 %define with_opensync4x 0%{?_with_opensync4x:1}
21 # enable desktop using: --with desktop
22 %define with_desktop 0%{?_with_desktop:1}
24 # enable kdesu for desktop instead of beesu: --with kdesu
25 %define with_kdesu 0%{?_with_kdesu:1}
27 %if %{with_kdesu}
28 %define guisu_name kdesu
29 %define guisu_package kdebase4-runtime
30 %else
31 %define guisu_name beesu
32 %define guisu_package beesu
33 %endif
36 Summary: BlackBerry(tm) Desktop for Linux
37 Name: barry
38 Version: 0.18.4
39 Release: 0
40 Group: Applications/Productivity
41 License: GPLv2+
42 Source: %{name}-%{version}.tar.bz2
43 URL: http://www.netdirect.ca/software/packages/barry
44 Vendor: Net Direct Inc.
45 BuildRoot: %{_tmppath}/%{name}-%{release}-%{version}-root
47 #BuildRequires: libusb-devel, gcc-c++, pkgconfig, boost-devel, fuse-devel, zlib-devel
49 #%if %{with_gui}
50 #BuildRequires: desktop-file-utils
51 #%endif
53 # desktop tree
54 #%if %{with_desktop}
55 #BuildRequires: wxGTK-devel, evolution-data-server-devel
56 #%endif
58 %define barryroot %{_builddir}/%{name}-%{version}
60 %description
61 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
62 is a registered trademark of Research in Motion Limited.)
65 %package -n libbarry0
66 Summary: BlackBerry(tm) Desktop for Linux - libbarry libraries
67 Group: Development/Libraries
68 #Requires: libusb boost
70 %description -n libbarry0
71 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
72 is a registered trademark of Research in Motion Limited.)
74 This package contains the library files, license agreement, README file,
75 and most other assorted documentation common to all sub-packages. You most
76 likely want to also install barry-util and barry-gui.
79 %package -n libbarry-devel
80 Summary: BlackBerry(tm) Desktop for Linux - libbarry libraries
81 Group: Development/Libraries
82 Requires: libbarry0 boost-devel
84 %description -n libbarry-devel
85 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
86 is a registered trademark of Research in Motion Limited.)
88 This package contains the development library files for Barry, libbarry.
91 %package util
92 Summary: BlackBerry(tm) Desktop for Linux - bcharge, btool, breset, bio and others
93 Group: Applications/Productivity
94 Requires: libbarry0 fuse
95 Conflicts: barry-bcharge
97 %description util
98 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
99 is a registered trademark of Research in Motion Limited.)
101 This package contains the commandline tools bcharge, btool, breset, bio and
102 others which will enable you to charge your device with a proper 500mA
103 and be able to access the data on the device in many ways.
106 %if %{with_gui}
107 %package gui
108 Summary: BlackBerry(tm) Desktop for Linux - bcharge, btool, breset and others
109 Group: Applications/Productivity
110 Requires: libbarry0
111 #BuildRequires: gtkmm24-devel libglademm24-devel libtar-devel
113 %description gui
114 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
115 is a registered trademark of Research in Motion Limited.)
117 This package contains the GUI applications built on top of libbarry.
118 %endif
120 # opensync 0.2x
121 %if %{with_opensync}
122 %package opensync
123 Summary: BlackBerry(tm) Desktop for Linux - opensync plugin
124 Group: Applications/Productivity
125 Requires: libbarry0, libopensync >= 0.22
126 #BuildRequires: libopensync-devel
128 %description opensync
129 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
130 is a registered trademark of Research in Motion Limited.)
132 This package contains the opensync plugin.
133 %endif
135 # opensync 0.4x
136 %if %{with_opensync4x}
137 %package opensync4x
138 Summary: BlackBerry(tm) Desktop for Linux - opensync 0.4x plugin
139 Group: Applications/Productivity
140 Requires: libbarry0, libopensync1 >= 0.39
141 #BuildRequires: libopensync1-devel
143 %description opensync4x
144 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
145 is a registered trademark of Research in Motion Limited.)
147 This package contains the opensync 0.4x plugin.
148 %endif
150 # desktop tree
151 %if %{with_desktop}
152 %package desktop
153 Summary: BlackBerry(tm) Desktop Panel GUI for Linux
154 Group: Applications/Productivity
155 Requires: libbarry0 barry-util ppp xterm %{guisu_package}
156 #BuildRequires: wxGTK-devel
158 %description desktop
159 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
160 is a registered trademark of Research in Motion Limited.)
162 This package contains the desktop panel GUI.
163 %endif
165 %prep
166 [ "%{buildroot}" != "/" ] && %{__rm} -rf %{buildroot}
167 %setup -q
169 %build
170 # some systems have an rpath checker, and need their own versions of
171 # configure built on the same system in order to pass... in particular,
172 # Fedora 14's 64bit version needs its own configure, for some reason,
173 # in order to recognize that /usr/lib64 is a system path and therefore
174 # there is no reason to use an rpath... unfortunately, configure's
175 # --disable-rpath option seems to have no effect whatsoever. :-(
176 %if "%{?_lib}" == "lib64"
177 ./buildgen.sh cleanall
178 ./buildgen.sh
179 %endif
181 # Generate configure if it does not exist already (for binary-meta)
182 if [ ! -f ./configure ] ; then
183 ./buildgen.sh
186 # setup the environment if there are additions (for binary-meta)
187 export ORIG_PKG_CONFIG_PATH="$PKG_CONFIG_PATH"
188 if [ -n "$ADD_TO_PKG_CONFIG_PATH" ] ; then
189 export PKG_CONFIG_PATH="$ADD_TO_PKG_CONFIG_PATH:$ORIG_PKG_CONFIG_PATH"
193 # main tree
194 %{configure} --enable-boost --enable-nls --with-zlib --with-libusb --enable-rpathhack
195 %{__make} %{?_smp_mflags}
197 # gui tree
198 %if %{with_gui}
199 cd gui/
200 %{configure} PKG_CONFIG_PATH="..:$PKG_CONFIG_PATH" CXXFLAGS="-I../.." LDFLAGS="-L../../src" --enable-nls --enable-rpathhack
201 %{__make} %{?_smp_mflags}
202 cd ../
203 %endif
205 # opensync tree
206 %if %{with_opensync}
207 # if there is a special pkgconfig for opensync 0.2x, use it
208 if [ -n "$OSYNC2X_PKG_CONFIG_PATH" ] ; then
209 export PKG_CONFIG_PATH="$OSYNC2X_PKG_CONFIG_PATH:$ORIG_PKG_CONFIG_PATH"
211 cd opensync-plugin/
212 %{configure} PKG_CONFIG_PATH="..:$PKG_CONFIG_PATH" CXXFLAGS="-I../.." LDFLAGS="-L../../src" --enable-nls --enable-rpathhack
213 %{__make} %{?_smp_mflags}
214 cd ../
215 %endif
217 # opensync4x tree
218 %if %{with_opensync4x}
219 # if there is a special pkgconfig for opensync 0.4x, use it
220 if [ -n "$OSYNC4X_PKG_CONFIG_PATH" ] ; then
221 export PKG_CONFIG_PATH="$OSYNC4X_PKG_CONFIG_PATH:$ORIG_PKG_CONFIG_PATH"
223 cd opensync-plugin-0.4x/
224 %{configure} PKG_CONFIG_PATH="..:$PKG_CONFIG_PATH" CXXFLAGS="-I../.." LDFLAGS="-L../../src" --enable-nls --enable-rpathhack
225 %{__make} %{?_smp_mflags}
226 cd ../
227 %endif
229 # desktop tree
230 %if %{with_desktop}
231 # if there is a special pkgconfig for both opensync 0.4x and 0.2x, use it
232 if [ -n "$OSYNCBOTH_PKG_CONFIG_PATH" ] ; then
233 export PKG_CONFIG_PATH="$OSYNCBOTH_PKG_CONFIG_PATH:$ORIG_PKG_CONFIG_PATH"
235 cd desktop/
236 %{configure} PKG_CONFIG_PATH="..:$PKG_CONFIG_PATH" CXXFLAGS="-I../.." LDFLAGS="-L../../src" --enable-nls --enable-rpathhack --with-evolution --with-guisu=/usr/bin/%{guisu_name}
237 %{__make} %{?_smp_mflags}
238 cd ../
239 %endif
241 %install
242 # main tree
243 %{__make} DESTDIR=%{buildroot} install
244 # delete some test-only programs
245 %{__rm} -f %{buildroot}%{_bindir}/bdptest
246 %{__rm} -f %{buildroot}%{_bindir}/bjvmdebug
247 # delete the .la files
248 %{__rm} -f %{buildroot}%{_libdir}/*.la
249 # proceed as usual...
250 %{__mkdir_p} %{buildroot}%{_sysconfdir}/udev/rules.d
251 %{__cp} udev/10-blackberry.rules %{buildroot}%{_sysconfdir}/udev/rules.d/
252 %{__cp} udev/99-blackberry-perms.rules %{buildroot}%{_sysconfdir}/udev/rules.d/
253 %{__mkdir_p} %{buildroot}%{_sysconfdir}/modprobe.d
254 %{__cp} modprobe/blacklist-berry_charge.conf %{buildroot}%{_sysconfdir}/modprobe.d/
255 %{__mkdir_p} %{buildroot}%{_sysconfdir}/ppp/peers
256 %{__cp} ppp/barry-rogers %{buildroot}%{_sysconfdir}/ppp/peers/
257 %{__cp} ppp/barry-minimal %{buildroot}%{_sysconfdir}/ppp/peers/
258 %{__cp} ppp/barry-verizon %{buildroot}%{_sysconfdir}/ppp/peers/
259 %{__cp} ppp/barry-sprint %{buildroot}%{_sysconfdir}/ppp/peers/
260 %{__cp} ppp/barry-telus %{buildroot}%{_sysconfdir}/ppp/peers/
261 %{__cp} ppp/barry-o2ireland %{buildroot}%{_sysconfdir}/ppp/peers/
262 %{__cp} ppp/barry-tmobileus %{buildroot}%{_sysconfdir}/ppp/peers/
263 %{__cp} ppp/barry-att_cingular %{buildroot}%{_sysconfdir}/ppp/peers/
264 %{__cp} ppp/barry-chinamobile %{buildroot}%{_sysconfdir}/ppp/peers/
265 %{__cp} ppp/barry-kpn %{buildroot}%{_sysconfdir}/ppp/peers/
266 %{__cp} ppp/barry-orange-spain %{buildroot}%{_sysconfdir}/ppp/peers/
267 %{__cp} ppp/barry-orangeuk %{buildroot}%{_sysconfdir}/ppp/peers/
268 %{__cp} ppp/barry-mts %{buildroot}%{_sysconfdir}/ppp/peers/
269 %{__cp} ppp/barry-optus-au %{buildroot}%{_sysconfdir}/ppp/peers/
270 %{__cp} ppp/barry-vodafone-au %{buildroot}%{_sysconfdir}/ppp/peers/
271 %{__mkdir_p} %{buildroot}%{_sysconfdir}/chatscripts
272 %{__cp} ppp/barry-rogers.chat %{buildroot}%{_sysconfdir}/chatscripts/
273 %{__cp} ppp/barry-minimal.chat %{buildroot}%{_sysconfdir}/chatscripts/
274 %{__cp} ppp/barry-verizon.chat %{buildroot}%{_sysconfdir}/chatscripts/
275 %{__cp} ppp/barry-sprint.chat %{buildroot}%{_sysconfdir}/chatscripts/
276 %{__cp} ppp/barry-telus.chat %{buildroot}%{_sysconfdir}/chatscripts/
277 %{__cp} ppp/barry-o2ireland.chat %{buildroot}%{_sysconfdir}/chatscripts/
278 %{__cp} ppp/barry-tmobileus.chat %{buildroot}%{_sysconfdir}/chatscripts/
279 %{__cp} ppp/barry-att_cingular.chat %{buildroot}%{_sysconfdir}/chatscripts/
280 %{__cp} ppp/barry-chinamobile.chat %{buildroot}%{_sysconfdir}/chatscripts/
281 %{__cp} ppp/barry-kpn.chat %{buildroot}%{_sysconfdir}/chatscripts/
282 %{__cp} ppp/barry-orange-spain.chat %{buildroot}%{_sysconfdir}/chatscripts/
283 %{__cp} ppp/barry-orangeuk.chat %{buildroot}%{_sysconfdir}/chatscripts/
284 %{__cp} ppp/barry-mts.chat %{buildroot}%{_sysconfdir}/chatscripts/
285 %{__cp} ppp/barry-optus-au.chat %{buildroot}%{_sysconfdir}/chatscripts/
286 %{__cp} ppp/barry-vodafone-au.chat %{buildroot}%{_sysconfdir}/chatscripts/
287 # Install hal fdi config
288 %{__mkdir_p} %{buildroot}%{_datadir}/hal/fdi/information/10freedesktop
289 %{__mkdir_p} %{buildroot}%{_datadir}/hal/fdi/policy/10osvendor
290 %{__cp} hal/fdi/information/10freedesktop/10-blackberry.fdi %{buildroot}%{_datadir}/hal/fdi/information/10freedesktop
291 %{__cp} hal/fdi/policy/10osvendor/19-blackberry-acl.fdi %{buildroot}%{_datadir}/hal/fdi/policy/10osvendor
292 # Install hal support script
293 %{__mkdir_p} %{buildroot}%{_libdir}/barry
294 %{__cp} hal/hal-blackberry %{buildroot}%{_libdir}/barry
295 # Install bash completion scripts
296 %{__mkdir_p} %{buildroot}%{_sysconfdir}/bash_completion.d
297 %{__cp} bash/bjavaloader %{buildroot}%{_sysconfdir}/bash_completion.d
298 %{__cp} bash/btool %{buildroot}%{_sysconfdir}/bash_completion.d
300 # gui tree
301 %if %{with_gui}
302 cd gui/
303 %{__make} DESTDIR=%{buildroot} install
304 # Install barry logo icon (name of icon must match the *.desktop file!)
305 cd ../
306 %{__mkdir_p} %{buildroot}%{_datadir}/pixmaps
307 %{__cp} logo/barry_logo_icon.png %{buildroot}%{_datadir}/pixmaps/barry_backup_menu_icon.png
308 desktop-file-install --vendor netdirect \
309 --dir %{buildroot}%{_datadir}/applications \
310 menu/barrybackup.desktop
311 %endif
313 # opensync tree
314 %if %{with_opensync}
315 cd opensync-plugin/
316 %{__make} DESTDIR=%{buildroot} install
317 # remove .la files
318 %{__rm} -f %{buildroot}%{_libdir}/opensync/plugins/*.la
319 cd ../
320 %endif
322 # opensync4x tree
323 %if %{with_opensync4x}
324 cd opensync-plugin-0.4x/
325 %{__make} DESTDIR=%{buildroot} install
326 # remove .la files
327 %{__rm} -f %{buildroot}%{_libdir}/libopensync1/plugins/*.la
328 cd ../
329 %endif
331 # desktop tree
332 %if %{with_desktop}
333 cd desktop/
334 %{__make} DESTDIR=%{buildroot} install
335 # remove .la files
336 %{__rm} -f %{buildroot}%{_libdir}/*.la
337 cd ../
338 %{__mkdir_p} %{buildroot}%{_datadir}/pixmaps
339 %{__cp} logo/barry_logo_icon.png %{buildroot}%{_datadir}/pixmaps/barry_desktop_menu_icon.png
340 desktop-file-install --vendor netdirect \
341 --dir %{buildroot}%{_datadir}/applications \
342 menu/barrydesktop.desktop
343 %endif
345 %files -n libbarry0
346 %defattr(-,root,root)
347 %attr(-,root,root) %{_libdir}/libbarry.so.*
348 %attr(-,root,root) %{_libdir}/libbarrydp.so.*
349 %attr(-,root,root) %{_libdir}/libbarryjdwp.so.*
350 %attr(-,root,root) %{_libdir}/libbarrysync.so.*
351 %attr(-,root,root) %{_libdir}/libbarrybackup.so.*
352 %attr(-,root,root) %{_libdir}/libbarryalx.so.*
353 %doc AUTHORS ChangeLog KnownBugs COPYING NEWS README
355 %files -n libbarry-devel
356 %defattr(-,root,root)
357 %attr(0644,root,root) %{_includedir}/barry*/barry/*
358 %attr(0644,root,root) %{_libdir}/libbarry.a
359 %attr(0644,root,root) %{_libdir}/libbarry.so
360 %attr(0644,root,root) %{_libdir}/libbarrydp.a
361 %attr(0644,root,root) %{_libdir}/libbarrydp.so
362 %attr(0644,root,root) %{_libdir}/libbarryjdwp.a
363 %attr(0644,root,root) %{_libdir}/libbarryjdwp.so
364 %attr(0644,root,root) %{_libdir}/libbarrysync.a
365 %attr(0644,root,root) %{_libdir}/libbarrysync.so
366 %attr(0644,root,root) %{_libdir}/libbarrybackup.a
367 %attr(0644,root,root) %{_libdir}/libbarrybackup.so
368 %attr(0644,root,root) %{_libdir}/libbarryalx.a
369 %attr(0644,root,root) %{_libdir}/libbarryalx.so
370 %attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
371 %doc COPYING TODO KnownBugs doc/* examples/*.cc
373 %files util
374 %defattr(-,root,root)
375 %attr(0755,root,root) %{_sbindir}/bcharge
376 %attr(0755,root,root) %{_sbindir}/breset
377 %attr(0755,root,root) %{_sbindir}/pppob
378 %attr(0755,root,root) %{_bindir}/btool
379 %attr(0755,root,root) %{_bindir}/bwatch
380 %attr(0755,root,root) %{_bindir}/bio
381 %attr(0755,root,root) %{_bindir}/btardump
382 %attr(0755,root,root) %{_bindir}/btarcmp
383 %attr(0755,root,root) %{_bindir}/bfuse
384 %attr(0755,root,root) %{_bindir}/bjavaloader
385 %attr(0755,root,root) %{_bindir}/balxparse
386 %attr(0755,root,root) %{_bindir}/bjdwp
387 %attr(0755,root,root) %{_bindir}/brawchannel
388 %attr(0755,root,root) %{_bindir}/bs11nread
389 %attr(0755,root,root) %{_bindir}/bidentify
390 %attr(0755,root,root) %{_bindir}/brecsum
391 %attr(0755,root,root) %{_bindir}/upldif
392 %attr(0755,root,root) %{_libdir}/barry/hal-blackberry
393 %attr(0644,root,root) %{_mandir}/man1/btool*
394 %attr(0644,root,root) %{_mandir}/man1/bwatch*
395 %attr(0644,root,root) %{_mandir}/man1/bio*
396 %attr(0644,root,root) %{_mandir}/man1/btardump*
397 %attr(0644,root,root) %{_mandir}/man1/btarcmp*
398 %attr(0644,root,root) %{_mandir}/man1/bfuse*
399 %attr(0644,root,root) %{_mandir}/man1/bjavaloader*
400 %attr(0644,root,root) %{_mandir}/man1/balxparse*
401 %attr(0644,root,root) %{_mandir}/man1/bjdwp*
402 %attr(0644,root,root) %{_mandir}/man1/brawchannel*
403 %attr(0644,root,root) %{_mandir}/man1/bs11nread*
404 %attr(0644,root,root) %{_mandir}/man1/bidentify*
405 %attr(0644,root,root) %{_mandir}/man1/bcharge*
406 %attr(0644,root,root) %{_mandir}/man1/pppob*
407 %attr(0644,root,root) %{_mandir}/man1/brecsum*
408 %attr(0644,root,root) %{_mandir}/man1/breset*
409 %attr(0644,root,root) %{_mandir}/man1/upldif*
410 %attr(0644,root,root) %{_datadir}/locale/*/LC_MESSAGES/barry.mo
411 %attr(0644,root,root) %{_datadir}/hal/fdi/information/10freedesktop/10-blackberry.fdi
412 %attr(0644,root,root) %{_datadir}/hal/fdi/policy/10osvendor/19-blackberry-acl.fdi
413 %attr(0644,root,root) %config %{_sysconfdir}/udev/rules.d/*
414 %attr(0644,root,root) %config %{_sysconfdir}/modprobe.d/blacklist-berry_charge.conf
415 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-rogers
416 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-minimal
417 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-verizon
418 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-sprint
419 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-telus
420 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-o2ireland
421 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-tmobileus
422 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-att_cingular
423 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-chinamobile
424 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-kpn
425 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-orange-spain
426 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-orangeuk
427 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-mts
428 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-optus-au
429 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-vodafone-au
430 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-rogers.chat
431 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-minimal.chat
432 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-verizon.chat
433 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-sprint.chat
434 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-telus.chat
435 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-o2ireland.chat
436 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-tmobileus.chat
437 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-att_cingular.chat
438 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-chinamobile.chat
439 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-kpn.chat
440 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-orange-spain.chat
441 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-orangeuk.chat
442 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-mts.chat
443 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-optus-au.chat
444 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-vodafone-au.chat
445 %attr(0640,root,root) %config %{_sysconfdir}/bash_completion.d/bjavaloader
446 %attr(0640,root,root) %config %{_sysconfdir}/bash_completion.d/btool
447 %doc COPYING
448 %doc zsh
449 %doc ppp/README
451 %if %{with_gui}
452 %files gui
453 %defattr(-,root,root)
454 %attr(0755,root,root) %{_bindir}/barrybackup
455 %attr(0644,root,root) %{_datadir}/barry/glade/*.glade
456 %attr(0644,root,root) %{_datadir}/pixmaps/barry_backup_menu_icon.png
457 %attr(0644,root,root) %{_datadir}/applications/*barrybackup.desktop
458 %attr(0644,root,root) %{_mandir}/man1/barrybackup*
459 %attr(0644,root,root) %{_datadir}/locale/*/LC_MESSAGES/barry-backup.mo
460 %doc COPYING
461 %endif
463 %if %{with_opensync}
464 %files opensync
465 %defattr(-,root,root)
466 %attr(0755,root,root) %{_libdir}/opensync/plugins/barry_sync.so
467 %attr(0644,root,root) %{_datadir}/opensync/defaults/barry-sync
468 %doc COPYING
469 %endif
471 %if %{with_opensync4x}
472 %files opensync4x
473 %defattr(-,root,root)
474 %attr(0755,root,root) %{_libdir}/libopensync1/plugins/barry_sync.so
475 %attr(0644,root,root) %{_datadir}/libopensync1/defaults/barry-sync
476 %doc COPYING
477 %endif
479 # desktop tree
480 %if %{with_desktop}
481 %files desktop
482 %defattr(-,root,root)
483 %attr(0755,root,root) %{_bindir}/barrydesktop
484 %attr(0755,root,root) %{_libexecdir}/barrydesktop/bsyncjail
485 %attr(0755,root,root) %{_libexecdir}/barrydesktop/blistevo
486 %attr(0644,root,root) %{_datadir}/barry/desktop/0.22/*
487 %attr(0644,root,root) %{_datadir}/barry/desktop/0.40/*
488 %attr(0644,root,root) %{_datadir}/barry/desktop/images/*.png
489 %attr(0644,root,root) %{_datadir}/pixmaps/barry_desktop_menu_icon.png
490 %attr(0644,root,root) %{_datadir}/applications/*barrydesktop.desktop
491 %attr(0644,root,root) %{_mandir}/man1/barrydesktop*
492 %attr(0644,root,root) %{_datadir}/locale/*/LC_MESSAGES/barrydesktop.mo
493 %attr(0644,root,root) %{_datadir}/locale/*/LC_MESSAGES/barryosyncwrap.mo
494 %attr(-,root,root) %{_libdir}/libosyncwrap.so.*
495 %attr(-,root,root) %{_libdir}/libosyncwrap.a
496 %attr(-,root,root) %{_libdir}/libosyncwrap.so
497 %attr(0644,root,root) %{_includedir}/barry*/osyncwrap/*
498 %doc COPYING
499 %endif
501 %clean
502 [ "%{buildroot}" != "/" ] && %{__rm} -rf %{buildroot}
503 [ "%{barryroot}" != "/" ] && %{__rm} -rf %{barryroot}
505 %post -n libbarry0
506 /sbin/ldconfig
508 %postun -n libbarry0
509 /sbin/ldconfig
511 %changelog
512 * Fri Jul 13 2012 Chris Frey <cdfrey@foursquare.net> 0.18.4-0
513 - version bump
514 - added spanish translation, and fixed locations of .mo files, so
515 barry.mo goes to utils, and barry-backup.mo goes to backup
516 - since we are building with binary-meta which contains depscripts,
517 removed all BuildRequires lines, to make spec file more portable
518 across Fedora and openSUSE
519 - use kdesu for openSUSE builds, beesu for Fedora
520 - added desktop's barrydesktop.mo and barryosyncwrap.mo files
522 * Tue May 15 2012 Chris Frey <cdfrey@foursquare.net> 0.18.3-0
523 - version bump
524 - renamed icon filenames to match .desktop file
526 * Tue May 15 2012 Chris Frey <cdfrey@foursquare.net> 0.18.2-0
527 - version bump
529 * Tue May 8 2012 Chris Frey <cdfrey@foursquare.net> 0.18.1-0
530 - version bump
532 * Mon Aug 31 2011 Chris Frey <cdfrey@foursquare.net> 0.18.0-0
533 - version bump
534 - removed dependency of libbarry-devel on libusb(-devel)
535 - added osyncwrap headers
536 - removed opensuse special cases
537 - back to optional --with behaviour
538 - added opensync 0.4x package support
539 - removed .la files
540 - split up dev libraries a little better (-devel should have the dev libs)
541 - put desktop library in desktop package
542 - added orangeuk and mts ppp chatscript files
543 - added bwatch
544 - added code to clean the buildroot at start
545 - added evolution dependencies for desktop build
546 - removed libopensync dependency from barry-desktop (can be either, both, or none)
547 - renamed 0.4x plugin dependency to libopensync1
548 - removed extraneous library dependencies, which should be handled automatically
549 - added btarcmp
550 - removed brimtrans, bktrans, and btranslate (devel tools)
551 - added beesu dependency for barrydesktop, for modem mode, to run pppd
553 * Fri May 28 2010 Chris Frey <cdfrey@foursquare.net> 0.17.0-0
554 - version bump
555 - added NLS support
556 - cleaned up conditionals
557 - added Fedora 13 support
558 - added new ppp chat scripts for Orange Spain, Optus and Vodafone AU
559 - added copy of barry-sprint as barry-telus
560 - added brawchannel, btardump, bio, and balxparse
561 - added desktop support
562 - cleaned up desktop variables
564 * Sat Sep 29 2009 Chris Frey <cdfrey@foursquare.net> 0.16-0
565 - version bump
566 - added new ppp chat script for KPN Nederland
567 - using new udev rules set
568 - added bjdwp and manpage, and removed some test-only programs
569 - added bash and zsh completion scripts
570 - added .desktop file and icon for barrybackup
572 * Fri Apr 10 2009 Chris Frey <cdfrey@foursquare.net> 0.15-0
573 - version bump
574 - added HAL FDI scripts
575 - added bjavaloader and bfuse
576 - updated for udev directory reorganization in Barry source tree
577 - added zlib-devel to BuildRequires list
578 - added brimtrans
580 * Wed Sep 24 2008 Chris Frey <cdfrey@foursquare.net> 0.14-0
581 - version bump
582 - added new ppp chat script for T-Mobile US
583 - renamed libbarry to libbarry0
585 * Thu May 29 2008 Chris Frey <cdfrey@foursquare.net> 0.13-1
586 - version bump
587 - added brecsum
588 - added ppp options and chat scripts
589 - added manpages for pppob, brecsum, breset, upldif, barrybackup
590 - spec file now assumes gui and opensync, with conditional checks depending on host
592 * Fri Dec 07 2007 Chris Frey <cdfrey@foursquare.net> 0.12-1
593 - version bump
595 * Fri Nov 30 2007 Chris Frey <cdfrey@foursquare.net> 0.11-1
596 - version bump
598 * Fri Nov 30 2007 Chris Frey <cdfrey@foursquare.net> 0.10-1
599 - version bump
600 - removed ktrans and translate from rpm package
601 - added bidentify
603 * Thu Aug 09 2007 Chris Frey <cdfrey@foursquare.net> 0.9-1
604 - version bump
606 * Fri Aug 03 2007 Chris Frey <cdfrey@foursquare.net> 0.8-1
607 - version bump
608 - changed tarball to bz2
610 * Tue May 01 2007 Chris Frey <cdfrey@foursquare.net> 0.7-2
611 - added pppob to utils
613 * Thu Mar 08 2007 Chris Frey <cdfrey@foursquare.net> 0.7-1
614 - removed barry base package that only contained docs, and put docs in libbarry*
615 - changed barrybackup reference to barry-gui
616 - removed the patch step, as version 0.7 shouldn't need it
617 - added license file to each package
619 * Sun Mar 04 2007 Troy Engel <tengel@users.sourceforge.net> 0.6-1
620 - initial build
621 - adding udev and console perms patch for raw 0.6