tzwrapper.cc: fixed use of iterator after erase
[barry.git] / debian / barry-util.postinst
blobe05a3d1a7eb5551580bfaef3a0eb54933db2b836
1 #!/bin/sh
3 set -e
5 everything() {
6 # set ownership for ppp options files
7 for f in /etc/ppp/peers/barry-*
8 do
9 chown root:dip "$f"
10 done
12 # set permissions for chatscripts
13 for f in /etc/chatscripts/barry-*.chat
15 chown root:dip "$f"
16 chmod 0640 "$f"
17 done
20 case "$1" in
21 configure)
22 everything
25 abort-upgrade|abort-remove|abort-deconfigure)
29 echo "postinst called with unknown argument '$1'" >&2
30 exit 1
32 esac
34 #DEBHELPER#
36 exit 0