1 ## pass in '--with gui' to build the GUI tools
2 # ex.: rpmbuild -ba barry.spec --with gui
4 ## pass in '--with opensync' to build the opensync plugin
5 # ex.: rpmbuild -ba barry.spec --with opensync
8 # When building on SuSE, remove the "-devel" on the following packages:
12 # SuSE also seems to name libglademm24 differently:
16 # newer bcond_with() macros are not available on RHEL4/CentOS4 and below
17 %{?_with_gui: %define with_gui 1}
18 %{!?_with_gui: %define with_gui 0}
19 %{?_with_opensync: %define with_opensync 1}
20 %{!?_with_opensync: %define with_opensync 0}
22 Summary: BlackBerry
(tm
) Desktop
for Linux
26 Group: Applications
/Productivity
28 Source: %{name}-%{version}.tar.bz2
29 URL: http
://www.netdirect.ca
/downloads
/barry
30 Vendor: Net Direct Inc.
31 BuildRoot: %{_tmppath}/%{name}-%{release}-%{version}-root
32 BuildRequires
: libusb
-devel
, gcc
-c
++, pkgconfig
, boost
-devel
, openssl
-devel
34 %define barryroot
%{_builddir}/%{name}-%{version}
37 Barry is a desktop toolset
for managing your BlackBerry
(tm
) device.
(BlackBerry
38 is a registered trademark of Research
in Motion Limited.
)
42 Summary: BlackBerry
(tm
) Desktop
for Linux
- libbarry libraries
43 Group: Development
/Libraries
44 Requires: libusb openssl boost
46 %description -n libbarry
47 Barry is a desktop toolset
for managing your BlackBerry
(tm
) device.
(BlackBerry
48 is a registered trademark of Research
in Motion Limited.
)
50 This package contains the library files
, license agreement
, README file
,
51 and most other assorted documentation common to all sub
-packages. You most
52 likely want to also
install barry
-util and barry
-gui.
55 %package -n libbarry
-devel
56 Summary: BlackBerry
(tm
) Desktop
for Linux
- libbarry libraries
57 Group: Development
/Libraries
58 Requires: libbarry libusb
-devel openssl
-devel boost
-devel
60 %description -n libbarry
-devel
61 Barry is a desktop toolset
for managing your BlackBerry
(tm
) device.
(BlackBerry
62 is a registered trademark of Research
in Motion Limited.
)
64 This package contains the development library files
for Barry
, libbarry.
68 Summary: BlackBerry
(tm
) Desktop
for Linux
- bcharge
, btool
, breset and others
69 Group: Applications
/Productivity
71 Conflicts: barry
-bcharge
74 Barry is a desktop toolset
for managing your BlackBerry
(tm
) device.
(BlackBerry
75 is a registered trademark of Research
in Motion Limited.
)
77 This package contains the commandline tools bcharge
, btool
, breset and others
78 which will
enable you to charge your device with a proper
500mA and be able
79 to access the data on the device
in many ways.
84 Summary: BlackBerry
(tm
) Desktop
for Linux
- bcharge
, btool
, breset and others
85 Group: Applications
/Productivity
86 Requires: libbarry gtkmm24 libglademm24 libtar
87 BuildRequires
: gtkmm24
-devel libglademm24
-devel libtar
-devel
90 Barry is a desktop toolset
for managing your BlackBerry
(tm
) device.
(BlackBerry
91 is a registered trademark of Research
in Motion Limited.
)
93 This package contains the GUI applications built on top of libbarry.
99 Summary: BlackBerry
(tm
) Desktop
for Linux
- opensync plugin
100 Group: Applications
/Productivity
101 Requires: libbarry
, libopensync
>= 0.22
102 BuildRequires
: libopensync
-devel
104 %description opensync
105 Barry is a desktop toolset
for managing your BlackBerry
(tm
) device.
(BlackBerry
106 is a registered trademark of Research
in Motion Limited.
)
108 This package contains the opensync plugin.
116 %{configure} --with-boost=%{_prefix}
117 %{__make} %{?_smp_mflags}
122 %{configure} PKG_CONFIG_PATH
="..
:$PKG_CONFIG_PATH" CXXFLAGS
="
-I..
/.." LDFLAGS
="
-L..
/..
/src"
123 %{__make} %{?_smp_mflags}
130 %{configure} PKG_CONFIG_PATH
="..
:$PKG_CONFIG_PATH" CXXFLAGS
="
-I..
/.." LDFLAGS
="
-L..
/..
/src"
131 %{__make} %{?_smp_mflags}
137 %{__make} DESTDIR=%{buildroot} install
138 %{__mkdir_p} %{buildroot}%{_sysconfdir}/udev
/rules.d
139 %{__cp} udev/10-blackberry.rules %{buildroot}%{_sysconfdir}/udev
/rules.d
/
140 %{__mkdir_p} %{buildroot}%{_sysconfdir}/security
/console.perms.d
141 %{__cp} udev/10-blackberry.perms %{buildroot}%{_sysconfdir}/security
/console.perms.d
/
142 %{__mkdir_p} %{buildroot}%{_sysconfdir}/modprobe.d
143 %{__cp} modprobe/blacklist-berry_charge %{buildroot}%{_sysconfdir}/modprobe.d
/
148 %{__make} DESTDIR=%{buildroot} install
155 %{__make} DESTDIR=%{buildroot} install
160 %defattr(-,root
,root
)
161 %attr(-,root
,root
) %{_libdir}/*.so
*
162 %doc AUTHORS ChangeLog COPYING NEWS README
164 %files -n libbarry
-devel
165 %defattr(-,root
,root
)
166 %doc examples
/*.cc examples
/*.am
167 %attr(0644,root
,root
) %{_includedir}/barry
/*
168 %attr(0644,root
,root
) %{_libdir}/*.a
169 %attr(0755,root
,root
) %{_libdir}/*.la
170 %attr(0644,root
,root
) %{_libdir}/pkgconfig
/*.pc
171 %doc COPYING TODO doc
/*
174 %defattr(-,root
,root
)
175 %attr(0755,root
,root
) %{_sbindir}/bcharge
176 %attr(0755,root
,root
) %{_sbindir}/breset
177 %attr(0755,root
,root
) %{_sbindir}/pppob
178 %attr(0755,root
,root
) %{_bindir}/btool
179 %attr(0755,root
,root
) %{_bindir}/upldif
180 %attr(0755,root
,root
) %{_bindir}/bktrans
181 %attr(0755,root
,root
) %{_bindir}/btranslate
182 %attr(0644,root
,root
) %{_mandir}/man1
/btool
*
183 %attr(0644,root
,root
) %{_mandir}/man1
/bcharge
*
184 %attr(0644,root
,root
) %config %{_sysconfdir}/udev
/rules.d
/*
185 %attr(0644,root
,root
) %config %{_sysconfdir}/security
/console.perms.d
/*
186 %attr(0644,root
,root
) %config %{_sysconfdir}/modprobe.d
/blacklist
-berry_charge
191 %defattr(-,root
,root
)
192 %attr(0755,root
,root
) %{_bindir}/barrybackup
193 %attr(0644,root
,root
) %{_datadir}/barry
/glade
/*.glade
199 %defattr(-,root
,root
)
200 %attr(0755,root
,root
) %{_libdir}/opensync
/plugins
/*
201 %attr(0644,root
,root
) %{_datadir}/opensync
/defaults
/*
206 [ "
%{buildroot}" != "/" ] && %{__rm} -rf %{buildroot}
207 [ "
%{barryroot}" != "/" ] && %{__rm} -rf %{barryroot}
216 * Fri Oct
12 2007 Chris Frey
<cdfrey@foursquare.net
> 0.10-1
218 - removed ktrans and translate from rpm package
220 * Thu Aug
09 2007 Chris Frey
<cdfrey@foursquare.net
> 0.9-1
223 * Fri Aug
03 2007 Chris Frey
<cdfrey@foursquare.net
> 0.8-1
225 - changed tarball to bz2
227 * Tue May
01 2007 Chris Frey
<cdfrey@foursquare.net
> 0.7-2
228 - added pppob to utils
230 * Thu Mar
08 2007 Chris Frey
<cdfrey@foursquare.net
> 0.7-1
231 - removed barry base package that only contained docs
, and put docs
in libbarry
*
232 - changed barrybackup reference to barry
-gui
233 - removed the patch step
, as version
0.7 shouldn't need it
234 - added license file to each package
236 * Sun Mar
04 2007 Troy Engel
<tengel@users.sourceforge.net
> 0.6-1
238 - adding udev and console perms patch
for raw
0.6