Updated Fedora and Mandriva maintainer info
[barry.git] / debian / rules
blob326f6b006e2f2ed9ac295374f3aa0c0f4a3d5283
1 #!/usr/bin/make -f
2 # Based on the multi2 sample debian/rules file:
3 # ---
4 # Sample debian/rules that uses debhelper.
5 # This file is public domain software, originally written by Joey Hess.
7 #export DH_VERBOSE=1
8 include /usr/share/cdbs/1/rules/debhelper.mk
9 include /usr/share/cdbs/1/class/autotools.mk
10 #include /usr/share/cdbs/1/rules/simple-patchsys.mk
12 # where sources are
13 DEB_SRCDIR = .
14 # in which directory to build
15 DEB_BUILDDIR = .
16 # in which directory to install the sofware
17 DEB_DESTDIR = $(CURDIR)/debian/tmp
18 #To register a debug library package libfoo-dbg for libfoo (which needs unstripped '.so') in compat mode 4:
19 DEB_DH_STRIP_ARGS := --dbg-package=libbarry0 --dbg-package=libbarry-dev --dbg-package=barry-util --dbg-package=barrybackup-gui --dbg-package=opensync-plugin-barry
20 #CDBS automatically handles common flags to pass to the configure script,
21 #but it is possible to give some extra parameters :
22 DEB_CONFIGURE_EXTRA_FLAGS := --enable-boost --enable-nls --with-zlib --enable-gui --enable-opensync-plugin
23 COMMON_CONFIGURE_FLAGS := --prefix=/usr
24 DEB_INSTALL_DOCS_ALL =
26 install/barry-util::
27 # Install udev rules for the barry-util package
28 install -d $(CURDIR)/debian/barry-util/etc/udev/rules.d
29 install -m 0644 \
30 $(CURDIR)/udev/10-blackberry.rules \
31 $(CURDIR)/udev/99-blackberry-perms.rules \
32 $(CURDIR)/debian/barry-util/etc/udev/rules.d
33 # Install modprobe blacklist file for bcharge, into barry-util package
34 install -d $(CURDIR)/debian/barry-util/etc/modprobe.d
35 install -m 0644 $(CURDIR)/modprobe/blacklist-berry_charge.conf $(CURDIR)/debian/barry-util/etc/modprobe.d/blacklist-berry_charge.conf
36 # Install default ppp options and chat scripts
37 install -d $(CURDIR)/debian/barry-util/etc/ppp/peers
38 install -m 0644 \
39 $(CURDIR)/ppp/barry-rogers \
40 $(CURDIR)/ppp/barry-verizon \
41 $(CURDIR)/ppp/barry-sprint \
42 $(CURDIR)/ppp/barry-o2ireland \
43 $(CURDIR)/ppp/barry-tmobileus \
44 $(CURDIR)/ppp/barry-att_cingular \
45 $(CURDIR)/ppp/barry-chinamobile \
46 $(CURDIR)/ppp/barry-kpn \
47 $(CURDIR)/debian/barry-util/etc/ppp/peers
48 install -d $(CURDIR)/debian/barry-util/etc/chatscripts
49 install -m 0640 \
50 $(CURDIR)/ppp/barry-rogers.chat \
51 $(CURDIR)/ppp/barry-verizon.chat \
52 $(CURDIR)/ppp/barry-sprint.chat \
53 $(CURDIR)/ppp/barry-o2ireland.chat \
54 $(CURDIR)/ppp/barry-tmobileus.chat \
55 $(CURDIR)/ppp/barry-att_cingular.chat \
56 $(CURDIR)/ppp/barry-chinamobile.chat \
57 $(CURDIR)/ppp/barry-kpn.chat \
58 $(CURDIR)/debian/barry-util/etc/chatscripts
59 # Install hal fdi configs
60 install -d $(CURDIR)/debian/barry-util/usr/share/hal/fdi/information/10freedesktop
61 install -d $(CURDIR)/debian/barry-util/usr/share/hal/fdi/policy/10osvendor
62 install -m 0644 $(CURDIR)/hal/fdi/information/10freedesktop/10-blackberry.fdi $(CURDIR)/debian/barry-util/usr/share/hal/fdi/information/10freedesktop
63 install -m 0644 $(CURDIR)/hal/fdi/policy/10osvendor/19-blackberry-acl.fdi $(CURDIR)/debian/barry-util/usr/share/hal/fdi/policy/10osvendor
64 # Install hal support script
65 install -d $(CURDIR)/debian/barry-util/usr/bin
66 install -m 0755 $(CURDIR)/hal/hal-blackberry $(CURDIR)/debian/barry-util/usr/bin
67 # Install bash and zsh completion scripts
68 install -d $(CURDIR)/debian/barry-util/etc/bash_completion.d
69 install -m 0644 \
70 $(CURDIR)/bash/bjavaloader \
71 $(CURDIR)/bash/btool \
72 $(CURDIR)/debian/barry-util/etc/bash_completion.d
74 install/barrybackup-gui::
75 # Install barry icon
76 install -d $(CURDIR)/debian/barrybackup-gui/usr/share/pixmaps
77 install -m 0644 $(CURDIR)/logo/barry_logo_icon.png $(CURDIR)/debian/barrybackup-gui/usr/share/pixmaps
79 post-patches::
80 @test -x $(DEB_SRCDIR)/configure && echo "allready autoreconf" || (cd $(DEB_SRCDIR) && autoreconf -i)
82 clean::
83 -@rm -f $(DEB_SRCDIR)/config.guess $(DEB_SRCDIR)/config.sub $(DEB_SRCDIR)/ltmain.sh $(DEB_SRCDIR)/aclocal.m4
84 -@rm -f $(DEB_SRCDIR)/config.h.in $(DEB_SRCDIR)/mkinstalldirs $(DEB_SRCDIR)/install-sh
85 -@rm -f $(DEB_SRCDIR)/missing $(DEB_SRCDIR)/depcomp $(DEB_SRCDIR)/configure $(DEB_SRCDIR)/subdirs
86 -@rm -rf build/ $(DEB_SRCDIR)/configure.files $(DEB_SRCDIR)/stamp-h.in
87 -@rm `find . -type f -name "Makefile.in" -print`