lib: added DBName support to parsers and builders
[barry.git] / debian / rules
bloba8d7569c2813b3c2a0ccce17acb0df1dadeb4570
1 #!/usr/bin/make -f
2 # Based on the multi2 sample debian/rules file:
3 # ---
4 # Sample debian/rules that uses debhelper.
5 # This file is public domain software, originally written by Joey Hess.
7 #export DH_VERBOSE=1
8 include /usr/share/cdbs/1/rules/debhelper.mk
9 include /usr/share/cdbs/1/class/autotools.mk
10 #include /usr/share/cdbs/1/rules/simple-patchsys.mk
12 # where sources are
13 DEB_SRCDIR = .
14 # in which directory to build
15 DEB_BUILDDIR = .
16 # in which directory to install the sofware
17 DEB_DESTDIR = $(CURDIR)/debian/tmp
18 #To register a debug library package libfoo-dbg for libfoo (which needs unstripped '.so') in compat mode 4:
19 DEB_DH_STRIP_ARGS := --dbg-package=libbarry0 --dbg-package=libbarry-dev --dbg-package=barry-util --dbg-package=barrybackup-gui
20 #CDBS automatically handles common flags to pass to the configure script,
21 #but it is possible to give some extra parameters :
22 DEB_CONFIGURE_EXTRA_FLAGS := --enable-boost --enable-nls --with-zlib --enable-gui
23 COMMON_CONFIGURE_FLAGS := --prefix=/usr
24 DEB_INSTALL_DOCS_ALL =
26 install/barry-util::
27 # Install udev rules for the barry-util package
28 install -d $(CURDIR)/debian/barry-util/etc/udev/rules.d
29 install -m 0644 \
30 $(DEB_SRCDIR)/udev/10-blackberry.rules \
31 $(DEB_SRCDIR)/udev/99-blackberry-perms.rules \
32 $(CURDIR)/debian/barry-util/etc/udev/rules.d
33 # Install modprobe blacklist file for bcharge, into barry-util package
34 install -d $(CURDIR)/debian/barry-util/etc/modprobe.d
35 install -m 0644 $(DEB_SRCDIR)/modprobe/blacklist-berry_charge.conf $(CURDIR)/debian/barry-util/etc/modprobe.d/blacklist-berry_charge.conf
36 # Install default ppp options and chat scripts
37 install -d $(CURDIR)/debian/barry-util/etc/ppp/peers
38 install -m 0644 \
39 $(DEB_SRCDIR)/ppp/barry-rogers \
40 $(DEB_SRCDIR)/ppp/barry-verizon \
41 $(DEB_SRCDIR)/ppp/barry-sprint \
42 $(DEB_SRCDIR)/ppp/barry-telus \
43 $(DEB_SRCDIR)/ppp/barry-o2ireland \
44 $(DEB_SRCDIR)/ppp/barry-tmobileus \
45 $(DEB_SRCDIR)/ppp/barry-att_cingular \
46 $(DEB_SRCDIR)/ppp/barry-chinamobile \
47 $(DEB_SRCDIR)/ppp/barry-kpn \
48 $(DEB_SRCDIR)/ppp/barry-orange-spain \
49 $(CURDIR)/debian/barry-util/etc/ppp/peers
50 install -d $(CURDIR)/debian/barry-util/etc/chatscripts
51 install -m 0640 \
52 $(DEB_SRCDIR)/ppp/barry-rogers.chat \
53 $(DEB_SRCDIR)/ppp/barry-verizon.chat \
54 $(DEB_SRCDIR)/ppp/barry-sprint.chat \
55 $(DEB_SRCDIR)/ppp/barry-telus.chat \
56 $(DEB_SRCDIR)/ppp/barry-o2ireland.chat \
57 $(DEB_SRCDIR)/ppp/barry-tmobileus.chat \
58 $(DEB_SRCDIR)/ppp/barry-att_cingular.chat \
59 $(DEB_SRCDIR)/ppp/barry-chinamobile.chat \
60 $(DEB_SRCDIR)/ppp/barry-kpn.chat \
61 $(DEB_SRCDIR)/ppp/barry-orange-spain.chat \
62 $(CURDIR)/debian/barry-util/etc/chatscripts
63 # Install hal fdi configs
64 install -d $(CURDIR)/debian/barry-util/usr/share/hal/fdi/information/10freedesktop
65 install -d $(CURDIR)/debian/barry-util/usr/share/hal/fdi/policy/10osvendor
66 install -m 0644 $(DEB_SRCDIR)/hal/fdi/information/10freedesktop/10-blackberry.fdi $(CURDIR)/debian/barry-util/usr/share/hal/fdi/information/10freedesktop
67 install -m 0644 $(DEB_SRCDIR)/hal/fdi/policy/10osvendor/19-blackberry-acl.fdi $(CURDIR)/debian/barry-util/usr/share/hal/fdi/policy/10osvendor
68 # Install hal support script
69 install -d $(CURDIR)/debian/barry-util/usr/bin
70 install -m 0755 $(DEB_SRCDIR)/hal/hal-blackberry $(CURDIR)/debian/barry-util/usr/bin
71 # Install bash and zsh completion scripts
72 install -d $(CURDIR)/debian/barry-util/etc/bash_completion.d
73 install -m 0644 \
74 $(DEB_SRCDIR)/bash/bjavaloader \
75 $(DEB_SRCDIR)/bash/btool \
76 $(CURDIR)/debian/barry-util/etc/bash_completion.d
77 # Install examples/ into libbarry-dev
78 install -d $(CURDIR)/debian/libbarry-dev/usr/share/doc/libbarry-dev/examples
79 install -m 0644 $(DEB_SRCDIR)/examples/*.cc \
80 $(CURDIR)/debian/libbarry-dev/usr/share/doc/libbarry-dev/examples
82 install/barrybackup-gui::
83 # Install barry icon
84 install -d $(CURDIR)/debian/barrybackup-gui/usr/share/pixmaps
85 install -m 0644 $(DEB_SRCDIR)/logo/barry_logo_icon.png $(CURDIR)/debian/barrybackup-gui/usr/share/pixmaps
87 post-patches::
88 @rm -f $(CURDIR)/deb_srcdir
89 @ln -s $(DEB_SRCDIR) $(CURDIR)/deb_srcdir
90 @test -x $(DEB_SRCDIR)/configure && echo "allready autoreconf" || (cd $(DEB_SRCDIR) && autoreconf -i)
92 os22-binary:: binary
93 # DEB_SRCDIR can be relative, so change into directory to use pwd.
95 # Note: that the compiler flags below depend on opensync-plugin's
96 # debian/rules having a DESTDIR target of opensync-plugin/debian/tmp
97 (cd $(DEB_SRCDIR) && \
98 export TREE_BUILD_CXXFLAGS="-I`pwd`/opensync-plugin/debian/tmp/usr/include" && \
99 export TREE_BUILD_LDFLAGS="-L`pwd`/opensync-plugin/debian/tmp/usr/lib" && \
100 export PKG_CONFIG_PATH="`pwd`:$(PKG_CONFIG_PATH)" && \
101 export LD_LIBRARY_PATH="`pwd`/opensync-plugin/debian/tmp/usr/lib:$(LD_LIBRARY_PATH)" && \
102 cd opensync-plugin && \
103 debian/rules TREE_BUILD_DIR="`pwd`/.." binary)
105 os22-clean::
106 (cd $(DEB_SRCDIR)/opensync-plugin && debian/rules clean)
108 os4x-binary:: binary
109 # DEB_SRCDIR can be relative, so change into directory to use pwd.
111 # Note: that the compiler flags below depend on opensync-plugin-0.4x's
112 # debian/rules having a DESTDIR target of opensync-plugin-0.4x/debian/tmp
113 (cd $(DEB_SRCDIR) && \
114 export TREE_BUILD_CXXFLAGS="-I`pwd`/opensync-plugin-0.4x/debian/tmp/usr/include" && \
115 export TREE_BUILD_LDFLAGS="-L`pwd`/opensync-plugin-0.4x/debian/tmp/usr/lib" && \
116 export PKG_CONFIG_PATH="`pwd`:$(PKG_CONFIG_PATH)" && \
117 export LD_LIBRARY_PATH="`pwd`/opensync-plugin-0.4x/debian/tmp/usr/lib:$(LD_LIBRARY_PATH)" && \
118 cd opensync-plugin-0.4x && \
119 debian/rules TREE_BUILD_DIR="`pwd`/.." binary)
121 os4x-clean::
122 (cd $(DEB_SRCDIR)/opensync-plugin-0.4x && debian/rules clean)
124 clean::
125 -@rm -f $(CURDIR)/deb_srcdir