- opensync module work:
[barry.git] / debian / rules
blobbe9a334000d4956be261faa9fc9d959b72e75c53
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
5 # This file was originally written by Joey Hess and Craig Small.
6 # As a special exception, when this file is copied by dh-make into a
7 # dh-make output file, you may use that output file without restriction.
8 # This special exception was added by Craig Small in version 0.37 of dh-make.
10 # Modified to make a template file for a multi-binary package with separated
11 # build-arch and build-indep targets by Bill Allombert 2001
13 # Uncomment this to turn on verbose mode.
14 #export DH_VERBOSE=1
16 # This has to be exported to make some magic below work.
17 export DH_OPTIONS
21 CFLAGS = -Wall -g
23 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
24 CFLAGS += -O0
25 else
26 CFLAGS += -O2
27 endif
29 configure: configure-stamp
31 configure-stamp:
32 dh_testdir
33 # Add here commands to configure the package.
35 touch configure-stamp
38 #Architecture
39 build: build-arch build-indep
41 build-arch: build-arch-stamp
42 build-arch-stamp: configure-stamp
44 # Add here commands to compile the arch part of the package.
45 ./configure --prefix=/usr
46 $(MAKE)
48 touch build-arch-stamp
50 build-indep: build-indep-stamp
51 build-indep-stamp: configure-stamp
53 # Add here commands to compile the indep part of the package.
54 $(MAKE) doc
55 #touch build-indep-stamp
57 clean:
58 dh_testdir
59 dh_testroot
60 rm -f build-arch-stamp build-indep-stamp #CONFIGURE-STAMP#
62 # Add here commands to clean up after the build process.
63 $(MAKE) distclean
65 dh_clean --exclude ./src/Makefile.orig
67 install: install-indep install-arch
68 install-indep:
69 dh_testdir
70 dh_testroot
71 dh_clean -k -i --exclude ./src/Makefile.orig
72 dh_installdirs -i
74 # Add here commands to install the indep part of the package into
75 # debian/<package>-doc.
76 #INSTALLDOC#
78 dh_install -i
80 install-arch:
81 dh_testdir
82 dh_testroot
83 dh_clean -k -s --exclude ./src/Makefile.orig
84 dh_installdirs -s
86 # Add here commands to install the arch part of the package into
87 # debian/tmp.
88 $(MAKE) install DESTDIR=$(CURDIR)/debian/barry
89 install -d $(CURDIR)/debian/barry/etc/udev/rules.d
90 install udev/10-blackberry.rules $(CURDIR)/debian/barry/etc/udev/rules.d/10-blackberry.rules
91 sed s/"barry"/"plugdev"/g <udev/99-barry-perms >$(CURDIR)/debian/barry/etc/udev/rules.d/99-barry-perms.rules
92 chmod 0644 $(CURDIR)/debian/barry/etc/udev/rules.d/99-barry-perms.rules
94 dh_install -s
95 # Must not depend on anything. This is to be called by
96 # binary-arch/binary-indep
97 # in another 'make' thread.
98 binary-common:
99 dh_testdir
100 dh_testroot
101 dh_installchangelogs ChangeLog
102 dh_installdocs
103 dh_installexamples
104 # dh_installmenu
105 # dh_installdebconf
106 # dh_installlogrotate
107 # dh_installemacsen
108 # dh_installpam
109 # dh_installmime
110 # dh_installinit
111 # dh_installcron
112 # dh_installinfo
113 dh_installman
114 dh_link
115 dh_strip
116 dh_compress
117 dh_fixperms
118 # dh_perl
119 # dh_python
120 dh_makeshlibs
121 dh_installdeb
122 dh_shlibdeps
123 dh_gencontrol
124 dh_md5sums
125 dh_builddeb
126 # Build architecture independant packages using the common target.
127 binary-indep: build-indep install-indep
128 $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
130 # Build architecture dependant packages using the common target.
131 binary-arch: build-arch install-arch
132 $(MAKE) -f debian/rules DH_OPTIONS=-a binary-common
134 binary: binary-arch binary-indep
135 .PHONY: build clean binary-indep binary-arch binary install install-indep install-arch configure