ppp: added barry-minimal
[barry.git] / rpm / barry.spec
blobc336a3e4fc297ac67a99f081b0aa92660da1f8d7
1 %dump
3 # always build with GUI
4 %define with_gui 1
6 # Fedora 9 doesn't support opensync 0.22
7 %if 0%{?fc9}
8 %define with_opensync 0
9 %else
10 %define with_opensync 1
11 %endif
13 %if 0%{?fc12} || 0%{?fc13}
14 %define use_69_rules 1
15 %else
16 %define use_69_rules 0
17 %endif
20 Summary: BlackBerry(tm) Desktop for Linux
21 Name: barry
22 Version: 0.17.0
23 Release: 0
24 Group: Applications/Productivity
25 License: GPLv2+
26 Source: %{name}-%{version}.tar.bz2
27 URL: http://www.netdirect.ca/software/packages/barry
28 Vendor: Net Direct Inc.
29 BuildRoot: %{_tmppath}/%{name}-%{release}-%{version}-root
31 %if 0%{?suse_version}
32 BuildRequires: libusb, gcc-c++, pkgconfig, boost-devel, fuse-devel, zlib-devel
33 %else
34 BuildRequires: libusb-devel, gcc-c++, pkgconfig, boost-devel, fuse-devel, zlib-devel
35 %endif
37 %if %{with_gui}
38 BuildRequires: desktop-file-utils
39 %endif
41 %define barryroot %{_builddir}/%{name}-%{version}
43 %description
44 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
45 is a registered trademark of Research in Motion Limited.)
48 %package -n libbarry0
49 Summary: BlackBerry(tm) Desktop for Linux - libbarry libraries
50 Group: Development/Libraries
51 Requires: libusb boost
53 %description -n libbarry0
54 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
55 is a registered trademark of Research in Motion Limited.)
57 This package contains the library files, license agreement, README file,
58 and most other assorted documentation common to all sub-packages. You most
59 likely want to also install barry-util and barry-gui.
62 %package -n libbarry-devel
63 Summary: BlackBerry(tm) Desktop for Linux - libbarry libraries
64 Group: Development/Libraries
65 %if 0%{?suse_version}
66 Requires: libbarry0 libusb boost-devel
67 %else
68 Requires: libbarry0 libusb-devel boost-devel
69 %endif
71 %description -n libbarry-devel
72 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
73 is a registered trademark of Research in Motion Limited.)
75 This package contains the development library files for Barry, libbarry.
78 %package util
79 Summary: BlackBerry(tm) Desktop for Linux - bcharge, btool, breset, bio and others
80 Group: Applications/Productivity
81 Requires: libbarry0 fuse
82 Conflicts: barry-bcharge
84 %description util
85 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
86 is a registered trademark of Research in Motion Limited.)
88 This package contains the commandline tools bcharge, btool, breset, bio and
89 others which will enable you to charge your device with a proper 500mA
90 and be able to access the data on the device in many ways.
93 %if %{with_gui}
94 %package gui
95 Summary: BlackBerry(tm) Desktop for Linux - bcharge, btool, breset and others
96 Group: Applications/Productivity
97 %if 0%{?suse_version}
98 Requires: libbarry0 gtkmm2 libglademm libtar
99 BuildRequires: gtkmm2-devel libglademm-devel libtar-devel
100 %else
101 Requires: libbarry0 gtkmm24 libglademm24 libtar
102 BuildRequires: gtkmm24-devel libglademm24-devel libtar-devel
103 %endif
105 %description gui
106 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
107 is a registered trademark of Research in Motion Limited.)
109 This package contains the GUI applications built on top of libbarry.
110 %endif
113 %if %{with_opensync}
114 %package opensync
115 Summary: BlackBerry(tm) Desktop for Linux - opensync plugin
116 Group: Applications/Productivity
117 Requires: libbarry0, libopensync >= 0.22
118 BuildRequires: libopensync-devel
120 %description opensync
121 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
122 is a registered trademark of Research in Motion Limited.)
124 This package contains the opensync plugin.
125 %endif
127 %prep
128 %setup -q
130 %build
131 # main tree
132 %{configure} --enable-boost --enable-nls --with-zlib
133 %{__make} %{?_smp_mflags}
135 # gui tree
136 %if %{with_gui}
137 cd gui/
138 %{configure} PKG_CONFIG_PATH="..:$PKG_CONFIG_PATH" CXXFLAGS="-I../.." LDFLAGS="-L../../src" --enable-nls
139 %{__make} %{?_smp_mflags}
140 cd ../
141 %endif
143 # opensync tree
144 %if %{with_opensync}
145 cd opensync-plugin/
146 %{configure} PKG_CONFIG_PATH="..:$PKG_CONFIG_PATH" CXXFLAGS="-I../.." LDFLAGS="-L../../src" --enable-nls
147 %{__make} %{?_smp_mflags}
148 cd ../
149 %endif
151 %install
152 # main tree
153 %{__make} DESTDIR=%{buildroot} install
154 # delete some test-only programs
155 %{__rm} -f %{buildroot}%{_bindir}/bdptest
156 %{__rm} -f %{buildroot}%{_bindir}/bjvmdebug
157 # proceed as usual...
158 %{__mkdir_p} %{buildroot}%{_sysconfdir}/udev/rules.d
159 %{__cp} udev/10-blackberry.rules %{buildroot}%{_sysconfdir}/udev/rules.d/
160 %if %{use_69_rules}
161 %{__cp} udev/69-blackberry.rules %{buildroot}%{_sysconfdir}/udev/rules.d/
162 %else
163 %{__cp} udev/99-blackberry-perms.rules %{buildroot}%{_sysconfdir}/udev/rules.d/
164 %endif
165 %{__mkdir_p} %{buildroot}%{_sysconfdir}/modprobe.d
166 %{__cp} modprobe/blacklist-berry_charge.conf %{buildroot}%{_sysconfdir}/modprobe.d/
167 %{__mkdir_p} %{buildroot}%{_sysconfdir}/ppp/peers
168 %{__cp} ppp/barry-rogers %{buildroot}%{_sysconfdir}/ppp/peers/
169 %{__cp} ppp/barry-minimal %{buildroot}%{_sysconfdir}/ppp/peers/
170 %{__cp} ppp/barry-verizon %{buildroot}%{_sysconfdir}/ppp/peers/
171 %{__cp} ppp/barry-sprint %{buildroot}%{_sysconfdir}/ppp/peers/
172 %{__cp} ppp/barry-telus %{buildroot}%{_sysconfdir}/ppp/peers/
173 %{__cp} ppp/barry-o2ireland %{buildroot}%{_sysconfdir}/ppp/peers/
174 %{__cp} ppp/barry-tmobileus %{buildroot}%{_sysconfdir}/ppp/peers/
175 %{__cp} ppp/barry-att_cingular %{buildroot}%{_sysconfdir}/ppp/peers/
176 %{__cp} ppp/barry-chinamobile %{buildroot}%{_sysconfdir}/ppp/peers/
177 %{__cp} ppp/barry-kpn %{buildroot}%{_sysconfdir}/ppp/peers/
178 %{__cp} ppp/barry-orange-spain %{buildroot}%{_sysconfdir}/ppp/peers/
179 %{__mkdir_p} %{buildroot}%{_sysconfdir}/chatscripts
180 %{__cp} ppp/barry-rogers.chat %{buildroot}%{_sysconfdir}/chatscripts/
181 %{__cp} ppp/barry-minimal.chat %{buildroot}%{_sysconfdir}/chatscripts/
182 %{__cp} ppp/barry-verizon.chat %{buildroot}%{_sysconfdir}/chatscripts/
183 %{__cp} ppp/barry-sprint.chat %{buildroot}%{_sysconfdir}/chatscripts/
184 %{__cp} ppp/barry-telus.chat %{buildroot}%{_sysconfdir}/chatscripts/
185 %{__cp} ppp/barry-o2ireland.chat %{buildroot}%{_sysconfdir}/chatscripts/
186 %{__cp} ppp/barry-tmobileus.chat %{buildroot}%{_sysconfdir}/chatscripts/
187 %{__cp} ppp/barry-att_cingular.chat %{buildroot}%{_sysconfdir}/chatscripts/
188 %{__cp} ppp/barry-chinamobile.chat %{buildroot}%{_sysconfdir}/chatscripts/
189 %{__cp} ppp/barry-kpn.chat %{buildroot}%{_sysconfdir}/chatscripts/
190 %{__cp} ppp/barry-orange-spain.chat %{buildroot}%{_sysconfdir}/chatscripts/
191 # Install hal fdi config
192 %{__mkdir_p} %{buildroot}%{_datadir}/hal/fdi/information/10freedesktop
193 %{__mkdir_p} %{buildroot}%{_datadir}/hal/fdi/policy/10osvendor
194 %{__cp} hal/fdi/information/10freedesktop/10-blackberry.fdi %{buildroot}%{_datadir}/hal/fdi/information/10freedesktop
195 %{__cp} hal/fdi/policy/10osvendor/19-blackberry-acl.fdi %{buildroot}%{_datadir}/hal/fdi/policy/10osvendor
196 # Install hal support script
197 %{__mkdir_p} %{buildroot}%{_bindir}
198 %{__cp} hal/hal-blackberry %{buildroot}%{_bindir}
199 # Install bash completion scripts
200 %{__mkdir_p} %{buildroot}%{_sysconfdir}/bash_completion.d
201 %{__cp} bash/bjavaloader %{buildroot}%{_sysconfdir}/bash_completion.d
202 %{__cp} bash/btool %{buildroot}%{_sysconfdir}/bash_completion.d
204 # gui tree
205 %if %{with_gui}
206 cd gui/
207 %{__make} DESTDIR=%{buildroot} install
208 # Install barry logo icon
209 cd ../
210 %{__mkdir_p} %{buildroot}%{_datadir}/pixmaps
211 %{__cp} logo/barry_logo_icon.png %{buildroot}%{_datadir}/pixmaps
212 desktop-file-install --vendor netdirect \
213 --dir %{buildroot}%{_datadir}/applications \
214 menu/barrybackup.desktop
215 %endif
217 # opensync tree
218 %if %{with_opensync}
219 cd opensync-plugin/
220 %{__make} DESTDIR=%{buildroot} install
221 cd ../
222 %endif
224 %files -n libbarry0
225 %defattr(-,root,root)
226 %attr(-,root,root) %{_libdir}/*.so*
227 %doc AUTHORS ChangeLog COPYING NEWS README
229 %files -n libbarry-devel
230 %defattr(-,root,root)
231 %attr(0644,root,root) %{_includedir}/barry/*
232 %attr(0644,root,root) %{_libdir}/*.a
233 %attr(0755,root,root) %{_libdir}/*.la
234 %attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
235 %doc COPYING TODO doc/* examples/*.cc
237 %files util
238 %defattr(-,root,root)
239 %attr(0755,root,root) %{_sbindir}/bcharge
240 %attr(0755,root,root) %{_sbindir}/breset
241 %attr(0755,root,root) %{_sbindir}/pppob
242 %attr(0755,root,root) %{_bindir}/btool
243 %attr(0755,root,root) %{_bindir}/bio
244 %attr(0755,root,root) %{_bindir}/btardump
245 %attr(0755,root,root) %{_bindir}/bfuse
246 %attr(0755,root,root) %{_bindir}/bjavaloader
247 %attr(0755,root,root) %{_bindir}/balxparse
248 %attr(0755,root,root) %{_bindir}/bjdwp
249 %attr(0755,root,root) %{_bindir}/brawchannel
250 %attr(0755,root,root) %{_bindir}/bs11nread
251 %attr(0755,root,root) %{_bindir}/bidentify
252 %attr(0755,root,root) %{_bindir}/brecsum
253 %attr(0755,root,root) %{_bindir}/upldif
254 %attr(0755,root,root) %{_bindir}/bktrans
255 %attr(0755,root,root) %{_bindir}/btranslate
256 %attr(0755,root,root) %{_bindir}/brimtrans
257 %attr(0755,root,root) %{_bindir}/hal-blackberry
258 %attr(0644,root,root) %{_mandir}/man1/btool*
259 %attr(0644,root,root) %{_mandir}/man1/bio*
260 %attr(0644,root,root) %{_mandir}/man1/btardump*
261 %attr(0644,root,root) %{_mandir}/man1/bfuse*
262 %attr(0644,root,root) %{_mandir}/man1/bjavaloader*
263 %attr(0644,root,root) %{_mandir}/man1/balxparse*
264 %attr(0644,root,root) %{_mandir}/man1/bjdwp*
265 %attr(0644,root,root) %{_mandir}/man1/brawchannel*
266 %attr(0644,root,root) %{_mandir}/man1/bs11nread*
267 %attr(0644,root,root) %{_mandir}/man1/bidentify*
268 %attr(0644,root,root) %{_mandir}/man1/bcharge*
269 %attr(0644,root,root) %{_mandir}/man1/pppob*
270 %attr(0644,root,root) %{_mandir}/man1/brecsum*
271 %attr(0644,root,root) %{_mandir}/man1/breset*
272 %attr(0644,root,root) %{_mandir}/man1/upldif*
273 %attr(0644,root,root) %{_datadir}/locale/*
274 %attr(0644,root,root) %{_datadir}/hal/fdi/information/10freedesktop/10-blackberry.fdi
275 %attr(0644,root,root) %{_datadir}/hal/fdi/policy/10osvendor/19-blackberry-acl.fdi
276 %attr(0644,root,root) %config %{_sysconfdir}/udev/rules.d/*
277 %attr(0644,root,root) %config %{_sysconfdir}/modprobe.d/blacklist-berry_charge.conf
278 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-rogers
279 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-minimal
280 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-verizon
281 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-sprint
282 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-telus
283 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-o2ireland
284 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-tmobileus
285 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-att_cingular
286 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-chinamobile
287 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-kpn
288 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-orange-spain
289 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-rogers.chat
290 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-minimal.chat
291 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-verizon.chat
292 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-sprint.chat
293 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-telus.chat
294 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-o2ireland.chat
295 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-tmobileus.chat
296 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-att_cingular.chat
297 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-chinamobile.chat
298 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-kpn.chat
299 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-orange-spain.chat
300 %attr(0640,root,root) %config %{_sysconfdir}/bash_completion.d/bjavaloader
301 %attr(0640,root,root) %config %{_sysconfdir}/bash_completion.d/btool
302 %doc COPYING
303 %doc zsh
304 %doc ppp/README
306 %if %{with_gui}
307 %files gui
308 %defattr(-,root,root)
309 %attr(0755,root,root) %{_bindir}/barrybackup
310 %attr(0644,root,root) %{_datadir}/barry/glade/*.glade
311 %attr(0644,root,root) %{_datadir}/pixmaps/barry_logo_icon.png
312 %attr(0644,root,root) %{_datadir}/applications/*barrybackup.desktop
313 %attr(0644,root,root) %{_mandir}/man1/barrybackup*
314 %doc COPYING
315 %endif
317 %if %{with_opensync}
318 %files opensync
319 %defattr(-,root,root)
320 %attr(0755,root,root) %{_libdir}/opensync/plugins/*
321 %attr(0644,root,root) %{_datadir}/opensync/defaults/*
322 %doc COPYING
323 %endif
325 %clean
326 [ "%{buildroot}" != "/" ] && %{__rm} -rf %{buildroot}
327 [ "%{barryroot}" != "/" ] && %{__rm} -rf %{barryroot}
329 %post -n libbarry0
330 /sbin/ldconfig
332 %postun -n libbarry0
333 /sbin/ldconfig
335 %changelog
336 * Fri May 28 2010 Chris Frey <cdfrey@foursquare.net> 0.17.0-0
337 - version bump
338 - added NLS support
339 - cleaned up conditionals
340 - added Fedora 13 support
341 - added new ppp chat script for Orange Spain
342 - added copy of barry-sprint as barry-telus
343 - added brawchannel, btardump, bio, and balxparse
345 * Sat Sep 29 2009 Chris Frey <cdfrey@foursquare.net> 0.16-0
346 - version bump
347 - added new ppp chat script for KPN Nederland
348 - using new udev rules set
349 - added bjdwp and manpage, and removed some test-only programs
350 - added bash and zsh completion scripts
351 - added .desktop file and icon for barrybackup
353 * Fri Apr 10 2009 Chris Frey <cdfrey@foursquare.net> 0.15-0
354 - version bump
355 - added HAL FDI scripts
356 - added bjavaloader and bfuse
357 - updated for udev directory reorganization in Barry source tree
358 - added zlib-devel to BuildRequires list
359 - added brimtrans
361 * Wed Sep 24 2008 Chris Frey <cdfrey@foursquare.net> 0.14-0
362 - version bump
363 - added new ppp chat script for T-Mobile US
364 - renamed libbarry to libbarry0
366 * Thu May 29 2008 Chris Frey <cdfrey@foursquare.net> 0.13-1
367 - version bump
368 - added brecsum
369 - added ppp options and chat scripts
370 - added manpages for pppob, brecsum, breset, upldif, barrybackup
371 - spec file now assumes gui and opensync, with conditional checks depending on host
373 * Fri Dec 07 2007 Chris Frey <cdfrey@foursquare.net> 0.12-1
374 - version bump
376 * Fri Nov 30 2007 Chris Frey <cdfrey@foursquare.net> 0.11-1
377 - version bump
379 * Fri Nov 30 2007 Chris Frey <cdfrey@foursquare.net> 0.10-1
380 - version bump
381 - removed ktrans and translate from rpm package
382 - added bidentify
384 * Thu Aug 09 2007 Chris Frey <cdfrey@foursquare.net> 0.9-1
385 - version bump
387 * Fri Aug 03 2007 Chris Frey <cdfrey@foursquare.net> 0.8-1
388 - version bump
389 - changed tarball to bz2
391 * Tue May 01 2007 Chris Frey <cdfrey@foursquare.net> 0.7-2
392 - added pppob to utils
394 * Thu Mar 08 2007 Chris Frey <cdfrey@foursquare.net> 0.7-1
395 - removed barry base package that only contained docs, and put docs in libbarry*
396 - changed barrybackup reference to barry-gui
397 - removed the patch step, as version 0.7 shouldn't need it
398 - added license file to each package
400 * Sun Mar 04 2007 Troy Engel <tengel@users.sourceforge.net> 0.6-1
401 - initial build
402 - adding udev and console perms patch for raw 0.6