3 # Sample debian/rules that uses debhelper.
5 # This file was originally written by Joey Hess and Craig Small.
6 # As a special exception, when this file is copied by dh-make into a
7 # dh-make output file, you may use that output file without restriction.
8 # This special exception was added by Craig Small in version 0.37 of dh-make.
10 # Modified to make a template file for a multi-binary package with separated
11 # build-arch and build-indep targets by Bill Allombert 2001
13 # Uncomment this to turn on verbose mode.
16 # This has to be exported to make some magic below work.
23 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
29 configure
: configure-stamp
32 # Add here commands to configure the package.
38 build
: build-arch build-indep
40 build-arch
: build-arch-stamp
41 build-arch-stamp
: configure-stamp
43 # Add here commands to compile the arch part of the package.
45 g
++-3.3 -Wall
-o tools
/bcharge tools
/bcharge.
cc -lusb
47 touch build-arch-stamp
49 build-indep
: build-indep-stamp
50 build-indep-stamp
: configure-stamp
52 # Add here commands to compile the indep part of the package.
54 touch build-indep-stamp
59 rm -f build-arch-stamp build-indep-stamp
#CONFIGURE-STAMP#
61 # Add here commands to clean up after the build process.
66 dh_clean
--exclude .
/src
/Makefile.orig
68 install: install-indep install-arch
72 dh_clean
-k
-i
--exclude .
/src
/Makefile.orig
75 # Add here commands to install the indep part of the package into
76 # debian/<package>-doc.
84 dh_clean
-k
-s
--exclude .
/src
/Makefile.orig
87 # Add here commands to install the arch part of the package into
89 #$(MAKE) install DESTDIR=$(CURDIR)/debian/barry
90 install -d
$(CURDIR
)/debian
/barry
/usr
/sbin
91 install -d
$(CURDIR
)/debian
/barry
/etc
/udev
/rules.d
92 install tools
/bcharge
$(CURDIR
)/debian
/barry
/usr
/sbin
93 install udev
/10-blackberry.rules.Debian
$(CURDIR
)/debian
/barry
/etc
/udev
/rules.d
/10-blackberry.rules
96 # Must not depend on anything. This is to be called by
97 # binary-arch/binary-indep
98 # in another 'make' thread.
102 dh_installchangelogs ChangeLog
107 # dh_installlogrotate
127 # Build architecture independant packages using the common target.
128 binary-indep
: build-indep install-indep
129 $(MAKE
) -f debian
/rules DH_OPTIONS
=-i binary-common
131 # Build architecture dependant packages using the common target.
132 binary-arch
: build-arch install-arch
133 $(MAKE
) -f debian
/rules DH_OPTIONS
=-a binary-common
135 binary
: binary-arch binary-indep
136 .PHONY
: build
clean binary-indep binary-arch binary
install install-indep install-arch configure