3 # always build with GUI
6 # Fedora 9 doesn't support opensync 0.22
8 %define with_opensync
0
10 %define with_opensync
1
13 %if 0%{?fc12} || 0%{?fc13}
14 %define use_69_rules
1
16 %define use_69_rules
0
20 Summary: BlackBerry
(tm
) Desktop
for Linux
24 Group: Applications
/Productivity
26 Source: %{name}-%{version}.tar.bz2
27 URL: http
://www.netdirect.ca
/software
/packages
/barry
28 Vendor: Net Direct Inc.
29 BuildRoot: %{_tmppath}/%{name}-%{release}-%{version}-root
32 BuildRequires
: libusb
, gcc
-c
++, pkgconfig
, boost
-devel
, fuse
-devel
, zlib
-devel
34 BuildRequires
: libusb
-devel
, gcc
-c
++, pkgconfig
, boost
-devel
, fuse
-devel
, zlib
-devel
38 BuildRequires
: desktop
-file
-utils
41 %define barryroot
%{_builddir}/%{name}-%{version}
44 Barry is a desktop toolset
for managing your BlackBerry
(tm
) device.
(BlackBerry
45 is a registered trademark of Research
in Motion Limited.
)
49 Summary: BlackBerry
(tm
) Desktop
for Linux
- libbarry libraries
50 Group: Development
/Libraries
51 Requires: libusb boost
53 %description -n libbarry0
54 Barry is a desktop toolset
for managing your BlackBerry
(tm
) device.
(BlackBerry
55 is a registered trademark of Research
in Motion Limited.
)
57 This package contains the library files
, license agreement
, README file
,
58 and most other assorted documentation common to all sub
-packages. You most
59 likely want to also
install barry
-util and barry
-gui.
62 %package -n libbarry
-devel
63 Summary: BlackBerry
(tm
) Desktop
for Linux
- libbarry libraries
64 Group: Development
/Libraries
66 Requires: libbarry0 libusb boost
-devel
68 Requires: libbarry0 libusb
-devel boost
-devel
71 %description -n libbarry
-devel
72 Barry is a desktop toolset
for managing your BlackBerry
(tm
) device.
(BlackBerry
73 is a registered trademark of Research
in Motion Limited.
)
75 This package contains the development library files
for Barry
, libbarry.
79 Summary: BlackBerry
(tm
) Desktop
for Linux
- bcharge
, btool
, breset and others
80 Group: Applications
/Productivity
81 Requires: libbarry0 fuse
82 Conflicts: barry
-bcharge
85 Barry is a desktop toolset
for managing your BlackBerry
(tm
) device.
(BlackBerry
86 is a registered trademark of Research
in Motion Limited.
)
88 This package contains the commandline tools bcharge
, btool
, breset and others
89 which will
enable you to charge your device with a proper
500mA and be able
90 to access the data on the device
in many ways.
95 Summary: BlackBerry
(tm
) Desktop
for Linux
- bcharge
, btool
, breset and others
96 Group: Applications
/Productivity
98 Requires: libbarry0 gtkmm2 libglademm libtar
99 BuildRequires
: gtkmm2
-devel libglademm
-devel libtar
-devel
101 Requires: libbarry0 gtkmm24 libglademm24 libtar
102 BuildRequires
: gtkmm24
-devel libglademm24
-devel libtar
-devel
106 Barry is a desktop toolset
for managing your BlackBerry
(tm
) device.
(BlackBerry
107 is a registered trademark of Research
in Motion Limited.
)
109 This package contains the GUI applications built on top of libbarry.
115 Summary: BlackBerry
(tm
) Desktop
for Linux
- opensync plugin
116 Group: Applications
/Productivity
117 Requires: libbarry0
, libopensync
>= 0.22
118 BuildRequires
: libopensync
-devel
120 %description opensync
121 Barry is a desktop toolset
for managing your BlackBerry
(tm
) device.
(BlackBerry
122 is a registered trademark of Research
in Motion Limited.
)
124 This package contains the opensync plugin.
132 %{configure} --enable-boost
--enable-nls
--with
-zlib
133 %{__make} %{?_smp_mflags}
138 %{configure} PKG_CONFIG_PATH
="..
:$PKG_CONFIG_PATH" CXXFLAGS
="
-I..
/.." LDFLAGS
="
-L..
/..
/src"
--enable-nls
139 %{__make} %{?_smp_mflags}
146 %{configure} PKG_CONFIG_PATH
="..
:$PKG_CONFIG_PATH" CXXFLAGS
="
-I..
/.." LDFLAGS
="
-L..
/..
/src"
--enable-nls
147 %{__make} %{?_smp_mflags}
153 %{__make} DESTDIR=%{buildroot} install
154 # delete some test-only programs
155 %{__rm} -f %{buildroot}%{_bindir}/bdptest
156 %{__rm} -f %{buildroot}%{_bindir}/bjvmdebug
157 # proceed as usual...
158 %{__mkdir_p} %{buildroot}%{_sysconfdir}/udev
/rules.d
159 %{__cp} udev/10-blackberry.rules %{buildroot}%{_sysconfdir}/udev
/rules.d
/
161 %{__cp} udev/69-blackberry.rules %{buildroot}%{_sysconfdir}/udev
/rules.d
/
163 %{__cp} udev/99-blackberry-perms.rules %{buildroot}%{_sysconfdir}/udev
/rules.d
/
165 %{__mkdir_p} %{buildroot}%{_sysconfdir}/modprobe.d
166 %{__cp} modprobe/blacklist-berry_charge.conf %{buildroot}%{_sysconfdir}/modprobe.d
/
167 %{__mkdir_p} %{buildroot}%{_sysconfdir}/ppp
/peers
168 %{__cp} ppp/barry-rogers %{buildroot}%{_sysconfdir}/ppp
/peers
/
169 %{__cp} ppp/barry-verizon %{buildroot}%{_sysconfdir}/ppp
/peers
/
170 %{__cp} ppp/barry-sprint %{buildroot}%{_sysconfdir}/ppp
/peers
/
171 %{__cp} ppp/barry-telus %{buildroot}%{_sysconfdir}/ppp
/peers
/
172 %{__cp} ppp/barry-o2ireland %{buildroot}%{_sysconfdir}/ppp
/peers
/
173 %{__cp} ppp/barry-tmobileus %{buildroot}%{_sysconfdir}/ppp
/peers
/
174 %{__cp} ppp/barry-att_cingular %{buildroot}%{_sysconfdir}/ppp
/peers
/
175 %{__cp} ppp/barry-chinamobile %{buildroot}%{_sysconfdir}/ppp
/peers
/
176 %{__cp} ppp/barry-kpn %{buildroot}%{_sysconfdir}/ppp
/peers
/
177 %{__cp} ppp/barry-orange-spain %{buildroot}%{_sysconfdir}/ppp
/peers
/
178 %{__mkdir_p} %{buildroot}%{_sysconfdir}/chatscripts
179 %{__cp} ppp/barry-rogers.chat %{buildroot}%{_sysconfdir}/chatscripts
/
180 %{__cp} ppp/barry-verizon.chat %{buildroot}%{_sysconfdir}/chatscripts
/
181 %{__cp} ppp/barry-sprint.chat %{buildroot}%{_sysconfdir}/chatscripts
/
182 %{__cp} ppp/barry-telus.chat %{buildroot}%{_sysconfdir}/chatscripts
/
183 %{__cp} ppp/barry-o2ireland.chat %{buildroot}%{_sysconfdir}/chatscripts
/
184 %{__cp} ppp/barry-tmobileus.chat %{buildroot}%{_sysconfdir}/chatscripts
/
185 %{__cp} ppp/barry-att_cingular.chat %{buildroot}%{_sysconfdir}/chatscripts
/
186 %{__cp} ppp/barry-chinamobile.chat %{buildroot}%{_sysconfdir}/chatscripts
/
187 %{__cp} ppp/barry-kpn.chat %{buildroot}%{_sysconfdir}/chatscripts
/
188 %{__cp} ppp/barry-orange-spain.chat %{buildroot}%{_sysconfdir}/chatscripts
/
189 # Install hal fdi config
190 %{__mkdir_p} %{buildroot}%{_datadir}/hal
/fdi
/information
/10freedesktop
191 %{__mkdir_p} %{buildroot}%{_datadir}/hal
/fdi
/policy
/10osvendor
192 %{__cp} hal/fdi/information/10freedesktop/10-blackberry.fdi %{buildroot}%{_datadir}/hal
/fdi
/information
/10freedesktop
193 %{__cp} hal/fdi/policy/10osvendor/19-blackberry-acl.fdi %{buildroot}%{_datadir}/hal
/fdi
/policy
/10osvendor
194 # Install hal support script
195 %{__mkdir_p} %{buildroot}%{_bindir}
196 %{__cp} hal/hal-blackberry %{buildroot}%{_bindir}
197 # Install bash completion scripts
198 %{__mkdir_p} %{buildroot}%{_sysconfdir}/bash_completion.d
199 %{__cp} bash/bjavaloader %{buildroot}%{_sysconfdir}/bash_completion.d
200 %{__cp} bash/btool %{buildroot}%{_sysconfdir}/bash_completion.d
205 %{__make} DESTDIR=%{buildroot} install
206 # Install barry logo icon
208 %{__mkdir_p} %{buildroot}%{_datadir}/pixmaps
209 %{__cp} logo/barry_logo_icon.png %{buildroot}%{_datadir}/pixmaps
210 desktop
-file
-install --vendor netdirect \
211 --dir
%{buildroot}%{_datadir}/applications \
212 menu
/barrybackup.desktop
218 %{__make} DESTDIR=%{buildroot} install
223 %defattr(-,root
,root
)
224 %attr(-,root
,root
) %{_libdir}/*.so
*
225 %doc AUTHORS ChangeLog COPYING NEWS README
227 %files -n libbarry
-devel
228 %defattr(-,root
,root
)
229 %attr(0644,root
,root
) %{_includedir}/barry
/*
230 %attr(0644,root
,root
) %{_libdir}/*.a
231 %attr(0755,root
,root
) %{_libdir}/*.la
232 %attr(0644,root
,root
) %{_libdir}/pkgconfig
/*.pc
233 %doc COPYING TODO doc
/* examples
/*.cc
236 %defattr(-,root
,root
)
237 %attr(0755,root
,root
) %{_sbindir}/bcharge
238 %attr(0755,root
,root
) %{_sbindir}/breset
239 %attr(0755,root
,root
) %{_sbindir}/pppob
240 %attr(0755,root
,root
) %{_bindir}/btool
241 %attr(0755,root
,root
) %{_bindir}/btardump
242 %attr(0755,root
,root
) %{_bindir}/bfuse
243 %attr(0755,root
,root
) %{_bindir}/bjavaloader
244 %attr(0755,root
,root
) %{_bindir}/bjdwp
245 %attr(0755,root
,root
) %{_bindir}/brawchannel
246 %attr(0755,root
,root
) %{_bindir}/bs11nread
247 %attr(0755,root
,root
) %{_bindir}/bidentify
248 %attr(0755,root
,root
) %{_bindir}/brecsum
249 %attr(0755,root
,root
) %{_bindir}/upldif
250 %attr(0755,root
,root
) %{_bindir}/bktrans
251 %attr(0755,root
,root
) %{_bindir}/btranslate
252 %attr(0755,root
,root
) %{_bindir}/brimtrans
253 %attr(0755,root
,root
) %{_bindir}/hal
-blackberry
254 %attr(0644,root
,root
) %{_mandir}/man1
/btool
*
255 %attr(0644,root
,root
) %{_mandir}/man1
/btardump
*
256 %attr(0644,root
,root
) %{_mandir}/man1
/bfuse
*
257 %attr(0644,root
,root
) %{_mandir}/man1
/bjavaloader
*
258 %attr(0644,root
,root
) %{_mandir}/man1
/bjdwp
*
259 %attr(0644,root
,root
) %{_mandir}/man1
/brawchannel
*
260 %attr(0644,root
,root
) %{_mandir}/man1
/bs11nread
*
261 %attr(0644,root
,root
) %{_mandir}/man1
/bidentify
*
262 %attr(0644,root
,root
) %{_mandir}/man1
/bcharge
*
263 %attr(0644,root
,root
) %{_mandir}/man1
/pppob
*
264 %attr(0644,root
,root
) %{_mandir}/man1
/brecsum
*
265 %attr(0644,root
,root
) %{_mandir}/man1
/breset
*
266 %attr(0644,root
,root
) %{_mandir}/man1
/upldif
*
267 %attr(0644,root
,root
) %{_datadir}/locale
/*
268 %attr(0644,root
,root
) %{_datadir}/hal
/fdi
/information
/10freedesktop
/10-blackberry.fdi
269 %attr(0644,root
,root
) %{_datadir}/hal
/fdi
/policy
/10osvendor
/19-blackberry
-acl.fdi
270 %attr(0644,root
,root
) %config %{_sysconfdir}/udev
/rules.d
/*
271 %attr(0644,root
,root
) %config %{_sysconfdir}/modprobe.d
/blacklist
-berry_charge.conf
272 %attr(0644,root
,root
) %config %{_sysconfdir}/ppp
/peers
/barry
-rogers
273 %attr(0644,root
,root
) %config %{_sysconfdir}/ppp
/peers
/barry
-verizon
274 %attr(0644,root
,root
) %config %{_sysconfdir}/ppp
/peers
/barry
-sprint
275 %attr(0644,root
,root
) %config %{_sysconfdir}/ppp
/peers
/barry
-telus
276 %attr(0644,root
,root
) %config %{_sysconfdir}/ppp
/peers
/barry
-o2ireland
277 %attr(0644,root
,root
) %config %{_sysconfdir}/ppp
/peers
/barry
-tmobileus
278 %attr(0644,root
,root
) %config %{_sysconfdir}/ppp
/peers
/barry
-att_cingular
279 %attr(0644,root
,root
) %config %{_sysconfdir}/ppp
/peers
/barry
-chinamobile
280 %attr(0644,root
,root
) %config %{_sysconfdir}/ppp
/peers
/barry
-kpn
281 %attr(0644,root
,root
) %config %{_sysconfdir}/ppp
/peers
/barry
-orange
-spain
282 %attr(0640,root
,root
) %config %{_sysconfdir}/chatscripts
/barry
-rogers.chat
283 %attr(0640,root
,root
) %config %{_sysconfdir}/chatscripts
/barry
-verizon.chat
284 %attr(0640,root
,root
) %config %{_sysconfdir}/chatscripts
/barry
-sprint.chat
285 %attr(0640,root
,root
) %config %{_sysconfdir}/chatscripts
/barry
-telus.chat
286 %attr(0640,root
,root
) %config %{_sysconfdir}/chatscripts
/barry
-o2ireland.chat
287 %attr(0640,root
,root
) %config %{_sysconfdir}/chatscripts
/barry
-tmobileus.chat
288 %attr(0640,root
,root
) %config %{_sysconfdir}/chatscripts
/barry
-att_cingular.chat
289 %attr(0640,root
,root
) %config %{_sysconfdir}/chatscripts
/barry
-chinamobile.chat
290 %attr(0640,root
,root
) %config %{_sysconfdir}/chatscripts
/barry
-kpn.chat
291 %attr(0640,root
,root
) %config %{_sysconfdir}/chatscripts
/barry
-orange
-spain.chat
292 %attr(0640,root
,root
) %config %{_sysconfdir}/bash_completion.d
/bjavaloader
293 %attr(0640,root
,root
) %config %{_sysconfdir}/bash_completion.d
/btool
300 %defattr(-,root
,root
)
301 %attr(0755,root
,root
) %{_bindir}/barrybackup
302 %attr(0644,root
,root
) %{_datadir}/barry
/glade
/*.glade
303 %attr(0644,root
,root
) %{_datadir}/pixmaps
/barry_logo_icon.png
304 %attr(0644,root
,root
) %{_datadir}/applications
/*barrybackup.desktop
305 %attr(0644,root
,root
) %{_mandir}/man1
/barrybackup
*
311 %defattr(-,root
,root
)
312 %attr(0755,root
,root
) %{_libdir}/opensync
/plugins
/*
313 %attr(0644,root
,root
) %{_datadir}/opensync
/defaults
/*
318 [ "
%{buildroot}" != "/" ] && %{__rm} -rf %{buildroot}
319 [ "
%{barryroot}" != "/" ] && %{__rm} -rf %{barryroot}
328 * Fri May
28 2010 Chris Frey
<cdfrey@foursquare.net
> 0.17.0-0
331 - cleaned up conditionals
332 - added Fedora
13 support
333 - added new ppp chat script
for Orange Spain
334 - added copy of barry
-sprint as barry
-telus
337 * Sat Sep
29 2009 Chris Frey
<cdfrey@foursquare.net
> 0.16-0
339 - added new ppp chat script
for KPN Nederland
340 - using new udev rules
set
341 - added bjdwp and manpage
, and removed some
test-only programs
342 - added bash and zsh completion scripts
343 - added .desktop file and icon
for barrybackup
345 * Fri Apr
10 2009 Chris Frey
<cdfrey@foursquare.net
> 0.15-0
347 - added HAL FDI scripts
348 - added bjavaloader and bfuse
349 - updated
for udev directory reorganization
in Barry
source tree
350 - added zlib
-devel to BuildRequires list
353 * Wed Sep
24 2008 Chris Frey
<cdfrey@foursquare.net
> 0.14-0
355 - added new ppp chat script
for T
-Mobile US
356 - renamed libbarry to libbarry0
358 * Thu May
29 2008 Chris Frey
<cdfrey@foursquare.net
> 0.13-1
361 - added ppp options and chat scripts
362 - added manpages
for pppob
, brecsum
, breset
, upldif
, barrybackup
363 - spec file now assumes gui and opensync
, with conditional checks depending on host
365 * Fri Dec
07 2007 Chris Frey
<cdfrey@foursquare.net
> 0.12-1
368 * Fri Nov
30 2007 Chris Frey
<cdfrey@foursquare.net
> 0.11-1
371 * Fri Nov
30 2007 Chris Frey
<cdfrey@foursquare.net
> 0.10-1
373 - removed ktrans and translate from rpm package
376 * Thu Aug
09 2007 Chris Frey
<cdfrey@foursquare.net
> 0.9-1
379 * Fri Aug
03 2007 Chris Frey
<cdfrey@foursquare.net
> 0.8-1
381 - changed tarball to bz2
383 * Tue May
01 2007 Chris Frey
<cdfrey@foursquare.net
> 0.7-2
384 - added pppob to utils
386 * Thu Mar
08 2007 Chris Frey
<cdfrey@foursquare.net
> 0.7-1
387 - removed barry base package that only contained docs
, and put docs
in libbarry
*
388 - changed barrybackup reference to barry
-gui
389 - removed the patch step
, as version
0.7 shouldn't need it
390 - added license file to each package
392 * Sun Mar
04 2007 Troy Engel
<tengel@users.sourceforge.net
> 0.6-1
394 - adding udev and console perms patch
for raw
0.6