Fix typo in description.
[barry.git] / debian / control
blobb737847781eda88ad20ae89788168e817ab52bbd
2 # Ideally, the evolution source path autodetection routines would
3 # load libebook and libecal dynamically, so that dependencies would
4 # not force the inclusion of evolution-data-server and friends.
6 # But there are two problems with that, which need to be
7 # cracked first:
9 #     - the glib major version numbers, according to the .so
10 #       files, are not consistent between distros
11 #     - when used dynamically, in a program that is not otherwise
12 #       linked to glib, it can segfault... and it seems to get
13 #       funky somewhere inside glib itself... so I'm guessing that
14 #       the library is not being initialized properly :-(
16 # All this means that general compilations of barrydesktop will
17 # need evolution-data-server and friends linked in.  It is possible
18 # to compile without by supplying --without-evolution on the configure
19 # command line, but then you risk getting a weak auto-detection
20 # of data sources in newer versions of evolution.  If your data
21 # sources are located in paths like this:
23 #      file:///home/cdfrey/.evolution/addressbook/local/system
25 # then it is safe to disable evolution for the barrydesktop compile.
27 # Otherwise, if your version of evolution is new, and uses funkier names,
28 # or uses local:system, or puts its files under ~/.config, then
29 # build --with-evolution and link against it.
31 Source: barry
32 Section: misc
33 Priority: optional
34 Maintainer: Chris Frey <cdfrey@foursquare.net>
35 Build-Depends: debhelper (>= 6.0.0), g++ (>= 4.1), cdbs, autoconf, automake, libtool, pkg-config, libusb-dev, libboost-serialization-dev, libxml++2.6-dev, libfuse-dev (>= 2.5), zlib1g-dev, libtar-dev, libglib2.0-dev, libgtkmm-2.4-dev, libglademm-2.4-dev, gettext (<< 0.18) | autopoint, libgcal-dev, wx-common, libwxgtk2.8-dev, evolution-data-server-dev, libebook1.2-dev, libedata-book1.2-dev, libedata-cal1.2-dev, libedataserver1.2-dev
36 Standards-Version: 3.8.0
38 Package: libbarry0
39 Section: libs
40 Architecture: any
41 Depends: ${shlibs:Depends}
42 Description: Library for using the BlackBerry handheld on Linux
43  Barry is a GPL C++ library for interfacing with the RIM BlackBerry Handheld.
44  .
45  This package contains shared libraries.
47 Package: libbarry0-dbg
48 Section: debug
49 Priority: extra
50 Architecture: any
51 Depends: libbarry0 (= ${binary:Version})
52 Description: Library for using the BlackBerry handheld and debugging symbols
53  Barry is a GPL C++ library for interfacing with the RIM BlackBerry Handheld.
54  .
55  This package contains the debug version of the shared library.
57 Package: libbarry-dev
58 Section: libdevel
59 Architecture: any
60 Depends: libbarry0 (= ${binary:Version})
61 Description: Development files for libbarry
62  Barry is a GPL C++ library for interfacing with the RIM BlackBerry Handheld.
63  .
64  This package contains the header files required for building applications
65  based on libbarry.
67 Package: barry-util
68 Section: utils
69 Architecture: any
70 Depends: libbarry0 (>= 0.18), libbarry0 (<< 0.19), udev (>= 0.056) [linux-any], python, ${shlibs:Depends}
71 Suggests: ppp
72 Description: Command line utilities for working with the RIM BlackBerry Handheld
73  Barry is a GPL C++ library for interfacing with the RIM BlackBerry Handheld.
74  .
75  This package contains command line utilities, such as bcharge, btool,
76  breset, bio, etc.
78 Package: barry-util-dbg
79 Section: debug
80 Priority: extra
81 Architecture: any
82 Depends: barry-util (= ${binary:Version})
83 Description: Command line BlackBerry utilities and debugging symbols
84  Barry is a GPL C++ library for interfacing with the RIM BlackBerry Handheld.
85  .
86  This package contains the debug versions of the command line utilities.
88 Package: barrybackup-gui
89 Section: utils
90 Architecture: any
91 Depends: libbarry0 (>= 0.18), libbarry0 (<< 0.19), ${shlibs:Depends}
92 Description: GTK+ GUI for backing up the RIM BlackBerry Handheld
93  Barry is a GPL C++ library for interfacing with the RIM BlackBerry Handheld.
94  .
95  This package contains a GUI application for making backups and restores.
97 Package: barrybackup-gui-dbg
98 Section: debug
99 Priority: extra
100 Architecture: any
101 Depends: barrybackup-gui (= ${binary:Version})
102 Description: GTK+ GUI for backing up BlackBerry and debugging symbols
103  Barry is a GPL C++ library for interfacing with the RIM BlackBerry Handheld.
105  This package contains the debug version of the backup GUI.
107 Package: barrydesktop
108 Section: utils
109 Architecture: any
110 Depends: libbarry0 (>= 0.18), libbarry0 (<< 0.19), ${shlibs:Depends}
111 Description: Desktop Panel GUI for the RIM BlackBerry Handheld
112  Barry is a GPL C++ library for interfacing with the RIM BlackBerry Handheld.
114  This package contains a GUI management application for backups, syncing, etc.
116 Package: barrydesktop-dbg
117 Section: debug
118 Priority: extra
119 Architecture: any
120 Depends: barrydesktop (= ${binary:Version})
121 Description: Desktop Panel GUI for the RIM BlackBerry Handheld
122  Barry is a GPL C++ library for interfacing with the RIM BlackBerry Handheld.
124  This package contains the debug files for the Barry desktop.
126 #Package: barry-doc
127 #Architecture: all
128 #Description: Documentation for barry
129 # Barry is a GPL C++ library for interfacing with the RIM BlackBerry Handheld.
130 # It comes with a command line tool for exploring the device and for making quick
131 # backups. The goal of this project is to create a fully functional syncing
132 # mechanism on Linux.