rpm: removed .la files, and fixed library packaging
[barry.git] / rpm / barry.spec
blobf37271f806cbc66d4211c3b612488a75a7f35b17
1 %dump
3 # always build with GUI
4 %define with_gui 1
6 # Fedora 9 doesn't support opensync 0.22
7 %if 0%{?fc9}
8 %define with_opensync 0
9 %else
10 %define with_opensync 1
11 %endif
13 # Fedora 12 has the desktop packages installed for our build system
14 %if 0%{?fc12} || 0%{?fc13} || 0%{?fc14}
15 %define with_desktop 1
16 %else
17 %define with_desktop 0
18 %endif
20 %if 0%{?fc12} || 0%{?fc13} || 0%{?fc14}
21 %define use_69_rules 1
22 %else
23 %define use_69_rules 0
24 %endif
27 Summary: BlackBerry(tm) Desktop for Linux
28 Name: barry
29 Version: 0.18.0
30 Release: 0
31 Group: Applications/Productivity
32 License: GPLv2+
33 Source: %{name}-%{version}.tar.bz2
34 URL: http://www.netdirect.ca/software/packages/barry
35 Vendor: Net Direct Inc.
36 BuildRoot: %{_tmppath}/%{name}-%{release}-%{version}-root
38 %if 0%{?suse_version}
39 BuildRequires: libusb, gcc-c++, pkgconfig, boost-devel, fuse-devel, zlib-devel
40 %else
41 BuildRequires: libusb-devel, gcc-c++, pkgconfig, boost-devel, fuse-devel, zlib-devel
42 %endif
44 %if %{with_gui}
45 BuildRequires: desktop-file-utils
46 %endif
48 # desktop tree
49 %if %{with_desktop}
50 BuildRequires: wxGTK-devel
51 %endif
53 %define barryroot %{_builddir}/%{name}-%{version}
55 %description
56 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
57 is a registered trademark of Research in Motion Limited.)
60 %package -n libbarry0
61 Summary: BlackBerry(tm) Desktop for Linux - libbarry libraries
62 Group: Development/Libraries
63 Requires: libusb boost
65 %description -n libbarry0
66 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
67 is a registered trademark of Research in Motion Limited.)
69 This package contains the library files, license agreement, README file,
70 and most other assorted documentation common to all sub-packages. You most
71 likely want to also install barry-util and barry-gui.
74 %package -n libbarry-devel
75 Summary: BlackBerry(tm) Desktop for Linux - libbarry libraries
76 Group: Development/Libraries
77 Requires: libbarry0 boost-devel
79 %description -n libbarry-devel
80 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
81 is a registered trademark of Research in Motion Limited.)
83 This package contains the development library files for Barry, libbarry.
86 %package util
87 Summary: BlackBerry(tm) Desktop for Linux - bcharge, btool, breset, bio and others
88 Group: Applications/Productivity
89 Requires: libbarry0 fuse
90 Conflicts: barry-bcharge
92 %description util
93 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
94 is a registered trademark of Research in Motion Limited.)
96 This package contains the commandline tools bcharge, btool, breset, bio and
97 others which will enable you to charge your device with a proper 500mA
98 and be able to access the data on the device in many ways.
101 %if %{with_gui}
102 %package gui
103 Summary: BlackBerry(tm) Desktop for Linux - bcharge, btool, breset and others
104 Group: Applications/Productivity
105 %if 0%{?suse_version}
106 Requires: libbarry0 gtkmm2 libglademm libtar
107 BuildRequires: gtkmm2-devel libglademm-devel libtar-devel
108 %else
109 Requires: libbarry0 gtkmm24 libglademm24 libtar
110 BuildRequires: gtkmm24-devel libglademm24-devel libtar-devel
111 %endif
113 %description gui
114 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
115 is a registered trademark of Research in Motion Limited.)
117 This package contains the GUI applications built on top of libbarry.
118 %endif
121 %if %{with_opensync}
122 %package opensync
123 Summary: BlackBerry(tm) Desktop for Linux - opensync plugin
124 Group: Applications/Productivity
125 Requires: libbarry0, libopensync >= 0.22
126 BuildRequires: libopensync-devel
128 %description opensync
129 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
130 is a registered trademark of Research in Motion Limited.)
132 This package contains the opensync plugin.
133 %endif
135 # desktop tree
136 %if %{with_desktop}
137 %package desktop
138 Summary: BlackBerry(tm) Desktop Panel GUI for Linux
139 Group: Applications/Productivity
140 Requires: libbarry0, libopensync >= 0.22
141 BuildRequires: wxGTK-devel
143 %description desktop
144 Barry is a desktop toolset for managing your BlackBerry(tm) device. (BlackBerry
145 is a registered trademark of Research in Motion Limited.)
147 This package contains the desktop panel GUI.
148 %endif
150 %prep
151 %setup -q
153 %build
154 # some systems have an rpath checker, and need their own versions of
155 # configure built on the same system in order to pass... in particular,
156 # Fedora 14's 64bit version needs its own configure, for some reason,
157 # in order to recognize that /usr/lib64 is a system path and therefore
158 # there is no reason to use an rpath... unfortunately, configure's
159 # --disable-rpath option seems to have no effect whatsoever. :-(
160 %if 0%{?fc14}
161 ./buildgen.sh cleanall
162 ./buildgen.sh
163 %endif
165 # main tree
166 %{configure} --enable-boost --enable-nls --with-zlib --with-libusb --enable-rpathhack
167 %{__make} %{?_smp_mflags}
169 # gui tree
170 %if %{with_gui}
171 cd gui/
172 %{configure} PKG_CONFIG_PATH="..:$PKG_CONFIG_PATH" CXXFLAGS="-I../.." LDFLAGS="-L../../src" --enable-nls --enable-rpathhack
173 %{__make} %{?_smp_mflags}
174 cd ../
175 %endif
177 # opensync tree
178 %if %{with_opensync}
179 cd opensync-plugin/
180 %{configure} PKG_CONFIG_PATH="..:$PKG_CONFIG_PATH" CXXFLAGS="-I../.." LDFLAGS="-L../../src" --enable-nls --enable-rpathhack
181 %{__make} %{?_smp_mflags}
182 cd ../
183 %endif
185 # desktop tree
186 %if %{with_desktop}
187 cd desktop/
188 %{configure} PKG_CONFIG_PATH="..:$PKG_CONFIG_PATH" CXXFLAGS="-I../.." LDFLAGS="-L../../src" --enable-nls --enable-rpathhack
189 %{__make} %{?_smp_mflags}
190 cd ../
191 %endif
193 %install
194 # main tree
195 %{__make} DESTDIR=%{buildroot} install
196 # delete some test-only programs
197 %{__rm} -f %{buildroot}%{_bindir}/bdptest
198 %{__rm} -f %{buildroot}%{_bindir}/bjvmdebug
199 # delete the .la files
200 %{__rm} -f %{buildroot}%{_libdir}/*.la
201 # proceed as usual...
202 %{__mkdir_p} %{buildroot}%{_sysconfdir}/udev/rules.d
203 %{__cp} udev/10-blackberry.rules %{buildroot}%{_sysconfdir}/udev/rules.d/
204 %if %{use_69_rules}
205 %{__cp} udev/69-blackberry.rules %{buildroot}%{_sysconfdir}/udev/rules.d/
206 %else
207 %{__cp} udev/99-blackberry-perms.rules %{buildroot}%{_sysconfdir}/udev/rules.d/
208 %endif
209 %{__mkdir_p} %{buildroot}%{_sysconfdir}/modprobe.d
210 %{__cp} modprobe/blacklist-berry_charge.conf %{buildroot}%{_sysconfdir}/modprobe.d/
211 %{__mkdir_p} %{buildroot}%{_sysconfdir}/ppp/peers
212 %{__cp} ppp/barry-rogers %{buildroot}%{_sysconfdir}/ppp/peers/
213 %{__cp} ppp/barry-minimal %{buildroot}%{_sysconfdir}/ppp/peers/
214 %{__cp} ppp/barry-verizon %{buildroot}%{_sysconfdir}/ppp/peers/
215 %{__cp} ppp/barry-sprint %{buildroot}%{_sysconfdir}/ppp/peers/
216 %{__cp} ppp/barry-telus %{buildroot}%{_sysconfdir}/ppp/peers/
217 %{__cp} ppp/barry-o2ireland %{buildroot}%{_sysconfdir}/ppp/peers/
218 %{__cp} ppp/barry-tmobileus %{buildroot}%{_sysconfdir}/ppp/peers/
219 %{__cp} ppp/barry-att_cingular %{buildroot}%{_sysconfdir}/ppp/peers/
220 %{__cp} ppp/barry-chinamobile %{buildroot}%{_sysconfdir}/ppp/peers/
221 %{__cp} ppp/barry-kpn %{buildroot}%{_sysconfdir}/ppp/peers/
222 %{__cp} ppp/barry-orange-spain %{buildroot}%{_sysconfdir}/ppp/peers/
223 %{__cp} ppp/barry-optus-au %{buildroot}%{_sysconfdir}/ppp/peers/
224 %{__cp} ppp/barry-vodafone-au %{buildroot}%{_sysconfdir}/ppp/peers/
225 %{__mkdir_p} %{buildroot}%{_sysconfdir}/chatscripts
226 %{__cp} ppp/barry-rogers.chat %{buildroot}%{_sysconfdir}/chatscripts/
227 %{__cp} ppp/barry-minimal.chat %{buildroot}%{_sysconfdir}/chatscripts/
228 %{__cp} ppp/barry-verizon.chat %{buildroot}%{_sysconfdir}/chatscripts/
229 %{__cp} ppp/barry-sprint.chat %{buildroot}%{_sysconfdir}/chatscripts/
230 %{__cp} ppp/barry-telus.chat %{buildroot}%{_sysconfdir}/chatscripts/
231 %{__cp} ppp/barry-o2ireland.chat %{buildroot}%{_sysconfdir}/chatscripts/
232 %{__cp} ppp/barry-tmobileus.chat %{buildroot}%{_sysconfdir}/chatscripts/
233 %{__cp} ppp/barry-att_cingular.chat %{buildroot}%{_sysconfdir}/chatscripts/
234 %{__cp} ppp/barry-chinamobile.chat %{buildroot}%{_sysconfdir}/chatscripts/
235 %{__cp} ppp/barry-kpn.chat %{buildroot}%{_sysconfdir}/chatscripts/
236 %{__cp} ppp/barry-orange-spain.chat %{buildroot}%{_sysconfdir}/chatscripts/
237 %{__cp} ppp/barry-optus-au.chat %{buildroot}%{_sysconfdir}/chatscripts/
238 %{__cp} ppp/barry-vodafone-au.chat %{buildroot}%{_sysconfdir}/chatscripts/
239 # Install hal fdi config
240 %{__mkdir_p} %{buildroot}%{_datadir}/hal/fdi/information/10freedesktop
241 %{__mkdir_p} %{buildroot}%{_datadir}/hal/fdi/policy/10osvendor
242 %{__cp} hal/fdi/information/10freedesktop/10-blackberry.fdi %{buildroot}%{_datadir}/hal/fdi/information/10freedesktop
243 %{__cp} hal/fdi/policy/10osvendor/19-blackberry-acl.fdi %{buildroot}%{_datadir}/hal/fdi/policy/10osvendor
244 # Install hal support script
245 %{__mkdir_p} %{buildroot}%{_bindir}
246 %{__cp} hal/hal-blackberry %{buildroot}%{_bindir}
247 # Install bash completion scripts
248 %{__mkdir_p} %{buildroot}%{_sysconfdir}/bash_completion.d
249 %{__cp} bash/bjavaloader %{buildroot}%{_sysconfdir}/bash_completion.d
250 %{__cp} bash/btool %{buildroot}%{_sysconfdir}/bash_completion.d
252 # gui tree
253 %if %{with_gui}
254 cd gui/
255 %{__make} DESTDIR=%{buildroot} install
256 # Install barry logo icon
257 cd ../
258 %{__mkdir_p} %{buildroot}%{_datadir}/pixmaps
259 %{__cp} logo/barry_logo_icon.png %{buildroot}%{_datadir}/pixmaps
260 desktop-file-install --vendor netdirect \
261 --dir %{buildroot}%{_datadir}/applications \
262 menu/barrybackup.desktop
263 %endif
265 # opensync tree
266 %if %{with_opensync}
267 cd opensync-plugin/
268 %{__make} DESTDIR=%{buildroot} install
269 # remove .la files
270 %{__rm} -f %{buildroot}%{_libdir}/opensync/plugins/*.la
271 cd ../
272 %endif
274 # desktop tree
275 %if %{with_desktop}
276 cd desktop/
277 %{__make} DESTDIR=%{buildroot} install
278 # remove .la files
279 %{__rm} -f %{buildroot}%{_libdir}/*.la
280 cd ../
281 %{__cp} logo/barry_logo_icon.png %{buildroot}%{_datadir}/pixmaps/barry_desktop_icon.png
282 desktop-file-install --vendor netdirect \
283 --dir %{buildroot}%{_datadir}/applications \
284 menu/barrydesktop.desktop
285 %endif
287 %files -n libbarry0
288 %defattr(-,root,root)
289 %attr(-,root,root) %{_libdir}/libbarry.so.*
290 %attr(-,root,root) %{_libdir}/libbarrydp.so.*
291 %attr(-,root,root) %{_libdir}/libbarryjdwp.so.*
292 %attr(-,root,root) %{_libdir}/libbarrysync.so.*
293 %attr(-,root,root) %{_libdir}/libbarrybackup.so.*
294 %attr(-,root,root) %{_libdir}/libbarryalx.so.*
295 %doc AUTHORS ChangeLog COPYING NEWS README
297 %files -n libbarry-devel
298 %defattr(-,root,root)
299 %attr(0644,root,root) %{_includedir}/barry*/barry/*
300 %attr(0644,root,root) %{_libdir}/libbarry.a
301 %attr(0644,root,root) %{_libdir}/libbarry.so
302 %attr(0644,root,root) %{_libdir}/libbarrydp.a
303 %attr(0644,root,root) %{_libdir}/libbarrydp.so
304 %attr(0644,root,root) %{_libdir}/libbarryjdwp.a
305 %attr(0644,root,root) %{_libdir}/libbarryjdwp.so
306 %attr(0644,root,root) %{_libdir}/libbarrysync.a
307 %attr(0644,root,root) %{_libdir}/libbarrysync.so
308 %attr(0644,root,root) %{_libdir}/libbarrybackup.a
309 %attr(0644,root,root) %{_libdir}/libbarrybackup.so
310 %attr(0644,root,root) %{_libdir}/libbarryalx.a
311 %attr(0644,root,root) %{_libdir}/libbarryalx.so
312 %attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
313 %doc COPYING TODO doc/* examples/*.cc
315 %files util
316 %defattr(-,root,root)
317 %attr(0755,root,root) %{_sbindir}/bcharge
318 %attr(0755,root,root) %{_sbindir}/breset
319 %attr(0755,root,root) %{_sbindir}/pppob
320 %attr(0755,root,root) %{_bindir}/btool
321 %attr(0755,root,root) %{_bindir}/bio
322 %attr(0755,root,root) %{_bindir}/btardump
323 %attr(0755,root,root) %{_bindir}/bfuse
324 %attr(0755,root,root) %{_bindir}/bjavaloader
325 %attr(0755,root,root) %{_bindir}/balxparse
326 %attr(0755,root,root) %{_bindir}/bjdwp
327 %attr(0755,root,root) %{_bindir}/brawchannel
328 %attr(0755,root,root) %{_bindir}/bs11nread
329 %attr(0755,root,root) %{_bindir}/bidentify
330 %attr(0755,root,root) %{_bindir}/brecsum
331 %attr(0755,root,root) %{_bindir}/upldif
332 %attr(0755,root,root) %{_bindir}/bktrans
333 %attr(0755,root,root) %{_bindir}/btranslate
334 %attr(0755,root,root) %{_bindir}/brimtrans
335 %attr(0755,root,root) %{_bindir}/hal-blackberry
336 %attr(0644,root,root) %{_mandir}/man1/btool*
337 %attr(0644,root,root) %{_mandir}/man1/bio*
338 %attr(0644,root,root) %{_mandir}/man1/btardump*
339 %attr(0644,root,root) %{_mandir}/man1/bfuse*
340 %attr(0644,root,root) %{_mandir}/man1/bjavaloader*
341 %attr(0644,root,root) %{_mandir}/man1/balxparse*
342 %attr(0644,root,root) %{_mandir}/man1/bjdwp*
343 %attr(0644,root,root) %{_mandir}/man1/brawchannel*
344 %attr(0644,root,root) %{_mandir}/man1/bs11nread*
345 %attr(0644,root,root) %{_mandir}/man1/bidentify*
346 %attr(0644,root,root) %{_mandir}/man1/bcharge*
347 %attr(0644,root,root) %{_mandir}/man1/pppob*
348 %attr(0644,root,root) %{_mandir}/man1/brecsum*
349 %attr(0644,root,root) %{_mandir}/man1/breset*
350 %attr(0644,root,root) %{_mandir}/man1/upldif*
351 %attr(0644,root,root) %{_datadir}/locale/*
352 %attr(0644,root,root) %{_datadir}/hal/fdi/information/10freedesktop/10-blackberry.fdi
353 %attr(0644,root,root) %{_datadir}/hal/fdi/policy/10osvendor/19-blackberry-acl.fdi
354 %attr(0644,root,root) %config %{_sysconfdir}/udev/rules.d/*
355 %attr(0644,root,root) %config %{_sysconfdir}/modprobe.d/blacklist-berry_charge.conf
356 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-rogers
357 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-minimal
358 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-verizon
359 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-sprint
360 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-telus
361 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-o2ireland
362 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-tmobileus
363 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-att_cingular
364 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-chinamobile
365 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-kpn
366 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-orange-spain
367 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-optus-au
368 %attr(0644,root,root) %config %{_sysconfdir}/ppp/peers/barry-vodafone-au
369 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-rogers.chat
370 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-minimal.chat
371 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-verizon.chat
372 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-sprint.chat
373 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-telus.chat
374 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-o2ireland.chat
375 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-tmobileus.chat
376 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-att_cingular.chat
377 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-chinamobile.chat
378 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-kpn.chat
379 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-orange-spain.chat
380 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-optus-au.chat
381 %attr(0640,root,root) %config %{_sysconfdir}/chatscripts/barry-vodafone-au.chat
382 %attr(0640,root,root) %config %{_sysconfdir}/bash_completion.d/bjavaloader
383 %attr(0640,root,root) %config %{_sysconfdir}/bash_completion.d/btool
384 %doc COPYING
385 %doc zsh
386 %doc ppp/README
388 %if %{with_gui}
389 %files gui
390 %defattr(-,root,root)
391 %attr(0755,root,root) %{_bindir}/barrybackup
392 %attr(0644,root,root) %{_datadir}/barry/glade/*.glade
393 %attr(0644,root,root) %{_datadir}/pixmaps/barry_logo_icon.png
394 %attr(0644,root,root) %{_datadir}/applications/*barrybackup.desktop
395 %attr(0644,root,root) %{_mandir}/man1/barrybackup*
396 %doc COPYING
397 %endif
399 %if %{with_opensync}
400 %files opensync
401 %defattr(-,root,root)
402 %attr(0755,root,root) %{_libdir}/opensync/plugins/barry_sync.so
403 %attr(0644,root,root) %{_datadir}/opensync/defaults/barry-sync
404 %doc COPYING
405 %endif
407 # desktop tree
408 %if %{with_desktop}
409 %files desktop
410 %defattr(-,root,root)
411 %attr(0755,root,root) %{_bindir}/barrydesktop
412 %attr(0755,root,root) %{_bindir}/bsyncjail
413 %attr(0755,root,root) %{_bindir}/bsynccl
414 %attr(0644,root,root) %{_datadir}/barry/desktop/0.22/*
415 %attr(0644,root,root) %{_datadir}/barry/desktop/0.40/*
416 %attr(0644,root,root) %{_datadir}/barry/desktop/images/*.png
417 %attr(0644,root,root) %{_datadir}/pixmaps/barry_desktop_icon.png
418 %attr(0644,root,root) %{_datadir}/applications/*barrydesktop.desktop
419 %attr(0644,root,root) %{_mandir}/man1/barrydesktop*
420 %attr(-,root,root) %{_libdir}/libosyncwrap.so.*
421 %attr(-,root,root) %{_libdir}/libosyncwrap.a
422 %attr(-,root,root) %{_libdir}/libosyncwrap.so
423 %attr(0644,root,root) %{_includedir}/barry*/osyncwrap/*
424 %doc COPYING
425 %endif
427 %clean
428 [ "%{buildroot}" != "/" ] && %{__rm} -rf %{buildroot}
429 [ "%{barryroot}" != "/" ] && %{__rm} -rf %{barryroot}
431 %post -n libbarry0
432 /sbin/ldconfig
434 %postun -n libbarry0
435 /sbin/ldconfig
437 %changelog
438 * Thu Feb 10 2011 Chris Frey <cdfrey@foursquare.net> 0.18.0-0
439 - version bump
440 - removed dependency of libbarry-devel on libusb(-devel)
441 - added osyncwrap headers
442 - removed .la files
443 - split up dev libraries a little better (-devel should have the dev libs)
444 - put desktop library in desktop package
446 * Fri May 28 2010 Chris Frey <cdfrey@foursquare.net> 0.17.0-0
447 - version bump
448 - added NLS support
449 - cleaned up conditionals
450 - added Fedora 13 support
451 - added new ppp chat scripts for Orange Spain, Optus and Vodafone AU
452 - added copy of barry-sprint as barry-telus
453 - added brawchannel, btardump, bio, and balxparse
454 - added desktop support
455 - cleaned up desktop variables
457 * Sat Sep 29 2009 Chris Frey <cdfrey@foursquare.net> 0.16-0
458 - version bump
459 - added new ppp chat script for KPN Nederland
460 - using new udev rules set
461 - added bjdwp and manpage, and removed some test-only programs
462 - added bash and zsh completion scripts
463 - added .desktop file and icon for barrybackup
465 * Fri Apr 10 2009 Chris Frey <cdfrey@foursquare.net> 0.15-0
466 - version bump
467 - added HAL FDI scripts
468 - added bjavaloader and bfuse
469 - updated for udev directory reorganization in Barry source tree
470 - added zlib-devel to BuildRequires list
471 - added brimtrans
473 * Wed Sep 24 2008 Chris Frey <cdfrey@foursquare.net> 0.14-0
474 - version bump
475 - added new ppp chat script for T-Mobile US
476 - renamed libbarry to libbarry0
478 * Thu May 29 2008 Chris Frey <cdfrey@foursquare.net> 0.13-1
479 - version bump
480 - added brecsum
481 - added ppp options and chat scripts
482 - added manpages for pppob, brecsum, breset, upldif, barrybackup
483 - spec file now assumes gui and opensync, with conditional checks depending on host
485 * Fri Dec 07 2007 Chris Frey <cdfrey@foursquare.net> 0.12-1
486 - version bump
488 * Fri Nov 30 2007 Chris Frey <cdfrey@foursquare.net> 0.11-1
489 - version bump
491 * Fri Nov 30 2007 Chris Frey <cdfrey@foursquare.net> 0.10-1
492 - version bump
493 - removed ktrans and translate from rpm package
494 - added bidentify
496 * Thu Aug 09 2007 Chris Frey <cdfrey@foursquare.net> 0.9-1
497 - version bump
499 * Fri Aug 03 2007 Chris Frey <cdfrey@foursquare.net> 0.8-1
500 - version bump
501 - changed tarball to bz2
503 * Tue May 01 2007 Chris Frey <cdfrey@foursquare.net> 0.7-2
504 - added pppob to utils
506 * Thu Mar 08 2007 Chris Frey <cdfrey@foursquare.net> 0.7-1
507 - removed barry base package that only contained docs, and put docs in libbarry*
508 - changed barrybackup reference to barry-gui
509 - removed the patch step, as version 0.7 shouldn't need it
510 - added license file to each package
512 * Sun Mar 04 2007 Troy Engel <tengel@users.sourceforge.net> 0.6-1
513 - initial build
514 - adding udev and console perms patch for raw 0.6