os4x: run plugin as process
[barry.git] / debian / rules
blobbf1060ddcd2d9300b635cffab2b198de6d784423
1 #!/usr/bin/make -f
2 # Based on the multi2 sample debian/rules file:
3 # ---
4 # Sample debian/rules that uses debhelper.
5 # This file is public domain software, originally written by Joey Hess.
7 #export DH_VERBOSE=1
8 include /usr/share/cdbs/1/rules/debhelper.mk
9 include /usr/share/cdbs/1/class/autotools.mk
10 #include /usr/share/cdbs/1/rules/simple-patchsys.mk
12 # where sources are
13 DEB_SRCDIR = .
14 # in which directory to build
15 DEB_BUILDDIR = .
16 # in which directory to install the sofware
17 DEB_DESTDIR = $(CURDIR)/debian/tmp
18 #To register a debug library package libfoo-dbg for libfoo (which needs unstripped '.so') in compat mode 4:
19 DEB_DH_STRIP_ARGS := --dbg-package=libbarry0 --dbg-package=libbarry-dev --dbg-package=barry-util --dbg-package=barrybackup-gui --dbg-package=opensync-plugin-barry
20 #CDBS automatically handles common flags to pass to the configure script,
21 #but it is possible to give some extra parameters :
22 DEB_CONFIGURE_EXTRA_FLAGS := --enable-boost --enable-nls --with-zlib --enable-gui --enable-opensync-plugin
23 COMMON_CONFIGURE_FLAGS := --prefix=/usr
24 DEB_INSTALL_DOCS_ALL =
26 install/barry-util::
27 # Install udev rules for the barry-util package
28 install -d $(CURDIR)/debian/barry-util/etc/udev/rules.d
29 install -m 0644 \
30 $(CURDIR)/udev/10-blackberry.rules \
31 $(CURDIR)/udev/99-blackberry-perms.rules \
32 $(CURDIR)/debian/barry-util/etc/udev/rules.d
33 # Install modprobe blacklist file for bcharge, into barry-util package
34 install -d $(CURDIR)/debian/barry-util/etc/modprobe.d
35 install -m 0644 $(CURDIR)/modprobe/blacklist-berry_charge.conf $(CURDIR)/debian/barry-util/etc/modprobe.d/blacklist-berry_charge.conf
36 # Install default ppp options and chat scripts
37 install -d $(CURDIR)/debian/barry-util/etc/ppp/peers
38 install -m 0644 \
39 $(CURDIR)/ppp/barry-rogers \
40 $(CURDIR)/ppp/barry-verizon \
41 $(CURDIR)/ppp/barry-sprint \
42 $(CURDIR)/ppp/barry-o2ireland \
43 $(CURDIR)/ppp/barry-tmobileus \
44 $(CURDIR)/ppp/barry-att_cingular \
45 $(CURDIR)/ppp/barry-chinamobile \
46 $(CURDIR)/ppp/barry-kpn \
47 $(CURDIR)/ppp/barry-orange-spain \
48 $(CURDIR)/debian/barry-util/etc/ppp/peers
49 install -d $(CURDIR)/debian/barry-util/etc/chatscripts
50 install -m 0640 \
51 $(CURDIR)/ppp/barry-rogers.chat \
52 $(CURDIR)/ppp/barry-verizon.chat \
53 $(CURDIR)/ppp/barry-sprint.chat \
54 $(CURDIR)/ppp/barry-o2ireland.chat \
55 $(CURDIR)/ppp/barry-tmobileus.chat \
56 $(CURDIR)/ppp/barry-att_cingular.chat \
57 $(CURDIR)/ppp/barry-chinamobile.chat \
58 $(CURDIR)/ppp/barry-kpn.chat \
59 $(CURDIR)/ppp/barry-orange-spain.chat \
60 $(CURDIR)/debian/barry-util/etc/chatscripts
61 # Install hal fdi configs
62 install -d $(CURDIR)/debian/barry-util/usr/share/hal/fdi/information/10freedesktop
63 install -d $(CURDIR)/debian/barry-util/usr/share/hal/fdi/policy/10osvendor
64 install -m 0644 $(CURDIR)/hal/fdi/information/10freedesktop/10-blackberry.fdi $(CURDIR)/debian/barry-util/usr/share/hal/fdi/information/10freedesktop
65 install -m 0644 $(CURDIR)/hal/fdi/policy/10osvendor/19-blackberry-acl.fdi $(CURDIR)/debian/barry-util/usr/share/hal/fdi/policy/10osvendor
66 # Install hal support script
67 install -d $(CURDIR)/debian/barry-util/usr/bin
68 install -m 0755 $(CURDIR)/hal/hal-blackberry $(CURDIR)/debian/barry-util/usr/bin
69 # Install bash and zsh completion scripts
70 install -d $(CURDIR)/debian/barry-util/etc/bash_completion.d
71 install -m 0644 \
72 $(CURDIR)/bash/bjavaloader \
73 $(CURDIR)/bash/btool \
74 $(CURDIR)/debian/barry-util/etc/bash_completion.d
76 install/barrybackup-gui::
77 # Install barry icon
78 install -d $(CURDIR)/debian/barrybackup-gui/usr/share/pixmaps
79 install -m 0644 $(CURDIR)/logo/barry_logo_icon.png $(CURDIR)/debian/barrybackup-gui/usr/share/pixmaps
81 post-patches::
82 @test -x $(DEB_SRCDIR)/configure && echo "allready autoreconf" || (cd $(DEB_SRCDIR) && autoreconf -i)
84 clean::
85 -@rm -f $(DEB_SRCDIR)/config.guess $(DEB_SRCDIR)/config.sub $(DEB_SRCDIR)/ltmain.sh $(DEB_SRCDIR)/aclocal.m4
86 -@rm -f $(DEB_SRCDIR)/config.h.in $(DEB_SRCDIR)/mkinstalldirs $(DEB_SRCDIR)/install-sh
87 -@rm -f $(DEB_SRCDIR)/missing $(DEB_SRCDIR)/depcomp $(DEB_SRCDIR)/configure $(DEB_SRCDIR)/subdirs
88 -@rm -rf build/ $(DEB_SRCDIR)/configure.files $(DEB_SRCDIR)/stamp-h.in
89 -@rm `find . -type f -name "Makefile.in" -print`