Release 960928
[wine/multimedia.git] / if1632 / crtdll.spec
blobbd0723409ea877686b9d5d1fcc4c4b1b1bc6cea9
1 # C RunTime DLL. All functions use cdecl!
2 name crtdll
3 type win32
4 base 1
6 001 stub ??2@YAPAXI@Z
7 002 stub ??3@YAXPAX@Z
8 003 stub ?_set_new_handler@@YAP6AHI@ZP6AHI@Z@Z
9 004 stub _CIacos
10 005 stub _CIasin
11 006 stub _CIatan
12 007 stub _CIatan2
13 008 stub _CIcos
14 009 stub _CIcosh
15 010 stub _CIexp
16 011 stub _CIfmod
17 012 stub _CIlog
18 013 stub _CIlog10
19 014 stub _CIpow
20 015 stub _CIsin
21 016 stub _CIsinh
22 017 stub _CIsqrt
23 018 stub _CItan
24 019 stub _CItanh
25 020 stub _HUGE_dll
26 021 stub _XcptFilter
27 022 cdecl __GetMainArgs(ptr ptr ptr long) CRTDLL__GetMainArgs
28 023 extern __argc_dll CRTDLL_argc_dll
29 024 extern __argv_dll CRTDLL_argv_dll
30 025 stub __dllonexit
31 026 stub __doserrno
32 027 stub __fpecode
33 028 stub __isascii
34 029 stub __iscsym
35 030 stub __iscsymf
36 031 stub __mb_cur_max_dll
37 032 stub __pxcptinfoptrs
38 033 stub __threadhandle
39 034 stub __threadid
40 035 stub __toascii
41 036 stub _abnormal_termination
42 037 stub _access
43 038 extern _acmdln_dll CRTDLL_acmdln_dll
44 039 stub _aexit_rtn_dll
45 040 stub _amsg_exit
46 041 stub _assert
47 042 extern _basemajor_dll CRTDLL_basemajor_dll
48 043 extern _baseminor_dll CRTDLL_baseminor_dll
49 044 extern _baseversion_dll CRTDLL_baseversion_dll
50 045 stub _beep
51 046 stub _beginthread
52 047 stub _c_exit
53 048 stub _cabs
54 049 stub _cexit
55 050 stub _cgets
56 051 stub _chdir
57 052 stub _chdrive
58 053 stub _chgsign
59 054 stub _chmod
60 055 stub _chsize
61 056 stub _clearfp
62 057 stub _close
63 058 stub _commit
64 059 long _commode_dll(0)
65 060 stub _control87
66 061 stub _controlfp
67 062 stub _copysign
68 063 stub _cprintf
69 064 stub _cpumode_dll
70 065 stub _cputs
71 066 stub _creat
72 067 stub _cscanf
73 068 stub _ctype
74 069 stub _cwait
75 070 stub _daylight_dll
76 071 stub _dup
77 072 stub _dup2
78 073 stub _ecvt
79 074 stub _endthread
80 075 extern _environ_dll CRTDLL_environ_dll
81 076 stub _eof
82 077 stub _errno
83 078 stub _except_handler2
84 079 stub _execl
85 080 stub _execle
86 081 stub _execlp
87 082 stub _execlpe
88 083 stub _execv
89 084 stub _execve
90 085 stub _execvp
91 086 stub _execvpe
92 087 stub _exit
93 088 stub _expand
94 089 stub _fcloseall
95 090 stub _fcvt
96 091 stub _fdopen
97 092 stub _fgetchar
98 093 stub _fgetwchar
99 094 stub _filbuf
100 095 stub _fileinfo_dll
101 096 stub _filelength
102 097 stub _fileno
103 098 stub _findclose
104 099 stub _findfirst
105 100 stub _findnext
106 101 stub _finite
107 102 stub _flsbuf
108 103 stub _flushall
109 104 long _fmode_dll(0)
110 105 stub _fpclass
111 106 stub _fpieee_flt
112 107 stub _fpreset
113 108 stub _fputchar
114 109 stub _fputwchar
115 110 stub _fsopen
116 111 stub _fstat
117 112 stub _ftime
118 113 stub _ftol
119 114 stub _fullpath
120 115 stub _futime
121 116 stub _gcvt
122 117 stub _get_osfhandle
123 118 stub _getch
124 119 stub _getche
125 120 stub _getcwd
126 121 stub _getdcwd
127 122 stub _getdiskfree
128 123 stub _getdllprocaddr
129 124 stub _getdrive
130 125 stub _getdrives
131 126 stub _getpid
132 127 stub _getsystime
133 128 stub _getw
134 129 stub _global_unwind2
135 130 stub _heapchk
136 131 stub _heapmin
137 132 stub _heapset
138 133 stub _heapwalk
139 134 stub _hypot
140 135 cdecl _initterm(ptr ptr) CRTDLL__initterm
141 136 stub _iob
142 137 cdecl _isatty(long) CRTDLL__isatty
143 138 stub _isctype
144 139 stub _ismbbalnum
145 140 stub _ismbbalpha
146 141 stub _ismbbgraph
147 142 stub _ismbbkalnum
148 143 stub _ismbbkana
149 144 stub _ismbbkpunct
150 145 stub _ismbblead
151 146 stub _ismbbprint
152 147 stub _ismbbpunct
153 148 stub _ismbbtrail
154 149 stub _ismbcalpha
155 150 stub _ismbcdigit
156 151 stub _ismbchira
157 152 stub _ismbckata
158 153 stub _ismbcl0
159 154 stub _ismbcl1
160 155 stub _ismbcl2
161 156 stub _ismbclegal
162 157 stub _ismbclower
163 158 stub _ismbcprint
164 159 stub _ismbcspace
165 160 stub _ismbcsymbol
166 161 stub _ismbcupper
167 162 stub _ismbslead
168 163 stub _ismbstrail
169 164 stub _isnan
170 165 stub _itoa
171 166 stub _itow
172 167 stub _j0
173 168 stub _j1
174 169 stub _jn
175 170 stub _kbhit
176 171 stub _lfind
177 172 stub _loaddll
178 173 stub _local_unwind2
179 174 stub _locking
180 175 stub _logb
181 176 stub _lrotl
182 177 stub _lrotr
183 178 stub _lsearch
184 179 stub _lseek
185 180 stub _ltoa
186 181 stub _ltow
187 182 stub _makepath
188 183 stub _matherr
189 184 stub _mbbtombc
190 185 stub _mbbtype
191 186 stub _mbccpy
192 187 stub _mbcjistojms
193 188 stub _mbcjmstojis
194 189 stub _mbclen
195 190 stub _mbctohira
196 191 stub _mbctokata
197 192 stub _mbctolower
198 193 stub _mbctombb
199 194 stub _mbctoupper
200 195 stub _mbctype
201 196 stub _mbsbtype
202 197 cdecl _mbscat(ptr ptr) CRTDLL__mbscat
203 198 stub _mbschr
204 199 stub _mbscmp
205 200 cdecl _mbscpy(ptr ptr) CRTDLL__mbscpy
206 201 stub _mbscspn
207 202 stub _mbsdec
208 203 stub _mbsdup
209 204 cdecl _mbsicmp(ptr ptr) CRTDLL__mbsicmp
210 205 cdecl _mbsinc(ptr) CRTDLL__mbsinc
211 206 stub _mbslen
212 207 stub _mbslwr
213 208 stub _mbsnbcat
214 209 stub _mbsnbcmp
215 210 stub _mbsnbcnt
216 211 stub _mbsnbcpy
217 212 stub _mbsnbicmp
218 213 stub _mbsnbset
219 214 stub _mbsncat
220 215 stub _mbsnccnt
221 216 stub _mbsncmp
222 217 stub _mbsncpy
223 218 stub _mbsnextc
224 219 stub _mbsnicmp
225 220 stub _mbsninc
226 221 stub _mbsnset
227 222 stub _mbspbrk
228 223 stub _mbsrchr
229 224 stub _mbsrev
230 225 stub _mbsset
231 226 stub _mbsspn
232 227 stub _mbsspnp
233 228 stub _mbsstr
234 229 stub _mbstok
235 230 stub _mbstrlen
236 231 stub _mbsupr
237 232 stub _memccpy
238 233 stub _memicmp
239 234 stub _mkdir
240 235 stub _mktemp
241 236 stub _msize
242 237 stub _nextafter
243 238 stub _onexit
244 239 stub _open
245 240 stub _open_osfhandle
246 241 extern _osmajor_dll CRTDLL_osmajor_dll
247 242 extern _osminor_dll CRTDLL_osminor_dll
248 243 long _osmode_dll(0)
249 244 extern _osver_dll CRTDLL_osver_dll
250 245 extern _osversion_dll CRTDLL_osversion_dll
251 246 stub _pclose
252 247 stub _pctype_dll
253 248 stub _pgmptr_dll
254 249 stub _pipe
255 250 stub _popen
256 251 stub _purecall
257 252 stub _putch
258 253 stub _putenv
259 254 stub _putw
260 255 stub _pwctype_dll
261 256 stub _read
262 257 stub _rmdir
263 258 stub _rmtmp
264 259 stub _rotl
265 260 stub _rotr
266 261 stub _scalb
267 262 stub _searchenv
268 263 stub _seterrormode
269 264 stub _setjmp
270 265 stub _setmode
271 266 stub _setsystime
272 267 stub _sleep
273 268 stub _snprintf
274 269 stub _snwprintf
275 270 stub _sopen
276 271 stub _spawnl
277 272 stub _spawnle
278 273 stub _spawnlp
279 274 stub _spawnlpe
280 275 stub _spawnv
281 276 stub _spawnve
282 277 stub _spawnvp
283 278 stub _spawnvpe
284 279 stub _splitpath
285 280 stub _stat
286 281 stub _statusfp
287 282 cdecl _strcmpi(ptr ptr) lstrcmpi32A
288 283 stub _strdate
289 284 stub _strdec
290 285 stub _strdup
291 286 stub _strerror
292 287 cdecl _stricmp(ptr ptr) lstrcmpi32A
293 288 stub _stricoll
294 289 stub _strinc
295 290 stub _strlwr
296 291 stub _strncnt
297 292 stub _strnextc
298 293 stub _strnicmp
299 294 stub _strninc
300 295 stub _strnset
301 296 stub _strrev
302 297 stub _strset
303 298 stub _strspnp
304 299 stub _strtime
305 300 cdecl _strupr(ptr) CRTDLL__strupr
306 301 stub _swab
307 302 stub _sys_errlist
308 303 stub _sys_nerr_dll
309 304 stub _tell
310 305 stub _tempnam
311 306 stub _timezone_dll
312 307 stub _tolower
313 308 stub _toupper
314 309 stub _tzname
315 310 stub _tzset
316 311 stub _ultoa
317 312 stub _ultow
318 313 stub _umask
319 314 stub _ungetch
320 315 stub _unlink
321 316 stub _unloaddll
322 317 stub _utime
323 318 stub _vsnprintf
324 319 stub _vsnwprintf
325 320 stub _wcsdup
326 321 stub _wcsicmp
327 322 stub _wcsicoll
328 323 stub _wcslwr
329 324 stub _wcsnicmp
330 325 stub _wcsnset
331 326 stub _wcsrev
332 327 stub _wcsset
333 328 stub _wcsupr
334 329 extern _winmajor_dll CRTDLL_winmajor_dll
335 330 extern _winminor_dll CRTDLL_winminor_dll
336 331 extern _winver_dll CRTDLL_winver_dll
337 332 cdecl _write(long ptr long) CRTDLL__write
338 333 stub _wtoi
339 334 stub _wtol
340 335 stub _y0
341 336 stub _y1
342 337 stub _yn
343 338 stub abort
344 339 cdecl abs(long) CRTDLL_abs
345 340 cdecl acos(long) CRTDLL_acos
346 341 stub asctime
347 342 cdecl asin(long) CRTDLL_asin
348 343 cdecl atan(long) CRTDLL_atan
349 344 cdecl atan2(long long) CRTDLL_atan2
350 345 stub atexit
351 346 cdecl atof(ptr) CRTDLL_atof
352 347 cdecl atoi(ptr) CRTDLL_atoi
353 348 cdecl atol(ptr) CRTDLL_atol
354 349 stub bsearch
355 350 stub calloc
356 351 stub ceil
357 352 stub clearerr
358 353 stub clock
359 354 cdecl cos(long) CRTDLL_cos
360 355 cdecl cosh(long) CRTDLL_cosh
361 356 stub ctime
362 357 stub difftime
363 358 stub div
364 359 cdecl exit(long) CRTDLL_exit
365 360 cdecl exp(long) CRTDLL_exp
366 361 cdecl fabs(long) CRTDLL_fabs
367 362 stub fclose
368 363 stub feof
369 364 stub ferror
370 365 cdecl fflush(ptr) CRTDLL_fflush
371 366 stub fgetc
372 367 stub fgetpos
373 368 stub fgets
374 369 stub fgetwc
375 370 stub floor
376 371 stub fmod
377 372 stub fopen
378 373 cdecl fprintf() CRTDLL_fprintf
379 374 stub fputc
380 375 stub fputs
381 376 stub fputwc
382 377 stub fread
383 378 cdecl free(ptr) CRTDLL_free
384 379 stub freopen
385 380 stub frexp
386 381 stub fscanf
387 382 stub fseek
388 383 stub fsetpos
389 384 stub ftell
390 385 stub fwprintf
391 386 stub fwrite
392 387 stub fwscanf
393 388 stub getc
394 389 stub getchar
395 390 stub getenv
396 391 cdecl gets(ptr) CRTDLL_gets
397 392 stub gmtime
398 393 stub is_wctype
399 394 cdecl isalnum(long) CRTDLL_isalnum
400 395 cdecl isalpha(long) CRTDLL_isalpha
401 396 cdecl iscntrl(long) CRTDLL_iscntrl
402 397 cdecl isdigit(long) CRTDLL_isdigit
403 398 cdecl isgraph(long) CRTDLL_isgraph
404 399 stub isleadbyte
405 400 cdecl islower(long) CRTDLL_islower
406 401 cdecl isprint(long) CRTDLL_isprint
407 402 cdecl ispunct(long) CRTDLL_ispunct
408 403 cdecl isspace(long) CRTDLL_isspace
409 404 cdecl isupper(long) CRTDLL_isupper
410 405 stub iswalnum
411 406 stub iswalpha
412 407 stub iswascii
413 408 stub iswcntrl
414 409 stub iswctype
415 410 stub iswdigit
416 411 stub iswgraph
417 412 stub iswlower
418 413 stub iswprint
419 414 stub iswpunct
420 415 stub iswspace
421 416 stub iswupper
422 417 stub iswxdigit
423 418 cdecl isxdigit(long) CRTDLL_isxdigit
424 419 cdecl labs(long) CRTDLL_labs
425 420 stub ldexp
426 421 stub ldiv
427 422 stub localeconv
428 423 stub localtime
429 424 cdecl log(long) CRTDLL_log
430 425 cdecl log10(long) CRTDLL_log10
431 426 stub longjmp
432 427 cdecl malloc(ptr) CRTDLL_malloc
433 428 stub mblen
434 429 stub mbstowcs
435 430 stub mbtowc
436 431 stub memchr
437 432 stub memcmp
438 433 stub memcpy
439 434 stub memmove
440 435 stub memset
441 436 stub mktime
442 437 stub modf
443 438 stub perror
444 439 cdecl pow(long long) CRTDLL_pow
445 440 cdecl printf() CRTDLL_printf
446 441 stub putc
447 442 cdecl putchar(long) CRTDLL_putchar
448 443 stub puts
449 444 stub qsort
450 445 stub raise
451 446 cdecl rand() CRTDLL_rand
452 447 stub realloc
453 448 stub remove
454 449 stub rename
455 450 stub rewind
456 451 stub scanf
457 452 stub setbuf
458 453 stub setlocale
459 454 stub setvbuf
460 455 stub signal
461 456 cdecl sin(long) CRTDLL_sin
462 457 cdecl sinh(long) CRTDLL_sinh
463 458 stub sprintf
464 459 cdecl sqrt(long) CRTDLL_sqrt
465 460 cdecl srand(long) CRTDLL_srand
466 461 stub sscanf
467 462 cdecl strcat(ptr ptr) lstrcat32A
468 463 stub strchr
469 464 cdecl strcmp(ptr ptr) lstrcmp32A
470 465 stub strcoll
471 466 cdecl strcpy(ptr ptr) lstrcpy32A
472 467 stub strcspn
473 468 stub strerror
474 469 stub strftime
475 470 cdecl strlen(ptr) lstrlen32A
476 471 cdecl strncat(ptr ptr long) lstrcatn32A
477 472 cdecl strncmp(ptr ptr long) lstrncmp32A
478 473 cdecl strncpy(ptr ptr long) lstrcpyn32A
479 474 stub strpbrk
480 475 stub strrchr
481 476 stub strspn
482 477 stub strstr
483 478 stub strtod
484 479 stub strtok
485 480 stub strtol
486 481 cdecl strtoul(ptr ptr long) strtoul
487 482 stub strxfrm
488 483 stub swprintf
489 484 stub swscanf
490 485 stub system
491 486 cdecl tan(long) CRTDLL_tan
492 487 cdecl tanh(long) CRTDLL_tanh
493 488 cdecl time(ptr) CRTDLL_time
494 489 stub tmpfile
495 490 stub tmpnam
496 491 cdecl tolower(long) CRTDLL_tolower
497 492 cdecl toupper(long) CRTDLL_toupper
498 493 stub towlower
499 494 stub towupper
500 495 stub ungetc
501 496 stub ungetwc
502 497 stub vfprintf
503 498 stub vfwprintf
504 499 stub vprintf
505 500 cdecl vsprintf() CRTDLL_vsprintf
506 501 stub vswprintf
507 502 stub vwprintf
508 503 stub wcscat
509 504 stub wcschr
510 505 stub wcscmp
511 506 stub wcscoll
512 507 stub wcscpy
513 508 stub wcscspn
514 509 stub wcsftime
515 510 stub wcslen
516 511 stub wcsncat
517 512 stub wcsncmp
518 513 stub wcsncpy
519 514 stub wcspbrk
520 515 stub wcsrchr
521 516 stub wcsspn
522 517 stub wcsstr
523 518 stub wcstod
524 519 stub wcstok
525 520 stub wcstol
526 521 stub wcstombs
527 522 stub wcstoul
528 523 stub wcsxfrm
529 524 stub wctomb
530 525 stub wprintf
531 526 stub wscanf