OBS: fix for Fedora 11 build
[siplcs.git] / contrib / opensuse-build-service / pidgin-sipe.spec
blobf61f4d5562bea54b8dd296687ebd60dd1d11cab9
2 # OBS SPEC file to generate a RPM for pidgin-sipe.
3 # It should work on Fedora 9/10/11/12, openSUSE 11.x, RHEL5/CentOS 5, SLES/D 11 and Mandriva 2009.1/2010.
6 %define purple_plugin libpurple-plugin-sipe
8 %define purple_develname libpurple-devel
10 %if 0%{?mandriva_version} >= 200910
11 %ifarch x86_64
12 %define purple_develname lib64purple-devel
13 %endif
14 %endif
16 %if 0%{?suse_version} || 0%{?sles_version}
17 %define pkg_group Productivity/Networking/Instant Messenger
18 %endif
19 %if 0%{?fedora_version}
20 %define pkg_group Applications/Internet
21 %endif
22 %if 0%{?mandriva_version}
23 %define pkg_group Networking/Instant messaging
24 %else
25 %define pkg_group Applications/Internet
26 %endif
28 Name: pidgin-sipe
29 Summary: Pidgin protocol plugin to connect to MS Office Communicator
30 Version: 1.10.0
31 Release: 1
32 Source: %{name}-%{version}.tar.gz
33 Group: %{pkg_group}
34 License: GPLv2+
35 URL: http://sipe.sourceforge.net/
37 BuildRoot: %{_tmppath}/%{name}-%{version}-build
39 BuildRequires: %{purple_develname} >= 2.4.0
40 BuildRequires: glib2-devel >= 2.12.0
41 BuildRequires: libxml2-devel
42 BuildRequires: libtool
43 BuildRequires: intltool
44 BuildRequires: gettext-devel
46 # Configurable components
47 %if !0%{?_without_kerberos:1}
48 BuildRequires: krb5-devel
49 %endif
51 # For directory ownership
52 BuildRequires: pidgin
53 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
54 Requires: pidgin
55 %if 0%{?sles_version} == 10
56 BuildRequires: gnome-keyring-devel
57 %endif
59 # For OBS's "have choice for" for Fedora 11 (only)
60 %if 0%{?fedora_version} == 11
61 BuildRequires: libproxy-mozjs
62 BuildRequires: PolicyKit-gnome
63 %endif
65 %description
66 A third-party plugin for the Pidgin multi-protocol instant messenger.
67 It implements the extended version of SIP/SIMPLE used by various products:
69 * Microsoft Office Communications Server (OCS 2007/2007 R2 and newer)
70 * Microsoft Live Communications Server (LCS 2003/2005)
71 * Reuters Messaging
73 With this plugin you should be able to replace your Microsoft Office
74 Communicator client with Pidgin.
76 This package provides the icon set for Pidgin.
79 %package -n %{purple_plugin}
80 Summary: Libpurple protocol plugin to connect to MS Office Communicator
81 Group: %{pkg_group}
82 License: GPLv2+
83 Obsoletes: purple-sipe
85 %description -n %{purple_plugin}
86 A third-party plugin for the Pidgin multi-protocol instant messenger.
87 It implements the extended version of SIP/SIMPLE used by various products:
89 * Microsoft Office Communications Server (OCS 2007/2007 R2 and newer)
90 * Microsoft Live Communications Server (LCS 2003/2005)
91 * Reuters Messaging
93 This package provides the protocol plugin for libpurple clients.
96 %prep
97 %setup -q
99 %build
100 %if 0%{?sles_version} == 10
101 export CFLAGS="%optflags -I%{_includedir}/gssapi"
102 %endif
103 %if 0%{?mandriva_version}
104 autoreconf --verbose --install --force
105 %endif
106 %configure \
107 --enable-purple \
108 --disable-telepathy
109 make %{_smp_mflags}
110 make %{_smp_mflags} check
113 %install
114 %makeinstall
115 find %{buildroot} -type f -name "*.la" -delete -print
116 # SLES11 defines suse_version = 1110
117 %if 0%{?suse_version} && 0%{?suse_version} < 1120
118 rm -r %{buildroot}/%{_datadir}/pixmaps/pidgin/protocols/scalable
119 %endif
120 %find_lang %{name}
123 %clean
124 rm -rf %{buildroot}
127 %files -n %{purple_plugin} -f %{name}.lang
128 %defattr(-,root,root,-)
129 %doc AUTHORS ChangeLog COPYING NEWS README TODO
130 %{_libdir}/purple-2/libsipe.so
133 %files
134 %defattr(-,root,root,-)
135 %doc AUTHORS COPYING
136 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
137 # SLES11 defines suse_version = 1110
138 %if !0%{?suse_version} || 0%{?suse_version} >= 1120
139 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
140 %endif
143 %changelog
144 * Fri Apr 02 2010 J. D. User <jduser@noreply.com> pre-1.10.0-*git*
145 - Mandriva has too old libtool version
147 * Fri Apr 02 2010 J. D. User <jduser@noreply.com> pre-1.10.0-*git*
148 - SLE11, openSUSE 11.0/1 don't have pidgin/protocols/scalable directory
150 * Sun Mar 07 2010 pier11 <pier11@operamail.com> pre-1.10.0-*git*
151 - OBS tests of pre-1.10.0 git-snapshot 4fa20cd65e5be0e469d4aa55d861f11c5b08b816
153 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
154 - added --enable/--disable build options
156 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
157 - removed --with-krb5 configure option as it is autodetected now
159 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
160 - add SVG icon
162 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
163 - add BR glib2-devel >= 2.12.0
165 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
166 - add tests to build
168 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
169 - update to 1.9.1
171 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
172 - add BR libxml2-devel
174 * Wed Mar 10 2010 pier11 <pier11@operamail.com> 1.9.0
175 - release
176 - dropped SLE 10 due to libpurple min version increase
177 - updated target distros in comment line
179 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
180 - increased libpurple build requisite to >= 2.4.0
182 * Sun Mar 07 2010 pier11 <pier11@operamail.com> pre-1.9.0-*git*
183 - OBS tests of pre-1.9.0 git-snapshot 61ea0856855483b9e18f23a87afe47437e526f0e
185 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
186 - sync with RPM SPEC from contrib/rpm
188 * Sun Feb 08 2010 pier11 <pier11@operamail.com> 1.8.0
189 - source is an original 1.8.0 with patch: git(upstream) 9c34cc3557daa3d61a002002492c71d0343c8cae
190 - temp hack - renamed source in spec from .bz2 to .gz as the latter was prepared with the patch.
192 * Sun Nov 22 2009 pier11 <pier11@operamail.com> 1.7.1
193 - reinstated enable-quality-check
195 * Wed Nov 04 2009 John Beranek <john@redux.org.uk> 1.7.0
196 - Spec file modifications to allow SLES/D 10 and Mandriva 2009.1 builds
198 * Tue Nov 03 2009 John Beranek <john@redux.org.uk> 1.7.0
199 - Spec file modifications for openSUSE build service
201 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
202 - move non-Pidgin files to new sub-package purple-sipe
204 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
205 - remove directory for emoticon theme icons
207 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
208 - libpurple protocol plugins are located under %%{_libdir}/purple-2
210 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
211 - added directory for emoticon theme icons
213 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
214 - update to 1.6.3
216 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
217 - reduce libpurple-devel requirement to >= 2.3.1
219 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
220 - update to 1.6.2
222 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
223 - reduce libpurple-devel requirement to >= 2.4.1
225 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
226 - com_err.h only required for kerberos
228 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
229 - require libpurple-devel >= 2.5.0
231 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
232 - refactor configure parameters
233 - make kerberos configurable
234 - don't hard code prefix for git builds
236 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
237 - removed unnecessary zlib-devel
239 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
240 - fix prefix for git builds
242 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
243 - append -Wno-unused-parameter for GCC <4.4 compilation errors
245 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
246 - remove duplicate GPL2
248 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
249 - use "--with git" to build from git
250 - corrected download URL for release archive
251 - add missing BR gettext-devel
253 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
254 - use default rpmbuild CFLAGS also for git builds
255 - merge with SPEC files created by mricon & jberanek
257 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
258 - initial RPM SPEC example generated