Release 1.25.0 -- Buddy Idle Time, RTF
[siplcs.git] / contrib / opensuse-build-service / pidgin-sipe.spec
bloba6b90c787849db904a8a8a88d9062f96be87131f
2 # OBS SPEC file to generate a RPM for pidgin-sipe.
4 # It has support for:
6 # RedHat family (CentOS, Fedora, RHEL, ScientificLinux)
7 # SUSE family (openSUSE, SLED, SLES)
8 # Mageia
9 # Windows (mingw32, mingw64)
12 # Build options
13 %undefine build_telepathy
15 # Check for mingw32 cross compilation build
17 # Manually add this repository to your private OBS project:
19 # <repository name="mingw32">
20 # <path repository="openSUSE_13.2" project="windows:mingw:win32"/>
21 # <arch>i586</arch>
22 # </repository>
24 %if "%{_repository}" == "mingw32"
25 %define purple_sipe_mingw32 1
26 %define mingw_prefix mingw32-
27 %define mingw_cache %{_mingw32_cache}
28 %define mingw_configure %{_mingw32_configure}
29 %define mingw_datadir %{_mingw32_datadir}
30 %define mingw_debug_package %{_mingw32_debug_package}
31 %define mingw_ldflags MINGW32_LDFLAGS
32 %define mingw_libdir %{_mingw32_libdir}
33 %define mingw_make %{_mingw32_make}
34 %define mingw_makeinstall %{_mingw32_makeinstall}
35 %define __strip %{_mingw32_strip}
36 %define __objdump %{_mingw32_objdump}
37 %define _use_internal_dependency_generator 0
38 %define __find_requires %{_mingw32_findrequires}
39 %define __find_provides %{_mingw32_findprovides}
40 %define __os_install_post %{_mingw32_debug_install_post} \
41 %{_mingw32_install_post}
42 %endif
44 # Check for mingw64 cross compilation build
46 # Manually add this repository to your private OBS project:
48 # <repository name="mingw64">
49 # <path repository="openSUSE_13.2" project="windows:mingw:win64"/>
50 # <arch>i586</arch>
51 # </repository>
53 %if "%{_repository}" == "mingw64"
54 %define purple_sipe_mingw64 1
55 %define mingw_prefix mingw64-
56 %define mingw_cache %{_mingw64_cache}
57 %define mingw_configure %{_mingw64_configure}
58 %define mingw_datadir %{_mingw64_datadir}
59 %define mingw_debug_package %{_mingw64_debug_package}
60 %define mingw_ldflags MINGW64_LDFLAGS
61 %define mingw_libdir %{_mingw64_libdir}
62 %define mingw_make %{_mingw64_make}
63 %define mingw_makeinstall %{_mingw64_makeinstall}
64 %define __strip %{_mingw64_strip}
65 %define __objdump %{_mingw64_objdump}
66 %define _use_internal_dependency_generator 0
67 %define __find_requires %{_mingw64_findrequires}
68 %define __find_provides %{_mingw64_findprovides}
69 %define __os_install_post %{_mingw64_debug_install_post} \
70 %{_mingw64_install_post}
71 %endif
73 %define purple_plugin %{?mingw_prefix:%{mingw_prefix}}libpurple-plugin-sipe
74 %define telepathy_plugin %{?mingw_prefix:%{mingw_prefix}}telepathy-plugin-sipe
75 %define nsis_package %{?mingw_prefix:%{mingw_prefix}}pidgin-sipe-nsis
76 %define common_files sipe-common
77 %define empathy_files empathy-sipe
78 %define ktp_files ktp-accounts-kcm-sipe
81 %if 0%{?mageia}
82 %if %{mageia} > 6
83 %define has_freerdp 1
84 %define has_gssntlmssp 1
85 %else
86 %define has_appstream_legacy 1
87 %endif
88 %define has_appstream 1
89 %define has_gstreamer 1
90 %endif
92 %if 0%{?suse_version}
93 %if 0%{?is_opensuse}
94 %define has_appstream 1
95 %define has_appstream_legacy 1
96 %if 0%{?suse_version} >= 1500
97 %define has_freerdp 1
98 %else
99 %define build_empathy 1
100 %endif
101 %endif
102 %define has_gstreamer 1
103 %define build_telepathy 1
104 %endif
106 %if 0%{?suse_version}
107 %define pkg_group Productivity/Networking/Instant Messenger
108 %else
109 %define pkg_group Applications/Communications
110 %endif
112 # workaround for Fedora Rawhide
113 %if 0%{?fedora_version}
114 %if 0%{?fedora}
115 %else
116 %define fedora %{?fedora_version}
117 %endif
118 %endif
120 %if 0%{?fedora}
121 %define has_appstream 1
122 %if %{fedora} <= 29
123 %define build_empathy 1
124 %endif
125 %if %{fedora} <= 26
126 %define has_appstream_legacy 1
127 %endif
128 %if %{fedora} > 25
129 %define has_freerdp 1
130 %endif
131 %define has_gssntlmssp 1
132 %define has_gstreamer 1
133 %define build_telepathy 1
134 %define build_ktp 1
135 %endif
137 %if 0%{?centos_version} || 0%{?scientificlinux_version}
138 %define has_krb5devel 1
139 %define rhel_base_version %{?centos_version}%{?scientificlinux_version}
140 %if %{rhel_base_version} >= 700
141 %define has_gstreamer 1
142 %endif
143 %endif
145 %if 0%{?purple_sipe_mingw32}
146 Name: mingw32-pidgin-sipe
147 %else
148 %if 0%{?purple_sipe_mingw64}
149 Name: mingw64-pidgin-sipe
150 %else
151 Name: pidgin-sipe
152 %endif
153 %endif
154 Summary: Pidgin protocol plugin to connect to MS Office Communicator
155 Version: 1.25.0
156 Release: 1
157 Source: pidgin-sipe-%{version}.tar.gz
158 Group: %{pkg_group}
159 License: GPL-2.0-or-later
160 URL: http://sipe.sourceforge.net/
162 BuildRoot: %{_tmppath}/%{name}-%{version}-build
164 %if 0%{?mingw_prefix:1}
166 # Windows cross-compilation build setup
168 BuildArch: noarch
169 #!BuildIgnore: post-build-checks
171 BuildRequires: libtool
172 BuildRequires: intltool
173 BuildRequires: %{mingw_prefix}filesystem >= 23
174 BuildRequires: %{mingw_prefix}cross-gcc
175 BuildRequires: %{mingw_prefix}cross-binutils
176 BuildRequires: %{mingw_prefix}gettext-runtime
177 BuildRequires: %{mingw_prefix}cross-pkg-config
178 BuildRequires: %{mingw_prefix}glib2-devel >= 2.18.0
179 BuildRequires: %{mingw_prefix}libxml2-devel
180 BuildRequires: %{mingw_prefix}mozilla-nss-devel
181 BuildRequires: %{mingw_prefix}libpurple-devel >= 2.7.0
182 BuildRequires: %{mingw_prefix}cross-nsis
184 # For directory ownership
185 BuildRequires: %{mingw_prefix}pidgin
187 # Make sure telepathy is disabled for Windows builds
188 %undefine build_telepathy
190 %else
192 # Standard Linux build setup
194 BuildRequires: gcc
195 BuildRequires: libtool
196 BuildRequires: intltool
197 BuildRequires: pkgconfig(dbus-1)
198 BuildRequires: pkgconfig(glib-2.0) >= 2.18.0
199 BuildRequires: pkgconfig(gmodule-2.0) >= 2.18.0
200 BuildRequires: pkgconfig(libxml-2.0)
201 BuildRequires: pkgconfig(nss)
202 BuildRequires: pkgconfig(purple) >= 2.7.0
203 %if 0%{?mageia}
204 # It seems linking against -lpurple is severely broken on Mageia...
205 BuildRequires: pkgconfig(libgadu)
206 %if %{mageia} > 7
207 # -lpurple depends on this but doesn't have a dependency in -devel?
208 BuildRequires: pkgconfig(libnm)
209 %endif
210 %endif
211 %if 0%{?has_appstream:1}
212 %if 0%{?suse_version}
213 BuildRequires: AppStream
214 %else
215 BuildRequires: appstream
216 %endif
217 %endif
218 %if 0%{?has_gstreamer:1}
219 BuildRequires: pkgconfig(farstream-0.2)
220 BuildRequires: pkgconfig(gio-2.0)
221 BuildRequires: pkgconfig(gstreamer-1.0)
222 BuildRequires: pkgconfig(gstreamer-rtp-1.0)
223 BuildRequires: pkgconfig(nice) >= 0.1.0
224 # Requirements for appshare server
225 %if 0%{?has_freerdp:1}
226 BuildRequires: pkgconfig(freerdp-shadow2)
227 %endif
228 %endif
229 # Requirements for telepathy backend
230 %if 0%{?build_telepathy:1}
231 BuildRequires: gmime-devel
232 BuildRequires: pkgconfig(dbus-glib-1)
233 BuildRequires: pkgconfig(gio-2.0) >= 2.32.0
234 BuildRequires: pkgconfig(glib-2.0) >= 2.32.0
235 BuildRequires: pkgconfig(gobject-2.0)
236 BuildRequires: pkgconfig(telepathy-glib) >= 0.24.0
237 %endif
239 # Configurable components
240 # Use "--without kerberos" to disable krb5
241 %if !0%{?_without_kerberos:1}
242 %if 0%{?has_krb5devel:1}
243 BuildRequires: krb5-devel
244 %else
245 BuildRequires: pkgconfig(krb5)
246 %endif
247 %if 0%{?has_gssntlmssp:1}
248 BuildRequires: gssntlmssp-devel >= 0.5.0
249 Requires: gssntlmssp >= 0.5.0
250 %endif
251 %endif
253 # For directory ownership
254 BuildRequires: pidgin
255 Requires: pidgin
256 %if 0%{?build_telepathy:1}
257 %if 0%{?build_empathy:1}
258 BuildRequires: empathy
259 %endif
260 %endif
262 # End Windows cross-compilation/Linux build setup
263 %endif
265 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
268 %description
269 A third-party plugin for the Pidgin multi-protocol instant messenger.
270 It implements the extended version of SIP/SIMPLE used by various products:
272 * Skype for Business
273 * Microsoft Office 365
274 * Microsoft Business Productivity Online Suite (BPOS)
275 * Microsoft Lync Server
276 * Microsoft Office Communications Server (OCS 2007/2007 R2)
277 * Microsoft Live Communications Server (LCS 2003/2005)
279 With this plugin you should be able to replace your Microsoft Office
280 Communicator client with Pidgin.
282 This package provides the icon set for Pidgin.
285 %package -n %{purple_plugin}
286 Summary: Libpurple protocol plugin to connect to MS Office Communicator
287 Group: %{pkg_group}
288 License: GPL-2.0-or-later
289 Obsoletes: purple-sipe
290 %if 0%{?build_telepathy:1}
291 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
292 %endif
294 %description -n %{purple_plugin}
295 A third-party plugin for the Pidgin multi-protocol instant messenger.
296 It implements the extended version of SIP/SIMPLE used by various products:
298 * Skype for Business
299 * Microsoft Office 365
300 * Microsoft Business Productivity Online Suite (BPOS)
301 * Microsoft Lync Server
302 * Microsoft Office Communications Server (OCS 2007/2007 R2)
303 * Microsoft Live Communications Server (LCS 2003/2005)
305 This package provides the protocol plugin for libpurple clients.
308 %if 0%{?build_telepathy:1}
309 %if 0%{?build_empathy:1}
310 %package -n %{empathy_files}
311 Summary: Telepathy connection manager to connect to MS Office Communicator
312 Group: %{pkg_group}
313 License: GPL-2.0-or-later
314 Requires: empathy
315 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
317 %description -n %{empathy_files}
318 A Telepathy connection manager that implements the extended version of
319 SIP/SIMPLE used by various products:
321 * Skype for Business
322 * Microsoft Office 365
323 * Microsoft Business Productivity Online Suite (BPOS)
324 * Microsoft Lync Server
325 * Microsoft Office Communications Server (OCS 2007/2007 R2)
326 * Microsoft Live Communications Server (LCS 2003/2005)
328 This package provides the icon set for Empathy.
329 %endif
332 %if 0%{?build_ktp:1}
333 %package -n %{ktp_files}
334 Summary: Telepathy connection manager to connect to MS Office Communicator
335 Group: %{pkg_group}
336 License: GPL-2.0-or-later
337 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
339 %description -n %{ktp_files}
340 A Telepathy connection manager that implements the extended version of
341 SIP/SIMPLE used by various products:
343 * Skype for Business
344 * Microsoft Office 365
345 * Microsoft Business Productivity Online Suite (BPOS)
346 * Microsoft Lync Server
347 * Microsoft Office Communications Server (OCS 2007/2007 R2)
348 * Microsoft Live Communications Server (LCS 2003/2005)
350 This package provides the profile for KTP account manager.
351 %endif
354 %package -n %{telepathy_plugin}
355 Summary: Telepathy connection manager to connect to MS Office Communicator
356 Group: %{pkg_group}
357 License: GPL-2.0-or-later
358 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
360 %description -n %{telepathy_plugin}
361 A Telepathy connection manager that implements the extended version of
362 SIP/SIMPLE used by various products:
364 * Skype for Business
365 * Microsoft Office 365
366 * Microsoft Business Productivity Online Suite (BPOS)
367 * Microsoft Lync Server
368 * Microsoft Office Communications Server (OCS 2007/2007 R2)
369 * Microsoft Live Communications Server (LCS 2003/2005)
371 This package provides the protocol support for Telepathy clients.
374 %package -n %{common_files}
375 Summary: Common files for SIPE protocol plugins
376 Group: %{pkg_group}
377 License: GPL-2.0-or-later
378 BuildArch: noarch
380 %description -n %{common_files}
381 This package provides common files for the SIPE protocol plugins:
383 * Localisation
384 %endif
387 %if 0%{?mingw_prefix:1}
388 %package -n %{nsis_package}
389 Summary: Windows Pidgin protocol plugin to connect to MS Office Communicator
390 Group: %{pkg_group}
391 License: GPL-2.0-or-later
393 %description -n %{nsis_package}
394 A third-party plugin for the Pidgin multi-protocol instant messenger.
395 It implements the extended version of SIP/SIMPLE used by various products:
397 * Skype for Business
398 * Microsoft Office 365
399 * Microsoft Business Productivity Online Suite (BPOS)
400 * Microsoft Lync Server
401 * Microsoft Office Communications Server (OCS 2007/2007 R2)
402 * Microsoft Live Communications Server (LCS 2003/2005)
404 This package contains the NSIS installer package of the protocol plugin
405 for Pidgin on Windows.
406 %endif
409 %{mingw_debug_package}
412 %prep
413 %setup -q -n pidgin-sipe-%{version}
415 %build
416 %if 0%{?mingw_prefix:1}
418 # Windows cross-compilation build
420 %{?env_options}
421 echo "lt_cv_deplibs_check_method='pass_all'" >>%{mingw_cache}
422 autoreconf --verbose --install --force
423 %{mingw_ldflags}="-Wl,--exclude-libs=libintl.a -Wl,--exclude-libs=libiconv.a -lws2_32"
424 %{mingw_configure} \
425 --enable-purple \
426 %if 0%{?build_telepathy:1}
427 --enable-telepathy
428 %else
429 --disable-telepathy
430 %endif
431 %{mingw_make} %{?_smp_mflags} || %{mingw_make}
433 %else
435 # Standard Linux build
437 # Special case handling for Mageia
438 %if 0%{?mageia}
439 %configure2_5x \
440 --with-krb5 \
441 --disable-telepathy
442 %make_build
443 %make_build check
445 # All other Linuxes
446 %else
447 %configure \
448 %if !0%{?has_appstream:1}
449 --without-appstream \
450 %endif
451 %if !0%{?_without_kerberos:1}
452 --with-krb5 \
453 %endif
454 --enable-purple \
455 %if 0%{?build_telepathy:1}
456 --enable-telepathy
457 %else
458 --disable-telepathy
459 %endif
460 make %{?_smp_mflags}
461 make %{?_smp_mflags} check
462 %endif
464 # End Windows cross-compilation/Linux build setup
465 %endif
468 %install
469 %if 0%{?mingw_prefix:1}
471 # Windows cross-compilation install
473 %{mingw_makeinstall}
474 rm -f %{buildroot}%{mingw_libdir}/purple-2/*.dll.a
476 # generate .dbgsym file
477 rm -f %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll.dbgsym
478 mv \
479 %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll \
480 %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll.dbgsym
481 %{__strip} --strip-unneeded \
482 %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll.dbgsym \
483 -o %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll \
485 # generate NSIS installer package
486 perl contrib/opensuse-build-service/generate_nsi.pl po/LINGUAS \
487 <contrib/opensuse-build-service/pidgin-sipe.nsi.template \
488 >%{buildroot}/pidgin-sipe.nsi
490 set -e; \
491 cd %{buildroot}; \
492 makensis \
493 -DPIDGIN_VERSION=UNKNOWN \
494 -DVERSION=%{version} \
495 -DMINGW_LIBDIR=%{buildroot}%{mingw_libdir} \
496 -DMINGW_DATADIR=%{buildroot}%{mingw_datadir} \
497 pidgin-sipe.nsi \
499 rm -f %{buildroot}/pidgin-sipe.nsi
501 %else
503 # Standard Linux install
505 %make_install
507 # End Windows cross-compilation/Linux build setup
508 %endif
510 find %{buildroot} -type f -name "*.la" -delete -print
511 # Pidgin doesn't have 24 or 32 pixel icons
512 rm -f \
513 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/24/sipe.png \
514 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/32/sipe.png
515 %if 0%{?has_appstream_legacy:1}
516 mv %{buildroot}/%{_datadir}/metainfo %{buildroot}/%{_datadir}/appdata
517 %endif
518 %if 0%{?build_telepathy:1}
519 %if !0%{?build_empathy:1}
520 rm -r %{buildroot}%{_datadir}/empathy
521 %endif
522 %if !0%{?build_ktp:1}
523 rm -r %{buildroot}%{_datadir}/telepathy
524 %endif
525 %endif
526 %find_lang pidgin-sipe
529 %if 0%{?build_telepathy:1}
530 %files -n %{purple_plugin}
531 %else
532 %files -n %{purple_plugin} -f pidgin-sipe.lang
533 %endif
534 %defattr(-,root,root,-)
535 %doc AUTHORS ChangeLog COPYING NEWS README TODO
536 %if 0%{?mingw_prefix:1}
537 %{mingw_libdir}/purple-2/libsipe.dll
538 %{mingw_libdir}/purple-2/libsipe.dll.dbgsym
539 %else
540 %{_libdir}/purple-2/libsipe.so
541 %endif
544 %if 0%{?build_telepathy:1}
545 %if 0%{?build_empathy:1}
546 %files -n %{empathy_files}
547 %defattr(-,root,root,-)
548 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.png
549 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.svg
550 %endif
553 %if 0%{?build_ktp:1}
554 %files -n %{ktp_files}
555 %defattr(-,root,root,-)
556 %doc AUTHORS COPYING
557 %{_datadir}/telepathy/profiles/sipe.profile
558 %endif
561 %files -n %{telepathy_plugin}
562 %defattr(-,root,root,-)
563 %doc AUTHORS ChangeLog COPYING NEWS README TODO
564 %{_datadir}/dbus-1/services/*.sipe.service
565 %{_libexecdir}/telepathy-sipe
568 %files -n %{common_files} -f pidgin-sipe.lang
569 %defattr(-,root,root,-)
570 %endif
573 %files
574 %defattr(-,root,root,-)
575 %doc AUTHORS COPYING
576 %if 0%{?mingw_prefix:1}
577 %if 0%{?has_appstream:1}
578 %{mingw_datadir}/metainfo/pidgin-sipe.metainfo.xml
579 %endif
580 %{mingw_datadir}/pixmaps/pidgin/protocols/*/sipe.png
581 %{mingw_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
582 %else
583 %if 0%{?has_appstream:1}
584 %if 0%{?has_appstream_legacy:1}
585 %{_datadir}/appdata/%{name}.metainfo.xml
586 %else
587 %{_datadir}/metainfo/%{name}.metainfo.xml
588 %endif
589 %endif
590 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
591 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
592 %endif
595 %if 0%{?mingw_prefix:1}
596 %files -n %{nsis_package}
597 %defattr(-, root, root)
598 /pidgin-sipe-%{version}.exe
599 %endif
602 %changelog
603 * Sat Oct 12 2019 J. D. User <jduser@noreply.com> 1.25.0
604 - update to 1.25.0
606 * Fri Oct 04 2019 J. D. User <jduser@noreply.com> 1.24.0-*git*
607 - add BR libnm for Mageia 8+
609 * Tue Jul 02 2019 J. D. User <jduser@noreply.com> 1.24.0-*git*
610 - add freerdp & gssntlmssp for Mageia 7+
612 * Sun Jun 30 2019 J. D. User <jduser@noreply.com> 1.24.0-*git*
613 - switch to SPDX identifier GPL-2.0-or-later
615 * Sun Jun 30 2019 J. D. User <jduser@noreply.com> 1.24.0-*git*
616 - newer distros no longer package empathy
618 * Sun Jun 30 2019 J. D. User <jduser@noreply.com> 1.24.0-*git*
619 - raise BR telepathy-glib >= 0.24.0
621 * Sat Nov 10 2018 J. D. User <jduser@noreply.com> 1.24.0
622 - update to 1.24.0
624 * Sat Sep 01 2018 J. D. User <jduser@noreply.com> 1.23.3-*git*
625 - update support for CentOS & Scientific Linux 7
627 * Mon Aug 27 2018 J. D. User <jduser@noreply.com> 1.23.3-*git*
628 - add BR freerdp-shadow2
630 * Mon Aug 20 2018 J. D. User <jduser@noreply.com> 1.23.3
631 - update to 1.23.3
633 * Sat Mar 10 2018 J. D. User <jduser@noreply.com> 1.23.2
634 - update to 1.23.2
636 * Sun Feb 25 2018 J. D. User <jduser@noreply.com> 1.23.1
637 - update to 1.23.1
639 * Sun Feb 18 2018 J. D. User <jduser@noreply.com> 1.23.0-*git*
640 - remove obsolete clean section
642 * Sun Feb 18 2018 J. D. User <jduser@noreply.com> 1.23.0-*git*
643 - add BR gcc
645 * Mon Nov 06 2017 J. D. User <jduser@noreply.com> 1.23.0-*git*
646 - add BR appstream
648 * Sun Nov 05 2017 J. D. User <jduser@noreply.com> 1.23.0-*git*
649 - add support for new AppStream metadata file location
651 * Sat Oct 28 2017 J. D. User <jduser@noreply.com> 1.23.0
652 - update to 1.23.0
653 - raise BR glib-2.0 >= 2.18.0
654 - raise BR purple >= 2.7.0
656 * Fri Aug 11 2017 J. D. User <jduser@noreply.com> 1.22.1-*git*
657 - add BR dbus-1
658 - fix incorrect BR gstreamer-0.10 when gstreamer-1.0 is selected
660 * Sun Jun 11 2017 J. D. User <jduser@noreply.com> 1.22.1
661 - update to 1.22.1
663 * Wed Feb 01 2017 J. D. User <jduser@noreply.com> 1.22.0
664 - update to 1.22.0
666 * Sun Dec 18 2016 J. D. User <jduser@noreply.com> 1.21.1-*git*
667 - add BR gio-2.0
669 * Wed Jun 15 2016 J. D. User <jduser@noreply.com> 1.21.1-*git*
670 - add BR farstream-0.2
672 * Sat May 28 2016 J. D. User <jduser@noreply.com> 1.21.1
673 - update to 1.21.1
675 * Sat Apr 23 2016 J. D. User <jduser@noreply.com> 1.21.0
676 - update to 1.21.0
678 * Tue Apr 05 2016 J. D. User <jduser@noreply.com> 1.20.1-*git*
679 - align with Fedora SPEC file
681 * Fri Jan 01 2016 J. D. User <jduser@noreply.com> 1.20.1-*git*
682 - add AppStream metadata file
684 * Sun Nov 08 2015 J. D. User <jduser@noreply.com> 1.20.1-*git*
685 - add dependency on pkgconfig(gstreamer-1.0) for F22+ & Leap 42.1+
687 * Sat Oct 24 2015 J. D. User <jduser@noreply.com> 1.20.1
688 - update to 1.20.1
690 * Thu Sep 03 2015 J. D. User <jduser@noreply.com> 1.20.0-*git*
691 - we also support "Skype for Business"
693 * Sat Aug 29 2015 J. D. User <jduser@noreply.com> 1.20.0
694 - update to 1.20.0
696 * Sat Apr 04 2015 J. D. User <jduser@noreply.com> 1.19.1
697 - update to 1.19.1
699 * Sat Feb 07 2015 J. D. User <jduser@noreply.com> 1.19.0
700 - update to 1.19.0
702 * Tue Jan 06 2015 J. D. User <jduser@noreply.com> 1.18.5-*git*
703 - add dependency on gssntlmssp(-devel) >= 0.5.0 for F21+
705 * Mon Jan 05 2015 J. D. User <jduser@noreply.com> 1.18.5-*git*
706 - remove support for obsolete distributions
707 - Fedora < 19
708 - Mandriva
709 - OpenSUSE < 13.x
711 * Mon Dec 29 2014 J. D. User <jduser@noreply.com> 1.18.5
712 - update to 1.18.5
714 * Thu Dec 18 2014 J. D. User <jduser@noreply.com> 1.18.4-*git*
715 - improve support for CentOS & Scientific Linux
717 * Sat Oct 18 2014 J. D. User <jduser@noreply.com> 1.18.4
718 - update to 1.18.4
720 * Sat Aug 16 2014 J. D. User <jduser@noreply.com> 1.18.3
721 - update to 1.18.3
723 * Sat Jun 07 2014 J. D. User <jduser@noreply.com> 1.18.2
724 - update to 1.18.2
726 * Sat Apr 12 2014 J. D. User <jduser@noreply.com> 1.18.1
727 - update to 1.18.1
729 * Tue Mar 04 2014 J. D. User <jduser@noreply.com> 1.18.0-*git*
730 - F20+/openSUSE 12.2+ require libnice gstreamer-0.10 plugin
732 * Sat Jan 11 2014 J. D. User <jduser@noreply.com> 1.18.0
733 - update to 1.18.0
735 * Wed Dec 11 2013 J. D. User <jduser@noreply.com> 1.17.3
736 - update to 1.17.3
738 * Sat Nov 30 2013 J. D. User <jduser@noreply.com> 1.17.2
739 - update to 1.17.2
741 * Sat Nov 16 2013 J. D. User <jduser@noreply.com> 1.17.1
742 - update to 1.17.1
744 * Sat Sep 21 2013 J. D. User <jduser@noreply.com> 1.17.0
745 - update to 1.17.0
747 * Sat Jul 13 2013 J. D. User <jduser@noreply.com> 1.16.1
748 - update to 1.16.1
750 * Fri Jun 14 2013 J. D. User <jduser@noreply.com> 1.16.0
751 - update to 1.16.0
753 * Sun Apr 07 2013 J. D. User <jduser@noreply.com> 1.15.1
754 - update to 1.15.1
756 * Fri Mar 29 2013 J. D. User <jduser@noreply.com> 1.15.0-*git*
757 - update package description texts
759 * Sat Mar 09 2013 J. D. User <jduser@noreply.com> 1.15.0
760 - update to 1.15.0
762 * Wed Dec 26 2012 J. D. User <jduser@noreply.com> 1.14.1
763 - update to 1.14.1
765 * Sun Dec 16 2012 J. D. User <jduser@noreply.com> 1.14.0
766 - update to 1.14.0
768 * Tue Sep 25 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
769 - change BR gstreamer-devel to pkgconfig(gstreamer-0.10)
771 * Sun Sep 09 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
772 - BR telepathy-glib-devel >= 0.18.0
774 * Wed Sep 05 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
775 - BR telepathy-glib-devel >= 0.14.0
777 * Sun Sep 02 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
778 - really disable telepathy for Windows cross-compilation builds
780 * Thu Aug 30 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
781 - updates to enable telepathy build
783 * Sun Aug 19 2012 J. D. User <jduser@noreply.com> 1.13.3
784 - update to 1.13.3
786 * Sun Jun 10 2012 J. D. User <jduser@noreply.com> 1.13.2
787 - update to 1.13.2
789 * Mon Apr 09 2012 J. D. User <jduser@noreply.com> 1.13.1
790 - update to 1.13.1
792 * Wed Mar 14 2012 J. D. User <jduser@noreply.com> 1.13.0
793 - update to 1.13.0
795 * Mon Dec 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
796 - we do support Microsoft Lync Server 2010 now.
798 * Tue Dec 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
799 - update GPL2 license name
801 * Sat Nov 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
802 - add BR gmime-devel for Fedora to have at least one verification platform
804 * Sun Nov 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
805 - fix Mandriva 2011 unresolvable BR
807 * Mon Oct 31 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
808 - add BR nss-devel
810 * Sat Oct 01 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
811 - add NSIS package for mingw builds
813 * Sat Oct 01 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
814 - add mingw64 build
816 * Wed Sep 28 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
817 - remove BR mingw32-mozilla-nss-devel, not needed for SSPI.
819 * Mon Sep 19 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
820 - update mingw32 build
821 - update descriptions
823 * Mon Aug 29 2011 J. D. User <jduser@noreply.com> 1.12.0
824 - update to 1.12.0
826 * Wed Jun 22 2011 J. D. User <jduser@noreply.com> 1.11.2-*git*
827 - add gstreamer-devel to enable Voice & Video features
829 * Sat Dec 11 2010 J. D. User <jduser@noreply.com> 1.11.2-*git*
830 - add optional subpackage for telepathy connection manager
832 * Tue Nov 02 2010 J. D. User <jduser@noreply.com> 1.11.2
833 - update to 1.11.2
835 * Sun Oct 24 2010 J. D. User <jduser@noreply.com> 1.11.1
836 - update to 1.11.1
838 * Fri Oct 15 2010 J. D. User <jduser@noreply.com> 1.11.0-*git*
839 - add mingw32 build configuration
841 * Sun Oct 03 2010 J. D. User <jduser@noreply.com> 1.11.0
842 - update to 1.11.0
844 * Thu Sep 02 2010 J. D. User <jduser@noreply.com> pre-1.11.0-*git*
845 - Mandriva config for OBS has changed
847 * Tue May 04 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
848 - add libnice build information discovered through OBS testing
850 * Mon Apr 12 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
851 - add NSS build information discovered through OBS testing
853 * Sun Apr 04 2010 pier11 <pier11@operamail.com> 1.10.0
854 - release
856 * Fri Apr 02 2010 J. D. User <jduser@noreply.com> pre-1.10.0-*git*
857 - Mandriva has too old libtool version
859 * Fri Apr 02 2010 J. D. User <jduser@noreply.com> pre-1.10.0-*git*
860 - SLE11, openSUSE 11.0/1 don't have pidgin/protocols/scalable directory
862 * Thu Apr 01 2010 pier11 <pier11@operamail.com> pre-1.10.0-*git*
863 - OBS tests of pre-1.10.0 git-snapshot 4fa20cd65e5be0e469d4aa55d861f11c5b08b816
865 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
866 - added --enable/--disable build options
868 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
869 - removed --with-krb5 configure option as it is autodetected now
871 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
872 - add SVG icon
874 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
875 - add BR glib2-devel >= 2.12.0
877 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
878 - add tests to build
880 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
881 - update to 1.9.1
883 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
884 - add BR libxml2-devel
886 * Wed Mar 10 2010 pier11 <pier11@operamail.com> 1.9.0
887 - release
888 - dropped SLE 10 due to libpurple min version increase
889 - updated target distros in comment line
891 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
892 - increased libpurple build requisite to >= 2.4.0
894 * Sun Mar 07 2010 pier11 <pier11@operamail.com> pre-1.9.0-*git*
895 - OBS tests of pre-1.9.0 git-snapshot 61ea0856855483b9e18f23a87afe47437e526f0e
897 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
898 - sync with RPM SPEC from contrib/rpm
900 * Mon Feb 08 2010 pier11 <pier11@operamail.com> 1.8.0
901 - source is an original 1.8.0 with patch: git(upstream) 9c34cc3557daa3d61a002002492c71d0343c8cae
902 - temp hack - renamed source in spec from .bz2 to .gz as the latter was prepared with the patch.
904 * Sun Nov 22 2009 pier11 <pier11@operamail.com> 1.7.1
905 - reinstated enable-quality-check
907 * Wed Nov 04 2009 John Beranek <john@redux.org.uk> 1.7.0
908 - Spec file modifications to allow SLES/D 10 and Mandriva 2009.1 builds
910 * Tue Nov 03 2009 John Beranek <john@redux.org.uk> 1.7.0
911 - Spec file modifications for openSUSE build service
913 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
914 - move non-Pidgin files to new sub-package purple-sipe
916 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
917 - remove directory for emoticon theme icons
919 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
920 - libpurple protocol plugins are located under %%{_libdir}/purple-2
922 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
923 - added directory for emoticon theme icons
925 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
926 - update to 1.6.3
928 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
929 - reduce libpurple-devel requirement to >= 2.3.1
931 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
932 - update to 1.6.2
934 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
935 - reduce libpurple-devel requirement to >= 2.4.1
937 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
938 - com_err.h only required for kerberos
940 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
941 - require libpurple-devel >= 2.5.0
943 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
944 - refactor configure parameters
945 - make kerberos configurable
946 - don't hard code prefix for git builds
948 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
949 - removed unnecessary zlib-devel
951 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
952 - fix prefix for git builds
954 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
955 - append -Wno-unused-parameter for GCC <4.4 compilation errors
957 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
958 - remove duplicate GPL2
960 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
961 - use "--with git" to build from git
962 - corrected download URL for release archive
963 - add missing BR gettext-devel
965 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
966 - use default rpmbuild CFLAGS also for git builds
967 - merge with SPEC files created by mricon & jberanek
969 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
970 - initial RPM SPEC example generated