OBS: update RPM SPEC changelog
[siplcs.git] / contrib / opensuse-build-service / pidgin-sipe.spec
blob95597244855c72e6ed2fcf5f9b9d841a20fbaafe
2 # OBS SPEC file to generate a RPM for pidgin-sipe.
3 # It should work on Fedora 9/10/11/12, openSUSE 11.x, RHEL5/CentOS 5, SLES/D 11 and Mandriva 2009.1/2010.
6 %define purple_plugin libpurple-plugin-sipe
8 %define purple_develname libpurple-devel
10 %if 0%{?mdkversion} >= 200910
11 %ifarch x86_64
12 %define purple_develname lib64purple-devel
13 %endif
14 %if 0%{?mdkversion} >= 201000
15 %ifnarch x86_64
16 %define has_libnice 1
17 %endif
18 %endif
19 %endif
21 %if 0%{?suse_version}
22 %define nss_develname mozilla-nss-devel
23 %if 0%{?suse_version} >= 1120
24 %define has_libnice 1
25 %endif
26 %else
27 %define nss_develname nss-devel
28 %endif
30 %if 0%{?suse_version} || 0%{?sles_version}
31 %define pkg_group Productivity/Networking/Instant Messenger
32 %endif
33 %if 0%{?fedora}
34 %define pkg_group Applications/Internet
35 %if 0%{?fedora} >= 11
36 %define has_libnice 1
37 %endif
38 %endif
39 %if 0%{?mdkversion}
40 %define pkg_group Networking/Instant messaging
41 %else
42 %define pkg_group Applications/Internet
43 %endif
45 Name: pidgin-sipe
46 Summary: Pidgin protocol plugin to connect to MS Office Communicator
47 Version: 1.11.0
48 Release: 1
49 Source: %{name}-%{version}.tar.gz
50 Group: %{pkg_group}
51 License: GPLv2+
52 URL: http://sipe.sourceforge.net/
54 BuildRoot: %{_tmppath}/%{name}-%{version}-build
56 BuildRequires: %{purple_develname} >= 2.4.0
57 BuildRequires: glib2-devel >= 2.12.0
58 BuildRequires: libxml2-devel
59 #BuildRequires: %{nss_develname}
60 BuildRequires: libtool
61 BuildRequires: intltool
62 BuildRequires: gettext-devel
63 %if 0%{?has_libnice:1}
64 BuildRequires: libnice-devel
65 %endif
67 # Configurable components
68 %if !0%{?_without_kerberos:1}
69 BuildRequires: krb5-devel
70 %endif
72 # For directory ownership
73 BuildRequires: pidgin
74 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
75 Requires: pidgin
76 %if 0%{?sles_version} == 10
77 BuildRequires: gnome-keyring-devel
78 %endif
80 # For OBS's "have choice for" for Fedora 11 (only)
81 %if 0%{?fedora_version} == 11
82 BuildRequires: libproxy-mozjs
83 BuildRequires: PolicyKit-gnome
84 %endif
86 # For OBS's "have choice for" for Mandriva 2010.1 (and up?)
87 %if 0%{?mdkversion} >= 201010
88 BuildRequires: polkit-gnome
89 %endif
91 %description
92 A third-party plugin for the Pidgin multi-protocol instant messenger.
93 It implements the extended version of SIP/SIMPLE used by various products:
95 * Microsoft Office Communications Server (OCS 2007/2007 R2 and newer)
96 * Microsoft Live Communications Server (LCS 2003/2005)
97 * Reuters Messaging
99 With this plugin you should be able to replace your Microsoft Office
100 Communicator client with Pidgin.
102 This package provides the icon set for Pidgin.
105 %package -n %{purple_plugin}
106 Summary: Libpurple protocol plugin to connect to MS Office Communicator
107 Group: %{pkg_group}
108 License: GPLv2+
109 Obsoletes: purple-sipe
111 %description -n %{purple_plugin}
112 A third-party plugin for the Pidgin multi-protocol instant messenger.
113 It implements the extended version of SIP/SIMPLE used by various products:
115 * Microsoft Office Communications Server (OCS 2007/2007 R2 and newer)
116 * Microsoft Live Communications Server (LCS 2003/2005)
117 * Reuters Messaging
119 This package provides the protocol plugin for libpurple clients.
122 %prep
123 %setup -q
125 %build
126 %if 0%{?sles_version} == 10
127 export CFLAGS="%optflags -I%{_includedir}/gssapi"
128 %endif
129 %if 0%{?mdkversion}
130 autoreconf --verbose --install --force
131 %endif
132 %configure \
133 --enable-purple \
134 --disable-telepathy
135 make %{_smp_mflags}
136 make %{_smp_mflags} check
139 %install
140 %makeinstall
141 find %{buildroot} -type f -name "*.la" -delete -print
142 # SLES11 defines suse_version = 1110
143 %if 0%{?suse_version} && 0%{?suse_version} < 1120
144 rm -r %{buildroot}/%{_datadir}/pixmaps/pidgin/protocols/scalable
145 %endif
146 %find_lang %{name}
149 %clean
150 rm -rf %{buildroot}
153 %files -n %{purple_plugin} -f %{name}.lang
154 %defattr(-,root,root,-)
155 %doc AUTHORS ChangeLog COPYING NEWS README TODO
156 %{_libdir}/purple-2/libsipe.so
159 %files
160 %defattr(-,root,root,-)
161 %doc AUTHORS COPYING
162 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
163 # SLES11 defines suse_version = 1110
164 %if !0%{?suse_version} || 0%{?suse_version} >= 1120
165 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
166 %endif
169 %changelog
170 * Thu Sep 02 2010 J. D. User <jduser@noreply.com> pre-1.11.0-*git*
171 - Mandriva config for OBS has changed
173 * Tue May 04 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
174 - add libnice build information discovered through OBS testing
176 * Mon Apr 12 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
177 - add NSS build information discovered through OBS testing
179 * Wed Apr 04 2010 pier11 <pier11@operamail.com> 1.10.0
180 - release
182 * Fri Apr 02 2010 J. D. User <jduser@noreply.com> pre-1.10.0-*git*
183 - Mandriva has too old libtool version
185 * Fri Apr 02 2010 J. D. User <jduser@noreply.com> pre-1.10.0-*git*
186 - SLE11, openSUSE 11.0/1 don't have pidgin/protocols/scalable directory
188 * Sun Mar 07 2010 pier11 <pier11@operamail.com> pre-1.10.0-*git*
189 - OBS tests of pre-1.10.0 git-snapshot 4fa20cd65e5be0e469d4aa55d861f11c5b08b816
191 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
192 - added --enable/--disable build options
194 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
195 - removed --with-krb5 configure option as it is autodetected now
197 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
198 - add SVG icon
200 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
201 - add BR glib2-devel >= 2.12.0
203 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
204 - add tests to build
206 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
207 - update to 1.9.1
209 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
210 - add BR libxml2-devel
212 * Wed Mar 10 2010 pier11 <pier11@operamail.com> 1.9.0
213 - release
214 - dropped SLE 10 due to libpurple min version increase
215 - updated target distros in comment line
217 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
218 - increased libpurple build requisite to >= 2.4.0
220 * Sun Mar 07 2010 pier11 <pier11@operamail.com> pre-1.9.0-*git*
221 - OBS tests of pre-1.9.0 git-snapshot 61ea0856855483b9e18f23a87afe47437e526f0e
223 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
224 - sync with RPM SPEC from contrib/rpm
226 * Sun Feb 08 2010 pier11 <pier11@operamail.com> 1.8.0
227 - source is an original 1.8.0 with patch: git(upstream) 9c34cc3557daa3d61a002002492c71d0343c8cae
228 - temp hack - renamed source in spec from .bz2 to .gz as the latter was prepared with the patch.
230 * Sun Nov 22 2009 pier11 <pier11@operamail.com> 1.7.1
231 - reinstated enable-quality-check
233 * Wed Nov 04 2009 John Beranek <john@redux.org.uk> 1.7.0
234 - Spec file modifications to allow SLES/D 10 and Mandriva 2009.1 builds
236 * Tue Nov 03 2009 John Beranek <john@redux.org.uk> 1.7.0
237 - Spec file modifications for openSUSE build service
239 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
240 - move non-Pidgin files to new sub-package purple-sipe
242 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
243 - remove directory for emoticon theme icons
245 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
246 - libpurple protocol plugins are located under %%{_libdir}/purple-2
248 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
249 - added directory for emoticon theme icons
251 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
252 - update to 1.6.3
254 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
255 - reduce libpurple-devel requirement to >= 2.3.1
257 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
258 - update to 1.6.2
260 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
261 - reduce libpurple-devel requirement to >= 2.4.1
263 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
264 - com_err.h only required for kerberos
266 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
267 - require libpurple-devel >= 2.5.0
269 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
270 - refactor configure parameters
271 - make kerberos configurable
272 - don't hard code prefix for git builds
274 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
275 - removed unnecessary zlib-devel
277 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
278 - fix prefix for git builds
280 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
281 - append -Wno-unused-parameter for GCC <4.4 compilation errors
283 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
284 - remove duplicate GPL2
286 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
287 - use "--with git" to build from git
288 - corrected download URL for release archive
289 - add missing BR gettext-devel
291 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
292 - use default rpmbuild CFLAGS also for git builds
293 - merge with SPEC files created by mricon & jberanek
295 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
296 - initial RPM SPEC example generated