OBS: cure against "directories not owned by a package"
[siplcs.git] / contrib / opensuse-build-service / pidgin-sipe.spec
blob3146acb07e611ce46aa2666886f078d4a3e099e2
2 # OBS SPEC file to generate a RPM for pidgin-sipe.
3 # It should work on Fedora 9/10/11/12, openSUSE 11.x, RHEL5/CentOS 5, SLES/D 11 and Mandriva 2009.1/2010.
6 %define purple_plugin libpurple-plugin-sipe
8 %define purple_develname libpurple-devel
10 %if 0%{?mandriva_version} >= 200910
11 %ifarch x86_64
12 %define purple_develname lib64purple-devel
13 %endif
14 %endif
16 %if 0%{?suse_version} || 0%{?sles_version}
17 %define pkg_group Productivity/Networking/Instant Messenger
18 %endif
19 %if 0%{?fedora_version}
20 %define pkg_group Applications/Internet
21 %endif
22 %if 0%{?mandriva_version}
23 %define pkg_group Networking/Instant messaging
24 %else
25 %define pkg_group Applications/Internet
26 %endif
28 Name: pidgin-sipe
29 Summary: Pidgin protocol plugin to connect to MS Office Communicator
30 Version: 1.10.0
31 Release: 1
32 Source: %{name}-%{version}.tar.gz
33 Group: %{pkg_group}
34 License: GPLv2+
35 URL: http://sipe.sourceforge.net/
37 BuildRoot: %{_tmppath}/%{name}-%{version}-build
39 BuildRequires: %{purple_develname} >= 2.4.0
40 BuildRequires: glib2-devel >= 2.12.0
41 BuildRequires: libxml2-devel
42 BuildRequires: libtool
43 BuildRequires: intltool
44 BuildRequires: gettext-devel
46 # Configurable components
47 %if !0%{?_without_kerberos:1}
48 BuildRequires: krb5-devel
49 %endif
51 # For directory ownership
52 BuildRequires: pidgin
53 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
54 Requires: pidgin
55 %if 0%{?sles_version} == 10
56 BuildRequires: gnome-keyring-devel
57 %endif
59 %description
60 A third-party plugin for the Pidgin multi-protocol instant messenger.
61 It implements the extended version of SIP/SIMPLE used by various products:
63 * Microsoft Office Communications Server (OCS 2007/2007 R2 and newer)
64 * Microsoft Live Communications Server (LCS 2003/2005)
65 * Reuters Messaging
67 With this plugin you should be able to replace your Microsoft Office
68 Communicator client with Pidgin.
70 This package provides the icon set for Pidgin.
73 %package -n %{purple_plugin}
74 Summary: Libpurple protocol plugin to connect to MS Office Communicator
75 Group: %{pkg_group}
76 License: GPLv2+
77 Obsoletes: purple-sipe
79 %description -n %{purple_plugin}
80 A third-party plugin for the Pidgin multi-protocol instant messenger.
81 It implements the extended version of SIP/SIMPLE used by various products:
83 * Microsoft Office Communications Server (OCS 2007/2007 R2 and newer)
84 * Microsoft Live Communications Server (LCS 2003/2005)
85 * Reuters Messaging
87 This package provides the protocol plugin for libpurple clients.
90 %prep
91 %setup -q
93 %build
94 %if 0%{?sles_version} == 10
95 export CFLAGS="%optflags -I%{_includedir}/gssapi"
96 %endif
97 %configure \
98 --enable-purple \
99 --disable-telepathy
100 make %{_smp_mflags}
101 make %{_smp_mflags} check
104 %install
105 %makeinstall
106 find %{buildroot} -type f -name "*.la" -delete -print
107 %find_lang %{name}
110 %clean
111 rm -rf %{buildroot}
114 %files -n %{purple_plugin} -f %{name}.lang
115 %defattr(-,root,root,-)
116 %doc AUTHORS ChangeLog COPYING NEWS README TODO
117 %{_libdir}/purple-2/libsipe.so
120 %files
121 %defattr(-,root,root,-)
122 %doc AUTHORS COPYING
123 %dir %{_datadir}/pixmaps/pidgin/protocols/scalable
124 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
125 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
128 %changelog
129 * Sun Mar 07 2010 pier11 <pier11@operamail.com> pre-1.10.0-*git*
130 - OBS tests of pre-1.10.0 git-snapshot 4fa20cd65e5be0e469d4aa55d861f11c5b08b816
132 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
133 - added --enable/--disable build options
135 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
136 - removed --with-krb5 configure option as it is autodetected now
138 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
139 - add SVG icon
141 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
142 - add BR glib2-devel >= 2.12.0
144 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
145 - add tests to build
147 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
148 - update to 1.9.1
150 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
151 - add BR libxml2-devel
153 * Wed Mar 10 2010 pier11 <pier11@operamail.com> 1.9.0
154 - release
155 - dropped SLE 10 due to libpurple min version increase
156 - updated target distros in comment line
158 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
159 - increased libpurple build requisite to >= 2.4.0
161 * Sun Mar 07 2010 pier11 <pier11@operamail.com> pre-1.9.0-*git*
162 - OBS tests of pre-1.9.0 git-snapshot 61ea0856855483b9e18f23a87afe47437e526f0e
164 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
165 - sync with RPM SPEC from contrib/rpm
167 * Sun Feb 08 2010 pier11 <pier11@operamail.com> 1.8.0
168 - source is an original 1.8.0 with patch: git(upstream) 9c34cc3557daa3d61a002002492c71d0343c8cae
169 - temp hack - renamed source in spec from .bz2 to .gz as the latter was prepared with the patch.
171 * Sun Nov 22 2009 pier11 <pier11@operamail.com> 1.7.1
172 - reinstated enable-quality-check
174 * Wed Nov 04 2009 John Beranek <john@redux.org.uk> 1.7.0
175 - Spec file modifications to allow SLES/D 10 and Mandriva 2009.1 builds
177 * Tue Nov 03 2009 John Beranek <john@redux.org.uk> 1.7.0
178 - Spec file modifications for openSUSE build service
180 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
181 - move non-Pidgin files to new sub-package purple-sipe
183 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
184 - remove directory for emoticon theme icons
186 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
187 - libpurple protocol plugins are located under %%{_libdir}/purple-2
189 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
190 - added directory for emoticon theme icons
192 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
193 - update to 1.6.3
195 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
196 - reduce libpurple-devel requirement to >= 2.3.1
198 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
199 - update to 1.6.2
201 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
202 - reduce libpurple-devel requirement to >= 2.4.1
204 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
205 - com_err.h only required for kerberos
207 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
208 - require libpurple-devel >= 2.5.0
210 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
211 - refactor configure parameters
212 - make kerberos configurable
213 - don't hard code prefix for git builds
215 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
216 - removed unnecessary zlib-devel
218 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
219 - fix prefix for git builds
221 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
222 - append -Wno-unused-parameter for GCC <4.4 compilation errors
224 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
225 - remove duplicate GPL2
227 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
228 - use "--with git" to build from git
229 - corrected download URL for release archive
230 - add missing BR gettext-devel
232 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
233 - use default rpmbuild CFLAGS also for git builds
234 - merge with SPEC files created by mricon & jberanek
236 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
237 - initial RPM SPEC example generated