Release 1.19.1 -- Bug Fixes I
[siplcs.git] / contrib / opensuse-build-service / pidgin-sipe.spec
blob210d5b368ff2569a723e2516323d315457880751
2 # OBS SPEC file to generate a RPM for pidgin-sipe.
4 # It has support for:
6 # RedHat family (CentOS, Fedora, RHEL, ScientificLinux)
7 # SUSE family (openSUSE, SLED, SLES)
8 # Windows (mingw32, mingw64)
11 # Build options
12 %undefine build_telepathy
14 # Check for mingw32 cross compilation build
16 # Manually add this repository to your private OBS project:
18 # <repository name="mingw32">
19 # <path repository="openSUSE_13.2" project="windows:mingw:win32"/>
20 # <arch>i586</arch>
21 # </repository>
23 %if "%{_repository}" == "mingw32"
24 %define purple_sipe_mingw32 1
25 %define mingw_prefix mingw32-
26 %define mingw_cache %{_mingw32_cache}
27 %define mingw_configure %{_mingw32_configure}
28 %define mingw_datadir %{_mingw32_datadir}
29 %define mingw_debug_package %{_mingw32_debug_package}
30 %define mingw_ldflags MINGW32_LDFLAGS
31 %define mingw_libdir %{_mingw32_libdir}
32 %define mingw_make %{_mingw32_make}
33 %define mingw_makeinstall %{_mingw32_makeinstall}
34 %define __strip %{_mingw32_strip}
35 %define __objdump %{_mingw32_objdump}
36 %define _use_internal_dependency_generator 0
37 %define __find_requires %{_mingw32_findrequires}
38 %define __find_provides %{_mingw32_findprovides}
39 %define __os_install_post %{_mingw32_debug_install_post} \
40 %{_mingw32_install_post}
41 %endif
43 # Check for mingw64 cross compilation build
45 # Manually add this repository to your private OBS project:
47 # <repository name="mingw64">
48 # <path repository="openSUSE_13.2" project="windows:mingw:win64"/>
49 # <arch>i586</arch>
50 # </repository>
52 %if "%{_repository}" == "mingw64"
53 %define purple_sipe_mingw64 1
54 %define mingw_prefix mingw64-
55 %define mingw_cache %{_mingw64_cache}
56 %define mingw_configure %{_mingw64_configure}
57 %define mingw_datadir %{_mingw64_datadir}
58 %define mingw_debug_package %{_mingw64_debug_package}
59 %define mingw_ldflags MINGW64_LDFLAGS
60 %define mingw_libdir %{_mingw64_libdir}
61 %define mingw_make %{_mingw64_make}
62 %define mingw_makeinstall %{_mingw64_makeinstall}
63 %define __strip %{_mingw64_strip}
64 %define __objdump %{_mingw64_objdump}
65 %define _use_internal_dependency_generator 0
66 %define __find_requires %{_mingw64_findrequires}
67 %define __find_provides %{_mingw64_findprovides}
68 %define __os_install_post %{_mingw64_debug_install_post} \
69 %{_mingw64_install_post}
70 %endif
72 %define purple_plugin %{?mingw_prefix:%{mingw_prefix}}libpurple-plugin-sipe
73 %define telepathy_plugin %{?mingw_prefix:%{mingw_prefix}}telepathy-plugin-sipe
74 %define nsis_package %{?mingw_prefix:%{mingw_prefix}}pidgin-sipe-nsis
75 %define common_files sipe-common
76 %define empathy_files empathy-sipe
77 %define ktp_files ktp-accounts-kcm-sipe
80 %define has_pidgin 1
82 %if 0%{?suse_version}
83 %define nss_develname mozilla-nss-devel
84 # SLES11 defines suse_version = 1110
85 %if 0%{?suse_version} > 1110
86 %define has_libnice 1
87 %define has_gstreamer 1
88 %define build_telepathy 1
89 %define nice_gstreamer gstreamer-0_10-libnice
90 %endif
91 %else
92 %define nss_develname nss-devel
93 %endif
95 %if 0%{?suse_version} || 0%{?sles_version}
96 %define pkg_group Productivity/Networking/Instant Messenger
97 %else
98 %define pkg_group Applications/Internet
99 %endif
101 %if 0%{?fedora}
102 %define has_libnice 1
103 %define has_gstreamer 1
104 %define build_telepathy 1
105 %define build_ktp 1
106 %if 0%{?fedora} >= 20
107 %define nice_gstreamer libnice-gstreamer
108 %if 0%{?fedora} >= 21
109 %define has_gssntlmssp 1
110 %endif
111 %endif
112 %endif
114 %if 0%{?centos_version} || 0%{?scientificlinux_version}
115 %define rhel_base_version %{?centos_version}%{?scientificlinux_version}
116 %if %{rhel_base_version} >= 600
117 %define has_gstreamer 1
118 %define has_libnice 1
119 %if %{rhel_base_version} >= 700
120 # pidgin has been removed, but libpurple still exists
121 %define has_pidgin 0
122 %endif
123 %endif
124 %endif
126 %if 0%{?purple_sipe_mingw32}
127 Name: mingw32-pidgin-sipe
128 %else
129 %if 0%{?purple_sipe_mingw64}
130 Name: mingw64-pidgin-sipe
131 %else
132 Name: pidgin-sipe
133 %endif
134 %endif
135 Summary: Pidgin protocol plugin to connect to MS Office Communicator
136 Version: 1.19.1
137 Release: 1
138 Source: pidgin-sipe-%{version}.tar.gz
139 Group: %{pkg_group}
140 License: GPL-2.0+
141 URL: http://sipe.sourceforge.net/
143 BuildRoot: %{_tmppath}/%{name}-%{version}-build
145 %if 0%{?mingw_prefix:1}
147 # Windows cross-compilation build setup
149 BuildArch: noarch
150 #!BuildIgnore: post-build-checks
152 BuildRequires: %{mingw_prefix}filesystem >= 23
153 BuildRequires: %{mingw_prefix}cross-gcc
154 BuildRequires: %{mingw_prefix}cross-binutils
155 BuildRequires: %{mingw_prefix}gettext-runtime
156 BuildRequires: %{mingw_prefix}cross-pkg-config
157 BuildRequires: %{mingw_prefix}glib2-devel >= 2.12.0
158 BuildRequires: %{mingw_prefix}libxml2-devel
159 BuildRequires: %{mingw_prefix}mozilla-nss-devel
160 BuildRequires: %{mingw_prefix}libpurple-devel >= 2.4.0
161 BuildRequires: %{mingw_prefix}cross-nsis
163 # For directory ownership
164 BuildRequires: %{mingw_prefix}pidgin
166 # Make sure telepathy is disabled for Windows builds
167 %undefine build_telepathy
169 %else
171 # Standard Linux build setup
173 BuildRequires: libpurple-devel >= 2.4.0
174 BuildRequires: libxml2-devel
175 BuildRequires: %{nss_develname}
176 BuildRequires: gettext-devel
177 # The following two are required to enable Voice & Video features
178 %if 0%{?has_libnice:1}
179 BuildRequires: libnice-devel
180 %if 0%{?nice_gstreamer:1}
181 # Dependency required when gstreamer support is split into two packages
182 Requires: %{nice_gstreamer}
183 %endif
184 %endif
185 %if 0%{?has_gstreamer:1}
186 BuildRequires: pkgconfig(gstreamer-0.10)
187 %endif
188 # Requirements for telepathy backend
189 %if 0%{?build_telepathy:1}
190 BuildRequires: pkgconfig(telepathy-glib) >= 0.18.0
191 BuildRequires: gmime-devel
192 BuildRequires: glib2-devel >= 2.28.0
193 %endif
195 # Configurable components
196 %if !0%{?_without_kerberos:1}
197 BuildRequires: krb5-devel
198 %if 0%{?has_gssntlmssp}
199 BuildRequires: gssntlmssp-devel >= 0.5.0
200 Requires: gssntlmssp >= 0.5.0
201 %endif
202 %endif
204 # For directory ownership
205 %if %{has_pidgin}
206 BuildRequires: pidgin
207 Requires: pidgin
208 %endif
209 %if 0%{?build_telepathy:1}
210 BuildRequires: empathy
211 %endif
213 # End Windows cross-compilation/Linux build setup
214 %endif
216 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
217 BuildRequires: libtool
218 BuildRequires: intltool
219 BuildRequires: glib2-devel >= 2.12.0
222 %description
223 A third-party plugin for the Pidgin multi-protocol instant messenger.
224 It implements the extended version of SIP/SIMPLE used by various products:
226 * Microsoft Office 365
227 * Microsoft Business Productivity Online Suite (BPOS)
228 * Microsoft Lync Server
229 * Microsoft Office Communications Server (OCS 2007/2007 R2)
230 * Microsoft Live Communications Server (LCS 2003/2005)
231 * Reuters Messaging
233 With this plugin you should be able to replace your Microsoft Office
234 Communicator client with Pidgin.
236 This package provides the icon set for Pidgin.
239 %package -n %{purple_plugin}
240 Summary: Libpurple protocol plugin to connect to MS Office Communicator
241 Group: %{pkg_group}
242 License: GPL-2.0+
243 Obsoletes: purple-sipe
244 %if 0%{?build_telepathy:1}
245 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
246 %endif
248 %description -n %{purple_plugin}
249 A third-party plugin for the Pidgin multi-protocol instant messenger.
250 It implements the extended version of SIP/SIMPLE used by various products:
252 * Microsoft Office 365
253 * Microsoft Business Productivity Online Suite (BPOS)
254 * Microsoft Lync Server
255 * Microsoft Office Communications Server (OCS 2007/2007 R2)
256 * Microsoft Live Communications Server (LCS 2003/2005)
257 * Reuters Messaging
259 This package provides the protocol plugin for libpurple clients.
262 %if 0%{?build_telepathy:1}
263 %package -n %{empathy_files}
264 Summary: Telepathy connection manager to connect to MS Office Communicator
265 Group: %{pkg_group}
266 License: GPL-2.0+
267 Requires: empathy
268 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
270 %description -n %{empathy_files}
271 A Telepathy connection manager that implements the extended version of
272 SIP/SIMPLE used by various products:
274 * Microsoft Office 365
275 * Microsoft Business Productivity Online Suite (BPOS)
276 * Microsoft Lync Server
277 * Microsoft Office Communications Server (OCS 2007/2007 R2)
278 * Microsoft Live Communications Server (LCS 2003/2005)
279 * Reuters Messaging
281 This package provides the icon set for Empathy.
284 %if 0%{?build_ktp:1}
285 %package -n %{ktp_files}
286 Summary: Telepathy connection manager to connect to MS Office Communicator
287 Group: %{pkg_group}
288 License: GPL-2.0+
289 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
291 %description -n %{ktp_files}
292 A Telepathy connection manager that implements the extended version of
293 SIP/SIMPLE used by various products:
295 * Microsoft Office 365
296 * Microsoft Business Productivity Online Suite (BPOS)
297 * Microsoft Lync Server
298 * Microsoft Office Communications Server (OCS 2007/2007 R2)
299 * Microsoft Live Communications Server (LCS 2003/2005)
300 * Reuters Messaging
302 This package provides the profile for KTP account manager.
303 %endif
306 %package -n %{telepathy_plugin}
307 Summary: Telepathy connection manager to connect to MS Office Communicator
308 Group: %{pkg_group}
309 License: GPL-2.0+
310 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
312 %description -n %{telepathy_plugin}
313 A Telepathy connection manager that implements the extended version of
314 SIP/SIMPLE used by various products:
316 * Microsoft Office 365
317 * Microsoft Business Productivity Online Suite (BPOS)
318 * Microsoft Lync Server
319 * Microsoft Office Communications Server (OCS 2007/2007 R2)
320 * Microsoft Live Communications Server (LCS 2003/2005)
321 * Reuters Messaging
323 This package provides the protocol support for Telepathy clients.
326 %package -n %{common_files}
327 Summary: Common files for SIPE protocol plugins
328 Group: %{pkg_group}
329 License: GPL-2.0+
330 BuildArch: noarch
332 %description -n %{common_files}
333 This package provides common files for the SIPE protocol plugins:
335 * Localisation
336 %endif
339 %if 0%{?mingw_prefix:1}
340 %package -n %{nsis_package}
341 Summary: Windows Pidgin protocol plugin to connect to MS Office Communicator
342 Group: %{pkg_group}
343 License: GPL-2.0+
345 %description -n %{nsis_package}
346 A third-party plugin for the Pidgin multi-protocol instant messenger.
347 It implements the extended version of SIP/SIMPLE used by various products:
349 * Microsoft Office 365
350 * Microsoft Business Productivity Online Suite (BPOS)
351 * Microsoft Lync Server
352 * Microsoft Office Communications Server (OCS 2007/2007 R2)
353 * Microsoft Live Communications Server (LCS 2003/2005)
354 * Reuters Messaging
356 This package contains the NSIS installer package of the protocol plugin
357 for Pidgin on Windows.
358 %endif
361 %{mingw_debug_package}
364 %prep
365 %setup -q -n pidgin-sipe-%{version}
367 %build
368 %if 0%{?mingw_prefix:1}
370 # Windows cross-compilation build
372 %{?env_options}
373 echo "lt_cv_deplibs_check_method='pass_all'" >>%{mingw_cache}
374 autoreconf --verbose --install --force
375 %{mingw_ldflags}="-Wl,--exclude-libs=libintl.a -Wl,--exclude-libs=libiconv.a -lws2_32"
376 %{mingw_configure} \
377 --enable-purple \
378 %if 0%{?build_telepathy:1}
379 --enable-telepathy
380 %else
381 --disable-telepathy
382 %endif
383 %{mingw_make} %{_smp_mflags} || %{mingw_make}
385 %else
387 # Standard Linux build
389 %configure \
390 --enable-purple \
391 %if 0%{?build_telepathy:1}
392 --enable-telepathy
393 %else
394 --disable-telepathy
395 %endif
396 make %{_smp_mflags}
397 make %{_smp_mflags} check
399 # End Windows cross-compilation/Linux build setup
400 %endif
403 %install
404 %if 0%{?mingw_prefix:1}
406 # Windows cross-compilation install
408 %{mingw_makeinstall}
409 rm -f %{buildroot}%{mingw_libdir}/purple-2/*.dll.a
411 # generate .dbgsym file
412 rm -f %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll.dbgsym
413 mv \
414 %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll \
415 %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll.dbgsym
416 %{__strip} --strip-unneeded \
417 %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll.dbgsym \
418 -o %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll \
420 # generate NSIS installer package
421 perl contrib/opensuse-build-service/generate_nsi.pl po/LINGUAS \
422 <contrib/opensuse-build-service/pidgin-sipe.nsi.template \
423 >%{buildroot}/pidgin-sipe.nsi
425 set -e; \
426 cd %{buildroot}; \
427 makensis \
428 -DPIDGIN_VERSION=UNKNOWN \
429 -DVERSION=%{version} \
430 -DMINGW_LIBDIR=%{buildroot}%{mingw_libdir} \
431 -DMINGW_DATADIR=%{buildroot}%{mingw_datadir} \
432 pidgin-sipe.nsi \
434 rm -f %{buildroot}/pidgin-sipe.nsi
436 %else
438 # Standard Linux install
440 %makeinstall
442 # End Windows cross-compilation/Linux build setup
443 %endif
445 find %{buildroot} -type f -name "*.la" -delete -print
446 # SLES11 defines suse_version = 1110
447 %if 0%{?suse_version} && 0%{?suse_version} < 1120
448 rm -r %{buildroot}/%{_datadir}/pixmaps/pidgin/protocols/scalable
449 %endif
450 # Pidgin doesn't have 24 or 32 pixel icons
451 rm -f \
452 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/24/sipe.png \
453 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/32/sipe.png
454 %if !%{has_pidgin}
455 # We don't have Pidgin, so we can't package icons at all
456 rm -r %{buildroot}/%{_datadir}/pixmaps/pidgin
457 %endif
458 %if 0%{?build_telepathy:1}
459 %if !0%{?build_ktp:1}
460 rm -r %{buildroot}%{_datadir}/telepathy
461 %endif
462 %endif
463 %find_lang pidgin-sipe
466 %clean
467 rm -rf %{buildroot}
470 %if 0%{?build_telepathy:1}
471 %files -n %{purple_plugin}
472 %else
473 %files -n %{purple_plugin} -f pidgin-sipe.lang
474 %endif
475 %defattr(-,root,root,-)
476 %doc AUTHORS ChangeLog COPYING NEWS README TODO
477 %if 0%{?mingw_prefix:1}
478 %{mingw_libdir}/purple-2/libsipe.dll
479 %{mingw_libdir}/purple-2/libsipe.dll.dbgsym
480 %else
481 %{_libdir}/purple-2/libsipe.so
482 %endif
485 %if 0%{?build_telepathy:1}
486 %files -n %{empathy_files}
487 %defattr(-,root,root,-)
488 %doc AUTHORS COPYING
489 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.png
490 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.svg
493 %if 0%{?build_ktp:1}
494 %files -n %{ktp_files}
495 %defattr(-,root,root,-)
496 %doc AUTHORS COPYING
497 %{_datadir}/telepathy/profiles/sipe.profile
498 %endif
501 %files -n %{telepathy_plugin}
502 %defattr(-,root,root,-)
503 %doc AUTHORS ChangeLog COPYING NEWS README TODO
504 %{_datadir}/dbus-1/services/*.sipe.service
505 %{_libexecdir}/telepathy-sipe
508 %files -n %{common_files} -f pidgin-sipe.lang
509 %defattr(-,root,root,-)
510 %endif
513 %files
514 %defattr(-,root,root,-)
515 %doc AUTHORS COPYING
516 %if 0%{?mingw_prefix:1}
517 %{mingw_datadir}/pixmaps/pidgin/protocols/*/sipe.png
518 %{mingw_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
519 %else
520 %if %{has_pidgin}
521 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
522 # SLES11 defines suse_version = 1110
523 %if !0%{?suse_version} || 0%{?suse_version} >= 1120
524 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
525 %endif
526 %endif
527 %endif
530 %if 0%{?mingw_prefix:1}
531 %files -n %{nsis_package}
532 %defattr(-, root, root)
533 /pidgin-sipe-%{version}.exe
534 %endif
537 %changelog
538 * Sat Apr 04 2015 J. D. User <jduser@noreply.com> 1.19.1
539 - update to 1.19.1
541 * Sat Feb 07 2015 J. D. User <jduser@noreply.com> 1.19.0
542 - update to 1.19.0
544 * Tue Jan 06 2015 J. D. User <jduser@noreply.com> 1.18.5-*git*
545 - add dependency on gssntlmssp(-devel) >= 0.5.0 for F21+
547 * Mon Jan 05 2015 J. D. User <jduser@noreply.com> 1.18.5-*git*
548 - remove support for obsolete distributions
549 - Fedora < 19
550 - Mandriva
551 - OpenSUSE < 13.x
553 * Mon Dec 29 2014 J. D. User <jduser@noreply.com> 1.18.5
554 - update to 1.18.5
556 * Thu Dec 18 2014 J. D. User <jduser@noreply.com> 1.18.4-*git*
557 - improve support for CentOS & Scientific Linux
559 * Sat Oct 18 2014 J. D. User <jduser@noreply.com> 1.18.4
560 - update to 1.18.4
562 * Sat Aug 16 2014 J. D. User <jduser@noreply.com> 1.18.3
563 - update to 1.18.3
565 * Sat Jun 07 2014 J. D. User <jduser@noreply.com> 1.18.2
566 - update to 1.18.2
568 * Sat Apr 12 2014 J. D. User <jduser@noreply.com> 1.18.1
569 - update to 1.18.1
571 * Sat Mar 04 2014 J. D. User <jduser@noreply.com> 1.18.0-*git*
572 - F20+/openSUSE 12.2+ require libnice gstreamer-0.10 plugin
574 * Sat Jan 11 2014 J. D. User <jduser@noreply.com> 1.18.0
575 - update to 1.18.0
577 * Wed Dec 11 2013 J. D. User <jduser@noreply.com> 1.17.3
578 - update to 1.17.3
580 * Sat Nov 30 2013 J. D. User <jduser@noreply.com> 1.17.2
581 - update to 1.17.2
583 * Sat Nov 16 2013 J. D. User <jduser@noreply.com> 1.17.1
584 - update to 1.17.1
586 * Sat Sep 21 2013 J. D. User <jduser@noreply.com> 1.17.0
587 - update to 1.17.0
589 * Sat Jul 13 2013 J. D. User <jduser@noreply.com> 1.16.1
590 - update to 1.16.1
592 * Fri Jun 14 2013 J. D. User <jduser@noreply.com> 1.16.0
593 - update to 1.16.0
595 * Sun Apr 07 2013 J. D. User <jduser@noreply.com> 1.15.1
596 - update to 1.15.1
598 * Fri Mar 29 2013 J. D. User <jduser@noreply.com> 1.15.0-*git*
599 - update package description texts
601 * Sat Mar 09 2013 J. D. User <jduser@noreply.com> 1.15.0
602 - update to 1.15.0
604 * Wed Dec 26 2012 J. D. User <jduser@noreply.com> 1.14.1
605 - update to 1.14.1
607 * Sun Dec 16 2012 J. D. User <jduser@noreply.com> 1.14.0
608 - update to 1.14.0
610 * Tue Sep 25 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
611 - change BR gstreamer-devel to pkgconfig(gstreamer-0.10)
613 * Sun Sep 09 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
614 - BR telepathy-glib-devel >= 0.18.0
616 * Wed Sep 05 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
617 - BR telepathy-glib-devel >= 0.14.0
619 * Sun Sep 02 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
620 - really disable telepathy for Windows cross-compilation builds
622 * Thu Aug 30 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
623 - updates to enable telepathy build
625 * Sun Aug 19 2012 J. D. User <jduser@noreply.com> 1.13.3
626 - update to 1.13.3
628 * Sun Jun 10 2012 J. D. User <jduser@noreply.com> 1.13.2
629 - update to 1.13.2
631 * Mon Apr 09 2012 J. D. User <jduser@noreply.com> 1.13.1
632 - update to 1.13.1
634 * Wed Mar 14 2012 J. D. User <jduser@noreply.com> 1.13.0
635 - update to 1.13.0
637 * Mon Dec 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
638 - we do support Microsoft Lync Server 2010 now.
640 * Tue Dec 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
641 - update GPL2 license name
643 * Sat Nov 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
644 - add BR gmime-devel for Fedora to have at least one verification platform
646 * Sun Nov 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
647 - fix Mandriva 2011 unresolvable BR
649 * Mon Oct 31 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
650 - add BR nss-devel
652 * Sat Oct 01 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
653 - add NSIS package for mingw builds
655 * Sat Oct 01 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
656 - add mingw64 build
658 * Wed Sep 28 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
659 - remove BR mingw32-mozilla-nss-devel, not needed for SSPI.
661 * Mon Sep 19 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
662 - update mingw32 build
663 - update descriptions
665 * Mon Aug 29 2011 J. D. User <jduser@noreply.com> 1.12.0
666 - update to 1.12.0
668 * Wed Jun 22 2011 J. D. User <jduser@noreply.com> 1.11.2-*git*
669 - add gstreamer-devel to enable Voice & Video features
671 * Sat Dec 11 2010 J. D. User <jduser@noreply.com> 1.11.2-*git*
672 - add optional subpackage for telepathy connection manager
674 * Tue Nov 02 2010 J. D. User <jduser@noreply.com> 1.11.2
675 - update to 1.11.2
677 * Sun Oct 24 2010 J. D. User <jduser@noreply.com> 1.11.1
678 - update to 1.11.1
680 * Fri Oct 15 2010 J. D. User <jduser@noreply.com> 1.11.0-*git*
681 - add mingw32 build configuration
683 * Sun Oct 03 2010 J. D. User <jduser@noreply.com> 1.11.0
684 - update to 1.11.0
686 * Thu Sep 02 2010 J. D. User <jduser@noreply.com> pre-1.11.0-*git*
687 - Mandriva config for OBS has changed
689 * Tue May 04 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
690 - add libnice build information discovered through OBS testing
692 * Mon Apr 12 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
693 - add NSS build information discovered through OBS testing
695 * Wed Apr 04 2010 pier11 <pier11@operamail.com> 1.10.0
696 - release
698 * Fri Apr 02 2010 J. D. User <jduser@noreply.com> pre-1.10.0-*git*
699 - Mandriva has too old libtool version
701 * Fri Apr 02 2010 J. D. User <jduser@noreply.com> pre-1.10.0-*git*
702 - SLE11, openSUSE 11.0/1 don't have pidgin/protocols/scalable directory
704 * Sun Mar 07 2010 pier11 <pier11@operamail.com> pre-1.10.0-*git*
705 - OBS tests of pre-1.10.0 git-snapshot 4fa20cd65e5be0e469d4aa55d861f11c5b08b816
707 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
708 - added --enable/--disable build options
710 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
711 - removed --with-krb5 configure option as it is autodetected now
713 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
714 - add SVG icon
716 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
717 - add BR glib2-devel >= 2.12.0
719 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
720 - add tests to build
722 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
723 - update to 1.9.1
725 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
726 - add BR libxml2-devel
728 * Wed Mar 10 2010 pier11 <pier11@operamail.com> 1.9.0
729 - release
730 - dropped SLE 10 due to libpurple min version increase
731 - updated target distros in comment line
733 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
734 - increased libpurple build requisite to >= 2.4.0
736 * Sun Mar 07 2010 pier11 <pier11@operamail.com> pre-1.9.0-*git*
737 - OBS tests of pre-1.9.0 git-snapshot 61ea0856855483b9e18f23a87afe47437e526f0e
739 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
740 - sync with RPM SPEC from contrib/rpm
742 * Sun Feb 08 2010 pier11 <pier11@operamail.com> 1.8.0
743 - source is an original 1.8.0 with patch: git(upstream) 9c34cc3557daa3d61a002002492c71d0343c8cae
744 - temp hack - renamed source in spec from .bz2 to .gz as the latter was prepared with the patch.
746 * Sun Nov 22 2009 pier11 <pier11@operamail.com> 1.7.1
747 - reinstated enable-quality-check
749 * Wed Nov 04 2009 John Beranek <john@redux.org.uk> 1.7.0
750 - Spec file modifications to allow SLES/D 10 and Mandriva 2009.1 builds
752 * Tue Nov 03 2009 John Beranek <john@redux.org.uk> 1.7.0
753 - Spec file modifications for openSUSE build service
755 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
756 - move non-Pidgin files to new sub-package purple-sipe
758 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
759 - remove directory for emoticon theme icons
761 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
762 - libpurple protocol plugins are located under %%{_libdir}/purple-2
764 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
765 - added directory for emoticon theme icons
767 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
768 - update to 1.6.3
770 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
771 - reduce libpurple-devel requirement to >= 2.3.1
773 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
774 - update to 1.6.2
776 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
777 - reduce libpurple-devel requirement to >= 2.4.1
779 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
780 - com_err.h only required for kerberos
782 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
783 - require libpurple-devel >= 2.5.0
785 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
786 - refactor configure parameters
787 - make kerberos configurable
788 - don't hard code prefix for git builds
790 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
791 - removed unnecessary zlib-devel
793 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
794 - fix prefix for git builds
796 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
797 - append -Wno-unused-parameter for GCC <4.4 compilation errors
799 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
800 - remove duplicate GPL2
802 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
803 - use "--with git" to build from git
804 - corrected download URL for release archive
805 - add missing BR gettext-devel
807 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
808 - use default rpmbuild CFLAGS also for git builds
809 - merge with SPEC files created by mricon & jberanek
811 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
812 - initial RPM SPEC example generated