OBS: dsc update and file mode change
[siplcs.git] / contrib / opensuse-build-service / pidgin-sipe.spec
blob7ec481b9e9a69296dceb865cfd7dbf6a12230e1f
2 # OBS SPEC file to generate a RPM for pidgin-sipe.
3 # It should work on Fedora 10/11, openSUSE 11.x, RHEL5/CentOS 5, SLES/D 10/11 and Mandriva 2009.1.
6 %define purple_plugin libpurple-plugin-sipe
8 %define purple_develname libpurple-devel
10 %if 0%{?mandriva_version} >= 200910
11 %ifarch x86_64
12 %define purple_develname lib64purple-devel
13 %endif
14 %endif
16 %if 0%{?suse_version} || 0%{?sles_version}
17 %define pkg_group Productivity/Networking/Instant Messenger
18 %endif
19 %if 0%{?fedora_version}
20 %define pkg_group Applications/Internet
21 %endif
22 %if 0%{?mandriva_version}
23 %define pkg_group Networking/Instant messaging
24 %else
25 %define pkg_group Applications/Internet
26 %endif
28 Name: pidgin-sipe
29 Summary: Pidgin protocol plugin to connect to MS Office Communicator
30 Version: 1.9.0
31 Release: 1
32 Source: %{name}-%{version}.tar.gz
33 Group: %{pkg_group}
34 License: GPLv2+
35 URL: http://sipe.sourceforge.net/
37 BuildRoot: %{_tmppath}/%{name}-%{version}-build
39 BuildRequires: %{purple_develname} >= 2.4.0
40 BuildRequires: libtool
41 BuildRequires: intltool
42 BuildRequires: gettext-devel
44 # Configurable components
45 %if !0%{?_without_kerberos:1}
46 %define config_krb5 --with-krb5
47 BuildRequires: krb5-devel
48 %endif
50 # For directory ownership
51 BuildRequires: pidgin
52 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
53 Requires: pidgin
54 %if 0%{?sles_version} == 10
55 BuildRequires: gnome-keyring-devel
56 %endif
58 %description
59 A third-party plugin for the Pidgin multi-protocol instant messenger.
60 It implements the extended version of SIP/SIMPLE used by various products:
62 * Microsoft Office Communications Server (OCS 2007/2007 R2 and newer)
63 * Microsoft Live Communications Server (LCS 2003/2005)
64 * Reuters Messaging
66 With this plugin you should be able to replace your Microsoft Office
67 Communicator client with Pidgin.
69 This package provides the icon set for Pidgin.
72 %package -n %{purple_plugin}
73 Summary: Libpurple protocol plugin to connect to MS Office Communicator
74 Group: %{pkg_group}
75 License: GPLv2+
76 Obsoletes: purple-sipe
78 %description -n %{purple_plugin}
79 A third-party plugin for the Pidgin multi-protocol instant messenger.
80 It implements the extended version of SIP/SIMPLE used by various products:
82 * Microsoft Office Communications Server (OCS 2007/2007 R2 and newer)
83 * Microsoft Live Communications Server (LCS 2003/2005)
84 * Reuters Messaging
86 This package provides the protocol plugin for libpurple clients.
89 %prep
90 %setup -q
92 %build
93 %define config_params %{?config_krb5:%{config_krb5}}
94 %if 0%{?sles_version} == 10
95 export CFLAGS="%optflags -I%{_includedir}/gssapi"
96 %endif
97 %configure %{config_params}
98 make %{_smp_mflags}
101 %install
102 %makeinstall
103 find %{buildroot} -type f -name "*.la" -delete -print
104 %find_lang %{name}
107 %clean
108 rm -rf %{buildroot}
111 %files -n %{purple_plugin} -f %{name}.lang
112 %defattr(-,root,root,-)
113 %doc AUTHORS ChangeLog COPYING NEWS README TODO
114 %{_libdir}/purple-2/libsipe.so
117 %files
118 %defattr(-,root,root,-)
119 %doc AUTHORS COPYING
120 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
123 %changelog
124 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
125 - increased libpurple build requisite to >= 2.4.0
127 * Sun Mar 07 2010 pier11 <pier11@operamail.com> pre-1.9.0-*git*
128 - OBS tests of pre-1.9.0 git-snapshot 61ea0856855483b9e18f23a87afe47437e526f0e
130 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
131 - sync with RPM SPEC from contrib/rpm
133 * Sun Feb 08 2010 pier11 <pier11@operamail.com> 1.8.0
134 - source is an original 1.8.0 with patch: git(upstream) 9c34cc3557daa3d61a002002492c71d0343c8cae
135 - temp hack - renamed source in spec from .bz2 to .gz as the latter was prepared with the patch.
137 * Sun Nov 22 2009 pier11 <pier11@operamail.com> 1.7.1
138 - reinstated enable-quality-check
140 * Wed Nov 04 2009 John Beranek <john@redux.org.uk> 1.7.0
141 - Spec file modifications to allow SLES/D 10 and Mandriva 2009.1 builds
143 * Tue Nov 03 2009 John Beranek <john@redux.org.uk> 1.7.0
144 - Spec file modifications for openSUSE build service
146 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
147 - move non-Pidgin files to new sub-package purple-sipe
149 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
150 - remove directory for emoticon theme icons
152 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
153 - libpurple protocol plugins are located under %%{_libdir}/purple-2
155 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
156 - added directory for emoticon theme icons
158 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
159 - update to 1.6.3
161 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
162 - reduce libpurple-devel requirement to >= 2.3.1
164 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
165 - update to 1.6.2
167 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
168 - reduce libpurple-devel requirement to >= 2.4.1
170 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
171 - com_err.h only required for kerberos
173 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
174 - require libpurple-devel >= 2.5.0
176 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
177 - refactor configure parameters
178 - make kerberos configurable
179 - don't hard code prefix for git builds
181 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
182 - removed unnecessary zlib-devel
184 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
185 - fix prefix for git builds
187 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
188 - append -Wno-unused-parameter for GCC <4.4 compilation errors
190 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
191 - remove duplicate GPL2
193 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
194 - use "--with git" to build from git
195 - corrected download URL for release archive
196 - add missing BR gettext-devel
198 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
199 - use default rpmbuild CFLAGS also for git builds
200 - merge with SPEC files created by mricon & jberanek
202 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
203 - initial RPM SPEC example generated