Release 1.17.2 -- Bug Fixes II
[siplcs.git] / contrib / opensuse-build-service / pidgin-sipe.spec
blob835f71a8a7a956560b5358ccc44ec491f209c106
2 # OBS SPEC file to generate a RPM for pidgin-sipe.
4 # It has support for:
6 # RedHat family (CentOS, Fedora, RHEL)
7 # Mandriva
8 # SUSE family (openSUSE, SLED, SLES)
9 # Windows (mingw32, mingw64)
12 # Build options
13 %undefine build_telepathy
15 # Check for mingw32 cross compilation build
17 # Manually add this repository to your private OBS project:
19 # <repository name="mingw32">
20 # <path repository="openSUSE_11.4" project="windows:mingw:win32"/>
21 # <arch>i586</arch>
22 # </repository>
24 %if "%{_repository}" == "mingw32"
25 %define purple_sipe_mingw32 1
26 %define mingw_prefix mingw32-
27 %define mingw_cache %{_mingw32_cache}
28 %define mingw_configure %{_mingw32_configure}
29 %define mingw_datadir %{_mingw32_datadir}
30 %define mingw_debug_package %{_mingw32_debug_package}
31 %define mingw_ldflags MINGW32_LDFLAGS
32 %define mingw_libdir %{_mingw32_libdir}
33 %define mingw_make %{_mingw32_make}
34 %define mingw_makeinstall %{_mingw32_makeinstall}
35 %define __strip %{_mingw32_strip}
36 %define __objdump %{_mingw32_objdump}
37 %define _use_internal_dependency_generator 0
38 %define __find_requires %{_mingw32_findrequires}
39 %define __find_provides %{_mingw32_findprovides}
40 %define __os_install_post %{_mingw32_debug_install_post} \
41 %{_mingw32_install_post}
42 %endif
44 # Check for mingw64 cross compilation build
46 # Manually add this repository to your private OBS project:
48 # <repository name="mingw64">
49 # <path repository="openSUSE_11.4" project="windows:mingw:win64"/>
50 # <arch>i586</arch>
51 # </repository>
53 %if "%{_repository}" == "mingw64"
54 %define purple_sipe_mingw64 1
55 %define mingw_prefix mingw64-
56 %define mingw_cache %{_mingw64_cache}
57 %define mingw_configure %{_mingw64_configure}
58 %define mingw_datadir %{_mingw64_datadir}
59 %define mingw_debug_package %{_mingw64_debug_package}
60 %define mingw_ldflags MINGW64_LDFLAGS
61 %define mingw_libdir %{_mingw64_libdir}
62 %define mingw_make %{_mingw64_make}
63 %define mingw_makeinstall %{_mingw64_makeinstall}
64 %define __strip %{_mingw64_strip}
65 %define __objdump %{_mingw64_objdump}
66 %define _use_internal_dependency_generator 0
67 %define __find_requires %{_mingw64_findrequires}
68 %define __find_provides %{_mingw64_findprovides}
69 %define __os_install_post %{_mingw64_debug_install_post} \
70 %{_mingw64_install_post}
71 %endif
73 %define purple_plugin %{?mingw_prefix:%{mingw_prefix}}libpurple-plugin-sipe
74 %define telepathy_plugin %{?mingw_prefix:%{mingw_prefix}}telepathy-plugin-sipe
75 %define nsis_package %{?mingw_prefix:%{mingw_prefix}}pidgin-sipe-nsis
76 %define common_files sipe-common
77 %define empathy_files empathy-sipe
78 %define ktp_files ktp-accounts-kcm-sipe
81 %define purple_develname libpurple-devel
83 %if 0%{?mdkversion} >= 200910
84 %ifarch x86_64
85 %define purple_develname lib64purple-devel
86 %endif
87 %if 0%{?mdkversion} >= 201000
88 %ifnarch x86_64
89 %define has_libnice 1
90 %endif
91 %endif
92 %endif
94 %if 0%{?suse_version}
95 %define nss_develname mozilla-nss-devel
96 %if 0%{?suse_version} >= 1120
97 %define has_libnice 1
98 %if 0%{?suse_version} > 1140
99 %define has_gstreamer 1
100 %if 0%{?suse_version} > 1210
101 %define build_telepathy 1
102 %endif
103 %endif
104 %endif
105 %else
106 %define nss_develname nss-devel
107 %endif
109 %if 0%{?suse_version} || 0%{?sles_version}
110 %define pkg_group Productivity/Networking/Instant Messenger
111 %endif
112 %if 0%{?fedora}
113 %define pkg_group Applications/Internet
114 %if 0%{?fedora} >= 11
115 %define has_libnice 1
116 %if 0%{?fedora} >= 15
117 %define has_gstreamer 1
118 %if 0%{?fedora} >= 17
119 %define build_telepathy 1
120 %define build_ktp 1
121 %endif
122 %endif
123 %endif
124 %endif
125 %if 0%{?mdkversion}
126 %define pkg_group Networking/Instant messaging
127 %else
128 %define pkg_group Applications/Internet
129 %endif
131 %if 0%{?purple_sipe_mingw32}
132 Name: mingw32-pidgin-sipe
133 %else
134 %if 0%{?purple_sipe_mingw64}
135 Name: mingw64-pidgin-sipe
136 %else
137 Name: pidgin-sipe
138 %endif
139 %endif
140 Summary: Pidgin protocol plugin to connect to MS Office Communicator
141 Version: 1.17.2
142 Release: 1
143 Source: pidgin-sipe-%{version}.tar.gz
144 Group: %{pkg_group}
145 License: GPL-2.0+
146 URL: http://sipe.sourceforge.net/
148 BuildRoot: %{_tmppath}/%{name}-%{version}-build
150 %if 0%{?mingw_prefix:1}
152 # Windows cross-compilation build setup
154 BuildArch: noarch
155 #!BuildIgnore: post-build-checks
157 BuildRequires: %{mingw_prefix}filesystem >= 23
158 BuildRequires: %{mingw_prefix}cross-gcc
159 BuildRequires: %{mingw_prefix}cross-binutils
160 BuildRequires: %{mingw_prefix}gettext-runtime
161 BuildRequires: %{mingw_prefix}cross-pkg-config
162 BuildRequires: %{mingw_prefix}glib2-devel >= 2.12.0
163 BuildRequires: %{mingw_prefix}libxml2-devel
164 BuildRequires: %{mingw_prefix}mozilla-nss-devel
165 BuildRequires: %{mingw_prefix}libpurple-devel >= 2.4.0
166 BuildRequires: %{mingw_prefix}cross-nsis
168 # For directory ownership
169 BuildRequires: %{mingw_prefix}pidgin
171 # Make sure telepathy is disabled for Windows builds
172 %undefine build_telepathy
174 %else
176 # Standard Linux build setup
178 BuildRequires: %{purple_develname} >= 2.4.0
179 BuildRequires: libxml2-devel
180 BuildRequires: %{nss_develname}
181 BuildRequires: gettext-devel
182 # The following two are required to enable Voice & Video features
183 %if 0%{?has_libnice:1}
184 BuildRequires: libnice-devel
185 %endif
186 %if 0%{?has_gstreamer:1}
187 BuildRequires: pkgconfig(gstreamer-0.10)
188 %endif
189 # Requirements for telepathy backend
190 %if 0%{?build_telepathy:1}
191 BuildRequires: pkgconfig(telepathy-glib) >= 0.18.0
192 BuildRequires: gmime-devel
193 BuildRequires: glib2-devel >= 2.28.0
194 %endif
196 # Configurable components
197 %if !0%{?_without_kerberos:1}
198 BuildRequires: krb5-devel
199 %endif
201 # For directory ownership
202 BuildRequires: pidgin
203 %if 0%{?build_telepathy:1}
204 BuildRequires: empathy
205 %endif
206 Requires: pidgin
207 %if 0%{?sles_version} == 10
208 BuildRequires: gnome-keyring-devel
209 %endif
211 # For OBS's "have choice for" for Fedora 11 (only)
212 %if 0%{?fedora_version} == 11
213 BuildRequires: libproxy-mozjs
214 BuildRequires: PolicyKit-gnome
215 %endif
217 # For OBS's "have choice for" for Mandriva 2010.1 (and up?)
218 %if 0%{?mdkversion} >= 201010
219 BuildRequires: polkit-gnome
220 %endif
222 # For OBS's "have choice for" for Mandriva 2011 (and up?)
223 %if 0%{?mdkversion} >= 201100
224 BuildRequires: packagekit-gstreamer-plugin
225 BuildRequires: gnome-packagekit-common
226 %endif
228 # End Windows cross-compilation/Linux build setup
229 %endif
231 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
232 BuildRequires: libtool
233 BuildRequires: intltool
234 BuildRequires: glib2-devel >= 2.12.0
237 %description
238 A third-party plugin for the Pidgin multi-protocol instant messenger.
239 It implements the extended version of SIP/SIMPLE used by various products:
241 * Microsoft Office 365
242 * Microsoft Business Productivity Online Suite (BPOS)
243 * Microsoft Lync Server
244 * Microsoft Office Communications Server (OCS 2007/2007 R2)
245 * Microsoft Live Communications Server (LCS 2003/2005)
246 * Reuters Messaging
248 With this plugin you should be able to replace your Microsoft Office
249 Communicator client with Pidgin.
251 This package provides the icon set for Pidgin.
254 %package -n %{purple_plugin}
255 Summary: Libpurple protocol plugin to connect to MS Office Communicator
256 Group: %{pkg_group}
257 License: GPL-2.0+
258 Obsoletes: purple-sipe
259 %if 0%{?build_telepathy:1}
260 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
261 %endif
263 %description -n %{purple_plugin}
264 A third-party plugin for the Pidgin multi-protocol instant messenger.
265 It implements the extended version of SIP/SIMPLE used by various products:
267 * Microsoft Office 365
268 * Microsoft Business Productivity Online Suite (BPOS)
269 * Microsoft Lync Server
270 * Microsoft Office Communications Server (OCS 2007/2007 R2)
271 * Microsoft Live Communications Server (LCS 2003/2005)
272 * Reuters Messaging
274 This package provides the protocol plugin for libpurple clients.
277 %if 0%{?build_telepathy:1}
278 %package -n %{empathy_files}
279 Summary: Telepathy connection manager to connect to MS Office Communicator
280 Group: %{pkg_group}
281 License: GPL-2.0+
282 Requires: empathy
283 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
285 %description -n %{empathy_files}
286 A Telepathy connection manager that implements the extended version of
287 SIP/SIMPLE used by various products:
289 * Microsoft Office 365
290 * Microsoft Business Productivity Online Suite (BPOS)
291 * Microsoft Lync Server
292 * Microsoft Office Communications Server (OCS 2007/2007 R2)
293 * Microsoft Live Communications Server (LCS 2003/2005)
294 * Reuters Messaging
296 This package provides the icon set for Empathy.
299 %if 0%{?build_ktp:1}
300 %package -n %{ktp_files}
301 Summary: Telepathy connection manager to connect to MS Office Communicator
302 Group: %{pkg_group}
303 License: GPL-2.0+
304 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
306 %description -n %{ktp_files}
307 A Telepathy connection manager that implements the extended version of
308 SIP/SIMPLE used by various products:
310 * Microsoft Office 365
311 * Microsoft Business Productivity Online Suite (BPOS)
312 * Microsoft Lync Server
313 * Microsoft Office Communications Server (OCS 2007/2007 R2)
314 * Microsoft Live Communications Server (LCS 2003/2005)
315 * Reuters Messaging
317 This package provides the profile for KTP account manager.
318 %endif
321 %package -n %{telepathy_plugin}
322 Summary: Telepathy connection manager to connect to MS Office Communicator
323 Group: %{pkg_group}
324 License: GPL-2.0+
325 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
327 %description -n %{telepathy_plugin}
328 A Telepathy connection manager that implements the extended version of
329 SIP/SIMPLE used by various products:
331 * Microsoft Office 365
332 * Microsoft Business Productivity Online Suite (BPOS)
333 * Microsoft Lync Server
334 * Microsoft Office Communications Server (OCS 2007/2007 R2)
335 * Microsoft Live Communications Server (LCS 2003/2005)
336 * Reuters Messaging
338 This package provides the protocol support for Telepathy clients.
341 %package -n %{common_files}
342 Summary: Common files for SIPE protocol plugins
343 Group: %{pkg_group}
344 License: GPL-2.0+
345 BuildArch: noarch
347 %description -n %{common_files}
348 This package provides common files for the SIPE protocol plugins:
350 * Localisation
351 %endif
354 %if 0%{?mingw_prefix:1}
355 %package -n %{nsis_package}
356 Summary: Windows Pidgin protocol plugin to connect to MS Office Communicator
357 Group: %{pkg_group}
358 License: GPL-2.0+
360 %description -n %{nsis_package}
361 A third-party plugin for the Pidgin multi-protocol instant messenger.
362 It implements the extended version of SIP/SIMPLE used by various products:
364 * Microsoft Office 365
365 * Microsoft Business Productivity Online Suite (BPOS)
366 * Microsoft Lync Server
367 * Microsoft Office Communications Server (OCS 2007/2007 R2)
368 * Microsoft Live Communications Server (LCS 2003/2005)
369 * Reuters Messaging
371 This package contains the NSIS installer package of the protocol plugin
372 for Pidgin on Windows.
373 %endif
376 %{mingw_debug_package}
379 %prep
380 %setup -q -n pidgin-sipe-%{version}
382 %build
383 %if 0%{?mingw_prefix:1}
385 # Windows cross-compilation build
387 %{?env_options}
388 echo "lt_cv_deplibs_check_method='pass_all'" >>%{mingw_cache}
389 autoreconf --verbose --install --force
390 %{mingw_ldflags}="-Wl,--exclude-libs=libintl.a -Wl,--exclude-libs=libiconv.a -lws2_32"
391 %{mingw_configure} \
392 --enable-purple \
393 %if 0%{?build_telepathy:1}
394 --enable-telepathy
395 %else
396 --disable-telepathy
397 %endif
398 %{mingw_make} %{_smp_mflags} || %{mingw_make}
400 %else
402 # Standard Linux build
404 %if 0%{?sles_version} == 10
405 export CFLAGS="%optflags -I%{_includedir}/gssapi"
406 %endif
407 %if 0%{?mdkversion}
408 autoreconf --verbose --install --force
409 %endif
410 %configure \
411 --enable-purple \
412 %if 0%{?build_telepathy:1}
413 --enable-telepathy
414 %else
415 --disable-telepathy
416 %endif
417 make %{_smp_mflags}
418 make %{_smp_mflags} check
420 # End Windows cross-compilation/Linux build setup
421 %endif
424 %install
425 %if 0%{?mingw_prefix:1}
427 # Windows cross-compilation install
429 %{mingw_makeinstall}
430 rm -f %{buildroot}%{mingw_libdir}/purple-2/*.dll.a
432 # generate NSIS installer package
433 perl contrib/opensuse-build-service/generate_nsi.pl po/LINGUAS \
434 <contrib/opensuse-build-service/pidgin-sipe.nsi.template \
435 >%{buildroot}/pidgin-sipe.nsi
437 set -e; \
438 cd %{buildroot}; \
439 makensis \
440 -DVERSION=%{version} \
441 -DMINGW_LIBDIR=%{buildroot}%{mingw_libdir} \
442 -DMINGW_DATADIR=%{buildroot}%{mingw_datadir} \
443 pidgin-sipe.nsi \
445 rm -f %{buildroot}/pidgin-sipe.nsi
447 %else
449 # Standard Linux install
451 %makeinstall
453 # End Windows cross-compilation/Linux build setup
454 %endif
456 find %{buildroot} -type f -name "*.la" -delete -print
457 # SLES11 defines suse_version = 1110
458 %if 0%{?suse_version} && 0%{?suse_version} < 1120
459 rm -r %{buildroot}/%{_datadir}/pixmaps/pidgin/protocols/scalable
460 %endif
461 # Pidgin doesn't have 24 or 32 pixel icons
462 rm -f \
463 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/24/sipe.png \
464 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/32/sipe.png
465 %if 0%{?build_telepathy:1}
466 %if !0%{?build_ktp:1}
467 rm -r %{buildroot}%{_datadir}/telepathy
468 %endif
469 %endif
470 %find_lang pidgin-sipe
473 %clean
474 rm -rf %{buildroot}
477 %if 0%{?build_telepathy:1}
478 %files -n %{purple_plugin}
479 %else
480 %files -n %{purple_plugin} -f pidgin-sipe.lang
481 %endif
482 %defattr(-,root,root,-)
483 %doc AUTHORS ChangeLog COPYING NEWS README TODO
484 %if 0%{?mingw_prefix:1}
485 %{mingw_libdir}/purple-2/libsipe.dll
486 %else
487 %{_libdir}/purple-2/libsipe.so
488 %endif
491 %if 0%{?build_telepathy:1}
492 %files -n %{empathy_files}
493 %defattr(-,root,root,-)
494 %doc AUTHORS COPYING
495 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.png
496 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.svg
499 %if 0%{?build_ktp:1}
500 %files -n %{ktp_files}
501 %defattr(-,root,root,-)
502 %doc AUTHORS COPYING
503 %{_datadir}/telepathy/profiles/sipe.profile
504 %endif
507 %files -n %{telepathy_plugin}
508 %defattr(-,root,root,-)
509 %doc AUTHORS ChangeLog COPYING NEWS README TODO
510 %{_datadir}/dbus-1/services/*.sipe.service
511 %{_libexecdir}/telepathy-sipe
514 %files -n %{common_files} -f pidgin-sipe.lang
515 %defattr(-,root,root,-)
516 %endif
519 %files
520 %defattr(-,root,root,-)
521 %doc AUTHORS COPYING
522 %if 0%{?mingw_prefix:1}
523 %{mingw_datadir}/pixmaps/pidgin/protocols/*/sipe.png
524 %{mingw_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
525 %else
526 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
527 # SLES11 defines suse_version = 1110
528 %if !0%{?suse_version} || 0%{?suse_version} >= 1120
529 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
530 %endif
531 %endif
534 %if 0%{?mingw_prefix:1}
535 %files -n %{nsis_package}
536 %defattr(-, root, root)
537 /pidgin-sipe-%{version}.exe
538 %endif
541 %changelog
542 * Sat Nov 30 2013 J. D. User <jduser@noreply.com> 1.17.2
543 - update to 1.17.2
545 * Sat Nov 16 2013 J. D. User <jduser@noreply.com> 1.17.1
546 - update to 1.17.1
548 * Sat Sep 21 2013 J. D. User <jduser@noreply.com> 1.17.0
549 - update to 1.17.0
551 * Sat Jul 13 2013 J. D. User <jduser@noreply.com> 1.16.1
552 - update to 1.16.1
554 * Fri Jun 14 2013 J. D. User <jduser@noreply.com> 1.16.0
555 - update to 1.16.0
557 * Sun Apr 07 2013 J. D. User <jduser@noreply.com> 1.15.1
558 - update to 1.15.1
560 * Fri Mar 29 2013 J. D. User <jduser@noreply.com> 1.15.0-*git*
561 - update package description texts
563 * Sat Mar 09 2013 J. D. User <jduser@noreply.com> 1.15.0
564 - update to 1.15.0
566 * Wed Dec 26 2012 J. D. User <jduser@noreply.com> 1.14.1
567 - update to 1.14.1
569 * Sun Dec 16 2012 J. D. User <jduser@noreply.com> 1.14.0
570 - update to 1.14.0
572 * Tue Sep 25 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
573 - change BR gstreamer-devel to pkgconfig(gstreamer-0.10)
575 * Sun Sep 09 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
576 - BR telepathy-glib-devel >= 0.18.0
578 * Wed Sep 05 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
579 - BR telepathy-glib-devel >= 0.14.0
581 * Sun Sep 02 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
582 - really disable telepathy for Windows cross-compilation builds
584 * Thu Aug 30 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
585 - updates to enable telepathy build
587 * Sun Aug 19 2012 J. D. User <jduser@noreply.com> 1.13.3
588 - update to 1.13.3
590 * Sun Jun 10 2012 J. D. User <jduser@noreply.com> 1.13.2
591 - update to 1.13.2
593 * Mon Apr 09 2012 J. D. User <jduser@noreply.com> 1.13.1
594 - update to 1.13.1
596 * Wed Mar 14 2012 J. D. User <jduser@noreply.com> 1.13.0
597 - update to 1.13.0
599 * Mon Dec 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
600 - we do support Microsoft Lync Server 2010 now.
602 * Tue Dec 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
603 - update GPL2 license name
605 * Sat Nov 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
606 - add BR gmime-devel for Fedora to have at least one verification platform
608 * Sun Nov 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
609 - fix Mandriva 2011 unresolvable BR
611 * Mon Oct 31 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
612 - add BR nss-devel
614 * Sat Oct 01 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
615 - add NSIS package for mingw builds
617 * Sat Oct 01 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
618 - add mingw64 build
620 * Wed Sep 28 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
621 - remove BR mingw32-mozilla-nss-devel, not needed for SSPI.
623 * Mon Sep 19 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
624 - update mingw32 build
625 - update descriptions
627 * Mon Aug 29 2011 J. D. User <jduser@noreply.com> 1.12.0
628 - update to 1.12.0
630 * Wed Jun 22 2011 J. D. User <jduser@noreply.com> 1.11.2-*git*
631 - add gstreamer-devel to enable Voice & Video features
633 * Sat Dec 11 2010 J. D. User <jduser@noreply.com> 1.11.2-*git*
634 - add optional subpackage for telepathy connection manager
636 * Tue Nov 02 2010 J. D. User <jduser@noreply.com> 1.11.2
637 - update to 1.11.2
639 * Sun Oct 24 2010 J. D. User <jduser@noreply.com> 1.11.1
640 - update to 1.11.1
642 * Fri Oct 15 2010 J. D. User <jduser@noreply.com> 1.11.0-*git*
643 - add mingw32 build configuration
645 * Sun Oct 03 2010 J. D. User <jduser@noreply.com> 1.11.0
646 - update to 1.11.0
648 * Thu Sep 02 2010 J. D. User <jduser@noreply.com> pre-1.11.0-*git*
649 - Mandriva config for OBS has changed
651 * Tue May 04 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
652 - add libnice build information discovered through OBS testing
654 * Mon Apr 12 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
655 - add NSS build information discovered through OBS testing
657 * Wed Apr 04 2010 pier11 <pier11@operamail.com> 1.10.0
658 - release
660 * Fri Apr 02 2010 J. D. User <jduser@noreply.com> pre-1.10.0-*git*
661 - Mandriva has too old libtool version
663 * Fri Apr 02 2010 J. D. User <jduser@noreply.com> pre-1.10.0-*git*
664 - SLE11, openSUSE 11.0/1 don't have pidgin/protocols/scalable directory
666 * Sun Mar 07 2010 pier11 <pier11@operamail.com> pre-1.10.0-*git*
667 - OBS tests of pre-1.10.0 git-snapshot 4fa20cd65e5be0e469d4aa55d861f11c5b08b816
669 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
670 - added --enable/--disable build options
672 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
673 - removed --with-krb5 configure option as it is autodetected now
675 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
676 - add SVG icon
678 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
679 - add BR glib2-devel >= 2.12.0
681 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
682 - add tests to build
684 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
685 - update to 1.9.1
687 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
688 - add BR libxml2-devel
690 * Wed Mar 10 2010 pier11 <pier11@operamail.com> 1.9.0
691 - release
692 - dropped SLE 10 due to libpurple min version increase
693 - updated target distros in comment line
695 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
696 - increased libpurple build requisite to >= 2.4.0
698 * Sun Mar 07 2010 pier11 <pier11@operamail.com> pre-1.9.0-*git*
699 - OBS tests of pre-1.9.0 git-snapshot 61ea0856855483b9e18f23a87afe47437e526f0e
701 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
702 - sync with RPM SPEC from contrib/rpm
704 * Sun Feb 08 2010 pier11 <pier11@operamail.com> 1.8.0
705 - source is an original 1.8.0 with patch: git(upstream) 9c34cc3557daa3d61a002002492c71d0343c8cae
706 - temp hack - renamed source in spec from .bz2 to .gz as the latter was prepared with the patch.
708 * Sun Nov 22 2009 pier11 <pier11@operamail.com> 1.7.1
709 - reinstated enable-quality-check
711 * Wed Nov 04 2009 John Beranek <john@redux.org.uk> 1.7.0
712 - Spec file modifications to allow SLES/D 10 and Mandriva 2009.1 builds
714 * Tue Nov 03 2009 John Beranek <john@redux.org.uk> 1.7.0
715 - Spec file modifications for openSUSE build service
717 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
718 - move non-Pidgin files to new sub-package purple-sipe
720 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
721 - remove directory for emoticon theme icons
723 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
724 - libpurple protocol plugins are located under %%{_libdir}/purple-2
726 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
727 - added directory for emoticon theme icons
729 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
730 - update to 1.6.3
732 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
733 - reduce libpurple-devel requirement to >= 2.3.1
735 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
736 - update to 1.6.2
738 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
739 - reduce libpurple-devel requirement to >= 2.4.1
741 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
742 - com_err.h only required for kerberos
744 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
745 - require libpurple-devel >= 2.5.0
747 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
748 - refactor configure parameters
749 - make kerberos configurable
750 - don't hard code prefix for git builds
752 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
753 - removed unnecessary zlib-devel
755 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
756 - fix prefix for git builds
758 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
759 - append -Wno-unused-parameter for GCC <4.4 compilation errors
761 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
762 - remove duplicate GPL2
764 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
765 - use "--with git" to build from git
766 - corrected download URL for release archive
767 - add missing BR gettext-devel
769 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
770 - use default rpmbuild CFLAGS also for git builds
771 - merge with SPEC files created by mricon & jberanek
773 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
774 - initial RPM SPEC example generated