OBS: really disable telepathy for mingw builds
[siplcs.git] / contrib / opensuse-build-service / pidgin-sipe.spec
blob23998c74136e4d66b57e4897b900308a75e6904b
2 # OBS SPEC file to generate a RPM for pidgin-sipe.
4 # It has support for:
6 # RedHat family (CentOS, Fedora, RHEL)
7 # Mandriva
8 # SUSE family (openSUSE, SLED, SLES)
9 # Windows (mingw32, mingw64)
12 # Build options
13 %undefine build_telepathy
15 # Check for mingw32 cross compilation build
17 # Manually add this repository to your private OBS project:
19 # <repository name="mingw32">
20 # <path repository="openSUSE_11.4" project="windows:mingw:win32"/>
21 # <arch>i586</arch>
22 # </repository>
24 %if "%{_repository}" == "mingw32"
25 %define purple_sipe_mingw32 1
26 %define mingw_prefix mingw32-
27 %define mingw_cache %{_mingw32_cache}
28 %define mingw_configure %{_mingw32_configure}
29 %define mingw_datadir %{_mingw32_datadir}
30 %define mingw_debug_package %{_mingw32_debug_package}
31 %define mingw_ldflags MINGW32_LDFLAGS
32 %define mingw_libdir %{_mingw32_libdir}
33 %define mingw_make %{_mingw32_make}
34 %define mingw_makeinstall %{_mingw32_makeinstall}
35 %define __strip %{_mingw32_strip}
36 %define __objdump %{_mingw32_objdump}
37 %define _use_internal_dependency_generator 0
38 %define __find_requires %{_mingw32_findrequires}
39 %define __find_provides %{_mingw32_findprovides}
40 %define __os_install_post %{_mingw32_debug_install_post} \
41 %{_mingw32_install_post}
42 %endif
44 # Check for mingw64 cross compilation build
46 # Manually add this repository to your private OBS project:
48 # <repository name="mingw64">
49 # <path repository="openSUSE_11.4" project="windows:mingw:win64"/>
50 # <arch>i586</arch>
51 # </repository>
53 %if "%{_repository}" == "mingw64"
54 %define purple_sipe_mingw64 1
55 %define mingw_prefix mingw64-
56 %define mingw_cache %{_mingw64_cache}
57 %define mingw_configure %{_mingw64_configure}
58 %define mingw_datadir %{_mingw64_datadir}
59 %define mingw_debug_package %{_mingw64_debug_package}
60 %define mingw_ldflags MINGW64_LDFLAGS
61 %define mingw_libdir %{_mingw64_libdir}
62 %define mingw_make %{_mingw64_make}
63 %define mingw_makeinstall %{_mingw64_makeinstall}
64 %define __strip %{_mingw64_strip}
65 %define __objdump %{_mingw64_objdump}
66 %define _use_internal_dependency_generator 0
67 %define __find_requires %{_mingw64_findrequires}
68 %define __find_provides %{_mingw64_findprovides}
69 %define __os_install_post %{_mingw64_debug_install_post} \
70 %{_mingw64_install_post}
71 %endif
73 %define purple_plugin %{?mingw_prefix:%{mingw_prefix}}libpurple-plugin-sipe
74 %define telepathy_plugin %{?mingw_prefix:%{mingw_prefix}}telepathy-plugin-sipe
75 %define nsis_package %{?mingw_prefix:%{mingw_prefix}}pidgin-sipe-nsis
76 %define common_files sipe-common
77 %define empathy_files empathy-sipe
78 %define ktp_files ktp-accounts-kcm-sipe
81 %define purple_develname libpurple-devel
83 %if 0%{?mdkversion} >= 200910
84 %ifarch x86_64
85 %define purple_develname lib64purple-devel
86 %endif
87 %if 0%{?mdkversion} >= 201000
88 %ifnarch x86_64
89 %define has_libnice 1
90 %endif
91 %endif
92 %endif
94 %if 0%{?suse_version}
95 %define nss_develname mozilla-nss-devel
96 %if 0%{?suse_version} >= 1120
97 %define has_libnice 1
98 %if 0%{?suse_version} > 1140
99 %define has_gstreamer 1
100 %define build_telepathy 1
101 %endif
102 %endif
103 %else
104 %define nss_develname nss-devel
105 %endif
107 %if 0%{?suse_version} || 0%{?sles_version}
108 %define pkg_group Productivity/Networking/Instant Messenger
109 %endif
110 %if 0%{?fedora}
111 %define pkg_group Applications/Internet
112 %if 0%{?fedora} >= 11
113 %define has_libnice 1
114 %if 0%{?fedora} >= 15
115 %define has_gstreamer 1
116 %define build_telepathy 1
117 %define build_ktp 1
118 %endif
119 %endif
120 %endif
121 %if 0%{?mdkversion}
122 %define pkg_group Networking/Instant messaging
123 %else
124 %define pkg_group Applications/Internet
125 %endif
127 %if 0%{?purple_sipe_mingw32}
128 Name: mingw32-pidgin-sipe
129 %else
130 %if 0%{?purple_sipe_mingw64}
131 Name: mingw64-pidgin-sipe
132 %else
133 Name: pidgin-sipe
134 %endif
135 %endif
136 Summary: Pidgin protocol plugin to connect to MS Office Communicator
137 Version: 1.13.3
138 Release: 1
139 Source: pidgin-sipe-%{version}.tar.gz
140 Group: %{pkg_group}
141 License: GPL-2.0+
142 URL: http://sipe.sourceforge.net/
144 BuildRoot: %{_tmppath}/%{name}-%{version}-build
146 %if 0%{?mingw_prefix:1}
148 # Windows cross-compilation build setup
150 BuildArch: noarch
151 #!BuildIgnore: post-build-checks
153 BuildRequires: %{mingw_prefix}filesystem >= 23
154 BuildRequires: %{mingw_prefix}cross-gcc
155 BuildRequires: %{mingw_prefix}cross-binutils
156 BuildRequires: %{mingw_prefix}gettext-runtime
157 BuildRequires: %{mingw_prefix}cross-pkg-config
158 BuildRequires: %{mingw_prefix}glib2-devel >= 2.12.0
159 BuildRequires: %{mingw_prefix}libxml2-devel
160 BuildRequires: %{mingw_prefix}mozilla-nss-devel
161 BuildRequires: %{mingw_prefix}libpurple-devel >= 2.4.0
162 BuildRequires: %{mingw_prefix}cross-nsis
164 # For directory ownership
165 BuildRequires: %{mingw_prefix}pidgin
167 # Make sure telepathy is disabled for Windows builds
168 %undefine build_telepathy
170 %else
172 # Standard Linux build setup
174 BuildRequires: %{purple_develname} >= 2.4.0
175 BuildRequires: libxml2-devel
176 BuildRequires: %{nss_develname}
177 BuildRequires: gettext-devel
178 # The following two are required to enable Voice & Video features
179 %if 0%{?has_libnice:1}
180 BuildRequires: libnice-devel
181 %endif
182 %if 0%{?has_gstreamer:1}
183 BuildRequires: gstreamer-devel
184 %endif
185 # Requirements for telepathy backend
186 %if 0%{?build_telepathy:1}
187 BuildRequires: telepathy-glib-devel
188 BuildRequires: gmime-devel
189 BuildRequires: glib2-devel >= 2.28.0
190 %endif
192 # Configurable components
193 %if !0%{?_without_kerberos:1}
194 BuildRequires: krb5-devel
195 %endif
197 # For directory ownership
198 BuildRequires: pidgin
199 %if 0%{?build_telepathy:1}
200 BuildRequires: empathy
201 BuildRequires: pkgconfig(telepathy-glib)
202 %endif
203 Requires: pidgin
204 %if 0%{?sles_version} == 10
205 BuildRequires: gnome-keyring-devel
206 %endif
208 # For OBS's "have choice for" for Fedora 11 (only)
209 %if 0%{?fedora_version} == 11
210 BuildRequires: libproxy-mozjs
211 BuildRequires: PolicyKit-gnome
212 %endif
214 # For OBS's "have choice for" for Mandriva 2010.1 (and up?)
215 %if 0%{?mdkversion} >= 201010
216 BuildRequires: polkit-gnome
217 %endif
219 # For OBS's "have choice for" for Mandriva 2011 (and up?)
220 %if 0%{?mdkversion} >= 201100
221 BuildRequires: packagekit-gstreamer-plugin
222 BuildRequires: gnome-packagekit-common
223 %endif
225 # End Windows cross-compilation/Linux build setup
226 %endif
228 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
229 BuildRequires: libtool
230 BuildRequires: intltool
231 BuildRequires: glib2-devel >= 2.12.0
234 %description
235 A third-party plugin for the Pidgin multi-protocol instant messenger.
236 It implements the extended version of SIP/SIMPLE used by various products:
238 * Microsoft Lync Server 2010
239 * Microsoft Office Communications Server (OCS 2007/2007 R2)
240 * Microsoft Live Communications Server (LCS 2003/2005)
241 * Reuters Messaging
243 With this plugin you should be able to replace your Microsoft Office
244 Communicator client with Pidgin.
246 This package provides the icon set for Pidgin.
249 %package -n %{purple_plugin}
250 Summary: Libpurple protocol plugin to connect to MS Office Communicator
251 Group: %{pkg_group}
252 License: GPL-2.0+
253 Obsoletes: purple-sipe
254 %if 0%{?build_telepathy:1}
255 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
256 %endif
258 %description -n %{purple_plugin}
259 A third-party plugin for the Pidgin multi-protocol instant messenger.
260 It implements the extended version of SIP/SIMPLE used by various products:
262 * Microsoft Lync Server 2010
263 * Microsoft Office Communications Server (OCS 2007/2007 R2)
264 * Microsoft Live Communications Server (LCS 2003/2005)
265 * Reuters Messaging
267 This package provides the protocol plugin for libpurple clients.
270 %if 0%{?build_telepathy:1}
271 %package -n %{empathy_files}
272 Summary: Telepathy connection manager to connect to MS Office Communicator
273 Group: %{pkg_group}
274 License: GPL-2.0+
275 Requires: empathy
276 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
278 %description -n %{empathy_files}
279 A Telepathy connection manager that implements the extended version of
280 SIP/SIMPLE used by various products:
282 * Microsoft Lync Server 2010
283 * Microsoft Office Communications Server (OCS 2007/2007 R2)
284 * Microsoft Live Communications Server (LCS 2003/2005)
285 * Reuters Messaging
287 This package provides the icon set for Empathy.
290 %if 0%{?build_ktp:1}
291 %package -n %{ktp_files}
292 Summary: Telepathy connection manager to connect to MS Office Communicator
293 Group: %{pkg_group}
294 License: GPL-2.0+
295 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
297 %description -n %{ktp_files}
298 A Telepathy connection manager that implements the extended version of
299 SIP/SIMPLE used by various products:
301 * Microsoft Lync Server 2010
302 * Microsoft Office Communications Server (OCS 2007/2007 R2)
303 * Microsoft Live Communications Server (LCS 2003/2005)
304 * Reuters Messaging
306 This package provides the profile for KTP account manager.
307 %endif
310 %package -n %{telepathy_plugin}
311 Summary: Telepathy connection manager to connect to MS Office Communicator
312 Group: %{pkg_group}
313 License: GPL-2.0+
314 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
316 %description -n %{telepathy_plugin}
317 A Telepathy connection manager that implements the extended version of
318 SIP/SIMPLE used by various products:
320 * Microsoft Lync Server 2010
321 * Microsoft Office Communications Server (OCS 2007/2007 R2)
322 * Microsoft Live Communications Server (LCS 2003/2005)
323 * Reuters Messaging
325 This package provides the protocol support for Telepathy clients.
328 %package -n %{common_files}
329 Summary: Common files for SIPE protocol plugins
330 Group: %{pkg_group}
331 License: GPL-2.0+
332 BuildArch: noarch
334 %description -n %{common_files}
335 This package provides common files for the SIPE protocol plugins:
337 * Localisation
338 %endif
341 %if 0%{?mingw_prefix:1}
342 %package -n %{nsis_package}
343 Summary: Windows Pidgin protocol plugin to connect to MS Office Communicator
344 Group: %{pkg_group}
345 License: GPL-2.0+
347 %description -n %{nsis_package}
348 A third-party plugin for the Pidgin multi-protocol instant messenger.
349 It implements the extended version of SIP/SIMPLE used by various products:
351 * Microsoft Lync Server 2010
352 * Microsoft Office Communications Server (OCS 2007/2007 R2)
353 * Microsoft Live Communications Server (LCS 2003/2005)
354 * Reuters Messaging
356 This package contains the NSIS installer package of the protocol plugin
357 for Pidgin on Windows.
358 %endif
361 %{mingw_debug_package}
364 %prep
365 %setup -q -n pidgin-sipe-%{version}
367 %build
368 %if 0%{?mingw_prefix:1}
370 # Windows cross-compilation build
372 %{?env_options}
373 echo "lt_cv_deplibs_check_method='pass_all'" >>%{mingw_cache}
374 autoreconf --verbose --install --force
375 %{mingw_ldflags}="-Wl,--exclude-libs=libintl.a -Wl,--exclude-libs=libiconv.a -lws2_32"
376 %{mingw_configure} \
377 --enable-purple \
378 %if 0%{?build_telepathy:1}
379 --enable-telepathy
380 %else
381 --disable-telepathy
382 %endif
383 %{mingw_make} %{_smp_mflags} || %{mingw_make}
385 %else
387 # Standard Linux build
389 %if 0%{?sles_version} == 10
390 export CFLAGS="%optflags -I%{_includedir}/gssapi"
391 %endif
392 %if 0%{?mdkversion}
393 autoreconf --verbose --install --force
394 %endif
395 %configure \
396 --enable-purple \
397 %if 0%{?build_telepathy:1}
398 --enable-telepathy
399 %else
400 --disable-telepathy
401 %endif
402 make %{_smp_mflags}
403 make %{_smp_mflags} check
405 # End Windows cross-compilation/Linux build setup
406 %endif
409 %install
410 %if 0%{?mingw_prefix:1}
412 # Windows cross-compilation install
414 %{mingw_makeinstall}
415 rm -f %{buildroot}%{mingw_libdir}/purple-2/*.dll.a
417 # generate NSIS installer package
418 perl contrib/opensuse-build-service/generate_nsi.pl po/LINGUAS \
419 <contrib/opensuse-build-service/pidgin-sipe.nsi.template \
420 >%{buildroot}/pidgin-sipe.nsi
422 set -e; \
423 cd %{buildroot}; \
424 makensis \
425 -DVERSION=%{version} \
426 -DMINGW_LIBDIR=%{buildroot}%{mingw_libdir} \
427 -DMINGW_DATADIR=%{buildroot}%{mingw_datadir} \
428 pidgin-sipe.nsi \
430 rm -f %{buildroot}/pidgin-sipe.nsi
432 %else
434 # Standard Linux install
436 %makeinstall
438 # End Windows cross-compilation/Linux build setup
439 %endif
441 find %{buildroot} -type f -name "*.la" -delete -print
442 # SLES11 defines suse_version = 1110
443 %if 0%{?suse_version} && 0%{?suse_version} < 1120
444 rm -r %{buildroot}/%{_datadir}/pixmaps/pidgin/protocols/scalable
445 %endif
446 # Pidgin doesn't have 24 or 32 pixel icons
447 rm -f \
448 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/24/sipe.png \
449 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/32/sipe.png
450 %if 0%{?build_telepathy:1}
451 %if !0%{?build_ktp:1}
452 rm -r %{buildroot}%{_datadir}/telepathy
453 %endif
454 %endif
455 %find_lang pidgin-sipe
458 %clean
459 rm -rf %{buildroot}
462 %if 0%{?build_telepathy:1}
463 %files -n %{purple_plugin}
464 %else
465 %files -n %{purple_plugin} -f pidgin-sipe.lang
466 %endif
467 %defattr(-,root,root,-)
468 %doc AUTHORS ChangeLog COPYING NEWS README TODO
469 %if 0%{?mingw_prefix:1}
470 %{mingw_libdir}/purple-2/libsipe.dll
471 %else
472 %{_libdir}/purple-2/libsipe.so
473 %endif
476 %if 0%{?build_telepathy:1}
477 %files -n %{empathy_files}
478 %defattr(-,root,root,-)
479 %doc AUTHORS COPYING
480 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.png
481 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.svg
484 %if 0%{?build_ktp:1}
485 %files -n %{ktp_files}
486 %defattr(-,root,root,-)
487 %doc AUTHORS COPYING
488 %{_datadir}/telepathy/profiles/sipe.profile
489 %endif
492 %files -n %{telepathy_plugin}
493 %defattr(-,root,root,-)
494 %doc AUTHORS ChangeLog COPYING NEWS README TODO
495 %{_datadir}/dbus-1/services/*.sipe.service
496 %{_libexecdir}/telepathy-sipe
499 %files -n %{common_files} -f pidgin-sipe.lang
500 %defattr(-,root,root,-)
501 %endif
504 %files
505 %defattr(-,root,root,-)
506 %doc AUTHORS COPYING
507 %if 0%{?mingw_prefix:1}
508 %{mingw_datadir}/pixmaps/pidgin/protocols/*/sipe.png
509 %{mingw_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
510 %else
511 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
512 # SLES11 defines suse_version = 1110
513 %if !0%{?suse_version} || 0%{?suse_version} >= 1120
514 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
515 %endif
516 %endif
519 %if 0%{?mingw_prefix:1}
520 %files -n %{nsis_package}
521 %defattr(-, root, root)
522 /pidgin-sipe-%{version}.exe
523 %endif
526 %changelog
527 * Sun Sep 02 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
528 - really disable telepathy for Windows cross-compilation builds
530 * Thu Aug 30 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
531 - updates to enable telepathy build
533 * Sun Aug 19 2012 J. D. User <jduser@noreply.com> 1.13.3
534 - update to 1.13.3
536 * Sun Jun 10 2012 J. D. User <jduser@noreply.com> 1.13.2
537 - update to 1.13.2
539 * Mon Apr 09 2012 J. D. User <jduser@noreply.com> 1.13.1
540 - update to 1.13.1
542 * Wed Mar 14 2012 J. D. User <jduser@noreply.com> 1.13.0
543 - update to 1.13.0
545 * Mon Dec 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
546 - we do support Microsoft Lync Server 2010 now.
548 * Tue Dec 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
549 - update GPL2 license name
551 * Sat Nov 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
552 - add BR gmime-devel for Fedora to have at least one verification platform
554 * Sun Nov 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
555 - fix Mandriva 2011 unresolvable BR
557 * Mon Oct 31 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
558 - add BR nss-devel
560 * Sat Oct 01 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
561 - add NSIS package for mingw builds
563 * Sat Oct 01 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
564 - add mingw64 build
566 * Wed Sep 28 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
567 - remove BR mingw32-mozilla-nss-devel, not needed for SSPI.
569 * Mon Sep 19 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
570 - update mingw32 build
571 - update descriptions
573 * Mon Aug 29 2011 J. D. User <jduser@noreply.com> 1.12.0
574 - update to 1.12.0
576 * Wed Jun 22 2011 J. D. User <jduser@noreply.com> 1.11.2-*git*
577 - add gstreamer-devel to enable Voice & Video features
579 * Sat Dec 11 2010 J. D. User <jduser@noreply.com> 1.11.2-*git*
580 - add optional subpackage for telepathy connection manager
582 * Tue Nov 02 2010 J. D. User <jduser@noreply.com> 1.11.2
583 - update to 1.11.2
585 * Sun Oct 24 2010 J. D. User <jduser@noreply.com> 1.11.1
586 - update to 1.11.1
588 * Fri Oct 15 2010 J. D. User <jduser@noreply.com> 1.11.0-*git*
589 - add mingw32 build configuration
591 * Sun Oct 03 2010 J. D. User <jduser@noreply.com> 1.11.0
592 - update to 1.11.0
594 * Thu Sep 02 2010 J. D. User <jduser@noreply.com> pre-1.11.0-*git*
595 - Mandriva config for OBS has changed
597 * Tue May 04 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
598 - add libnice build information discovered through OBS testing
600 * Mon Apr 12 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
601 - add NSS build information discovered through OBS testing
603 * Wed Apr 04 2010 pier11 <pier11@operamail.com> 1.10.0
604 - release
606 * Fri Apr 02 2010 J. D. User <jduser@noreply.com> pre-1.10.0-*git*
607 - Mandriva has too old libtool version
609 * Fri Apr 02 2010 J. D. User <jduser@noreply.com> pre-1.10.0-*git*
610 - SLE11, openSUSE 11.0/1 don't have pidgin/protocols/scalable directory
612 * Sun Mar 07 2010 pier11 <pier11@operamail.com> pre-1.10.0-*git*
613 - OBS tests of pre-1.10.0 git-snapshot 4fa20cd65e5be0e469d4aa55d861f11c5b08b816
615 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
616 - added --enable/--disable build options
618 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
619 - removed --with-krb5 configure option as it is autodetected now
621 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
622 - add SVG icon
624 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
625 - add BR glib2-devel >= 2.12.0
627 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
628 - add tests to build
630 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
631 - update to 1.9.1
633 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
634 - add BR libxml2-devel
636 * Wed Mar 10 2010 pier11 <pier11@operamail.com> 1.9.0
637 - release
638 - dropped SLE 10 due to libpurple min version increase
639 - updated target distros in comment line
641 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
642 - increased libpurple build requisite to >= 2.4.0
644 * Sun Mar 07 2010 pier11 <pier11@operamail.com> pre-1.9.0-*git*
645 - OBS tests of pre-1.9.0 git-snapshot 61ea0856855483b9e18f23a87afe47437e526f0e
647 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
648 - sync with RPM SPEC from contrib/rpm
650 * Sun Feb 08 2010 pier11 <pier11@operamail.com> 1.8.0
651 - source is an original 1.8.0 with patch: git(upstream) 9c34cc3557daa3d61a002002492c71d0343c8cae
652 - temp hack - renamed source in spec from .bz2 to .gz as the latter was prepared with the patch.
654 * Sun Nov 22 2009 pier11 <pier11@operamail.com> 1.7.1
655 - reinstated enable-quality-check
657 * Wed Nov 04 2009 John Beranek <john@redux.org.uk> 1.7.0
658 - Spec file modifications to allow SLES/D 10 and Mandriva 2009.1 builds
660 * Tue Nov 03 2009 John Beranek <john@redux.org.uk> 1.7.0
661 - Spec file modifications for openSUSE build service
663 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
664 - move non-Pidgin files to new sub-package purple-sipe
666 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
667 - remove directory for emoticon theme icons
669 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
670 - libpurple protocol plugins are located under %%{_libdir}/purple-2
672 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
673 - added directory for emoticon theme icons
675 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
676 - update to 1.6.3
678 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
679 - reduce libpurple-devel requirement to >= 2.3.1
681 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
682 - update to 1.6.2
684 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
685 - reduce libpurple-devel requirement to >= 2.4.1
687 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
688 - com_err.h only required for kerberos
690 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
691 - require libpurple-devel >= 2.5.0
693 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
694 - refactor configure parameters
695 - make kerberos configurable
696 - don't hard code prefix for git builds
698 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
699 - removed unnecessary zlib-devel
701 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
702 - fix prefix for git builds
704 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
705 - append -Wno-unused-parameter for GCC <4.4 compilation errors
707 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
708 - remove duplicate GPL2
710 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
711 - use "--with git" to build from git
712 - corrected download URL for release archive
713 - add missing BR gettext-devel
715 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
716 - use default rpmbuild CFLAGS also for git builds
717 - merge with SPEC files created by mricon & jberanek
719 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
720 - initial RPM SPEC example generated