games-engines/hugor-9999: remove qt4/qt5 flags as upstream is now qt5-only
[gentoo-interactive-fiction.git] / games-engines / hugor / hugor-9999.ebuild
blob14f881e9127c1aa5cede4dfb44bfdaa664cfe407
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="5"
7 if [ "$PV" != "9999" ]; then
8 SRC_URI="https://github.com/realnc/hugor/releases/download/${PV}/hugor-${PV}-src.tar.bz2"
9 KEYWORDS="x86 amd64"
10 else
11 SRC_URI=""
12 KEYWORDS=""
15 inherit eutils gnome2-utils fdo-mime games qmake-utils confutils
17 if [ "$PV" == "9999" ]; then
18 EGIT_REPO_URI="git://github.com/realnc/hugor.git"
19 inherit git-2
22 DESCRIPTION="Multimedia interpreter for Hugo text adventures"
23 HOMEPAGE="http://ifwiki.org/index.php/Hugor"
25 LICENSE="Hugo"
26 SLOT="0"
27 IUSE="+gstreamer"
29 RDEPEND="gstreamer? (
30 media-libs/gst-plugins-good:1.0
31 media-plugins/gst-plugins-libav
34 DEPEND="${RDEPEND}
35 dev-qt/qtgui:5
36 media-libs/sdl-mixer[mp3,mad,midi,mod]
37 gstreamer? ( media-libs/gst-plugins-base:1.0 )
38 x11-misc/shared-mime-info"
40 src_configure() {
41 local conf
42 ! use gstreamer && conf="disable-video"
43 eqmake5 "${S}/hugor.pro" CONFIG+="${conf}"
46 src_install() {
47 dogamesbin "hugor"
48 dodoc README
49 doicon "${FILESDIR}/hugor.png"
50 make_desktop_entry hugor Hugor "hugor" Game "GenericName=Hugo Multimedia Interpreter\nMimeType=application/x-hugo-image;"
51 insinto /usr/share/icons
52 doins -r "${FILESDIR}/hicolor"
53 insinto /usr/share/mime/packages
54 doins "${FILESDIR}/hugor.xml"
55 prepgamesdirs
58 pkg_preinst() {
59 games_pkg_preinst
60 gnome2_icon_savelist
63 pkg_postinst() {
64 games_pkg_postinst
65 fdo-mime_desktop_database_update
66 fdo-mime_mime_database_update
67 gnome2_icon_cache_update
70 pkg_postrm() {
71 fdo-mime_desktop_database_update
72 fdo-mime_mime_database_update
73 gnome2_icon_cache_update