gargoyle: only grab the "-jN" option from MAKEOPTS and pass it to jam
[gentoo-interactive-fiction.git] / games-engines / glulxe / glulxe-0.4.6.ebuild
blob9670d1a55f364a299e7309be80327199ee809060
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI=1
7 inherit eutils flag-o-matic games
9 MY_P=${P//./}
10 DESCRIPTION="An interpreter for the Glulx Virtual Machine"
11 HOMEPAGE="http://www.eblong.com/zarf/glulx/"
12 SRC_URI="mirror://ifarchive/programming/glulx/interpreters/${PN}/${MY_P}.tar.gz"
14 LICENSE="Zarf"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="+verify"
19 RDEPEND="dev-games/glkloader"
20 DEPEND="${RDEPEND}
21 dev-games/glk-headers"
23 S=${WORKDIR}/${PN}
25 src_unpack() {
26 unpack ${A}
27 cd "${S}"
29 epatch "${FILESDIR}"/glulxe-0.4.6-user-CFLAGS.patch
30 epatch "${FILESDIR}"/glulxe-0.4.3-gargoyle.patch
31 sed -i -e "s,@PV@,${PV}," unixstrt.c || die "sed failed"
34 src_compile() {
35 use verify && append-flags -DVERIFY_MEMORY_ACCESS=1
36 emake \
37 GLKINCLUDEDIR=/usr/include/glk \
38 GLKMAKEFILE=Make.glkloader \
39 || die "emake failed"
42 src_install() {
43 dogamesbin glulxe || die "dogamesbin failed"
44 dodoc README || die "dodoc failed"
45 prepgamesdirs