grotesque: Convert Python shebangs, use games.eclass, revbump
[gentoo-interactive-fiction.git] / games-util / grotesque / grotesque-0.9.2-r2.ebuild
blobe5b77d910f9fd3c99c359b427823e20c5650802c
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="3"
6 PYTHON_DEPEND="2:2.7"
8 inherit eutils python games distutils
10 DESCRIPTION="Interactive Fiction library manager"
11 HOMEPAGE="http://grotesque.sourceforge.net"
12 SRC_URI="mirror://sourceforge/grotesque/${P}-gtk2.tar.gz"
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS="amd64 x86"
17 IUSE=""
19 DEPEND="dev-python/pygtk"
20 RDEPEND="${DEPEND}"
22 src_prepare() {
23 python_convert_shebangs -r 2 .
26 pkg_setup() {
27 python_set_active_version 2
28 python_pkg_setup
29 games_pkg_setup
32 src_install() {
33 distutils_src_install --install-data="/usr/share/doc/${PF}" --install-scripts="${GAMES_BINDIR}"
34 rm "${D}/usr/share/doc/${PF}/COPYING"
35 doicon src/grotesque/data/grotesque_icon.png
36 make_desktop_entry grotesque Grotesque grotesque_icon Game "GenericName=IF Library Manager"
37 prepgamesdirs