qtads: Sync ebuilds, enable verbose builds, inherit games last
[gentoo-interactive-fiction.git] / games-engines / git / git-1.2.8.ebuild
blobda3f72327f77675b0434126ffc3cf123f4f075cc
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit eutils toolchain-funcs multilib games
7 MY_P=${P//./}
8 DESCRIPTION="Fast interpreter for the Glulx VM"
9 HOMEPAGE="http://www.diden.net/if/git/"
10 SRC_URI="mirror://ifarchive/programming/glulx/interpreters/${PN}/${MY_P}.zip"
12 LICENSE="MIT"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
17 RDEPEND="dev-games/glkloader"
18 DEPEND="${RDEPEND}
19 app-arch/unzip
20 dev-games/glk-headers"
22 src_unpack() {
23 unpack ${A}
24 cd "${S}"
26 epatch "${FILESDIR}"/git-1.2.2-LDFLAGS.patch
27 epatch "${FILESDIR}"/git-1.2.2-gargoyle.patch
30 src_compile() {
31 emake CC=$(tc-getCC) OPTIONS="-DUSE_INLINE ${CFLAGS}" LINKLIBS=-lm \
32 GLKLIBDIR=/usr/$(get_libdir) GLKINCLUDEDIR=/usr/include/glk GLK=glkloader || die "emake failed"
35 src_install() {
36 newgamesbin git glulxgit || die "newgamesbin failed"
37 dodoc README.txt || die "dodoc failed"
38 prepgamesdirs