frobtads-9999: Add net-misc/curl as a dep
[gentoo-interactive-fiction.git] / games-engines / frobtads / frobtads-9999.ebuild
blobcae06fa00c9c8a417b3e0ad9f6f04e20a83fc93b
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI=2
6 if [ "$PV" == "9999" ]; then
7 # The package uses AM_SILENT_RULES which is only available in automake
8 # 1.11 and later.
9 WANT_AUTOMAKE="1.11"
10 inherit git autotools
12 inherit flag-o-matic games
14 DESCRIPTION="Curses-based interpreter and development tools for TADS 2 and TADS 3 text adventures"
15 HOMEPAGE="http://www.tads.org/frobtads.htm"
16 if [ "$PV" != "9999" ]; then
17 SRC_URI="http://www.tads.org/frobtads/${P}.tar.gz
18 tads2compiler? ( http://www.tads.org/frobtads/${PN}-t2compiler-${PV}.tar.gz )
19 tads3compiler? ( http://www.tads.org/frobtads/${PN}-t3compiler-${PV}.tar.gz )"
20 KEYWORDS="~amd64 ~x86"
21 else
22 SRC_URI=""
23 EGIT_REPO_URI="git://git.assembla.com/frobtads.git"
24 KEYWORDS=""
26 LICENSE="TADS2 TADS3"
27 SLOT="0"
28 RESTRICT="!tads3compiler? ( test )"
29 IUSE="debug +tads2compiler +tads3compiler"
31 DEPEND="sys-libs/ncurses
32 net-misc/curl"
33 RDEPEND="${DEPEND}"
35 src_unpack() {
36 if [ "${PV}" == "9999" ]; then
37 git_src_unpack
38 cd "${S}"
39 einfo "Regenerating autotools files..."
40 eautoreconf
44 src_configure() {
45 append-cxxflags -fno-strict-aliasing
46 egamesconf \
47 $(use_enable debug t3debug) \
48 $(use_enable tads2compiler t2-compiler) \
49 $(use_enable tads3compiler t3-compiler) \
50 || die "egamesconf failed"
53 src_test() {
54 if use debug; then
55 emake -j1 check || die "TADS 3 compiler test suite failed"
58 emake -j1 sample || die "Failed to build test game"
59 ./frob -i plain -p samples/sample.t3 <<- END_FROB_TEST
60 save
61 testsave.sav
62 restore
63 testsave.sav
64 END_FROB_TEST
65 [[ $? -eq 0 ]] || die "Failed to run test game"
68 src_install() {
69 emake DESTDIR="${D}" install || die "emake install failed"
70 dodoc doc/{AUTHORS,BUGS,NEWS,README,SRC_GUIDELINES,THANKS}
71 prepgamesdirs