frobtads-9999: Add net-misc/curl as a dep
[gentoo-interactive-fiction.git] / games-engines / frobtads / frobtads-1.0.ebuild
blob271e23f823ab54fd8ab57553e65a714b2164147b
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/games-engines/frobtads/frobtads-0.13.ebuild,v 1.2 2009/10/29 14:41:58 maekke Exp $
5 EAPI=2
6 inherit flag-o-matic games
8 DESCRIPTION="Curses-based interpreter and development tools for TADS 2 and TADS 3 text adventures"
9 HOMEPAGE="http://www.tads.org/frobtads.htm"
10 SRC_URI="http://www.tads.org/frobtads/${P}.tar.gz
11 tads2compiler? ( http://www.tads.org/frobtads/${PN}-t2compiler-${PV}.tar.gz )
12 tads3compiler? ( http://www.tads.org/frobtads/${PN}-t3compiler-${PV}.tar.gz )"
14 LICENSE="TADS2 TADS3"
15 SLOT="0"
16 KEYWORDS="amd64 x86"
17 IUSE="debug tads2compiler tads3compiler"
19 RESTRICT="!tads3compiler? ( test )"
21 DEPEND="sys-libs/ncurses"
23 src_unpack() {
24 unpack ${A}
25 if use tads2compiler; then
26 mv t2compiler/* "${S}"/t2compiler || die "mv t2compiler failed"
28 if use tads3compiler; then
29 mv t3compiler/* "${S}"/t3compiler || die "mv t3compiler failed"
33 src_configure() {
34 append-cxxflags -fno-strict-aliasing
35 egamesconf $(use_enable debug t3debug) || die "egamesconf failed"
38 src_test() {
39 if use debug; then
40 emake -j1 check || die "TADS 3 compiler test suite failed"
43 emake -j1 sample || die "Failed to build test game"
44 ./frob -i plain -p samples/sample.t3 <<- END_FROB_TEST
45 save
46 testsave.sav
47 restore
48 testsave.sav
49 END_FROB_TEST
50 [[ $? -eq 0 ]] || die "Failed to run test game"
53 src_install() {
54 emake DESTDIR="${D}" install || die "emake install failed"
55 dodoc doc/{AUTHORS,BUGS,ChangeLog.old,NEWS,README,SRC_GUIDELINES,THANKS}
56 prepgamesdirs