Add Hugor 0.8
[gentoo-interactive-fiction.git] / games-engines / hugor / hugor-0.8.ebuild
blobbc9d674fe213312379c0dc6250de4b5c3dfdb0e7
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI=3
6 inherit toolchain-funcs eutils fdo-mime games
8 DESCRIPTION="Multimedia interpreter for Hugo text adventures"
9 HOMEPAGE="http://ifwiki.org/index.php/Hugor"
10 SRC_URI="http://foss.aegean.gr/~realnc/hugor/${P}-linux.tar.bz2"
12 LICENSE="freedist"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15 IUSE=""
17 DEPEND="x11-libs/qt-gui:4
18 media-libs/libsdl[audio]
19 x11-misc/shared-mime-info"
21 QA_DT_HASH="usr/games/bin/hugor"
22 QA_PRESTRIPPED="${QA_DT_HASH}"
24 src_install() {
25 if [[ "$(tc-arch)" == "amd64" ]]; then
26 dogamesbin "64-bit/hugor"
27 elif [[ "$(tc-arch)" == "x86" ]]; then
28 dogamesbin "32-bit/hugor"
29 else
30 die "Only x86 and amd64 systems are supported."
32 dodoc README README.linux-bin
33 doicon "${FILESDIR}/hugor.png"
34 make_desktop_entry hugor Hugor "hugor" Game "GenericName=Hugo Multimedia Interpreter\nMimeType=application/x-hugo-image;"
35 insinto /usr/share/icons
36 doins -r "${FILESDIR}/hicolor"
37 insinto /usr/share/mime/packages
38 doins "${FILESDIR}/hugor.xml"
39 prepgamesdirs
42 pkg_postinst() {
43 fdo-mime_desktop_database_update
44 fdo-mime_mime_database_update