Patch non-Gargoyle Glk implementations to support some more functions
[gentoo-interactive-fiction.git] / dev-games / glk-headers / glk-headers-0.7.0-r1.ebuild
blobee3ea387e2e8a854b0f883450d3a3910c879f110
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit eutils
7 DESCRIPTION="Headers for the Glk API"
8 HOMEPAGE="http://www.eblong.com/zarf/glk/"
9 SRC_URI="" # no versioned download as far as I know, so in ${FILESDIR}
11 LICENSE="Zarf"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
16 DEPEND="!=dev-games/glkloader-0.3.2"
17 RDEPEND="${DEPEND}"
19 src_unpack() {
20 mkdir "${S}"
21 cd "${S}" || die "cd failed"
22 cp "${FILESDIR}"/${PV}/*.h . || die "cp failed"
24 epatch "${FILESDIR}"/glk-headers-0.7.0-64bit.patch
25 epatch "${FILESDIR}"/glk-headers-0.7.0-gtkglk-extensions.patch
26 epatch "${FILESDIR}"/glk-headers-0.7.0-garglk-extensions-20081225.patch
29 src_install() {
30 insinto /usr/include/glk
31 doins *.h || die "doins failed"