Use autotools eclass, remove automake from DEPEND and drop EGIT_BRANCH.
[gentoo-interactive-fiction.git] / dev-games / gnome-inform7 / gnome-inform7-7.5u_p92_p1.ebuild
blob004c92a9b5d5e18086612988b22a1addc31570ea
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI=1
7 inherit eutils versionator autotools gnome2-utils
9 MY_MAJOR=$(get_version_component_range 2)
10 MY_LETTER=$(get_version_component_range 3)
11 MY_MINOR=$(get_version_component_range 4)
12 MY_PATCH=$(get_version_component_range 5)
14 MY_LOWERS=abcdefghijklmnopqrstuvwxyz
15 MY_UPPERS=ABCDEFGHIJKLMNOPQRSTUVWXYZ
16 MY_INDEX=${MY_LOWERS%${MY_LETTER}*}
17 MY_UPPER=${MY_UPPERS:${#MY_INDEX}:1}
19 MY_PV=${MY_MAJOR}${MY_UPPER}${MY_MINOR#p}${MY_PATCH:+.${MY_PATCH#p}}
20 DESCRIPTION="GNOME user interface for Inform 7"
21 HOMEPAGE="http://inform7.com/ http://sourceforge.net/projects/gnome-inform7/"
22 SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.tar.gz"
24 LICENSE="GPL-2 LICENSE-BITSTREAM font-bh-ttf"
25 SLOT="0"
26 KEYWORDS="~amd64 ~x86"
27 IUSE="linguas_es" # optional nls seems broken
29 RESTRICT="test" # intltool silliness
31 DEPEND="=app-text/gtkspell-2*
32 dev-libs/dbus-glib
33 >=gnome-base/libgnomeui-2
34 gnome-extra/gtkhtml:3.14
35 media-libs/freetype:2
36 media-libs/jpeg
37 media-libs/libpng
38 media-libs/libsdl
39 media-libs/sdl-mixer
40 media-libs/sdl-sound
41 || ( sys-libs/e2fsprogs-libs <sys-fs/e2fsprogs-1.41.0 )
42 virtual/libintl
43 >=x11-libs/gtk+-2.8:2
44 x11-libs/gtksourceview:2.0"
45 RDEPEND="${DEPEND}
46 ~dev-lang/inform-${PV%${MY_PATCH:+_${MY_PATCH}}}
47 games-engines/glkfrotz
48 games-engines/glulxe"
49 DEPEND="${DEPEND}
50 dev-games/glk-headers
51 >=dev-util/intltool-0.35.0
52 dev-util/pkgconfig
53 sys-devel/gettext"
55 S=${WORKDIR}/${PN}-${MY_PV}
57 src_unpack() {
58 unpack ${A}
59 cd "${S}"
61 epatch "${FILESDIR}"/gnome-inform7-5U92.1-unbundling.patch
62 epatch "${FILESDIR}"/gnome-inform7-5J39-no-ossp-uuid.patch
64 eautoreconf
66 rm src/gtkterp/garglk/{glk,gi_blorb,gi_dispa,glkstart}.h || die "rm glk headers failed"
69 src_compile() {
70 # Don't build libgtkerp-garglk.a: the library is useless except
71 # when running under the IDE, and the IDE uses the glkfrotz and
72 # glulxe binaries linked against glkloader.
73 econf --disable-static || die "econf failed"
74 emake || die "emake failed"
77 src_install() {
78 emake DESTDIR="${D}" GCONFTOOL=true install || die "emake install failed"
79 dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die "dodoc failed"
80 dodoc src/gtkterp/{CharterBT.txt,TODO-garglk} || die "dodoc gtkterp failed"
82 cd "${D}"/usr/share
83 mv gnome-inform7/Documentation doc/${PF}/html || die "mv Documentation failed"
84 dosym /usr/share/doc/${PF}/html /usr/share/gnome-inform7/Documentation || die "dosym Documentation failed"
86 dosym /usr/{libexec,share/gnome-inform7/Compilers}/cBlorb || die "dosym cBlorb failed"
87 dosym /usr/{libexec,share/gnome-inform7/Compilers}/inform-6.31-biplatform || die "dosym inform-6.31-biplatform failed"
88 dosym /usr/{libexec,share/gnome-inform7/Compilers}/ni || die "dosym ni failed"
90 dosym /usr/share/{,gnome-}inform7/Inform7 || die "dosym Inform7 failed"
91 dosym /usr/share/{,gnome-}inform7/Library || die "dosym Library failed"
94 pkg_preinst() {
95 gnome2_gconf_savelist
98 pkg_postinst() {
99 gnome2_gconf_install
102 #pkg_prerm() {
103 # gnome2_gconf_uninstall