Debian package: Remove obsolete build-time modification of application.js
[conkeror.git] / debian / rules
blob0c6219130f967278324130db597503c548ec5b6b
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Uncomment this to turn on verbose mode.
4 #export DH_VERBOSE=1
6 # Generating a xulrunner build id and other strings
7 DEBIAN_VERSION := $(shell echo -n `head -1 debian/changelog | sed -e 's/^.*(\(.*\)).*$$/\\1/'`)
8 DATE := $(shell dpkg-parsechangelog | awk -F ': ' '$$1=="Date" {print $$2}')
9 BUILDID := debian@$(DEBIAN_VERSION)_$(shell date -d "$(DATE)" +%s)
10 USC = $(CURDIR)/debian/conkeror/usr/share/conkeror
13 dh $@
15 override_dh_install-indep:
16 dh_install -i
18 # Add generated Build ID and Debian version to version output
19 sed -e 's/BuildID=git/BuildID=${BUILDID}/;s/^Version=\(.*\)$$/Version=\1 (Debian-${DEBIAN_VERSION})/' \
20 -i $(USC)/application.ini