Debian package: Consistently use "$(MAKE)" instead of "make"
[conkeror.git] / debian / patches / sensible-editor.diff
blob94278dc66eb88fd523009d30938d917e70cc6c28
1 Let Debian's sensible-editor guess the editor.
2 Index: conkeror/modules/external-editor.js
3 ===================================================================
4 --- conkeror.orig/modules/external-editor.js 2012-01-31 18:28:37.000000000 +0100
5 +++ conkeror/modules/external-editor.js 2012-01-31 18:35:45.000000000 +0100
6 @@ -5,7 +5,7 @@
7 * COPYING file.
8 **/
10 -define_variable("editor_shell_command", getenv("VISUAL") || getenv("EDITOR") || "emacs",
11 +define_variable("editor_shell_command", "/usr/bin/sensible-editor",
12 "Shell command used to invoke an external editor.\n" +
13 "This defaults to the value of the EDITOR environment variable. If " +
14 "`run_external_editor_function' is non-null, it is used instead to " +