Fix compilation with wxWidgets 2.8.12
[amule.git] / debian / rules
blobe81c5b7a96e982f02d52d4ad09c5e3ee56853f34
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # This file was originally written by Vollstrecker
5 # Uncomment this to turn on verbose mode.
6 export DH_VERBOSE=1
7 export DEB_BUILD_OPTIONS_PARALLEL=3
9 # These are used for cross-compiling and for saving the configure script
10 # from having to guess our platform (since we know it already)
11 DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
13 #Here are the packages that can't be compiled separate now
14 general_pkgs = "amule-common"\
15 "amule-skin-gnome"\
16 "amule-skin-kde4"\
17 "amule-skin-mac-gray"\
18 "amule-skin-priscilla"\
19 "amule-skin-tango"\
20 "amule-skin-xfce"
22 # First, get the targets from commandline
23 flags = ${MAKECMDGOALS}
25 #First we have to find out, if we are called from dpkg-buildpackage
27 ifeq ("binary", "$(findstring binary, $(flags))")
29 PLASMAMULE = --enable-plasmamule
30 WXCAS = --enable-wxcas
31 XAS = --enable-xas
32 CAS = --enable-cas
33 WEBSERVER = --enable-webserver
34 REMOTEGUI = --enable-amule-gui
35 DAEMON = --enable-amule-daemon
36 ALCC = --enable-alcc
37 ALC = --enable-alc
38 AMULECMD = --enable-amulecmd
39 DEBUGGING = --enable-debug --disable-optimize --disable-profile
40 LANGFLAG = --with-language=all
42 else ifeq ("build", "$(findstring build, $(flags))")
44 PLASMAMULE = --enable-plasmamule
45 WXCAS = --enable-wxcas
46 XAS = --enable-xas
47 CAS = --enable-cas
48 WEBSERVER = --enable-webserver
49 REMOTEGUI = --enable-amule-gui
50 DAEMON = --enable-amule-daemon
51 ALCC = --enable-alcc
52 ALC = --enable-alc
53 AMULECMD = --enable-amulecmd
54 DEBUGGING = --enable-debug --disable-optimize --disable-profile
55 LANGFLAG = --with-language=all
57 else
58 #Now we have to check what packages are build to configure only them
60 #We have to filter the right targets (wo_ means without)
61 wo_wxcas = $(subst wxcas,, ${flags})
62 wo_alcc = $(subst alcc,, ${flags})
63 wo_amule_utils_gui = $(subst amule-utils-gui,,${flags})
64 wo_all_other_amules = $(subst amulecmd,,$(subst amule-utils-gui,,$(subst amule-utils,,${flags})))
65 LANGUAGE := en_GB
67 ifeq ("plasmamule", "$(findstring plasmamule, $(flags))")
68 PLASMAMULE = --enable-plasmamule
69 endif
71 ifeq ("wxcas", "$(findstring wxcas, $(flags))")
72 WXCAS = --enable-wxcas
73 endif
75 ifeq ("cas", "$(findstring cas, $(wo_wxcas))")
76 CAS = --enable-cas
77 endif
79 ifeq ("webserver", "$(findstring webserver, $(flags))")
80 WEBSERVER = --enable-webserver
81 endif
83 ifeq ("remotegui", "$(findstring remotegui, $(flags))")
84 REMOTEGUI = --enable-amule-gui
85 endif
87 ifeq ("daemon", "$(findstring daemon, $(flags))")
88 DAEMON = --enable-amule-daemon
89 endif
91 ifeq ("alcc", "$(findstring alcc, $(flags))")
92 ALCC = --enable-alcc
93 endif
95 ifeq ("alc", "$(findstring alc, $(wo_alcc))")
96 ALC = --enable-alc
97 endif
99 ifeq ("amulecmd", "$(findstring amulecmd, $(flags))")
100 AMULECMD = --enable-amulecmd
101 endif
103 ifneq ("amule", "$(findstring amule, $(wo_all_other_amules))")
104 AMULE = --disable-monolithic
105 endif
107 ifneq ("ed2k", "$(findstring ed2k, $(flags))")
108 ED2K = --disable-ed2k
109 endif
111 ifeq ("xas", "$(findstring xas, $(flags))")
112 XAS = --enable-xas
113 endif
115 #Now find out if a Metapackage should be build
116 ifeq ("amule-utils-gui", "$(findstring amule-utils-gui, $(flags))")
117 ALC = --enable-alc
118 REMOTEGUI = --enable-amule-gui
119 WXCAS = --enable-wxcas
120 endif
122 ifeq ("amule-utils", "$(findstring amule-utils, $(wo_amule_utils_gui))")
123 ALCC = --enable-alcc
124 AMULECMD = --enable-amulecmd
125 CAS = --enable-cas
126 endif
128 #Find this whole i18n stuff
129 ifneq ("i18n-en-only", "$(findstring i18n-en-only, $(flags))")
131 ifeq ("i18n-ar", "$(findstring i18n-ar, $(flags))")
132 LANGUAGE := $(LANGUAGE),ar
133 endif
135 ifeq ("i18n-ast", "$(findstring i18n-ast, $(flags))")
136 LANGUAGE := $(LANGUAGE),ast
137 endif
139 ifeq ("i18n-bg", "$(findstring i18n-bg, $(flags))")
140 LANGUAGE := $(LANGUAGE),bg
141 endif
143 ifeq ("i18n-ca", "$(findstring i18n-ca, $(flags))")
144 LANGUAGE := $(LANGUAGE),ca
145 endif
147 ifeq ("i18n-cs", "$(findstring i18n-cs, $(flags))")
148 LANGUAGE := $(LANGUAGE),cs
149 endif
151 ifeq ("i18n-da", "$(findstring i18n-da, $(flags))")
152 LANGUAGE := $(LANGUAGE),da
153 endif
155 ifeq ("i18n-de", "$(findstring i18n-de, $(flags))")
156 LANGUAGE := $(LANGUAGE),de
157 endif
159 ifeq ("i18n-el", "$(findstring i18n-el, $(flags))")
160 LANGUAGE := $(LANGUAGE),el
161 endif
163 ifeq ("i18n-es", "$(findstring i18n-es, $(flags))")
164 LANGUAGE := $(LANGUAGE),es
165 endif
167 ifeq ("i18n-et-ee", "$(findstring i18n-et-ee, $(flags))")
168 LANGUAGE := $(LANGUAGE),et_EE
169 endif
171 ifeq ("i18n-eu", "$(findstring i18n-eu, $(flags))")
172 LANGUAGE := $(LANGUAGE),eu
173 endif
175 ifeq ("i18n-fi", "$(findstring i18n-fi, $(flags))")
176 LANGUAGE := $(LANGUAGE),fi
177 endif
179 ifeq ("i18n-fr", "$(findstring i18n-fr, $(flags))")
180 LANGUAGE := $(LANGUAGE),fr
181 endif
183 ifeq ("i18n-gl", "$(findstring i18n-gl, $(flags))")
184 LANGUAGE := $(LANGUAGE),gl
185 endif
187 ifeq ("i18n-he", "$(findstring i18n-he, $(flags))")
188 LANGUAGE := $(LANGUAGE),he
189 endif
191 ifeq ("i18n-hr", "$(findstring i18n-hr, $(flags))")
192 LANGUAGE := $(LANGUAGE),hr
193 endif
195 ifeq ("i18n-hu", "$(findstring i18n-hu, $(flags))")
196 LANGUAGE := $(LANGUAGE),hu
197 endif
199 ifeq ("i18n-it", "$(findstring i18n-it, $(flags))")
200 LANGUAGE := $(LANGUAGE),it
201 endif
203 ifeq ("i18n-it-ch", "$(findstring i18n-it-ch, $(flags))")
204 LANGUAGE := $(LANGUAGE),it_CH
205 endif
207 ifeq ("i18n-ja", "$(findstring i18n-ja, $(flags))")
208 LANGUAGE := $(LANGUAGE),ja
209 endif
211 ifeq ("i18n-ko-kr", "$(findstring i18n-ko-kr, $(flags))")
212 LANGUAGE := $(LANGUAGE),ko_KR
213 endif
215 ifeq ("i18n-lt", "$(findstring i18n-lt, $(flags))")
216 LANGUAGE := $(LANGUAGE),lt
217 endif
219 ifeq ("i18n-nl", "$(findstring i18n-nl, $(flags))")
220 LANGUAGE := $(LANGUAGE),hl
221 endif
223 ifeq ("i18n-nn", "$(findstring i18n-nn, $(flags))")
224 LANGUAGE := $(LANGUAGE),nn
225 endif
227 ifeq ("i18n-pl", "$(findstring i18n-pl, $(flags))")
228 LANGUAGE := $(LANGUAGE),pl
229 endif
231 ifeq ("i18n-pt-br", "$(findstring i18n-pt-br, $(flags))")
232 LANGUAGE := $(LANGUAGE),pt_BR
233 endif
235 ifeq ("i18n-pt-pt", "$(findstring i18n-pt-pt, $(flags))")
236 LANGUAGE := $(LANGUAGE),pt_PT
237 endif
239 ifeq ("i18n-ru", "$(findstring i18n-ru, $(flags))")
240 LANGUAGE := $(LANGUAGE),ru
241 endif
243 ifeq ("i18n-sl", "$(findstring i18n-sl, $(flags))")
244 LANGUAGE := $(LANGUAGE),sl
245 endif
247 ifeq ("i18n-sq", "$(findstring i18n-sq, $(flags))")
248 LANGUAGE := $(LANGUAGE),sq
249 endif
251 ifeq ("i18n-sv", "$(findstring i18n-sv, $(flags))")
252 LANGUAGE := $(LANGUAGE),sv
253 endif
255 ifeq ("i18n-tr", "$(findstring i18n-tr, $(flags))")
256 LANGUAGE := $(LANGUAGE),tr
257 endif
259 ifeq ("i18n-uk", "$(findstring i18n-uk, $(flags))")
260 LANGUAGE := $(LANGUAGE),uk
261 endif
263 ifeq ("i18n-zh-cn", "$(findstring i18n-zh-cn, $(flags))")
264 LANGUAGE := $(LANGUAGE),zh_CN
265 endif
267 ifeq ("i18n-zh-tw", "$(findstring i18n-zh-tw, $(flags))")
268 LANGUAGE := $(LANGUAGE),zh_TW
269 endif
271 ifeq ($(LANGUAGE),en_GB)
272 LANGUAGE = all
273 endif
275 endif
277 LANGFLAG = --with-language=$(LANGUAGE)
279 #And at Last, find out if we compile a debug-package or not.
280 ifeq ("dbg", "$(findstring dbg, $(flags))")
281 DEBUGGING = --enable-debug --disable-optimize --disable-profile
282 else
283 DEBUGGING = --disable-debug --enable-optimize --disable-profile
284 endif
285 endif
287 #Before we start, I want to introduce two sequences for building the packages
288 #I define two, so I can put the commands for the *-dbg packages between them
289 define stage1
290 dh_testdir -p$(subst -stage1,,$@)
291 dh_testroot -p$(subst -stage1,,$@)
292 dh_installdirs -p$(subst -stage1,,$@)
293 dh_installchangelogs docs/Changelog -p$(subst -stage1,,$@)
294 dh_installdocs -p$(subst -stage1,,$@)
295 dh_install -Xlicense.txt -p$(subst -stage1,,$@)
296 dh_installmenu -p$(subst -stage1,,$@)
297 dh_installdebconf -p$(subst -stage1,,$@)
298 dh_installman -p$(subst -stage1,,$@)
299 dh_installmime -p$(subst -stage1,,$@)
300 dh_link -p$(subst -stage1,,$@)
301 dh_lintian -p$(subst -stage1,,$@)
302 touch $@
303 endef
305 define strip-stage
306 dh_strip -p$(subst -dbg,,$@) --dbg-package=$@
307 endef
309 define stage2
310 dh_compress -X.pl -p$(subst -stage2,,$@)
311 dh_perl -p$(subst -stage2,,$@)
312 dh_makeshlibs -p$(subst -stage2,,$@)
313 dh_installdeb -p$(subst -stage2,,$@)
314 dh_shlibdeps -p$(subst -stage2,,$@)
315 dh_gencontrol -p$(subst -stage2,,$@)
316 dh_md5sums -p$(subst -stage2,,$@)
317 dh_fixperms -p$(subst -stage2,,$@)
318 dh_builddeb -p$(subst -stage2,,$@)
319 touch $@
320 endef
322 #Now we configure this whole thing
323 config.status: configure
324 dh_testdir
325 CFLAGS="$(CFLAGS)" dh_auto_configure -- --host=$(DEB_HOST_GNU_TYPE)\
326 LDFLAGS="-Wl,--as-needed ${LDFLAGS}"\
327 --enable-ccache\
328 --enable-geoip\
329 ${PLASMAMULE}\
330 ${AMULECMD}\
331 ${DEBUGGING}\
332 ${WEBSERVER}\
333 ${CAS}\
334 ${WXCAS}\
335 ${ALC}\
336 ${ALCC}\
337 ${REMOTEGUI}\
338 ${DAEMON}\
339 ${AMULE}\
340 ${ED2K}\
341 $(LANGFLAG)\
342 $(XAS)
344 #And here is the well known clean target
345 clean:
346 dh_testdir
347 dh_testroot
348 dh_clean
349 dh_auto_clean
350 dh_prep
352 #Some generic targets to check the build process
353 build: build-stamp
355 build-stamp: config.status
356 dh_testdir
358 dh_auto_build
360 touch build-stamp
362 #Now we install the packages all together to the tmp-dir inside of debian/
363 install: build
364 dh_testdir
365 dh_testroot
367 dh_auto_install
369 #Now first build the packages that are compiled and installed on every build
370 amule-common: install
372 for pkg in $(general_pkgs); do \
373 dh_testdir -p$$pkg; \
374 dh_testroot -p$$pkg; \
375 dh_installdirs -p$$pkg; \
376 dh_installchangelogs docs/Changelog -p$$pkg; \
377 dh_installdocs -p$$pkg; \
378 dh_install -Xlicense.txt -p$$pkg; \
379 dh_installmenu -p$$pkg; \
380 dh_installdebconf -p$$pkg; \
381 dh_installman -p$$pkg; \
382 dh_link -p$$pkg; \
383 dh_lintian -p$$pkg; \
384 dh_compress -X.pl -p$$pkg; \
385 dh_perl -p$$pkg; \
386 dh_makeshlibs -p$$pkg; \
387 dh_installdeb -p$$pkg; \
388 dh_shlibdeps -p$$pkg; \
389 dh_gencontrol -p$$pkg; \
390 dh_md5sums -p$$pkg; \
391 dh_fixperms -p$$pkg; \
392 dh_builddeb -p$$pkg; \
393 done
394 touch amule-common
396 %-stage1: amule-common
397 ${stage1}
399 %-stage2: %-stage1
400 ${stage2}
402 amule-%-dbg: amule-%-stage1
403 ${stage1}
404 $(strip-stage)
405 ${stage2}
407 amule-dbg: amule-stage1
408 ${stage1}
409 $(strip-stage)
410 ${stage2}
412 amuleweb-dbg: amuleweb-stage1
413 ${stage1}
414 $(strip-stage)
415 ${stage2}
417 #Now just the targets to map the Commandline Name to the package names
418 amule: amule-stage2
419 touch @
421 ed2k: amule-ed2k-stage2
422 touch @
424 cas: amule-cas-stage2
425 touch @
427 wxcas: amule-wxcas-stage2
428 touch @
430 webserver: amuleweb-stage2 amule-theme-default-stage2
431 touch @
433 remotegui: amule-remote-gui-stage2
434 touch @
436 daemon: amule-daemon-stage2
437 touch @
439 alc: amule-alc-stage2
440 touch @
442 alcc: amule-alcc-stage2
443 touch @
445 amulecmd: amule-cmd-stage2
446 touch @
448 xas: amule-xas-stage2
449 touch @
451 ed2k-dbg: amule-ed2k-dbg
452 touch @
454 cas-dbg: amule-cas-dbg
455 touch @
457 wxcas-dbg: amule-wxcas-dbg
458 touch @
460 webserver-dbg: amuleweb-dbg
461 touch @
463 remotegui-dbg: amule-remote-gui-dbg
464 touch @
466 daemon-dbg: amule-daemon-dbg
467 touch @
469 alc-dbg: amule-alc-dbg
470 touch @
472 alcc-dbg: amule-alcc-dbg
473 touch @
475 amulecmd-dbg: amule-cmd-dbg
476 touch @
478 plasmamule: amule-plasmamule-stage2
479 touch @
481 plasmamule-dbg: amule-plasmamule-dbg
482 touch @
484 #Here come the Targets for the langauge packages
485 i18n-%: amule-i18n-% ;
487 amule-i18n-%: amule-common
488 ${stage1}
489 ${stage2}
491 #They are just metapackages
492 amule-utils: alcc amulecmd cas
493 ${stage1}
494 ${stage2}
496 amule-utils-gui: alc remotegui wxcas
497 ${stage1}
498 ${stage2}
500 #These are empty (Space after Semicolon)
501 debug-packages: amule-dbg ed2k-dbg cas-dbg wxcas-dbg webserver-dbg remotegui-dbg daemon-dbg alc-dbg alcc-dbg amulecmd-dbg plasmamule-dbg;
502 normal-packages: amule-utils amule-utils-gui amule ed2k webserver daemon xas plasmamule ;
503 language-packages: i18n-ar i18n-ast i18n-bg i18n-ca i18n-cs i18n-da i18n-de i18n-el i18n-en-gb i18n-es i18n-et-ee i18n-eu i18n-fi i18n-fr i18n-gl i18n-he i18n-hr i18n-hu i18n-it-ch i18n-it i18n-ja i18n-ko-kr i18n-lt i18n-nn i18n-nl i18n-pl i18n-pt-br i18n-pt-pt i18n-ru i18n-sl i18n-sq i18n-sv i18n-tr i18n-uk i18n-zh-cn i18n-zh-tw ;
504 i18n-en-only: ;
506 #If we build from a svn checkout, we need to generate configure
507 configure:
508 ./autogen.sh
510 #Now the targets for dpkg-buildpackage
511 binary-indep: build install
513 binary-arch: debug-packages normal-packages language-packages
515 binary: binary-indep binary-arch
517 help:
518 cat README.Debian-Packages
520 .DEFAULT_GOAL = help
521 .PHONY: build clean binary-indep binary-arch binary install debug-packages normal-packages i18n-only language-packages