Fix compilation with wxWidgets 2.8.12
[amule.git] / aMule-CVS.spec
blob1dea1fc0eae647d89fec32b2dcbb3101eb32b86e
1 %define svndate %(date +%Y%m%d)
2 %define optflags %{nil}
4 Summary: aMule - another eMule p2p client
5 Name: aMule
6 Version: SVN
7 Release: %{svndate}
8 License: GPL
9 Group: Applications/Internet
10 Packager: The aMule Team (http://forum.amule.org/)
11 Vendor: The aMule Project
12 URL: http://www.amule.org/
13 Source: %{name}-%{version}-%{release}.tar.bz2
14 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
16 %description
17 aMule is a peer to peer file sharing client, based on the well known eMule.
18 Starting with 2.0.0 aMule works on Linux, Mac, *BSD and Windows, which makes it
19 the first multi-platform edonkey network client.
21 %pre
22 echo "****************************************************************************"
23 echo "Warning: This is a svn release!"
24 echo "This release is made for testing purpose and it may cause several problems,"
25 echo "burn your house, kill your dog, etc, but it *should* be safe to use anyway."
26 echo "If you would like to test some of the great new features go on and install."
27 echo "Otherwise you may press ctrl-c within the next 10 seconds to abort the"
28 echo "installation."
29 echo -n "Waiting for user... "
30 for i in $(seq 10 -1 1); do
31 echo -n "$i, "
32 sleep 1
33 done
34 echo " 0, ok, here we go then... Muhahaha :), installing."
36 %prep
37 %setup -q -n amule-cvs
39 %build
40 %configure \
41 --disable-optimize \
42 --enable-debug \
43 --enable-cas \
44 --enable-wxcas \
45 --enable-amulecmd \
46 --enable-webserver \
47 --enable-ccache
48 %{__make} %{?_smp_mflags}
50 %install
51 [ ! "$RPM_BUILD_ROOT" = "/" ] && %{__rm} -rf "$RPM_BUILD_ROOT"
52 %{__make} DESTDIR="$RPM_BUILD_ROOT" install
53 %find_lang amule
55 %clean
56 [ ! "$RPM_BUILD_ROOT" = "/" ] && %{__rm} -rf "$RPM_BUILD_ROOT"
58 %files -f amule.lang
59 %defattr(-,root,root,-)
60 %{_bindir}/amule
61 %{_bindir}/ed2k
62 %{_bindir}/amulecmd
63 %{_bindir}/cas
64 %{_bindir}/wxcas
65 %{_bindir}/amuleweb
66 %{_bindir}/autostart-xas
67 %{_libdir}/xchat/plugins/xas.pl
68 %{_datadir}/applications/*
69 %{_datadir}/pixmaps/*
70 %{_mandir}/man1/*
71 %{_mandir}/*/man1/*
72 %docdir %{_datadir}/doc/*
73 %{_datadir}/doc/*
74 %{_datadir}/cas
75 %{_datadir}/amule
77 %changelog
78 * Sun Dec 25 2005 Gerd78 <aMule forum>
79 - Really disable optimizations by defining optflags to nil.
81 * Mon Apr 19 2005 Marcelo Jimenez <phoenix@amule.org>
82 - Removed curl dependency, aMule now uses wxHTTP.
84 * Mon Mar 26 2005 Marcelo Jimenez <phoenix@amule.org>
85 - Added a distro test, so we know the distro.
86 - Tests for UTF-8 enabled LANG to use UTF-8 systray.
88 * Mon Mar 21 2005 Marcelo Jimenez <phoenix@amule.org>
89 - Removed krb5-libs require and krb5-devel buildprereq. curl-lib and
90 curl-devel is enough.
92 * Tue Mar 08 2005 Marcelo Jimenez <phoenix@amule.org>
93 - Made it work with cvs snapshots at their very same day.
95 * Wed Jun 16 2004 Ariano Bertacca <ariano@hirnriss.net>
96 - added tool package.
98 * Sat May 22 2004 Ariano Bertacca <ariano@hirnriss.net>
99 - added webserver package.
101 * Sun Mar 28 2004 Ariano Bertacca <ariano@hirnriss.net>
102 - added libcryptopp to dependencies/BuildPreReq
103 - getting wx-config and wxbase-config from installed rpm to avoid problems
104 with people using wxGTK-2.5.
105 Idea taken from aMule-2.0.0rc1.spec done by
106 deltaHF <deltahf@users.sourceforge.net> and
107 pure_ascii <pure_ascii@users.sourceforge.net>
109 * Tue Feb 10 2004 Ariano Bertacca <ariano@hirnriss.net>
110 - modified the BuildPreReq to satisfy amulecmd build requirements.
112 * Sat Jan 23 2004 Ariano Bertacca <ariano@hirnriss.net>
113 - initial amule.spec release