logrotate PKGBUILD updated
[Archlinux-Stable.git] / PKGBUILD.proto
blobfd3d63ecdffa0a9f97a778d6fa8712c3f0400130
1 # This is an example PKGBUILD file. Use this as a start to creating your own,
2 # and remove these comments. For more information, see 'man PKGBUILD'.
3 # NOTE: Please fill out the license field for your package! If it is unknown,
4 # then please put 'unknown'.
6 # Contributor: Your Name <youremail@domain.com>
7 pkgname=NAME
8 pkgver=VERSION
9 pkgrel=1
10 pkgdesc=""
11 arch=()
12 url=""
13 license=('GPL')
14 groups=()
15 depends=()
16 makedepends=()
17 provides=()
18 conflicts=()
19 replaces=()
20 backup=()
21 options=()
22 install=
23 source=(${pkgname}-${pkgver}.tar.gz)
24 noextract=()
25 md5sums=() #generate with 'makepkg -g'
27 prebuild() {
28   cd "${startdir}/src/${pkgname}-${pkgver}"
30   patch -Np0 -i ../one.patch || return 1
31   patch -Np0 -i ../two.patch || return 1
34 build() {
35   prebuild
36   ./configure --prefix=/usr
37   make || return 1
38   make DESTDIR="${startdir}/pkg" install