Removed 'sources' from model.Interface. It is covered by metadata now.
[zeroinstall.git] / debian / rules
blob7aef4a7ebdb53117de069ddc9182013b9de9db8d
1 #!/usr/bin/make -f
3 # Uncomment this to turn on verbose mode.
4 #export DH_VERBOSE=1
6 configure:
7 dh_testdir
9 build:
10 dh_testdir
11 python setup.py build
13 clean:
14 dh_testdir
15 dh_testroot
16 rm -f build-stamp configure-stamp
17 python setup.py clean
18 dh_clean
20 install: build
21 dh_testdir
22 dh_testroot
23 dh_clean -k
24 dh_installdirs
25 python setup.py install --root=$(CURDIR)/debian/zeroinstall-injector
26 rm -r $(CURDIR)/debian/zeroinstall-injector/usr/man
28 # Build architecture-independent files here.
29 binary-indep: build install
30 dh_testdir
31 dh_testroot
32 dh_installchangelogs
33 dh_installdocs
34 dh_installman 0launch.1 0alias.1 0store.1
35 dh_compress
36 dh_fixperms
37 dh_python
38 dh_installdeb
39 dh_gencontrol
40 dh_md5sums
41 dh_builddeb
43 # Build architecture-dependent files here.
44 binary-arch: build install
45 # We have nothing to do by default.
47 binary: binary-indep binary-arch
48 .PHONY: build clean binary-indep binary-arch binary install configure