Make mv's use signed chars explicitly.
[xiph/unicode.git] / cdparanoia / cdparanoia.spec
blob77ddc9b9216034ced658d205292233764d064ac0
1 %define ver 9.8
2 %define realver alpha%{ver}
4 Name: cdparanoia
5 Version: %{realver}
6 Release: 22
7 License: GPL
8 Group: Applications/Multimedia
9 Source: http://www.xiph.org/paranoia/download/%{name}-III-%{realver}.src.tgz
10 Url: http://www.xiph.org/paranoia/index.html
11 BuildRoot: %{_tmppath}/cdparanoia-%{version}-root
12 Requires: cdparanoia-libs = %{version}-%{release}
13 Obsoletes: cdparanoia-III
14 Summary: A Compact Disc Digital Audio (CDDA) extraction tool (or ripper).
16 %description
17 Cdparanoia (Paranoia III) reads digital audio directly from a CD, then
18 writes the data to a file or pipe in WAV, AIFC or raw 16 bit linear
19 PCM format. Cdparanoia doesn't contain any extra features (like the ones
20 included in the cdda2wav sampling utility). Instead, cdparanoia's strength
21 lies in its ability to handle a variety of hardware, including inexpensive
22 drives prone to misalignment, frame jitter and loss of streaming during
23 atomic reads. Cdparanoia is also good at reading and repairing data from
24 damaged CDs.
26 %package -n cdparanoia-devel
27 Summary: Development tools for libcdda_paranoia (Paranoia III).
28 Group: Development/Libraries
29 Requires: cdparanoia-libs = %{version}-%{release}
31 %description -n cdparanoia-devel
32 The cdparanoia-devel package contains the static libraries and header
33 files needed for developing applications to read CD Digital Audio disks.
35 %package -n cdparanoia-libs
36 Summary: Libraries for libcdda_paranoia (Paranoia III).
37 Group: Development/Libraries
39 %description -n cdparanoia-libs
40 The cdparanoia-libs package contains the dynamic libraries needed for
41 applications which read CD Digital Audio disks.
43 %prep
44 %setup -q -n %{name}-III-%{realver}
46 %build
47 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
48 export OPT="${CFLAGS:-%optflags}"
49 %configure --includedir=%{_includedir}/cdda
50 make OPT="$OPT"
52 %install
53 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT%{_bindir}
56 install -d $RPM_BUILD_ROOT%{_includedir}/cdda
57 install -d $RPM_BUILD_ROOT%{_libdir}
58 install -d $RPM_BUILD_ROOT%{_mandir}/man1
59 install -m 0755 cdparanoia $RPM_BUILD_ROOT%{_bindir}
60 install -m 0644 cdparanoia.1 $RPM_BUILD_ROOT%{_mandir}/man1/
61 install -m 0644 utils.h paranoia/cdda_paranoia.h interface/cdda_interface.h \
62 $RPM_BUILD_ROOT%{_includedir}/cdda
63 install -m 0755 paranoia/libcdda_paranoia.so.0.%{ver} \
64 interface/libcdda_interface.so.0.%{ver} \
65 $RPM_BUILD_ROOT%{_libdir}
66 install -m 0755 paranoia/libcdda_paranoia.a interface/libcdda_interface.a \
67 $RPM_BUILD_ROOT%{_libdir}
69 /sbin/ldconfig -n $RPM_BUILD_ROOT/%{_libdir}
71 pushd $RPM_BUILD_ROOT%{_libdir}
72 ln -s libcdda_paranoia.so.0.%{ver} libcdda_paranoia.so
73 ln -s libcdda_interface.so.0.%{ver} libcdda_interface.so
74 popd
76 %post -n cdparanoia-libs
77 /sbin/ldconfig
79 %postun -n cdparanoia-libs
80 if [ "$1" -ge "1" ]; then
81 /sbin/ldconfig
84 %clean
85 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
87 %files -n cdparanoia
88 %defattr(-,root,root)
89 %doc README GPL FAQ.txt
90 %{_bindir}/*
91 %{_mandir}/man1/*
93 %files -n cdparanoia-libs
94 %defattr(-,root,root)
95 %{_libdir}/*.so*
97 %files -n cdparanoia-devel
98 %defattr(-,root,root)
99 %{_includedir}/cdda
100 %{_includedir}/cdda/*
101 %{_libdir}/*.a
103 %changelog
104 * Fri Jun 25 2004 Peter Jones <pjones@redhat.com> alpha9.8-22
105 - take ownership of %{_includedir}/cdda
106 - sync to mainline
108 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
109 - rebuilt
111 * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
112 - rebuilt
114 * Tue Feb 17 2004 Peter Jones <pjones@redhat.com> alpha9.8-20
115 - take ownership of %{_includedir}/cdda
117 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
118 - rebuilt
120 * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
121 - rebuilt
123 * Tue May 20 2003 Peter Jones <pjones@redhat.com> alpha9.8-17
124 - typo fix (g_fd -> fd)
125 - add errno output
127 * Tue May 06 2003 Peter Jones <pjones@redhat.com> alpha9.8-16
128 - fix warnings on switches
129 - use O_EXCL
131 * Tue Feb 04 2003 Florian La Roche <Florian.LaRoche@redhat.de>
132 - add symlinks to shared libs
134 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
135 - rebuilt
137 * Wed Dec 25 2002 Tim Powers <timp@redhat.com> alpha9.8-13
138 - fix %%install references in the changelog so that it will rebuild properly
140 * Wed Dec 11 2002 Tim Powers <timp@redhat.com> alpha9.8-12
141 - rebuild on all arches
143 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
144 - automated rebuild
146 * Thu May 23 2002 Tim Powers <timp@redhat.com>
147 - automated rebuild
149 * Wed Apr 3 2002 Peter Jones <pjones@redhat.com> alpha9.8-8
150 - don't strip, let rpm do that
152 * Mon Feb 25 2002 Tim Powers <timp@redhat.com> alpha9.8-7
153 - fix broken Obsoletes of cdparanoia-devel
155 * Wed Jan 2 2002 Peter Jones <pjones@redhat.com> alpha9.8-7
156 - minor cleanups of $RPM_BUILD_ROOT pruning
158 * Thu Dec 6 2001 Peter Jones <pjones@redhat.com> alpha9.8-6
159 - move includes to %{_includedir}/cdda/
160 - add utils.h to %%install
161 - clean up %%install some.
163 * Sun Nov 4 2001 Peter Jones <pjones@redhat.com> alpha9.8-5
164 - make a -libs package which contains the .so files
165 - make the cdparanoia dependancy towards that, not -devel
167 * Thu Aug 2 2001 Peter Jones <pjones@redhat.com>
168 - bump the release not to conflict with on in the RH build tree :/
169 - reverse devel dependency
171 * Wed Aug 1 2001 Peter Jones <pjones@redhat.com>
172 - fix %post and %postun to only run ldconfig for devel packages
174 * Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
175 - devel now depends on package
177 * Wed Mar 28 2001 Peter Jones <pjones@redhat.com>
178 - 9.8 release.
180 * Tue Feb 27 2001 Karsten Hopp <karsten@redhat.de>
181 - fix spelling error in description
183 * Thu Dec 7 2000 Crutcher Dunnavant <crutcher@redhat.com>
184 - rebuild for new tree
186 * Fri Jul 21 2000 Trond Eivind Glomsrød <teg@redhat.com>
187 - use %%{_tmppath}
189 * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
190 - automatic rebuild
192 * Wed Jun 06 2000 Preston Brown <pbrown@redhat.com>
193 - revert name change
194 - use new rpm macro paths
196 * Wed Apr 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
197 - Switched spec file from the one used in Red Hat Linux 6.2, which
198 also changes the name
199 - gzip man page
201 * Thu Dec 23 1999 Peter Jones <pjones@redhat.com>
202 - update package to provide cdparanoia-alpha9.7-2.*.rpm and
203 cdparanoia-devel-alpha9.7-2.*.rpm. Also, URLs point at xiph.org
204 like they should.
206 * Wed Dec 22 1999 Peter Jones <pjones@redhat.com>
207 - updated package for alpha9.7, based on input from:
208 Monty <xiphmont@xiph.org>
209 David Philippi <david@torangan.saar.de>
211 * Mon Apr 12 1999 Michael Maher <mike@redhat.com>
212 - updated pacakge
214 * Tue Oct 06 1998 Michael Maher <mike@redhat.com>
215 - updated package
217 * Mon Jun 29 1998 Michael Maher <mike@redhat.com>
218 - built package