4 # Window Maker postinst.
6 # Marcelo Magallon <mmagallo@debian.org>
7 # Rodolfo "kix" GarcĂa <kix@kix.es>
9 inst
="/etc/menu-methods/wmaker /etc/menu-methods/wmappearance"
13 for file in $inst ; do
14 if [ -f $file ] ; then
19 if [ -x /usr
/bin
/update-menus
-a -x /usr
/bin
/install-menu
] ; then
20 # Remove the menu.hook from all the possible paths.
21 rm -f /etc
/X11
/WindowMaker
/menu.hook
22 rm -f /usr
/share
/WindowMaker
/menu.hook
23 # Remove appearance.menu
24 rm -f /usr
/share
/WindowMaker
/appearance.menu
29 abort-upgrade|abort-deconfigure|abort-remove
)
30 # how did we got here? Force a non-zero exit code
35 echo "postinst called with unkown argument: \$1" >&2