4 # Window Maker postinst.
6 # Marcelo Magallon <mmagallo@debian.org>
7 # Rodolfo "kix" GarcĂa <kix@kix.es>
9 x_wm_link
=/etc
/alternatives
/x-window-manager
10 x_wm_man_link
=/usr
/share
/man
/man
1/x-window-manager
.1.gz
12 inst
="/etc/menu-methods/wmaker"
16 for file in $inst ; do
17 if [ -f $file ] ; then
22 update-alternatives
--install /usr
/bin
/x-window-manager \
23 x-window-manager
/usr
/bin
/wmaker
50 \
24 --slave /usr
/share
/man
/man
1/x-window-manager
.1.gz \
25 x-window-manager
.1.gz
/usr
/share
/man
/man
1/wmaker
.1x.gz
27 if [ -x /usr
/bin
/update-menus
-a -x /usr
/bin
/install-menu
] ; then
32 abort-upgrade|abort-deconfigure|abort-remove
)
33 # how did we got here? Force a non-zero exit code
38 echo "postinst called with unkown argument: \$1" >&2