Move URL_SCHEME typedef to match PSDK.
[wine/wine64.git] / dlls / crypt32 / crypt32.spec
blob8f6d320477593d69f012e071ee62d6fbf3550769
1 @ stub CertAddCRLContextToStore
2 @ stub CertAddCTLContextToStore
3 @ stub CertAddCertificateContextToStore
4 @ stub CertAddEncodedCRLToStore
5 @ stub CertAddEncodedCTLToStore
6 @ stub CertAddEncodedCertificateToStore
7 @ stub CertAddEncodedCertificateToSystemStoreA
8 @ stub CertAddEncodedCertificateToSystemStoreW
9 @ stub CertAddEnhancedKeyUsageIdentifier
10 @ stub CertAddSerializedElementToStore
11 @ stub CertAddStoreToCollection
12 @ stub CertAlgIdToOID
13 @ stdcall CertCloseStore(ptr long)
14 @ stub CertCompareCertificate
15 @ stub CertCompareCertificateName
16 @ stub CertCompareIntegerBlob
17 @ stub CertComparePublicKeyInfo
18 @ stub CertControlStore
19 @ stdcall CertCreateCRLContext(long ptr long)
20 @ stub CertCreateCTLContext
21 @ stub CertCreateCertificateChainEngine
22 @ stub CertCreateCertificateContext
23 @ stub CertDeleteCRLFromStore
24 @ stub CertDeleteCTLFromStore
25 @ stub CertDeleteCertificateFromStore
26 @ stub CertDuplicateCRLContext
27 @ stub CertDuplicateCTLContext
28 @ stub CertDuplicateCertificateContext
29 @ stub CertDuplicateStore
30 @ stub CertEnumCRLContextProperties
31 @ stub CertEnumCTLContextProperties
32 @ stub CertEnumCTLsInStore
33 @ stub CertEnumCertificateContextProperties
34 @ stdcall CertEnumCertificatesInStore(long ptr)
35 @ stub CertFindAttribute
36 @ stub CertFindCTLInStore
37 @ stdcall CertFindCertificateInStore(long long long long ptr ptr)
38 @ stub CertFindExtension
39 @ stub CertFindRDNAttr
40 @ stub CertFindSubjectInCTL
41 @ stub CertFreeCRLContext
42 @ stub CertFreeCTLContext
43 @ stub CertFreeCertificateChain
44 @ stub CertFreeCertificateChainEngine
45 @ stdcall CertFreeCertificateContext(ptr)
46 @ stub CertGetCRLContextProperty
47 @ stub CertGetCRLFromStore
48 @ stub CertGetCTLContextProperty
49 @ stub CertGetCertificateContextProperty
50 @ stub CertGetEnhancedKeyUsage
51 @ stub CertGetIntendedKeyUsage
52 @ stub CertGetIssuerCertificateFromStore
53 @ stub CertGetPublicKeyLength
54 @ stub CertGetCertificateChain
55 @ stub CertGetSubjectCertificateFromStore
56 @ stub CertIsRDNAttrsInCertificateName
57 @ stub CertNameToStrA
58 @ stub CertNameToStrW
59 @ stub CertOIDToAlgId
60 @ stdcall CertOpenStore(str long long long ptr)
61 @ stdcall CertOpenSystemStoreA(long str)
62 @ stdcall CertOpenSystemStoreW(long wstr)
63 @ stub CertRDNValueToStrA
64 @ stub CertRDNValueToStrW
65 @ stub CertRemoveEnhancedKeyUsageIdentifier
66 @ stdcall CertSaveStore(long long long long ptr long)
67 @ stub CertSerializeCRLStoreElement
68 @ stub CertSerializeCTLStoreElement
69 @ stub CertSerializeCertificateStoreElement
70 @ stub CertSetCRLContextProperty
71 @ stub CertSetCTLContextProperty
72 @ stub CertSetCertificateContextProperty
73 @ stub CertSetEnhancedKeyUsage
74 @ stub CertStrToNameA
75 @ stub CertStrToNameW
76 @ stub CertVerifyCRLRevocation
77 @ stub CertVerifyCRLTimeValidity
78 @ stub CertVerifyCTLUsage
79 @ stub CertVerifyRevocation
80 @ stub CertVerifySubjectCertificateContext
81 @ stub CertVerifyTimeValidity
82 @ stub CertVerifyValidityNesting
83 @ stub CreateFileU
84 @ stub CryptAcquireContextU
85 @ stub CryptCloseAsyncHandle
86 @ stub CryptCreateAsyncHandle
87 @ stub CryptDecodeMessage
88 @ stub CryptDecodeObject
89 @ stub CryptDecryptAndVerifyMessageSignature
90 @ stub CryptDecryptMessage
91 @ stub CryptEncodeObject
92 @ stub CryptEncryptMessage
93 @ stub CryptEnumOIDFunction
94 @ stub CryptEnumOIDInfo
95 @ stub CryptEnumProvidersU
96 @ stub CryptExportPKCS8
97 @ stub CryptExportPublicKeyInfo
98 @ stub CryptExportPublicKeyInfoEx
99 @ stub CryptFindOIDInfo
100 @ stub CryptFormatObject
101 @ stub CryptFreeOIDFunctionAddress
102 @ stub CryptGetAsyncParam
103 @ stub CryptGetDefaultOIDDllList
104 @ stub CryptGetDefaultOIDFunctionAddress
105 @ stub CryptGetMessageCertificates
106 @ stub CryptGetMessageSignerCount
107 @ stub CryptGetOIDFunctionAddress
108 @ stdcall CryptGetOIDFunctionValue(long str str wstr ptr ptr ptr)
109 @ stub CryptHashCertificate
110 @ stub CryptHashMessage
111 @ stub CryptHashPublicKeyInfo
112 @ stub CryptHashToBeSigned
113 @ stub CryptImportPKCS8
114 @ stub CryptImportPublicKeyInfo
115 @ stub CryptImportPublicKeyInfoEx
116 @ stub CryptInitOIDFunctionSet
117 @ stub CryptInstallOIDFunctionAddress
118 @ stub CryptLoadSip
119 @ stub CryptMemAlloc
120 @ stub CryptMemFree
121 @ stub CryptMemRealloc
122 @ stub CryptMsgCalculateEncodedLength
123 @ stub CryptMsgClose
124 @ stub CryptMsgControl
125 @ stub CryptMsgCountersign
126 @ stub CryptMsgCountersignEncoded
127 @ stub CryptMsgEncodeAndSignCTL
128 @ stub CryptMsgGetAndVerifySigner
129 @ stub CryptMsgGetParam
130 @ stub CryptMsgOpenToDecode
131 @ stub CryptMsgOpenToEncode
132 @ stub CryptMsgSignCTL
133 @ stub CryptMsgUpdate
134 @ stub CryptMsgVerifyCountersignatureEncoded
135 @ stdcall CryptProtectData(ptr wstr ptr ptr ptr long ptr)
136 @ stdcall CryptRegisterDefaultOIDFunction(long str long wstr)
137 @ stdcall CryptRegisterOIDFunction(long str str wstr str)
138 @ stub CryptRegisterOIDInfo
139 @ stdcall CryptSIPAddProvider(ptr)
140 @ stdcall CryptSIPLoad(ptr long ptr)
141 @ stdcall CryptSIPRemoveProvider(ptr)
142 @ stdcall CryptSIPRetrieveSubjectGuid(wstr long ptr)
143 @ stub CryptSetAsyncParam
144 @ stub CryptSetOIDFunctionValue
145 @ stub CryptSetProviderU
146 @ stub CryptSignAndEncodeCertificate
147 @ stub CryptSignAndEncryptMessage
148 @ stub CryptSignCertificate
149 @ stub CryptSignHashU
150 @ stub CryptSignMessage
151 @ stub CryptSignMessageWithKey
152 @ stub CryptUnprotectData
153 @ stub CryptUnregisterDefaultOIDFunction
154 @ stub CryptUnregisterOIDFunction
155 @ stub CryptUnregisterOIDInfo
156 @ stub CryptVerifyCertificateSignature
157 @ stub CryptVerifyDetachedMessageHash
158 @ stub CryptVerifyDetachedMessageSignature
159 @ stub CryptVerifyMessageHash
160 @ stub CryptVerifyMessageSignature
161 @ stub CryptVerifyMessageSignatureWithKey
162 @ stub CryptVerifySignatureU
163 @ stub I_CryptAllocTls
164 @ stdcall I_CryptCreateLruCache(long long)
165 @ stub I_CryptCreateLruEntry
166 @ stub I_CryptDetachTls
167 @ stdcall I_CryptFindLruEntryData(long)
168 @ stdcall I_CryptFlushLruCache(long)
169 @ stdcall I_CryptFreeLruCache(long)
170 @ stub I_CryptGetDefaultCryptProv
171 @ stub I_CryptGetDefaultCryptProvForEncrypt
172 @ stub I_CryptGetOssGlobal
173 @ stub I_CryptGetTls
174 @ stub I_CryptInsertLruEntry
175 @ stub I_CryptInstallOssGlobal
176 @ stub I_CryptReleaseLruEntry
177 @ stub I_CryptSetTls
178 @ stub I_CryptUninstallOssGlobal
179 @ stub PFXExportCertStore
180 @ stub PFXImportCertStore
181 @ stub RegCreateHKCUKeyExU
182 @ stub RegCreateKeyExU
183 @ stub RegDeleteValueU
184 @ stub RegEnumValueU
185 @ stub RegOpenHKCUKeyExU
186 @ stub RegOpenKeyExU
187 @ stub RegQueryInfoKeyU
188 @ stub RegQueryValueExU
189 @ stub RegSetValueExU