Implement LdapUnicodeToUTF8, LdapUTF8ToUnicode,
[wine/wine-kai.git] / dlls / wldap32 / wldap32.spec
blob0707a8a4c9f51fd876e50da277937a6ba7554ac6
1 @ stub LdapGetLastError
2 @ cdecl LdapMapErrorToWin32(long)
3 @ cdecl LdapUnicodeToUTF8(wstr long ptr long)
4 @ cdecl LdapUTF8ToUnicode(str long ptr long)
5 @ cdecl ber_alloc_t(long)
6 @ cdecl ber_bvdup(ptr)
7 @ cdecl ber_bvecfree(ptr)
8 @ cdecl ber_bvfree(ptr)
9 @ cdecl ber_first_element(ptr ptr ptr)
10 @ cdecl ber_flatten(ptr ptr)
11 @ cdecl ber_free(ptr long)
12 @ cdecl ber_init(ptr)
13 @ cdecl ber_next_element(ptr ptr ptr)
14 @ cdecl ber_peek_tag(ptr ptr)
15 @ varargs ber_printf(ptr str)
16 @ varargs ber_scanf(ptr str)
17 @ cdecl ber_skip_tag(ptr ptr)
18 @ cdecl ldap_bind(ptr str str long) ldap_bindA
19 @ cdecl ldap_bindA(ptr str str long)
20 @ cdecl ldap_bindW(ptr wstr wstr long)
21 @ cdecl ldap_bind_s(ptr str str long) ldap_bind_sA
22 @ cdecl ldap_bind_sA(ptr str str long)
23 @ cdecl ldap_bind_sW(ptr wstr wstr long)
24 @ cdecl ldap_compare(ptr str str str) ldap_compareA
25 @ cdecl ldap_compareA(ptr str str str)
26 @ cdecl ldap_compareW(ptr wstr wstr wstr)
27 @ cdecl ldap_compare_ext(ptr str str str ptr ptr ptr ptr) ldap_compare_extA
28 @ cdecl ldap_compare_extA(ptr str str str ptr ptr ptr ptr)
29 @ cdecl ldap_compare_extW(ptr wstr wstr wstr ptr ptr ptr ptr)
30 @ cdecl ldap_compare_ext_s(ptr str str str ptr ptr ptr) ldap_compare_ext_sA
31 @ cdecl ldap_compare_ext_sA(ptr str str str ptr ptr ptr)
32 @ cdecl ldap_compare_ext_sW(ptr wstr wstr wstr ptr ptr ptr)
33 @ cdecl ldap_compare_s(ptr str str str) ldap_compare_sA
34 @ cdecl ldap_compare_sA(ptr str str str)
35 @ cdecl ldap_compare_sW(ptr wstr wstr wstr)
36 @ cdecl ldap_dn2ufn(str) ldap_dn2ufnA
37 @ cdecl ldap_dn2ufnA(str)
38 @ cdecl ldap_dn2ufnW(wstr)
39 @ cdecl ldap_err2string(long) ldap_err2stringA
40 @ cdecl ldap_err2stringA(long)
41 @ cdecl ldap_err2stringW(long)
42 @ cdecl ldap_explode_dn(str long) ldap_explode_dnA
43 @ cdecl ldap_explode_dnA(str long)
44 @ cdecl ldap_explode_dnW(wstr long)
45 @ cdecl ldap_get_dn(ptr ptr) ldap_get_dnA
46 @ cdecl ldap_get_dnA(ptr ptr)
47 @ cdecl ldap_get_dnW(ptr ptr)
48 @ cdecl ldap_init(str long) ldap_initA
49 @ cdecl ldap_initA(str long)
50 @ cdecl ldap_initW(wstr long)
51 @ cdecl ldap_memfree(ptr) ldap_memfreeA
52 @ cdecl ldap_memfreeA(ptr)
53 @ cdecl ldap_memfreeW(ptr)
54 @ cdecl ldap_open(str long) ldap_openA
55 @ cdecl ldap_openA(str long)
56 @ cdecl ldap_openW(wstr long)
57 @ cdecl ldap_perror(ptr ptr) WLDAP32_ldap_perror
58 @ cdecl ldap_result2error(ptr ptr long) WLDAP32_ldap_result2error
59 @ cdecl ldap_sasl_bindA(ptr str str ptr ptr ptr ptr)
60 @ cdecl ldap_sasl_bindW(ptr wstr wstr ptr ptr ptr ptr)
61 @ cdecl ldap_sasl_bind_sA(ptr str str ptr ptr ptr ptr)
62 @ cdecl ldap_sasl_bind_sW(ptr wstr wstr ptr ptr ptr ptr)
63 @ cdecl ldap_search(ptr str long str ptr long) ldap_searchA
64 @ cdecl ldap_searchA(ptr str long str ptr long)
65 @ cdecl ldap_searchW(ptr wstr long wstr ptr long)
66 @ cdecl ldap_search_ext(ptr str long str ptr long ptr ptr long long ptr) ldap_search_extA
67 @ cdecl ldap_search_extA(ptr str long str ptr long ptr ptr long long ptr)
68 @ cdecl ldap_search_extW(ptr wstr long wstr ptr long ptr ptr long long ptr)
69 @ cdecl ldap_search_ext_s(ptr str long str ptr long ptr ptr ptr long ptr) ldap_search_ext_sA
70 @ cdecl ldap_search_ext_sA(ptr str long str ptr long ptr ptr ptr long ptr)
71 @ cdecl ldap_search_ext_sW(ptr wstr long wstr ptr long ptr ptr ptr long ptr)
72 @ cdecl ldap_search_s(ptr str long str ptr long ptr) ldap_search_sA
73 @ cdecl ldap_search_sA(ptr str long str ptr long ptr)
74 @ cdecl ldap_search_sW(ptr wstr long wstr ptr long ptr)
75 @ cdecl ldap_search_st(ptr str long str ptr long ptr ptr) ldap_search_stA
76 @ cdecl ldap_search_stA(ptr str long str ptr long ptr ptr)
77 @ cdecl ldap_search_stW(ptr wstr long wstr ptr long ptr ptr)
78 @ cdecl ldap_simple_bind(ptr str str) ldap_simple_bindA
79 @ cdecl ldap_simple_bindA(ptr str str)
80 @ cdecl ldap_simple_bindW(ptr wstr wstr)
81 @ cdecl ldap_simple_bind_s(ptr str str) ldap_simple_bind_sA
82 @ cdecl ldap_simple_bind_sA(ptr str str)
83 @ cdecl ldap_simple_bind_sW(ptr wstr wstr)
84 @ cdecl ldap_start_tls_sA(ptr ptr ptr ptr ptr)
85 @ cdecl ldap_start_tls_sW(ptr ptr ptr ptr ptr)
86 @ cdecl ldap_unbind(ptr) WLDAP32_ldap_unbind
87 @ cdecl ldap_unbind_s(ptr) WLDAP32_ldap_unbind_s
88 @ cdecl ldap_ufn2dn(str ptr) ldap_ufn2dnA
89 @ cdecl ldap_ufn2dnA(str ptr)
90 @ cdecl ldap_ufn2dnW(wstr ptr)
91 @ cdecl ldap_value_free(ptr) ldap_value_freeA
92 @ cdecl ldap_value_freeA(ptr)
93 @ cdecl ldap_value_freeW(ptr)