Implement ldap_search* functions.
[wine/wine-kai.git] / dlls / wldap32 / wldap32.spec
blob220d0f6ab6b94286db1560701a2b9720e56be077
1 @ stub LdapGetLastError
2 @ stub LdapMapErrorToWin32
3 @ cdecl ber_alloc_t(long)
4 @ cdecl ber_bvdup(ptr)
5 @ cdecl ber_bvecfree(ptr)
6 @ cdecl ber_bvfree(ptr)
7 @ cdecl ber_first_element(ptr ptr ptr)
8 @ cdecl ber_flatten(ptr ptr)
9 @ cdecl ber_free(ptr long)
10 @ cdecl ber_init(ptr)
11 @ cdecl ber_next_element(ptr ptr ptr)
12 @ cdecl ber_peek_tag(ptr ptr)
13 @ varargs ber_printf(ptr str)
14 @ varargs ber_scanf(ptr str)
15 @ cdecl ber_skip_tag(ptr ptr)
16 @ cdecl ldap_bind(ptr str str long) ldap_bindA
17 @ cdecl ldap_bindA(ptr str str long)
18 @ cdecl ldap_bindW(ptr wstr wstr long)
19 @ cdecl ldap_bind_s(ptr str str long) ldap_bind_sA
20 @ cdecl ldap_bind_sA(ptr str str long)
21 @ cdecl ldap_bind_sW(ptr wstr wstr long)
22 @ cdecl ldap_init(str long) ldap_initA
23 @ cdecl ldap_initA(str long)
24 @ cdecl ldap_initW(wstr long)
25 @ cdecl ldap_open(str long) ldap_openA
26 @ cdecl ldap_openA(str long)
27 @ cdecl ldap_openW(wstr long)
28 @ cdecl ldap_search(ptr str long str ptr long) ldap_searchA
29 @ cdecl ldap_searchA(ptr str long str ptr long)
30 @ cdecl ldap_searchW(ptr wstr long wstr ptr long)
31 @ cdecl ldap_search_s(ptr str long str ptr long) ldap_search_sA
32 @ cdecl ldap_search_sA(ptr str long str ptr long)
33 @ cdecl ldap_search_sW(ptr wstr long wstr ptr long)
34 @ cdecl ldap_search_st(ptr str long str ptr long ptr ptr) ldap_search_stA
35 @ cdecl ldap_search_stA(ptr str long str ptr long ptr ptr)
36 @ cdecl ldap_search_stW(ptr wstr long wstr ptr long ptr ptr)
37 @ cdecl ldap_simple_bind(ptr str str) ldap_simple_bindA
38 @ cdecl ldap_simple_bindA(ptr str str)
39 @ cdecl ldap_simple_bindW(ptr wstr wstr)
40 @ cdecl ldap_simple_bind_s(ptr str str) ldap_simple_bind_sA
41 @ cdecl ldap_simple_bind_sA(ptr str str)
42 @ cdecl ldap_simple_bind_sW(ptr wstr wstr)
43 @ cdecl ldap_unbind(ptr) WLDAP32_ldap_unbind
44 @ cdecl ldap_unbind_s(ptr) WLDAP32_ldap_unbind_s