winemenubuilder: silence an err
[wine/multimedia.git] / dlls / iphlpapi / iphlpapi.spec
blob4be42fe997199110b7c1dd94a627db48c9b2982e
1 @ stdcall AddIPAddress( long long long ptr ptr )
2 @ stub AllocateAndGetArpEntTableFromStack
3 @ stdcall AllocateAndGetIfTableFromStack( ptr long long long )
4 #@ stub AllocateAndGetInterfaceInfoFromStack
5 @ stdcall AllocateAndGetIpAddrTableFromStack( ptr long long long )
6 @ stdcall AllocateAndGetIpForwardTableFromStack( ptr long long long )
7 @ stdcall AllocateAndGetIpNetTableFromStack( ptr long long long )
8 @ stdcall AllocateAndGetTcpTableFromStack( ptr long long long )
9 @ stdcall AllocateAndGetUdpTableFromStack( ptr long long long )
10 @ stdcall CancelIPChangeNotify( ptr )
11 @ stdcall CancelMibChangeNotify2( ptr )
12 #@ stub ConvertGuidToStringA
13 #@ stub ConvertGuidToStringW
14 #@ stub ConvertInterfaceAliasToLuid
15 @ stdcall ConvertInterfaceGuidToLuid( ptr ptr )
16 @ stdcall ConvertInterfaceIndexToLuid( long ptr )
17 #@ stub ConvertInterfaceLuidToAlias
18 @ stdcall ConvertInterfaceLuidToGuid( ptr ptr )
19 @ stdcall ConvertInterfaceLuidToIndex( ptr ptr )
20 @ stdcall ConvertInterfaceLuidToNameA( ptr ptr long )
21 @ stdcall ConvertInterfaceLuidToNameW( ptr ptr long )
22 @ stdcall ConvertInterfaceNameToLuidA( str ptr )
23 @ stdcall ConvertInterfaceNameToLuidW( wstr ptr )
24 #@ stub ConvertInterfacePhysicalAddressToLuid
25 #@ stub ConvertIpv4MaskToLength
26 #@ stub ConvertLengthToIpv4Mask
27 #@ stub ConvertRemoteInterfaceAliasToLuid
28 #@ stub ConvertRemoteInterfaceGuidToLuid
29 #@ stub ConvertRemoteInterfaceIndexToLuid
30 #@ stub ConvertRemoteInterfaceLuidToAlias
31 #@ stub ConvertRemoteInterfaceLuidToGuid
32 #@ stub ConvertRemoteInterfaceLuidToIndex
33 #@ stub ConvertStringToGuidA
34 #@ stub ConvertStringToGuidW
35 #@ stub ConvertStringToInterfacePhysicalAddress
36 #@ stub CPNatfwtCreateProviderInstance
37 #@ stub CPNatfwtDeregisterProviderInstance
38 #@ stub CPNatfwtDestroyProviderInstance
39 #@ stub CPNatfwtIndicateReceivedBuffers
40 #@ stub CPNatfwtRegisterProviderInstance
41 #@ stub CreateAnycastIpAddressEntry
42 #@ stub CreateIpForwardEntry2
43 @ stdcall CreateIpForwardEntry( ptr )
44 #@ stub CreateIpNetEntry2
45 @ stdcall CreateIpNetEntry( ptr )
46 #@ stub CreatePersistentTcpPortReservation
47 #@ stub CreatePersistentUdpPortReservation
48 @ stdcall CreateProxyArpEntry( long long long )
49 @ stdcall CreateSortedAddressPairs( ptr long ptr long long ptr ptr )
50 #@ stub CreateUnicastIpAddressEntry
51 #@ stub DeleteAnycastIpAddressEntry
52 @ stdcall DeleteIPAddress( long )
53 #@ stub DeleteIpForwardEntry2
54 @ stdcall DeleteIpForwardEntry( ptr )
55 #@ stub DeleteIpNetEntry2
56 @ stdcall DeleteIpNetEntry( ptr )
57 #@ stub DeletePersistentTcpPortReservation
58 #@ stub DeletePersistentUdpPortReservation
59 @ stdcall DeleteProxyArpEntry( long long long )
60 #@ stub DeleteUnicastIpAddressEntry
61 #@ stub DisableMediaSense
62 #@ stub do_echo_rep
63 #@ stub do_echo_req
64 @ stdcall EnableRouter( ptr ptr )
65 @ stdcall FlushIpNetTable( long )
66 #@ stub FlushIpNetTable2
67 @ stub FlushIpNetTableFromStack
68 #@ stub FlushIpPathTable
69 @ stdcall FreeMibTable( ptr )
70 @ stdcall GetAdapterIndex( wstr ptr )
71 @ stub GetAdapterOrderMap
72 @ stdcall GetAdaptersAddresses( long long ptr ptr ptr )
73 @ stdcall GetAdaptersInfo( ptr ptr )
74 #@ stub GetAnycastIpAddressEntry
75 #@ stub GetAnycastIpAddressTable
76 @ stdcall GetBestInterface( long ptr )
77 @ stdcall GetBestInterfaceEx( ptr ptr )
78 @ stub GetBestInterfaceFromStack
79 @ stdcall GetBestRoute( long long long )
80 #@ stub GetBestRoute2
81 @ stub GetBestRouteFromStack
82 #@ stub GetCurrentThreadCompartmentId
83 @ stdcall GetExtendedTcpTable( ptr ptr long long long long )
84 @ stdcall GetExtendedUdpTable( ptr ptr long long long long )
85 @ stdcall GetFriendlyIfIndex( long )
86 @ stdcall GetIcmpStatisticsEx( ptr long )
87 @ stdcall GetIcmpStatistics( ptr )
88 @ stub GetIcmpStatsFromStack
89 @ stdcall GetIfEntry( ptr )
90 @ stdcall GetIfEntry2( ptr )
91 @ stub GetIfEntryFromStack
92 #@ stub GetIfStackTable
93 @ stdcall GetIfTable( ptr ptr long )
94 @ stdcall GetIfTable2( ptr )
95 #@ stub GetIfTable2Ex
96 @ stub GetIfTableFromStack
97 @ stub GetIgmpList
98 @ stdcall GetInterfaceInfo( ptr ptr )
99 #@ stub GetInvertedIfStackTable
100 @ stdcall GetIpAddrTable( ptr ptr long )
101 @ stub GetIpAddrTableFromStack
102 #@ stub GetIpErrorString
103 #@ stub GetIpForwardEntry2
104 @ stdcall GetIpForwardTable( ptr ptr long )
105 #@ stub GetIpForwardTable2
106 @ stub GetIpForwardTableFromStack
107 #@ stub GetIpInterfaceEntry
108 #@ stub GetIpInterfaceTable
109 #@ stub GetIpNetEntry2
110 @ stdcall GetIpNetTable( ptr ptr long )
111 #@ stub GetIpNetTable2
112 @ stub GetIpNetTableFromStack
113 #@ stub GetIpPathEntry
114 #@ stub GetIpPathTable
115 @ stdcall GetIpStatisticsEx( ptr long )
116 @ stdcall GetIpStatistics( ptr )
117 @ stub GetIpStatsFromStack
118 #@ stub GetMulticastIpAddressEntry
119 #@ stub GetMulticastIpAddressTable
120 #@ stub GetNetworkInformation
121 @ stdcall GetNetworkParams( ptr ptr )
122 @ stdcall GetNumberOfInterfaces( ptr )
123 #@ stub GetOwnerModuleFromPidAndInfo
124 #@ stub GetOwnerModuleFromTcp6Entry
125 #@ stub GetOwnerModuleFromTcpEntry
126 #@ stub GetOwnerModuleFromUdp6Entry
127 #@ stub GetOwnerModuleFromUdpEntry
128 @ stdcall GetPerAdapterInfo( long ptr ptr )
129 #@ stub GetPerTcp6ConnectionEStats
130 #@ stub GetPerTcp6ConnectionStats
131 #@ stub GetPerTcpConnectionEStats
132 #@ stub GetPerTcpConnectionStats
133 @ stdcall GetRTTAndHopCount( long ptr long ptr )
134 #@ stub GetSessionCompartmentId
135 @ stdcall GetTcp6Table( ptr ptr long )
136 @ stdcall GetTcp6Table2( ptr ptr long )
137 @ stdcall GetTcpStatisticsEx( ptr long )
138 @ stdcall GetTcpStatistics( ptr )
139 @ stub GetTcpStatsFromStack
140 @ stdcall GetTcpTable( ptr ptr long )
141 @ stdcall GetTcpTable2( ptr ptr long )
142 @ stub GetTcpTableFromStack
143 #@ stub GetTeredoPort
144 #@ stub GetUdp6Table
145 @ stdcall GetUdpStatisticsEx( ptr long )
146 @ stdcall GetUdpStatistics( ptr )
147 @ stub GetUdpStatsFromStack
148 @ stdcall GetUdpTable( ptr ptr long )
149 @ stub GetUdpTableFromStack
150 #@ stub GetUnicastIpAddressEntry
151 #@ stub GetUnicastIpAddressTable
152 @ stdcall GetUniDirectionalAdapterInfo( ptr ptr )
153 @ stdcall Icmp6CreateFile()
154 #@ stub Icmp6ParseReplies
155 @ stdcall Icmp6SendEcho2(ptr ptr ptr ptr ptr ptr ptr long ptr ptr long long)
156 @ stdcall IcmpCloseHandle(ptr)
157 @ stdcall IcmpCreateFile()
158 @ stub IcmpParseReplies
159 @ stdcall IcmpSendEcho2Ex(ptr ptr ptr ptr long long ptr long ptr ptr long long)
160 @ stdcall IcmpSendEcho2(ptr ptr ptr ptr long ptr long ptr ptr long long)
161 @ stdcall IcmpSendEcho(ptr long ptr long ptr ptr long long)
162 #@ stub if_indextoname
163 #@ stub if_nametoindex
164 #@ stub InitializeIpForwardEntry
165 #@ stub InitializeIpInterfaceEntry
166 #@ stub InitializeUnicastIpAddressEntry
167 #@ stub InternalCleanupPersistentStore
168 #@ stub InternalCreateAnycastIpAddressEntry
169 @ stub InternalCreateIpForwardEntry
170 #@ stub InternalCreateIpForwardEntry2
171 @ stub InternalCreateIpNetEntry
172 #@ stub InternalCreateIpNetEntry2
173 #@ stub InternalCreateUnicastIpAddressEntry
174 #@ stub InternalDeleteAnycastIpAddressEntry
175 @ stub InternalDeleteIpForwardEntry
176 #@ stub InternalDeleteIpForwardEntry2
177 @ stub InternalDeleteIpNetEntry
178 #@ stub InternalDeleteIpNetEntry2
179 #@ stub InternalDeleteUnicastIpAddressEntry
180 #@ stub InternalFindInterfaceByAddress
181 #@ stub InternalGetAnycastIpAddressEntry
182 #@ stub InternalGetAnycastIpAddressTable
183 #@ stub InternalGetForwardIpTable2
184 #@ stub InternalGetIfEntry2
185 @ stub InternalGetIfTable
186 #@ stub InternalGetIfTable2
187 @ stub InternalGetIpAddrTable
188 #@ stub InternalGetIpForwardEntry2
189 @ stub InternalGetIpForwardTable
190 #@ stub InternalGetIpInterfaceEntry
191 #@ stub InternalGetIpInterfaceTable
192 #@ stub InternalGetIpNetEntry2
193 @ stub InternalGetIpNetTable
194 #@ stub InternalGetIpNetTable2
195 #@ stub InternalGetMulticastIpAddressEntry
196 #@ stub InternalGetMulticastIpAddressTable
197 #@ stub InternalGetTcp6Table2
198 #@ stub InternalGetTcp6TableWithOwnerModule
199 #@ stub InternalGetTcp6TableWithOwnerPid
200 @ stub InternalGetTcpTable
201 #@ stub InternalGetTcpTable2
202 #@ stub InternalGetTcpTableEx
203 #@ stub InternalGetTcpTableWithOwnerModule
204 #@ stub InternalGetTcpTableWithOwnerPid
205 #@ stub InternalGetTunnelPhysicalAdapter
206 #@ stub InternalGetUdp6TableWithOwnerModule
207 #@ stub InternalGetUdp6TableWithOwnerPid
208 @ stub InternalGetUdpTable
209 #@ stub InternalGetUdpTableEx
210 #@ stub InternalGetUdpTableWithOwnerModule
211 #@ stub InternalGetUdpTableWithOwnerPid
212 #@ stub InternalGetUnicastIpAddressEntry
213 #@ stub InternalGetUnicastIpAddressTable
214 @ stub InternalSetIfEntry
215 @ stub InternalSetIpForwardEntry
216 #@ stub InternalSetIpForwardEntry2
217 #@ stub InternalSetIpInterfaceEntry
218 @ stub InternalSetIpNetEntry
219 #@ stub InternalSetIpNetEntry2
220 @ stub InternalSetIpStats
221 @ stub InternalSetTcpEntry
222 #@ stub InternalSetTeredoPort
223 #@ stub InternalSetUnicastIpAddressEntry
224 @ stdcall IpReleaseAddress( ptr )
225 @ stdcall IpRenewAddress( ptr )
226 @ stub IsLocalAddress
227 #@ stub LookupPersistentTcpPortReservation
228 #@ stub LookupPersistentUdpPortReservation
229 @ stub NhGetGuidFromInterfaceName
230 #@ stub NhGetInterfaceDescriptionFromGuid
231 #@ stub NhGetInterfaceNameFromDeviceGuid
232 @ stub NhGetInterfaceNameFromGuid
233 @ stub NhpAllocateAndGetInterfaceInfoFromStack
234 @ stub NhpGetInterfaceIndexFromStack
235 @ stdcall NotifyAddrChange( ptr ptr )
236 @ stdcall NotifyIpInterfaceChange( long ptr ptr long ptr )
237 @ stdcall NotifyRouteChange( ptr ptr )
238 #@ stub NotifyRouteChange2
239 @ stub NotifyRouteChangeEx
240 #@ stub NotifyStableUnicastIpAddressTable
241 #@ stub NotifyTeredoPortChange
242 #@ stub NotifyUnicastIpAddressChange
243 #@ stub NTPTimeToNTFileTime
244 #@ stub NTTimeToNTPTime
245 #@ stub ParseNetworkString
246 @ stub _PfAddFiltersToInterface@24
247 @ stub _PfAddGlobalFilterToInterface@8
248 @ stdcall _PfBindInterfaceToIPAddress@12(long long ptr) PfBindInterfaceToIPAddress
249 @ stub _PfBindInterfaceToIndex@16
250 @ stdcall _PfCreateInterface@24(long long long long long ptr) PfCreateInterface
251 @ stdcall _PfDeleteInterface@4(long) PfDeleteInterface
252 @ stub _PfDeleteLog@0
253 @ stub _PfGetInterfaceStatistics@16
254 @ stub _PfMakeLog@4
255 @ stub _PfRebindFilters@8
256 @ stub _PfRemoveFilterHandles@12
257 @ stub _PfRemoveFiltersFromInterface@20
258 @ stub _PfRemoveGlobalFilterFromInterface@8
259 @ stub _PfSetLogBuffer@28
260 @ stub _PfTestPacket@20
261 @ stdcall _PfUnBindInterface@4(long) PfUnBindInterface
262 #@ stub register_icmp
263 #@ stub ResolveIpNetEntry2
264 #@ stub ResolveNeighbor
265 #@ stub RestoreMediaSense
266 @ stdcall SendARP( long long ptr ptr )
267 @ stub SetAdapterIpAddress
268 @ stub SetBlockRoutes
269 #@ stub SetCurrentThreadCompartmentId
270 @ stdcall SetIfEntry( ptr )
271 @ stub SetIfEntryToStack
272 #@ stub SetIpForwardEntry2
273 @ stdcall SetIpForwardEntry( ptr )
274 @ stub SetIpForwardEntryToStack
275 #@ stub SetIpInterfaceEntry
276 @ stub SetIpMultihopRouteEntryToStack
277 #@ stub SetIpNetEntry2
278 @ stdcall SetIpNetEntry( ptr )
279 @ stub SetIpNetEntryToStack
280 @ stub SetIpRouteEntryToStack
281 #@ stub SetIpStatisticsEx
282 @ stdcall SetIpStatistics( ptr )
283 @ stub SetIpStatsToStack
284 @ stdcall SetIpTTL( long )
285 #@ stub SetNetworkInformation
286 #@ stub SetPerTcp6ConnectionEStats
287 #@ stub SetPerTcp6ConnectionStats
288 @ stdcall SetPerTcpConnectionEStats( ptr long ptr long long long )
289 #@ stub SetPerTcpConnectionStats
290 @ stub SetProxyArpEntryToStack
291 @ stub SetRouteWithRef
292 #@ stub SetSessionCompartmentId
293 @ stdcall SetTcpEntry( ptr )
294 @ stub SetTcpEntryToStack
295 #@ stub SetUnicastIpAddressEntry
296 @ stdcall UnenableRouter( ptr ptr )