Declare debug channels in all dlls that need them; added imports of
[wine/multimedia.git] / dlls / wsock32 / wsock32.spec
blob154c780e18c413adf7f1ed394f035133320e8470
1 name wsock32
2 type win32
4 import ws2_32.dll
5 import kernel32.dll
6 import ntdll.dll
8 debug_channels (winsock)
10 1 forward accept ws2_32.accept
11 2 forward bind ws2_32.bind
12 3 forward closesocket ws2_32.closesocket
13 4 forward connect ws2_32.connect
14 5 forward getpeername ws2_32.getpeername
15 6 forward getsockname ws2_32.getsockname
16 7 forward getsockopt ws2_32.getsockopt
17 8 forward htonl ws2_32.htonl
18 9 forward htons ws2_32.htons
19 10 forward inet_addr ws2_32.inet_addr
20 11 forward inet_ntoa ws2_32.inet_ntoa
21 12 forward ioctlsocket ws2_32.ioctlsocket
22 13 forward listen ws2_32.listen
23 14 forward ntohl ws2_32.ntohl
24 15 forward ntohs ws2_32.ntohs
25 16 forward recv ws2_32.recv
26 17 forward recvfrom ws2_32.recvfrom
27 18 forward select ws2_32.select
28 19 forward send ws2_32.send
29 20 forward sendto ws2_32.sendto
30 21 forward setsockopt ws2_32.setsockopt
31 22 forward shutdown ws2_32.shutdown
32 23 forward socket ws2_32.socket
33 51 forward gethostbyaddr ws2_32.gethostbyaddr
34 52 forward gethostbyname ws2_32.gethostbyname
35 53 forward getprotobyname ws2_32.getprotobyname
36 54 forward getprotobynumber ws2_32.getprotobynumber
37 55 forward getservbyname ws2_32.getservbyname
38 56 forward getservbyport ws2_32.getservbyport
39 57 forward gethostname ws2_32.gethostname
40 101 forward WSAAsyncSelect ws2_32.WSAAsyncSelect
41 102 forward WSAAsyncGetHostByAddr ws2_32.WSAAsyncGetHostByAddr
42 103 forward WSAAsyncGetHostByName ws2_32.WSAAsyncGetHostByName
43 104 forward WSAAsyncGetProtoByNumber ws2_32.WSAAsyncGetProtoByNumber
44 105 forward WSAAsyncGetProtoByName ws2_32.WSAAsyncGetProtoByName
45 106 forward WSAAsyncGetServByPort ws2_32.WSAAsyncGetServByPort
46 107 forward WSAAsyncGetServByName ws2_32.WSAAsyncGetServByName
47 108 forward WSACancelAsyncRequest ws2_32.WSACancelAsyncRequest
48 109 forward WSASetBlockingHook ws2_32.WSASetBlockingHook
49 110 forward WSAUnhookBlockingHook ws2_32.WSAUnhookBlockingHook
50 111 forward WSAGetLastError ws2_32.WSAGetLastError
51 112 forward WSASetLastError ws2_32.WSASetLastError
52 113 forward WSACancelBlockingCall ws2_32.WSACancelBlockingCall
53 114 forward WSAIsBlocking ws2_32.WSAIsBlocking
54 115 forward WSAStartup ws2_32.WSAStartup
55 116 forward WSACleanup ws2_32.WSACleanup
56 151 forward __WSAFDIsSet ws2_32.__WSAFDIsSet
57 500 forward WEP ws2_32.WEP
59 # applications *should* 'degrade gracefully if these are not present
60 # ... as it is, they don't
61 #1000 stub WSApSetPostRoutine
62 1001 stdcall WsControl(long long ptr ptr ptr ptr) WsControl
63 1100 stdcall inet_network(str) inet_network
64 1101 stdcall getnetbyname(str) getnetbyname
65 #1102 stub rcmd
66 #1103 stub rexec
67 #1104 stub rresvport
68 #1105 stub sethostname
69 #1106 stub dn_expand
70 1107 stdcall WSARecvEx(long ptr long ptr) WSARecvEx
71 1108 stdcall s_perror(str) WS_s_perror
72 1109 stub GetAddressByNameA
73 1110 stub GetAddressByNameW
74 #1111 stub EnumProtocolsA
75 #1112 stub EnumProtocolsW
76 #1113 stub GetTypeByNameA
77 #1114 stub GetTypeByNameW
78 #1115 stub GetNameByTypeA
79 #1116 stub GetNameByTypeW
80 #1117 stub SetServiceA
81 #1118 stub SetServiceW
82 #1119 stub GetServiceA
83 #1120 stub GetServiceW
84 #1130 stub NPLoadNameSpaces
85 #1140 stub TransmitFile
86 #1141 stub AcceptEx
87 #1142 stub GetAcceptExSockaddrs