Stub for VerifyVersionInfoW.
[wine/multimedia.git] / dlls / comctl32 / comctl32.spec
blobdf980ec1f6860ff6e825ebc9aa276c9308ecc469
1 name comctl32
2 type win32
3 init COMCTL32_LibMain
4 rsrc rsrc.res
6 debug_channels (animate comboex commctrl datetime header hotkey imagelist ipaddress
7 listview message monthcal nativefont pager progress propsheet
8 rebar statusbar tab toolbar tooltips trackbar treeview updown)
10 # Functions exported by the Win95 comctl32.dll
11 # (these need to have these exact ordinals, because some win95 dlls
12 # import comctl32.dll by ordinal)
13 # This list was created from a comctl32.dll v5.81 (IE5.01).
15 2 stdcall MenuHelp(long long long long long long ptr) MenuHelp
16 3 stdcall ShowHideMenuCtl(long long ptr) ShowHideMenuCtl
17 4 stdcall GetEffectiveClientRect(long long long) GetEffectiveClientRect
18 5 stdcall DrawStatusTextA(long ptr str long) DrawStatusTextA
19 6 stdcall CreateStatusWindowA(long str long long) CreateStatusWindowA
20 7 stdcall CreateToolbar(long long long long long long ptr long) CreateToolbar
21 8 stdcall CreateMappedBitmap(long long long ptr long) CreateMappedBitmap
22 9 stdcall DPA_LoadStream(ptr ptr ptr long) DPA_LoadStream
23 10 stdcall DPA_SaveStream(ptr ptr ptr long) DPA_SaveStream
24 11 stdcall DPA_Merge(ptr ptr long ptr ptr long) DPA_Merge
25 #12 stub Cctl1632_ThunkData32
26 13 stdcall MakeDragList(long) MakeDragList
27 14 stdcall LBItemFromPt(long long long long) LBItemFromPt
28 15 stdcall DrawInsert(long long long) DrawInsert
29 16 stdcall CreateUpDownControl(long long long long long long long long long long long long) CreateUpDownControl
30 17 stdcall InitCommonControls() InitCommonControls
31 18 stdcall CreatePropertySheetPage(ptr) CreatePropertySheetPageA
32 19 stdcall CreatePropertySheetPageA(ptr) CreatePropertySheetPageA
33 20 stdcall CreatePropertySheetPageW(ptr) CreatePropertySheetPageW
34 21 stdcall CreateStatusWindow(long str long long) CreateStatusWindowA
35 22 stdcall CreateStatusWindowW(long wstr long long) CreateStatusWindowW
36 23 stdcall CreateToolbarEx(long long long long long long ptr long long long long long long) CreateToolbarEx
37 24 stdcall DestroyPropertySheetPage(long) DestroyPropertySheetPage
38 25 stdcall DllGetVersion(ptr) COMCTL32_DllGetVersion
39 26 stdcall DllInstall(long ptr) COMCTL32_DllInstall
40 27 stdcall DrawStatusText(long ptr ptr long) DrawStatusTextA
41 28 stdcall DrawStatusTextW(long ptr wstr long) DrawStatusTextW
42 29 stdcall FlatSB_EnableScrollBar (long long long) FlatSB_EnableScrollBar
43 30 stdcall FlatSB_GetScrollInfo (long long ptr) FlatSB_GetScrollInfo
44 31 stdcall FlatSB_GetScrollPos (long long) FlatSB_GetScrollPos
45 32 stdcall FlatSB_GetScrollProp (long long ptr) FlatSB_GetScrollProp
46 33 stdcall FlatSB_GetScrollRange (long long ptr ptr) FlatSB_GetScrollRange
47 34 stdcall FlatSB_SetScrollInfo (long long ptr long) FlatSB_SetScrollInfo
48 35 stdcall FlatSB_SetScrollPos (long long long long) FlatSB_SetScrollPos
49 36 stdcall FlatSB_SetScrollProp (long long long long) FlatSB_SetScrollProp
50 37 stdcall FlatSB_SetScrollRange (long long long long long) FlatSB_SetScrollRange
51 38 stdcall FlatSB_ShowScrollBar (long long long) FlatSB_ShowScrollBar
52 39 stdcall GetMUILanguage() GetMUILanguage
53 40 stdcall ImageList_Add(ptr long long) ImageList_Add
54 41 stdcall ImageList_AddIcon(ptr long) ImageList_AddIcon
55 42 stdcall ImageList_AddMasked(ptr long long) ImageList_AddMasked
56 43 stdcall ImageList_BeginDrag(ptr long long long) ImageList_BeginDrag
57 44 stdcall ImageList_Copy(ptr long ptr long long) ImageList_Copy
58 45 stdcall ImageList_Create(long long long long long) ImageList_Create
59 46 stdcall ImageList_Destroy(ptr) ImageList_Destroy
60 47 stdcall ImageList_DragEnter(long long long) ImageList_DragEnter
61 48 stdcall ImageList_DragLeave(long) ImageList_DragLeave
62 49 stdcall ImageList_DragMove(long long) ImageList_DragMove
63 50 stdcall ImageList_DragShowNolock(long) ImageList_DragShowNolock
64 51 stdcall ImageList_Draw(ptr long long long long long) ImageList_Draw
65 52 stdcall ImageList_DrawEx(ptr long long long long long long long long long) ImageList_DrawEx
66 53 stdcall ImageList_DrawIndirect(ptr) ImageList_DrawIndirect
67 54 stdcall ImageList_Duplicate(ptr) ImageList_Duplicate
68 55 stdcall ImageList_EndDrag() ImageList_EndDrag
69 56 stdcall ImageList_GetBkColor(ptr) ImageList_GetBkColor
70 57 stdcall ImageList_GetDragImage(ptr ptr) ImageList_GetDragImage
71 58 stdcall ImageList_GetFlags(ptr) ImageList_GetFlags
72 59 stdcall ImageList_GetIcon(ptr long long) ImageList_GetIcon
73 60 stdcall ImageList_GetIconSize(ptr ptr ptr) ImageList_GetIconSize
74 61 stdcall ImageList_GetImageCount(ptr) ImageList_GetImageCount
75 62 stdcall ImageList_GetImageInfo(ptr long ptr) ImageList_GetImageInfo
76 63 stdcall ImageList_GetImageRect(ptr long ptr) ImageList_GetImageRect
77 64 stdcall ImageList_LoadImage(long str long long long long long) ImageList_LoadImageA
78 65 stdcall ImageList_LoadImageA(long str long long long long long) ImageList_LoadImageA
79 66 stdcall ImageList_LoadImageW(long wstr long long long long long) ImageList_LoadImageW
80 67 stdcall ImageList_Merge(ptr long ptr long long long) ImageList_Merge
81 68 stdcall ImageList_Read(ptr) ImageList_Read
82 69 stdcall ImageList_Remove(ptr long) ImageList_Remove
83 70 stdcall ImageList_Replace(ptr long long long) ImageList_Replace
84 71 stdcall Alloc(long) COMCTL32_Alloc
85 72 stdcall ReAlloc(ptr long) COMCTL32_ReAlloc
86 73 stdcall Free(ptr) COMCTL32_Free
87 74 stdcall GetSize(ptr) COMCTL32_GetSize
88 75 stdcall ImageList_ReplaceIcon(ptr long long) ImageList_ReplaceIcon
89 76 stdcall ImageList_SetBkColor(ptr long) ImageList_SetBkColor
90 77 stdcall ImageList_SetDragCursorImage(ptr long long long) ImageList_SetDragCursorImage
91 78 stdcall ImageList_SetFilter(ptr long long) ImageList_SetFilter
92 79 stdcall ImageList_SetFlags(ptr long) ImageList_SetFlags
93 80 stdcall ImageList_SetIconSize(ptr long long) ImageList_SetIconSize
94 81 stdcall ImageList_SetImageCount(ptr long) ImageList_SetImageCount
95 82 stdcall ImageList_SetOverlayImage(ptr long long) ImageList_SetOverlayImage
96 83 stdcall ImageList_Write(ptr ptr) ImageList_Write
97 84 stdcall InitCommonControlsEx(ptr) InitCommonControlsEx
98 85 stdcall InitMUILanguage(long) InitMUILanguage
99 86 stdcall InitializeFlatSB(long) InitializeFlatSB
100 87 stdcall PropertySheet(ptr) PropertySheetA
101 88 stdcall PropertySheetA(ptr) PropertySheetA
102 89 stdcall PropertySheetW(ptr) PropertySheetW
103 90 stdcall UninitializeFlatSB(long) UninitializeFlatSB
104 91 stdcall _TrackMouseEvent(ptr) _TrackMouseEvent
106 151 stdcall CreateMRUListA(ptr) CreateMRUListA
107 152 stdcall FreeMRUList(long) FreeMRUList
108 153 stdcall AddMRUStringA(long str) AddMRUStringA
109 154 stdcall EnumMRUListA(long long ptr long) EnumMRUListA
110 155 stdcall FindMRUStringA(long str ptr) FindMRUStringA
111 156 stdcall DelMRUString(long long) DelMRUString
112 157 stdcall CreateMRUListLazyA(ptr long long long) CreateMRUListLazyA
114 163 stub CreatePage
115 164 stub CreateProxyPage
117 167 stdcall AddMRUData(long ptr long) AddMRUData
118 169 stdcall FindMRUData(long ptr long ptr) FindMRUData
120 233 stdcall Str_GetPtrA(str str long) Str_GetPtrA
121 234 stdcall Str_SetPtrA(str str) Str_SetPtrA
122 235 stdcall Str_GetPtrW(wstr wstr long) Str_GetPtrW
123 236 stdcall Str_SetPtrW(wstr wstr) Str_SetPtrW
125 320 stdcall DSA_Create(long long) DSA_Create
126 321 stdcall DSA_Destroy(ptr) DSA_Destroy
127 322 stdcall DSA_GetItem(ptr long long) DSA_GetItem
128 323 stdcall DSA_GetItemPtr(ptr long) DSA_GetItemPtr
129 324 stdcall DSA_InsertItem(ptr long long) DSA_InsertItem
130 325 stdcall DSA_SetItem (ptr long long) DSA_SetItem
131 326 stdcall DSA_DeleteItem(ptr long) DSA_DeleteItem
132 327 stdcall DSA_DeleteAllItems(ptr) DSA_DeleteAllItems
133 328 stdcall DPA_Create(long) DPA_Create
134 329 stdcall DPA_Destroy(ptr) DPA_Destroy
135 330 stdcall DPA_Grow(ptr long) DPA_Grow
136 331 stdcall DPA_Clone(ptr ptr) DPA_Clone
137 332 stdcall DPA_GetPtr(ptr long) DPA_GetPtr
138 333 stdcall DPA_GetPtrIndex(ptr ptr) DPA_GetPtrIndex
139 334 stdcall DPA_InsertPtr(ptr long ptr) DPA_InsertPtr
140 335 stdcall DPA_SetPtr(ptr long ptr) DPA_SetPtr
141 336 stdcall DPA_DeletePtr(ptr long) DPA_DeletePtr
142 337 stdcall DPA_DeleteAllPtrs(ptr) DPA_DeleteAllPtrs
143 338 stdcall DPA_Sort(ptr ptr long) DPA_Sort
144 339 stdcall DPA_Search(ptr ptr long ptr long long) DPA_Search
145 340 stdcall DPA_CreateEx(long long) DPA_CreateEx
146 341 stdcall SendNotify(long long long ptr) COMCTL32_SendNotify
147 342 stdcall SendNotifyEx(long long long ptr long) COMCTL32_SendNotifyEx
149 350 stdcall StrChrA(str str) COMCTL32_StrChrA
150 351 stdcall StrRChrA(str str long) COMCTL32_StrRChrA
151 352 stdcall StrCmpNA(str str long) COMCTL32_StrCmpNA
152 353 stdcall StrCmpNIA(str str long) COMCTL32_StrCmpNIA
153 354 stdcall StrStrA(str str) COMCTL32_StrStrA
154 355 stdcall StrStrIA(str str) COMCTL32_StrStrIA
155 356 stdcall StrCSpnA(str str) COMCTL32_StrCSpnA
156 357 stdcall StrToIntA(str) COMCTL32_StrToIntA
157 358 stdcall StrChrW(wstr long) COMCTL32_StrChrW
158 359 stdcall StrRChrW(wstr wstr long) COMCTL32_StrRChrW
159 360 stdcall StrCmpNW(wstr wstr long) COMCTL32_StrCmpNW
160 361 stdcall StrCmpNIW(wstr wstr long) COMCTL32_StrCmpNIW
161 362 stdcall StrStrW(wstr wstr) COMCTL32_StrStrW
162 363 stub StrStrIW
163 364 stdcall StrSpnW(wstr wstr) COMCTL32_StrSpnW
164 365 stdcall StrToIntW(wstr) COMCTL32_StrToIntW
165 366 stub StrChrIA
166 367 stub StrChrIW
167 368 stub StrRChrIA
168 369 stub StrRChrIW
170 372 stub StrRStrIA
171 373 stub StrRStrIW
172 374 stub StrCSpnIA
173 375 stub StrCSpnIW
174 376 stub IntlStrEqWorkerA@16
175 377 stub IntlStrEqWorkerW@16
177 382 stdcall SmoothScrollWindow(ptr) SmoothScrollWindow
178 383 stub DoReaderMode@4
179 384 stub SetPathWordBreakProc@8
180 385 stdcall DPA_EnumCallback(long long long) DPA_EnumCallback
181 386 stdcall DPA_DestroyCallback(ptr ptr long) DPA_DestroyCallback
182 387 stdcall DSA_EnumCallback(ptr ptr long) DSA_EnumCallback
183 388 stdcall DSA_DestroyCallback(ptr ptr long) DSA_DestroyCallback
184 389 stub @
185 390 stub @
187 400 stdcall CreateMRUListW(ptr) CreateMRUListW
188 401 stdcall AddMRUStringW(long wstr) AddMRUStringW
189 402 stdcall FindMRUStringW(long wstr ptr) FindMRUStringW
190 403 stdcall EnumMRUListW(long long ptr long) EnumMRUListW
191 404 stdcall CreateMRUListLazyW(ptr long long long) CreateMRUListLazyW
193 410 stdcall @(long long long long) COMCTL32_410
194 411 stdcall @(long long long) COMCTL32_411
195 412 stdcall @(long long long) COMCTL32_412
196 413 stdcall @(long long long long) COMCTL32_413
197 414 stub @
198 415 stdcall @(long long long long long) COMCTL32_415
199 416 stub @
200 417 stub @
201 418 stub @
202 419 stdcall @(long long long long) COMCTL32_419
203 420 stub @
204 421 stub @