Added winebuild support for generating a .dbg.c file containing the
[wine/multimedia.git] / dlls / mapi32 / mapi32.spec
blobbe82299aba060b75c657466f686f81056652141f
1 name mapi32
3 @ stub BMAPIAddress
4 @ stub BMAPIDetails
5 @ stub BMAPIFindNext
6 @ stub BMAPIGetAddress
7 @ stub BMAPIGetReadMail
8 @ stub BMAPIReadMail
9 @ stub BMAPIResolveName
10 @ stub BMAPISaveMail
11 @ stub BMAPISendMail
12 @ stub BuildDisplayTable@40
13 @ stub CbOfEncoded@4
14 @ stub CchOfEncoding@4
15 @ stub ChangeIdleRoutine@28
16 @ stub CloseIMsgSession@4
17 @ stub CreateIProp@24
18 @ stub CreateTable@36
19 @ stub DeinitMapiUtil@0
20 @ stub DeregisterIdleRoutine@4
21 @ stub DllCanUnloadNow
22 @ stub DllGetClassObject
23 @ stub EnableIdleRoutine@8
24 @ stub EncodeID@12
25 @ stub FBadColumnSet@4
26 @ stub FBadEntryList@4
27 @ stub FBadProp@4
28 @ stub FBadPropTag@4
29 @ stub FBadRestriction@4
30 @ stub FBadRglpNameID@8
31 @ stub FBadRglpszA@8
32 @ stub FBadRglpszW@8
33 @ stub FBadRow@4
34 @ stub FBadRowSet@4
35 @ stub FBadSortOrderSet@4
36 @ stub FBinFromHex@8
37 @ stub FDecodeID@12
38 @ stub FEqualNames@8
39 @ stub FGetComponentPath
40 # @ stub FGetComponentPath@20
41 @ stub FPropCompareProp@12
42 @ stub FPropContainsProp@12
43 @ stub FPropExists@8
44 @ stub FixMAPI
45 # @ stub FixMAPI@0
46 @ stub FreePadrlist@4
47 @ stub FreeProws@4
48 @ stub FtAdcFt@20
49 @ stub FtAddFt@16
50 @ stub FtDivFtBogus@20
51 @ stub FtMulDw@12
52 @ stub FtMulDwDw@8
53 @ stub FtNegFt@8
54 @ stub FtSubFt@16
55 @ stub FtgRegisterIdleRoutine@20
56 @ stub GetAttribIMsgOnIStg@12
57 @ stub GetOutlookVersion
58 # @ stub GetOutlookVersion@0
59 @ stub GetTnefStreamCodepage
60 # @ stub GetTnefStreamCodepage@12
61 @ stub HexFromBin@12
62 @ stub HrAddColumns@16
63 @ stub HrAddColumnsEx@20
64 @ stub HrAllocAdviseSink@12
65 @ stub HrComposeEID@28
66 @ stub HrComposeMsgID@24
67 @ stub HrDecomposeEID@28
68 @ stub HrDecomposeMsgID@24
69 @ stub HrDispatchNotifications@4
70 @ stub HrEntryIDFromSz@12
71 @ stub HrGetOmiProvidersFlags
72 # @ stub HrGetOmiProvidersFlags@8
73 @ stub HrGetOneProp@12
74 @ stub HrIStorageFromStream@16
75 @ stub HrQueryAllRows@24
76 @ stub HrSetOmiProvidersFlagsInvalid
77 # @ stub HrSetOmiProvidersFlagsInvalid@4
78 @ stub HrSetOneProp@8
79 @ stub HrSzFromEntryID@12
80 @ stub HrThisThreadAdviseSink@8
81 @ stub HrValidateIPMSubtree@20
82 @ stub HrValidateParameters@8
83 @ stub InstallFilterHook@4
84 @ stub IsBadBoundedStringPtr@8
85 @ stub LAUNCHWIZARD
86 @ stub LPropCompareProp@8
87 @ stub LaunchWizard@20
88 @ stub LpValFindProp@12
89 @ stub MAPIAddress
90 @ stub MAPIAdminProfiles
91 # @ stub MAPIAdminProfiles@8
92 @ stdcall MAPIAllocateBuffer(long ptr) MAPIAllocateBuffer
93 # @ stub MAPIAllocateBuffer@8
94 @ stub MAPIAllocateMore
95 # @ stub MAPIAllocateMore@12
96 @ stub MAPIDeinitIdle@0
97 @ stub MAPIDeleteMail
98 @ stub MAPIDetails
99 @ stub MAPIFindNext
100 @ stub MAPIFreeBuffer
101 # @ stub MAPIFreeBuffer@4
102 @ stub MAPIGetDefaultMalloc@0
103 @ stub MAPIInitIdle@4
104 @ stdcall MAPIInitialize(ptr) MAPIInitialize
105 # @ stub MAPIInitialize@4
106 @ stub MAPILogoff
107 @ stdcall MAPILogon(long ptr ptr long long ptr) MAPILogon
108 @ stdcall MAPILogonEx(long ptr ptr long ptr) MAPILogonEx
109 # @ stub MAPILogonEx@20
110 @ stub MAPIOpenFormMgr
111 # @ stub MAPIOpenFormMgr@8
112 @ stub MAPIOpenLocalFormContainer
113 # @ stub MAPIOpenLocalFormContainer@4
114 @ stub MAPIReadMail
115 @ stub MAPIResolveName
116 @ stub MAPISaveMail
117 @ stub MAPISendDocuments
118 @ stub MAPISendMail
119 @ stdcall MAPIUninitialize() MAPIUninitialize
120 # @ stub MAPIUninitialize@0
121 @ stub MNLS_CompareStringW@24
122 @ stub MNLS_IsBadStringPtrW@8
123 @ stub MNLS_MultiByteToWideChar@24
124 @ stub MNLS_WideCharToMultiByte@32
125 @ stub MNLS_lstrcmpW@8
126 @ stub MNLS_lstrcpyW@8
127 @ stub MNLS_lstrlenW@4
128 @ stub MapStorageSCode@4
129 @ stub OpenIMsgOnIStg@44
130 @ stub OpenIMsgSession@12
131 @ stub OpenStreamOnFile
132 # @ stub OpenStreamOnFile@24
133 @ stub OpenTnefStream
134 # @ stub OpenTnefStream@28
135 @ stub OpenTnefStreamEx
136 # @ stub OpenTnefStreamEx@32
137 @ stub PRProviderInit
138 @ stub PpropFindProp@12
139 @ stub PropCopyMore@16
140 @ stub RTFSync
141 # @ stub RTFSync@12
142 @ stub ScBinFromHexBounded@12
143 @ stub ScCopyNotifications@16
144 @ stub ScCopyProps@16
145 @ stub ScCountNotifications@12
146 @ stub ScCountProps@12
147 @ stub ScCreateConversationIndex@16
148 @ stub ScDupPropset@16
149 @ stub ScGenerateMuid@4
150 @ stub ScInitMapiUtil@4
151 @ stub ScLocalPathFromUNC@12
152 @ stub ScMAPIXFromCMC
153 @ stub ScMAPIXFromSMAPI
154 @ stub ScRelocNotifications@20
155 @ stub ScRelocProps@20
156 @ stub ScUNCFromLocalPath@12
157 @ stub SetAttribIMsgOnIStg@16
158 @ stub SwapPlong@8
159 @ stub SwapPword@8
160 @ stub SzFindCh@8
161 @ stub SzFindLastCh@8
162 @ stub SzFindSz@8
163 @ stub UFromSz@4
164 @ stub UNKOBJ_COFree@8
165 @ stub UNKOBJ_Free@8
166 @ stub UNKOBJ_FreeRows@8
167 @ stub UNKOBJ_ScAllocate@12
168 @ stub UNKOBJ_ScAllocateMore@16
169 @ stub UNKOBJ_ScCOAllocate@12
170 @ stub UNKOBJ_ScCOReallocate@12
171 @ stub UNKOBJ_ScSzFromIdsAlloc@20
172 @ stub UlAddRef@4
173 @ stub UlFromSzHex@4
174 @ stub UlPropSize@4
175 @ stub UlRelease@4
176 @ stub WrapCompressedRTFStream
177 # @ stub WrapCompressedRTFStream@12
178 @ stub WrapProgress@20
179 @ stub WrapStoreEntryID@24
180 @ stub __CPPValidateParameters@8
181 @ stub __ValidateParameters@8
182 @ stub cmc_act_on
183 @ stub cmc_free
184 @ stub cmc_list
185 @ stub cmc_logoff
186 @ stub cmc_logon
187 @ stub cmc_look_up
188 @ stub cmc_query_configuration
189 @ stub cmc_read
190 @ stub cmc_send
191 @ stub cmc_send_documents