Added winebuild support for generating a .dbg.c file containing the
[wine/multimedia.git] / dlls / ddraw / ddraw.spec
blob0f98a0730146a41872566fe60934275e321243db
1 name ddraw
2 init DDRAW_DllMain
4 @ stub DDHAL32_VidMemAlloc
5 @ stub DDHAL32_VidMemFree
6 @ stub DDInternalLock
7 @ stub DDInternalUnlock
8 @ stub DSoundHelp
9 @ stdcall DirectDrawCreate(ptr ptr ptr) DirectDrawCreate
10 @ stdcall DirectDrawCreateClipper(long ptr ptr) DirectDrawCreateClipper
11 @ stdcall DirectDrawCreateEx(ptr ptr ptr ptr) DirectDrawCreateEx
12 @ stdcall DirectDrawEnumerateA(ptr ptr) DirectDrawEnumerateA
13 @ stdcall DirectDrawEnumerateW(ptr ptr) DirectDrawEnumerateW
14 @ stdcall DirectDrawEnumerateExA(ptr ptr long) DirectDrawEnumerateExA
15 @ stdcall DirectDrawEnumerateExW(ptr ptr long) DirectDrawEnumerateExW
16 @ stdcall DllCanUnloadNow() DDRAW_DllCanUnloadNow
17 @ stdcall DllGetClassObject(ptr ptr ptr) DDRAW_DllGetClassObject
18 @ stub GetNextMipMap
19 @ stub GetSurfaceFromDC
20 @ stub HeapVidMemAllocAligned
21 @ stub InternalLock
22 @ stub InternalUnlock
23 @ stub LateAllocateSurfaceMem
24 @ stub VidMemAlloc
25 @ stub VidMemAmountFree
26 @ stub VidMemFini
27 @ stub VidMemFree
28 @ stub VidMemInit
29 @ stub VidMemLargestFree
30 @ stub thk1632_ThunkData32
31 @ stub thk3216_ThunkData32