Avoid going past the end of the relocation section. Skip sanity checks
[wine/multimedia.git] / dlls / crtdll / crtdll.spec
blob12b0c5ddee61f08a6c2c92178f6f54278218226c
1 # C RunTime DLL. All functions use cdecl!
2 name crtdll
3 type win32
4 init CRTDLL_Init
6 import kernel32.dll
7 import ntdll.dll
9 @ cdecl ??2@YAPAXI@Z(long) CRTDLL_new
10 @ cdecl ??3@YAXPAX@Z(long) CRTDLL_delete
11 @ cdecl ?_set_new_handler@@YAP6AHI@ZP6AHI@Z@Z(ptr) CRTDLL_set_new_handler
12 @ stub _CIacos
13 @ stub _CIasin
14 @ stub _CIatan
15 @ stub _CIatan2
16 @ stub _CIcos
17 @ stub _CIcosh
18 @ stub _CIexp
19 @ stub _CIfmod
20 @ stub _CIlog
21 @ stub _CIlog10
22 @ forward _CIpow ntdll._CIpow
23 @ stub _CIsin
24 @ stub _CIsinh
25 @ stub _CIsqrt
26 @ stub _CItan
27 @ stub _CItanh
28 @ stub _HUGE_dll
29 @ stub _XcptFilter
30 @ cdecl __GetMainArgs(ptr ptr ptr long) CRTDLL__GetMainArgs
31 @ extern __argc_dll CRTDLL_argc_dll
32 @ extern __argv_dll CRTDLL_argv_dll
33 @ cdecl __dllonexit() CRTDLL___dllonexit
34 @ stub __doserrno
35 @ stub __fpecode
36 @ stub __isascii
37 @ stub __iscsym
38 @ stub __iscsymf
39 @ stub __mb_cur_max_dll
40 @ stub __pxcptinfoptrs
41 @ cdecl __threadhandle() GetCurrentThread
42 @ cdecl __threadid() GetCurrentThreadId
43 @ stub __toascii
44 @ cdecl _abnormal_termination() CRTDLL__abnormal_termination
45 @ cdecl _access(str long) CRTDLL__access
46 @ extern _acmdln_dll CRTDLL_acmdln_dll
47 @ stub _aexit_rtn_dll
48 @ stub _amsg_exit
49 @ stub _assert
50 @ extern _basemajor_dll CRTDLL_basemajor_dll
51 @ extern _baseminor_dll CRTDLL_baseminor_dll
52 @ extern _baseversion_dll CRTDLL_baseversion_dll
53 @ stub _beep
54 @ stub _beginthread
55 @ stub _c_exit
56 @ stub _cabs
57 @ cdecl _cexit(long) CRTDLL__cexit
58 @ stub _cgets
59 @ cdecl _chdir(str) CRTDLL__chdir
60 @ cdecl _chdrive(long) CRTDLL__chdrive
61 @ stub _chgsign
62 @ stub _chmod
63 @ stub _chsize
64 @ stub _clearfp
65 @ cdecl _close(long) CRTDLL__close
66 @ stub _commit
67 @ extern _commode_dll CRTDLL_commode_dll
68 @ stub _control87
69 @ stub _controlfp
70 @ stub _copysign
71 @ stub _cprintf
72 @ stub _cpumode_dll
73 @ stub _cputs
74 @ stub _creat
75 @ stub _cscanf
76 @ stub _ctype
77 @ stub _cwait
78 @ stub _daylight_dll
79 @ stub _dup
80 @ stub _dup2
81 @ stub _ecvt
82 @ stub _endthread
83 @ extern _environ_dll CRTDLL_environ_dll
84 @ stub _eof
85 @ cdecl _errno() CRTDLL__errno
86 @ cdecl _except_handler2(ptr ptr ptr ptr) CRTDLL__except_handler2
87 @ stub _execl
88 @ stub _execle
89 @ stub _execlp
90 @ stub _execlpe
91 @ stub _execv
92 @ stub _execve
93 @ stub _execvp
94 @ stub _execvpe
95 @ stub _exit
96 @ stub _expand
97 @ stub _fcloseall
98 @ stub _fcvt
99 @ cdecl _fdopen(long ptr) CRTDLL__fdopen
100 @ stub _fgetchar
101 @ stub _fgetwchar
102 @ stub _filbuf
103 @ stub _fileinfo_dll
104 @ stub _filelength
105 @ stub _fileno
106 @ stub _findclose
107 @ cdecl _findfirst(str ptr) CRTDLL__findfirst
108 @ cdecl _findnext(long ptr) CRTDLL__findnext
109 @ stub _finite
110 @ stub _flsbuf
111 @ stub _flushall
112 @ extern _fmode_dll CRTDLL_fmode_dll
113 @ stub _fpclass
114 @ stub _fpieee_flt
115 @ cdecl _fpreset() CRTDLL__fpreset
116 @ stub _fputchar
117 @ stub _fputwchar
118 @ cdecl _fsopen(str str long) CRTDLL__fsopen
119 @ cdecl _fstat(long ptr) CRTDLL__fstat
120 @ stub _ftime
121 @ forward _ftol ntdll._ftol
122 @ cdecl _fullpath(ptr str long) CRTDLL__fullpath
123 @ stub _futime
124 @ stub _gcvt
125 @ stub _get_osfhandle
126 @ stub _getch
127 @ stub _getche
128 @ cdecl _getcwd(ptr long) CRTDLL__getcwd
129 @ cdecl _getdcwd(long ptr long) CRTDLL__getdcwd
130 @ stub _getdiskfree
131 @ stub _getdllprocaddr
132 @ cdecl _getdrive() CRTDLL__getdrive
133 @ stub _getdrives
134 @ stub _getpid
135 @ stub _getsystime
136 @ stub _getw
137 @ cdecl _global_unwind2(ptr) CRTDLL__global_unwind2
138 @ stub _heapchk
139 @ stub _heapmin
140 @ stub _heapset
141 @ stub _heapwalk
142 @ cdecl _hypot(double double) hypot
143 @ cdecl _initterm(ptr ptr) CRTDLL__initterm
144 @ extern _iob CRTDLL_iob
145 @ cdecl _isatty(long) CRTDLL__isatty
146 @ cdecl _isctype(long long) CRTDLL__isctype
147 @ stub _ismbbalnum
148 @ stub _ismbbalpha
149 @ stub _ismbbgraph
150 @ stub _ismbbkalnum
151 @ stub _ismbbkana
152 @ stub _ismbbkpunct
153 @ stub _ismbblead
154 @ stub _ismbbprint
155 @ stub _ismbbpunct
156 @ stub _ismbbtrail
157 @ stub _ismbcalpha
158 @ stub _ismbcdigit
159 @ stub _ismbchira
160 @ stub _ismbckata
161 @ stub _ismbcl0
162 @ stub _ismbcl1
163 @ stub _ismbcl2
164 @ stub _ismbclegal
165 @ stub _ismbclower
166 @ stub _ismbcprint
167 @ stub _ismbcspace
168 @ stub _ismbcsymbol
169 @ stub _ismbcupper
170 @ stub _ismbslead
171 @ stub _ismbstrail
172 @ stub _isnan
173 @ forward _itoa ntdll._itoa
174 @ stub _itow
175 @ cdecl _j0(double) j0
176 @ cdecl _j1(double) j1
177 @ cdecl _jn(long double) jn
178 @ stub _kbhit
179 @ stub _lfind
180 @ stub _loaddll
181 @ cdecl _local_unwind2(ptr long) CRTDLL__local_unwind2
182 @ stub _locking
183 @ stub _logb
184 @ cdecl _lrotl (long long) CRTDLL__lrotl
185 @ stub _lrotr
186 @ stub _lsearch
187 @ cdecl _lseek(long long long) CRTDLL__lseek
188 @ forward _ltoa ntdll._ltoa
189 @ stub _ltow
190 @ cdecl _makepath (ptr str str str str) CRTDLL__makepath
191 @ stub _matherr
192 @ stub _mbbtombc
193 @ stub _mbbtype
194 @ stub _mbccpy
195 @ stub _mbcjistojms
196 @ stub _mbcjmstojis
197 @ stub _mbclen
198 @ stub _mbctohira
199 @ stub _mbctokata
200 @ stub _mbctolower
201 @ stub _mbctombb
202 @ stub _mbctoupper
203 @ stub _mbctype
204 @ stub _mbsbtype
205 @ cdecl _mbscat(str str) strcat
206 @ stub _mbschr
207 @ stub _mbscmp
208 @ cdecl _mbscpy(ptr str) strcpy
209 @ stub _mbscspn
210 @ stub _mbsdec
211 @ cdecl _mbsdup(str) CRTDLL__strdup
212 @ cdecl _mbsicmp(str str) CRTDLL__mbsicmp
213 @ cdecl _mbsinc(str) CRTDLL__mbsinc
214 @ cdecl _mbslen(str) CRTDLL__mbslen
215 @ stub _mbslwr
216 @ stub _mbsnbcat
217 @ stub _mbsnbcmp
218 @ stub _mbsnbcnt
219 @ stub _mbsnbcpy
220 @ stub _mbsnbicmp
221 @ stub _mbsnbset
222 @ stub _mbsncat
223 @ stub _mbsnccnt
224 @ stub _mbsncmp
225 @ stub _mbsncpy
226 @ stub _mbsnextc
227 @ stub _mbsnicmp
228 @ stub _mbsninc
229 @ stub _mbsnset
230 @ stub _mbspbrk
231 @ cdecl _mbsrchr(str long) CRTDLL__mbsrchr
232 @ stub _mbsrev
233 @ stub _mbsset
234 @ stub _mbsspn
235 @ stub _mbsspnp
236 @ stub _mbsstr
237 @ stub _mbstok
238 @ stub _mbstrlen
239 @ stub _mbsupr
240 @ stub _memccpy
241 @ forward _memicmp ntdll._memicmp
242 @ cdecl _mkdir(str) CRTDLL__mkdir
243 @ stub _mktemp
244 @ stub _msize
245 @ stub _nextafter
246 @ stub _onexit
247 @ cdecl _open(str long) CRTDLL__open
248 @ cdecl _open_osfhandle(long long) CRTDLL__open_osfhandle
249 @ extern _osmajor_dll CRTDLL_osmajor_dll
250 @ extern _osminor_dll CRTDLL_osminor_dll
251 @ extern _osmode_dll CRTDLL_osmode_dll
252 @ extern _osver_dll CRTDLL_osver_dll
253 @ extern _osversion_dll CRTDLL_osversion_dll
254 @ stub _pclose
255 @ stub _pctype_dll
256 @ stub _pgmptr_dll
257 @ stub _pipe
258 @ stub _popen
259 @ stub _purecall
260 @ stub _putch
261 @ stub _putenv
262 @ stub _putw
263 @ stub _pwctype_dll
264 @ cdecl _read(long ptr long) CRTDLL__read
265 @ stub _rmdir
266 @ stub _rmtmp
267 @ cdecl _rotl (long long) CRTDLL__rotl
268 @ stub _rotr
269 @ stub _scalb
270 @ stub _searchenv
271 @ stub _seterrormode
272 @ cdecl _setjmp (ptr) CRTDLL__setjmp
273 @ cdecl _setmode(long long) CRTDLL__setmode
274 @ stub _setsystime
275 @ cdecl _sleep(long) CRTDLL__sleep
276 @ stub _snprintf
277 @ stub _snwprintf
278 @ stub _sopen
279 @ stub _spawnl
280 @ stub _spawnle
281 @ stub _spawnlp
282 @ stub _spawnlpe
283 @ stub _spawnv
284 @ stub _spawnve
285 @ stub _spawnvp
286 @ stub _spawnvpe
287 @ cdecl _splitpath (str ptr ptr ptr ptr) CRTDLL__splitpath
288 @ cdecl _stat (str ptr) CRTDLL__stat
289 @ stub _statusfp
290 @ cdecl _strcmpi(str str) strcasecmp
291 @ cdecl _strdate(str) CRTDLL__strdate
292 @ stub _strdec
293 @ cdecl _strdup(str) CRTDLL__strdup
294 @ stub _strerror
295 @ cdecl _stricmp(str str) strcasecmp
296 @ stub _stricoll
297 @ stub _strinc
298 @ forward _strlwr ntdll._strlwr
299 @ stub _strncnt
300 @ stub _strnextc
301 @ cdecl _strnicmp(str str long) strncasecmp
302 @ stub _strninc
303 @ stub _strnset
304 @ stub _strrev
305 @ stub _strset
306 @ stub _strspnp
307 @ cdecl _strtime(str) CRTDLL__strtime
308 @ forward _strupr ntdll._strupr
309 @ stub _swab
310 @ stub _sys_errlist
311 @ stub _sys_nerr_dll
312 @ stub _tell
313 @ cdecl _tempnam(str ptr) CRTDLL__tempnam
314 @ stub _timezone_dll
315 @ stub _tolower
316 @ stub _toupper
317 @ stub _tzname
318 @ stub _tzset
319 @ forward _ultoa ntdll._ultoa
320 @ stub _ultow
321 @ stub _umask
322 @ stub _ungetch
323 @ cdecl _unlink(str) CRTDLL__unlink
324 @ stub _unloaddll
325 @ stub _utime
326 @ cdecl _vsnprintf(ptr long ptr ptr) vsnprintf
327 @ stub _vsnwprintf
328 @ cdecl _wcsdup(wstr) CRTDLL__wcsdup
329 @ forward _wcsicmp ntdll._wcsicmp
330 @ cdecl _wcsicoll(wstr wstr) CRTDLL__wcsicoll
331 @ forward _wcslwr ntdll._wcslwr
332 @ forward _wcsnicmp ntdll._wcsnicmp
333 @ cdecl _wcsnset(wstr long long) CRTDLL__wcsnset
334 @ cdecl _wcsrev(wstr) CRTDLL__wcsrev
335 @ cdecl _wcsset(wstr long) CRTDLL__wcsset
336 @ forward _wcsupr ntdll._wcsupr
337 @ extern _winmajor_dll CRTDLL_winmajor_dll
338 @ extern _winminor_dll CRTDLL_winminor_dll
339 @ extern _winver_dll CRTDLL_winver_dll
340 @ cdecl _write(long ptr long) CRTDLL__write
341 @ stub _wtoi
342 @ stub _wtol
343 @ cdecl _y0(double) y0
344 @ cdecl _y1(double) y1
345 @ cdecl _yn(long double) yn
346 @ stub abort
347 @ cdecl abs(long) abs
348 @ cdecl acos(double) acos
349 @ cdecl asctime(ptr) asctime
350 @ cdecl asin(double) asin
351 @ cdecl atan(double) atan
352 @ cdecl atan2(double double) atan2
353 @ cdecl atexit(ptr) CRTDLL_atexit
354 @ cdecl atof(str) atof
355 @ cdecl atoi(str) atoi
356 @ cdecl atol(str) atol
357 @ cdecl bsearch(ptr ptr long long ptr) bsearch
358 @ cdecl calloc(long long) CRTDLL_calloc
359 @ cdecl ceil(double) ceil
360 @ stub clearerr
361 @ cdecl clock() CRTDLL_clock
362 @ cdecl cos(double) cos
363 @ cdecl cosh(double) cosh
364 @ cdecl ctime(ptr) ctime
365 @ cdecl difftime(long long) CRTDLL_difftime
366 @ cdecl div(long long) div
367 @ cdecl exit(long) CRTDLL_exit
368 @ cdecl exp(double) exp
369 @ cdecl fabs(double) fabs
370 @ cdecl fclose(ptr) CRTDLL_fclose
371 @ cdecl feof(ptr) CRTDLL_feof
372 @ stub ferror
373 @ cdecl fflush(ptr) CRTDLL_fflush
374 @ cdecl fgetc(ptr) CRTDLL_fgetc
375 @ stub fgetpos
376 @ cdecl fgets(ptr long ptr) CRTDLL_fgets
377 @ stub fgetwc
378 @ cdecl floor(double) floor
379 @ cdecl fmod(double double) fmod
380 @ cdecl fopen(str str) CRTDLL_fopen
381 @ varargs fprintf(ptr str) CRTDLL_fprintf
382 @ cdecl fputc(long ptr) CRTDLL_fputc
383 @ cdecl fputs(str ptr) CRTDLL_fputs
384 @ stub fputwc
385 @ cdecl fread(ptr long long ptr) CRTDLL_fread
386 @ cdecl free(ptr) CRTDLL_free
387 @ cdecl freopen(str str ptr) CRTDLL_freopen
388 @ cdecl frexp(double ptr) frexp
389 @ varargs fscanf(ptr str) CRTDLL_fscanf
390 @ cdecl fseek(ptr long long) CRTDLL_fseek
391 @ cdecl fsetpos(ptr ptr) CRTDLL_fsetpos
392 @ cdecl ftell(ptr) CRTDLL_ftell
393 @ stub fwprintf
394 @ cdecl fwrite(ptr long long ptr) CRTDLL_fwrite
395 @ stub fwscanf
396 @ cdecl getc(ptr) CRTDLL_getc
397 @ stub getchar
398 @ cdecl getenv (str) CRTDLL_getenv
399 @ cdecl gets(ptr) CRTDLL_gets
400 @ cdecl gmtime(ptr) gmtime
401 @ stub is_wctype
402 @ cdecl isalnum(long) isalnum
403 @ cdecl isalpha(long) isalpha
404 @ cdecl iscntrl(long) iscntrl
405 @ cdecl isdigit(long) isdigit
406 @ cdecl isgraph(long) isgraph
407 @ stub isleadbyte
408 @ cdecl islower(long) islower
409 @ cdecl isprint(long) isprint
410 @ cdecl ispunct(long) ispunct
411 @ cdecl isspace(long) isspace
412 @ cdecl isupper(long) isupper
413 @ cdecl iswalnum(long) CRTDLL_iswalnum
414 @ forward iswalpha ntdll.iswalpha
415 @ stub iswascii
416 @ cdecl iswcntrl(long) CRTDLL_iswcntrl
417 @ forward iswctype ntdll.iswctype
418 @ cdecl iswdigit(long) CRTDLL_iswdigit
419 @ cdecl iswgraph(long) CRTDLL_iswgraph
420 @ cdecl iswlower(long) CRTDLL_iswlower
421 @ cdecl iswprint(long) CRTDLL_iswprint
422 @ cdecl iswpunct(long) CRTDLL_iswpunct
423 @ cdecl iswspace(long) CRTDLL_iswspace
424 @ cdecl iswupper(long) CRTDLL_iswupper
425 @ cdecl iswxdigit(long) CRTDLL_iswxdigit
426 @ cdecl isxdigit(long) isxdigit
427 @ cdecl labs(long) labs
428 @ cdecl ldexp(double long) ldexp
429 @ cdecl ldiv(long long) ldiv
430 @ stub localeconv
431 @ cdecl localtime(ptr) localtime
432 @ cdecl log(double) log
433 @ cdecl log10(double) log10
434 @ cdecl longjmp(ptr long) CRTDLL_longjmp
435 @ cdecl malloc(ptr) CRTDLL_malloc
436 @ cdecl mblen(str long) mblen
437 @ forward mbstowcs ntdll.mbstowcs
438 @ cdecl mbtowc(ptr ptr long) CRTDLL_mbtowc
439 @ cdecl memchr(ptr long long) memchr
440 @ cdecl memcmp(ptr ptr long) memcmp
441 @ cdecl memcpy(ptr ptr long) memcpy
442 @ cdecl memmove(ptr ptr long) memmove
443 @ cdecl memset(ptr long long) memset
444 @ cdecl mktime(ptr) mktime
445 @ cdecl modf(double ptr) modf
446 @ stub perror
447 @ cdecl pow(double double) pow
448 @ varargs printf() printf
449 @ cdecl putc(long ptr) CRTDLL_putc
450 @ cdecl putchar(long) CRTDLL_putchar
451 @ cdecl puts(str) CRTDLL_puts
452 @ cdecl qsort(ptr long long ptr) qsort
453 @ stub raise
454 @ cdecl rand() CRTDLL_rand
455 @ cdecl realloc(ptr long) CRTDLL_realloc
456 @ cdecl remove(str) CRTDLL_remove
457 @ cdecl rename(str str) CRTDLL_rename
458 @ stub rewind
459 @ stub scanf
460 @ cdecl setbuf(ptr ptr) CRTDLL_setbuf
461 @ cdecl setlocale(long ptr) CRTDLL_setlocale
462 @ stub setvbuf
463 @ cdecl signal(long ptr) CRTDLL_signal
464 @ cdecl sin(double) sin
465 @ cdecl sinh(double) sinh
466 @ varargs sprintf() sprintf
467 @ cdecl sqrt(double) sqrt
468 @ cdecl srand(long) CRTDLL_srand
469 @ varargs sscanf() sscanf
470 @ cdecl strcat(str str) strcat
471 @ cdecl strchr(str long) strchr
472 @ cdecl strcmp(str str) strcmp
473 @ cdecl strcoll(str str) strcoll
474 @ cdecl strcpy(ptr str) strcpy
475 @ cdecl strcspn(str str) strcspn
476 @ cdecl strerror(long) strerror
477 @ cdecl strftime(ptr long str ptr) strftime
478 @ cdecl strlen(str) strlen
479 @ cdecl strncat(str str long) strncat
480 @ cdecl strncmp(str str long) strncmp
481 @ cdecl strncpy(ptr str long) strncpy
482 @ cdecl strpbrk(str str) strpbrk
483 @ cdecl strrchr(str long) strrchr
484 @ cdecl strspn(str str) strspn
485 @ cdecl strstr(str str) strstr
486 @ cdecl strtod(str ptr) strtod
487 @ cdecl strtok(str str) strtok
488 @ cdecl strtol(str ptr long) strtol
489 @ cdecl strtoul(str ptr long) strtoul
490 @ cdecl strxfrm(ptr str long) strxfrm
491 @ varargs swprintf(wstr wstr) wsprintfW
492 @ stub swscanf
493 @ cdecl system(str) CRTDLL_system
494 @ cdecl tan(double) tan
495 @ cdecl tanh(double) tanh
496 @ cdecl time(ptr) CRTDLL_time
497 @ stub tmpfile
498 @ cdecl tmpnam(str) CRTDLL_tmpnam
499 @ cdecl tolower(long) tolower
500 @ cdecl toupper(long) toupper
501 @ forward towlower ntdll.towlower
502 @ forward towupper ntdll.towupper
503 @ stub ungetc
504 @ stub ungetwc
505 @ cdecl vfprintf(ptr str ptr) CRTDLL_vfprintf
506 @ stub vfwprintf
507 @ stub vprintf
508 @ cdecl vsprintf(ptr str ptr) vsprintf
509 @ cdecl vswprintf(ptr wstr ptr) CRTDLL_vswprintf
510 @ stub vwprintf
511 @ forward wcscat ntdll.wcscat
512 @ forward wcschr ntdll.wcschr
513 @ forward wcscmp ntdll.wcscmp
514 @ cdecl wcscoll(wstr wstr) CRTDLL_wcscoll
515 @ forward wcscpy ntdll.wcscpy
516 @ forward wcscspn ntdll.wcscspn
517 @ stub wcsftime
518 @ forward wcslen ntdll.wcslen
519 @ forward wcsncat ntdll.wcsncat
520 @ forward wcsncmp ntdll.wcsncmp
521 @ forward wcsncpy ntdll.wcsncpy
522 @ cdecl wcspbrk(wstr wstr) CRTDLL_wcspbrk
523 @ forward wcsrchr ntdll.wcsrchr
524 @ forward wcsspn ntdll.wcsspn
525 @ forward wcsstr ntdll.wcsstr
526 @ stub wcstod
527 @ forward wcstok ntdll.wcstok
528 @ forward wcstol ntdll.wcstol
529 @ forward wcstombs ntdll.wcstombs
530 @ stub wcstoul
531 @ stub wcsxfrm
532 @ cdecl wctomb(ptr long) CRTDLL_wctomb
533 @ stub wprintf
534 @ stub wscanf