TESTING -- override pthreads to fix gstreamer v5
[wine/multimedia.git] / dlls / vcomp / vcomp.spec
blob7703e2ed5a1d104b4c4457305bf0665903ded9e2
1 @ stub _vcomp_atomic_add_i1
2 @ stub _vcomp_atomic_add_i2
3 @ cdecl _vcomp_atomic_add_i4(ptr long)
4 @ stub _vcomp_atomic_add_i8
5 @ cdecl _vcomp_atomic_add_r4(ptr float)
6 @ cdecl _vcomp_atomic_add_r8(ptr double)
7 @ stub _vcomp_atomic_and_i1
8 @ stub _vcomp_atomic_and_i2
9 @ cdecl _vcomp_atomic_and_i4(ptr long)
10 @ stub _vcomp_atomic_and_i8
11 @ stub _vcomp_atomic_div_i1
12 @ stub _vcomp_atomic_div_i2
13 @ cdecl _vcomp_atomic_div_i4(ptr long)
14 @ stub _vcomp_atomic_div_i8
15 @ cdecl _vcomp_atomic_div_r4(ptr float)
16 @ cdecl _vcomp_atomic_div_r8(ptr double)
17 @ stub _vcomp_atomic_div_ui1
18 @ stub _vcomp_atomic_div_ui2
19 @ cdecl _vcomp_atomic_div_ui4(ptr long)
20 @ stub _vcomp_atomic_div_ui8
21 @ stub _vcomp_atomic_mul_i1
22 @ stub _vcomp_atomic_mul_i2
23 @ cdecl _vcomp_atomic_mul_i4(ptr long)
24 @ stub _vcomp_atomic_mul_i8
25 @ cdecl _vcomp_atomic_mul_r4(ptr float)
26 @ cdecl _vcomp_atomic_mul_r8(ptr double)
27 @ stub _vcomp_atomic_or_i1
28 @ stub _vcomp_atomic_or_i2
29 @ cdecl _vcomp_atomic_or_i4(ptr long)
30 @ stub _vcomp_atomic_or_i8
31 @ stub _vcomp_atomic_shl_i1
32 @ stub _vcomp_atomic_shl_i2
33 @ cdecl _vcomp_atomic_shl_i4(ptr long)
34 @ stub _vcomp_atomic_shl_i8
35 @ stub _vcomp_atomic_shr_i1
36 @ stub _vcomp_atomic_shr_i2
37 @ cdecl _vcomp_atomic_shr_i4(ptr long)
38 @ stub _vcomp_atomic_shr_i8
39 @ stub _vcomp_atomic_shr_ui1
40 @ stub _vcomp_atomic_shr_ui2
41 @ cdecl _vcomp_atomic_shr_ui4(ptr long)
42 @ stub _vcomp_atomic_shr_ui8
43 @ stub _vcomp_atomic_sub_i1
44 @ stub _vcomp_atomic_sub_i2
45 @ cdecl _vcomp_atomic_sub_i4(ptr long)
46 @ stub _vcomp_atomic_sub_i8
47 @ cdecl _vcomp_atomic_sub_r4(ptr float)
48 @ cdecl _vcomp_atomic_sub_r8(ptr double)
49 @ stub _vcomp_atomic_xor_i1
50 @ stub _vcomp_atomic_xor_i2
51 @ cdecl _vcomp_atomic_xor_i4(ptr long)
52 @ stub _vcomp_atomic_xor_i8
53 @ cdecl _vcomp_barrier()
54 @ stub _vcomp_copyprivate_broadcast
55 @ stub _vcomp_copyprivate_receive
56 @ cdecl _vcomp_enter_critsect(ptr)
57 @ cdecl _vcomp_flush()
58 @ cdecl _vcomp_for_dynamic_init(long long long long long)
59 @ stub _vcomp_for_dynamic_init_i8
60 @ cdecl _vcomp_for_dynamic_next(ptr ptr)
61 @ stub _vcomp_for_dynamic_next_i8
62 @ cdecl _vcomp_for_static_end()
63 @ cdecl _vcomp_for_static_init(long long long long ptr ptr ptr ptr ptr)
64 @ stub _vcomp_for_static_init_i8
65 @ cdecl _vcomp_for_static_simple_init(long long long long ptr ptr)
66 @ stub _vcomp_for_static_simple_init_i8
67 @ varargs _vcomp_fork(long long ptr)
68 @ cdecl _vcomp_get_thread_num()
69 @ cdecl _vcomp_leave_critsect(ptr)
70 @ stub _vcomp_master_barrier
71 @ cdecl _vcomp_master_begin()
72 @ cdecl _vcomp_master_end()
73 @ stub _vcomp_ordered_begin
74 @ stub _vcomp_ordered_end
75 @ stub _vcomp_ordered_loop_end
76 @ stub _vcomp_reduction_i1
77 @ stub _vcomp_reduction_i2
78 @ stub _vcomp_reduction_i4
79 @ stub _vcomp_reduction_i8
80 @ stub _vcomp_reduction_r4
81 @ stub _vcomp_reduction_r8
82 @ stub _vcomp_reduction_u1
83 @ stub _vcomp_reduction_u2
84 @ stub _vcomp_reduction_u4
85 @ stub _vcomp_reduction_u8
86 @ cdecl _vcomp_sections_init(long)
87 @ cdecl _vcomp_sections_next()
88 @ cdecl _vcomp_set_num_threads(long)
89 @ cdecl _vcomp_single_begin(long)
90 @ cdecl _vcomp_single_end()
91 @ cdecl omp_destroy_lock(ptr)
92 @ cdecl omp_destroy_nest_lock(ptr) omp_destroy_lock
93 @ cdecl omp_get_dynamic()
94 @ cdecl omp_get_max_threads()
95 @ cdecl omp_get_nested()
96 @ cdecl omp_get_num_procs()
97 @ cdecl omp_get_num_threads()
98 @ cdecl omp_get_thread_num()
99 @ stub omp_get_wtick
100 @ cdecl omp_get_wtime()
101 @ cdecl omp_in_parallel()
102 @ cdecl omp_init_lock(ptr)
103 @ cdecl omp_init_nest_lock(ptr) omp_init_lock
104 @ cdecl omp_set_dynamic(long)
105 @ cdecl omp_set_lock(ptr)
106 @ cdecl omp_set_nest_lock(ptr)
107 @ cdecl omp_set_nested(long)
108 @ cdecl omp_set_num_threads(long)
109 @ cdecl omp_test_lock(ptr)
110 @ cdecl omp_test_nest_lock(ptr)
111 @ cdecl omp_unset_lock(ptr)
112 @ cdecl omp_unset_nest_lock(ptr)